Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Cavalier Climate Control/AC Issues

Hi all,
Currently own a 2003 Cavalier 2.2L ecotec. Having problems with the A/C compressor not kicking on or kicking on intermittently. Yes there are some criteria you have to meet for clutch to engage
1. engine temp<250 farenheit
2. engine <5000 rpms.
3. call from dash (have to turn dial on control panel)
4. battery voltage between 9 and 18 volts.
5. High and low pressure between ?
I meet all the criteria for the compressor to engage (although I can't check high and low pressure) and the clutch will not engage. I will drive the car and then the clutch may engage and A/C will work and other times it won't. Problem is extremely intermittent with no real rhyme or reason. Dealer says it works properly but I know they are full of it. Any advice may help.
Thank you.
«13

Comments

  • I have a 1998 Cavalier LS, and started having problems with the AC last August. Eventually, it stopped completely. One mechanic said that '98 Cavaliers were used as fleet vehicles, and that he has had a couple come in with AC problems as well. Has anyone else had problems?
  • rorytaterorytate Posts: 21
    Hey, I have something weird.
    The standard fan control on a '98 cavalier. It has 4 settings.
    the LAST 2 (medium high/high) work. The 1st one (low) works ok,
    but the medium low doesn't work. Anyone help me out with that?
    Is there something I can check on that?
    :confuse:
  • joe3891joe3891 Posts: 759
    Blower resistor, $28 at the dealer, I think it available aftermarket. Not too easy to change but I can give you some tips if you want to DIY. :)
  • rorytaterorytate Posts: 21
    yeah that'd be good..i've kinda been reading it's under the glove compartment.
    is that right?
  • joe3891joe3891 Posts: 759
    Its behind the heater blower motor, remove that first, then two 7mm screws. The screw against the firewall is hard,I used a tip I saw on another forum, as close to the screw cut the firewall insulation 1 inch across, then 1 1/2 inches down both sides, the fold down, it will give you room to work. You will see when you get there. :)
  • Hi! My girlfriend owns a 2004 Cavalier and is having some problems with the front defroster and the floor air flow. I did a quick check last night and the fan works at all speeds fine, but the air flow won't switch from the panel to the floor or the defroster. When I would turn the knob to defroster the A/C light would come on, and when I switched it back to panel, the light shut off. Can someone tell me what is wrong and what I can do to fix it? Thanks
  • haha I am having the exact same problem as of this morning. It takes for ever for the car to get warm and the air conditioner light appears when it shouldnt. I'm curious to know whats the cause of it is too.
  • When you go to the defrost position, the A/C should come on to help get rid of the moisture in the car. As far as the vents not changing, you might have to pull the dash apart and see if you have anything loose in the HVAC controls.
  • MY GIRL FRIEND HAS THE SAME PROBLEM!.......THE BLOWER WORKS FINE.....BUT THE AIR COMES OUT THE VENTS NO MATTER WHAT POSITION THE CONTROL POINT S TO...........WISH IT WAS STUCK ON DEFROST POSITION!......GETTING COLD SOON HERE IN THE NORTH EAST...........DOES ANY BODY KNOW WHAT THE PROBLEM IS?.........IT MUST BE THE SAME THING THAT IS WORNG WITH YOURS..........ANY HELP WOULD BE APPRECIATED.......CHRIS
  • gmoudygmoudy Posts: 67
    Chris...I do not have any of the problems you mention. What I was suggesting was to take the dash apart and see if any of the controls have come loose for the vent position switch. Until you can find the problem, in any of the vent positions, you will still get heat out. You just won't be able to defrost your windows. Bad in a cold climate. As stated, check for loose connections in the HVAC controls.
  • lee30lee30 Posts: 2
    Chris, I also have a 2004Cav. You have described my exact problem to a tee. If you find out what it is, please post it. I have checked vaccum lines,fuses,etc. I have found out nothing yet, but it is getting cold in the north. I do have recirculation and vent but nothing else. My A/C works but only out of the mid-vents and my heat will cook you out of the car. I just wish it was stuck on defrost too! When I put it on defrost, I do see the green light come on but that is it.I'm stumped.
  • lee30lee30 Posts: 2
    Chris, I believe the problem you have is a broken or kinked cable. If the green light comes on when you turn the knob to defrost, than more then likely it is the cable. Remove the access panel on the left side near the accelerator and the small panel that covers the brake switch also. You can see directly behind the switch that you are concerned with. I had to manually move the vent door because my cable was kinked and frayed.LEAVE the unit in defrost position for the winter or until you can get it repaired or replace the cable yourself.P.S. You need a flashlight. Good Luck! :-)
  • mtandstmtandst Posts: 5
    Bought my Cavalier new and have kept up with it as I should with regular checks, etc. Have had several problems thru the years...most have been fixed...(except the persistent electrical issue with the ABS lights remaining on all the time...and something draining my 4 batteries way too fast)

    I just noticed a week ago that the air conditioning system wasn't cooling. Took it in to a air conditioning specialist. They said they put some dye into the system...and they at first thought it might be a problem (with the schrader ? valve or the suction valve core ?) but when I checked with them a bit later...they said that they thought they detected a small leak at the casing of the compressor..maybe around 1/2 inch. They said that the cost to replace the compressor would be around $1,000 job and that would also include replacement of the accumulator. I just went ahead and paid for the dye and the service and the added R-134A. He said it may hold for 2 days, 2 weeks or 2 mos. So...I am wondering exactly what I should do about this.

    I don't really understand why he can't just fix/repair the leak in the compressor vs. buying a new one. When I asked that question...he just said that he preferred to do it that way...to better guarantee or assure that my problem will be fixed. After all...he would hate to have me come back in to him...and have the compressor replaced after all and then have to pay all those labor costs all over again. Also, something about some seal/suction at both ends of the compressor...and some lubricating would be all new, etc.

    If you ask me...it sounded like a lot of razzle/dazzle...and being a woman...I tried to stand my ground and ask questions etc. but...I really wonder...if I am being hosed.

    Any thoughts on this ordeal...or if you have experienced any problems like this...I would like to hear from you.

    Thanks in advance for reading :cry:
  • halscahalsca Posts: 15
    If the case is cracked any repairs probably would be temporary. Most mechanics prefer to replace stuff like A/C compressors rather than repairing them. You'd still have to pay all the labor charges anyway, it's better to go with a remanufactured unit in the long run.

    All I can say is shop around to see if you can get a better price.
  • mtandstmtandst Posts: 5
    halsca....

    Thanks for your reply. :)

    You are probably right...when you say that getting a remanufactured unit put in my car...would be better in the long run than having my old compressor fixed. I noticed that you used the words remanufactured...So...they are not NEW compressors that the repair shops put in? :confuse:

    Interesting?

    I suppose...they will then take my old compressor...and turn it in somewhere and get some money for that...and then that place will work it over...and resell it again. :)
  • halscahalsca Posts: 15
    Yes they turn it in to cover the 'core' charge. Places that rebuild auto parts charge more if you don't have a core or turn in a unit so trashed they can't use it.

    I worked for years as a mechanic this is standard practice. Most mechanics don't have the stuff or don't want take the time to rebuild precision parts like A/C compressors, alternators or starters UNLESS they come from really rare autos. There are lots of places that specialize in rebuilding auto parts and MOST stand behind their work.
  • mervsmervs Posts: 1
    Hi all. I am a new member here. I logged in to share my problem with you guyz and get some feedback. I have a 1999 Cavalier-automatic-2.2 ltr engine. Recently i started feeling a kind of choking in my engine when i switch on the AC. When the compressor is on, the engine becomes very heavy and there is a huge noise when i press the gas, if i switch off the AC, the engine is as smooth as it was earlier. What could be the reason? The dealer says there is no much diff...but i feel it while driving. Any suggestions guys? May be the compressor is weak? Thanks
  • I have a 2000 Z24 convert., purchased used in 2002 with 10K mile, now has 67K miles. Have always noticed brightening/dimming of lights with concurrent speed changes in blower motor fan speed since we have owned the car, but it did not seem to affect anything other than to be slightly annoying. Yesterday my daughter was driving the car and noticed that the speedometer went to 0 [she was doing about 35 at the time], all the warning lights started flashing on the dashboard and the engine cut off. I had it towed home. It now starts and runs fine, the alternator puts ~14V across the battery. I am unable to recreate the 'surge/sag' observation with the car sitting in the driveway so I can't see if the alternator is cutting out. Battery is ~1 year old. Anybody have any ideas regarding where I should look next? Does anyone think ECM is involved? ---Thanks!
  • I'm having the same problem as mentioned above with the vent cable. Last winter the cable froze and when I tried to turn the knob the cable kinked and slipped off the control arm. I have managed to get the vent into the defrost position but would like to change out the cable. Does anyone know the best way to access this cable without pulling the entire dashboard out? Thank you.
  • Hello again. A/C isn't quite up to snuff. Filled AC with refrigerant correctly after illing it a month earlier and was only able to fill it midway into the blue and will not go further up even after using a whole can. A day later the AC is still at the same spot on the guage but isn't really cold but makes it bearable. My father's Chevy Blazer (same year) had the same problem but eventually fixed itself. I'm going to use the refrigerant with stop leak to fill it again but I'm a little cautious. Advice or Green light would be a great help. Thanks for the help about the mildew.
  • gonogogonogo Posts: 874
    DON'T use stop leak, to get it going after that will cost you thousands. Only put in straight 134a or with dye so you can find the leak. The mostly likely place for a Cavalier to leak is the shaft seal on the V-5 compressor.
  • Unfortunately, for ease, you will need to remove the dash.
  • Chris I had the same problem. The cable that is connected to the back side of the control knob is kinked. Take the cover that is located to the right of the gas pedal off and the cover that is just above the break pedal off. You will have to lay on your back to reach the cable. The cable is located behind the knob. It helps to turn the knob back and forth to locate it. Pull the cable up and off of the back of the control knob and straighten it with a pair of pliers and snap back on to the control knob. You may have to follow the cable up to where it connects to the vent control and manualy move the vent control up and down a couple of times to get the cable moving freely. Good luck. It took me about 15 min to complete the repair.
  • My 2000 cavalier is overheating when i have the heat on. IT blows out cold air unless it is on defrost then it still blows out warm air. But it still runs hot. WHat is going on?
  • hoodlatchhoodlatch Mid-westPosts: 255
    Sounds like your low on coolant. :)
  • My g/f's 03 Cavalier is having a weird ac issue. Air will blow from the passenger vent, floor, and defroster but not from the two middle and driver's side vents. The switch seems to be working fine, because I can hear a little air coming out of the vents. Is there a hose that connects just those 3 vents? :confuse:
  • My Rear Window Defogger is no longer working. Replaced the fuse (even though passed continuity test), the switch LED comes on and there is voltage supplied testing the pins at the back of the connector when the button is pushed. There are a purple and black wire coming out of the connector that backprobe fine about an inch or so but the purple one does not test continuous from one end to the positive window terminal. My Haynes manual doesn't show the wiring for the rear defogger so I'm wondering if there is a fusible link somewhere or a relay or something I should be looking at, or even where the heck this purple wire is routed to in the car. Any help?
  • I have the same problem, and I guess the same Haynes manuala s post 29. Wondering if anyone knows something about it.
  • I have a 1999 cavalier. the air conditioner is just blowing hot air. the thing is the compressor isn't kicking in. I think it is just a fuse. I've checked the fuses in the dash no problem there. Is there another fuse for the air conditioner that I can check before I go broke paying a mechanic. also I had a circuit board replaced (i think) but before it was replaced the air worked perfectly (it would freeze you out of the car. wanted to add that just in case.
    any help would be great. Thanks in advance.
  • gonogogonogo Posts: 874
    Could be low on 134a, circuit board is not much to go on.
«13
Sign In or Register to comment.