Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Durango Overheating Problems

I have a 2001 Durango with a problem no one can solve. I can drive for about 60 minutes in the city then the engine begins to heat up then quickly goes to overheat. I have had the engine fan clutch replaced, thermostat replaced, sensor replaced, waterpump replaced, still happening. No coolant leaks can be found, no smell of coolant inside or outside the vehicle. I have over 127,000 miles on it run great for an hour. The air conditioning is not working I put in new coolent it worked for about 2 weeks and now is no longer working. I don't know if the AC has anything to do with overheating or not. I am about ready to drive it off a cliff any ideas PLEASE!
«13456

Comments

  • Im having the same problems. But now I have a different problem that I just changed out my battery and the head lights will not shut off along with the dome lights. Also door locks, windshield wipers, and dash lights will not work. What is going on with the 2001 dodge durango? The cooling problem is an issue.
  • I have a 2004 Durango (4.7L V8) with the same/similar overheating problem. I figured it was the fan clutch (nope) because when I rev the engine in idle, the temp comes down. I have noticed that this car seems to run at lower RPM's than all my prior vehicles so perhaps at low revs the vehicle just can't keep cool. I am considering welding the viscous clutch solid so it spins faster. Before I do that, I was hoping someone might have a better solution.
  • hotrod13hotrod13 Posts: 1
    HAD SIMILAR PROBS ON MY 98 WITH 5.2, 3 WATER PUMPS A FAN CLUTCH AND SHROUD FOR A 3500 V-10 AND STILL HAD THE PROB, SO I SWAPPED FOR AN ALUMINUM 2 ROW RADIATOR (ORIGINAL IS A SINGLE ROW RADITOR THAT DOESNT GET THE JOB DONE) FROM JEGS THAT WAS MEANT FOR A FIRST GEN CAMARO AND A 1700CFM ELECTRIC FAN AND I DROVE ALL SUMMER WITH AC ON AND 0 OVERHEATING, ONLY HARD PART WAS FABRICATING THE BRAKETS, NOW GRIFFIN MAKES ONE TO BOLT IN
  • at idleing and low speeds it doesnt overheat, but when i go 70 mph it over heats. i have changed water pump,thermostat, tempeture resister, radiater , and coolant. 4.7L
  • mine is doing that now.
    I changed thermostat.
    Driving it over heats, but when stop it cools down.
    2 hoses going into firewall are hot
    Hose on right with radiator cap is hot,
    hose on left of radiator is warm at best.

    Could this be bad radiator? or water pump?
    Durango is now sitting waiting to get in the shop!!!!
  • Try back flushing the heater core. I had this happen twice now, once when I bought the truck and just last year. I have owned my 98 Durango for 4 years now and have had my fair share of troubles, but the one you described fit last years trouble to a T. I lost my heat and it was overheating, when I took it to the garage we replaced the thermostat but it did not give heat so they back flushed the heater core and that did the trick. Unfortunately, now a year later, I think we have to do it again as the problem is coming back. Chalk it up to a Dodge, and I'll never buy one again.
  • Fan clutch was the culprit for my 2000 Durango 4.7. Hayes aftermarket worked better than original OEM. It was an easy fix. But, that should have been found when water pump was replaced, right? So, maybe something else? What is tempeture resister?
  • :sick: :confuse: I have a 04 slt 4.7 with 82000 miles. All of a sudden it is "trying to run hot". I have replaced the the air filter, had the cooling system (radiator) flushed and chemically cleaned, new belt, had clutch fan checked out, water pump checked and so on... nothing is fixing the problem. It gets up between 1/2 way and "hot" and as long as I drive it will come back down, but if I stop it keeps going up. It also over revs when you stop and it's running "hot"..... please help?????!!!!!!!
  • I have a 2000 5.9l dodge durango and it keeps overheating. I have replaced the thermostat 2x in the last 7 months. When it overheats it shuts out rust color water. I don't know what else it could be. Any help would be great..
  • tkitascatkitasca Posts: 1
    2004durango, I have almost the identical problem. If I run at low RPM's city driving, my temp gauge climbs to hot then returns back to 1/2. I've replaced the fan clutch, thermostat and radiator in the last year but I still overheat. My dealer did a pressure test and thinks there is a 'leak' (cracked head?) on cylinder 3 and I'm loosing pressure in my cooling system. I know nothing about cars...all I know is I'm not sticking the $4,000 they want to try and fix it. If you figure anything else out..I'm all ears!
  • rakissarakissa Posts: 1
    My truck has been heating up lately. I have been running the AC alot. I know it causes the engine to strain but it nearly over heats. My transmittion even struggles to shift into the next gear when the AC has been on for awhile. My truck has never acted like this before. I took my truck into the neighborhood mechanic and he said it was a pump. There was a leak and that was causing the problem. Well to find out, he replaced the pump, flushed the coolant and gave a minor tune-up and it's still over heating. What else could it be??
  • sdoutsdout Posts: 23
    First of all, I would like to thank all of the people who post their problems. I have searched all over the web on this problem and have found that there are several people going through the same problem that I have experienced. While I rarely post, I hope you will find this information meaningful and helpful. If you are experiencing a chronic overheating problem with your Durango, I hope that you will find value in mistakes I've made and problems I have found.

    I have a 2001 Dodge Durango SLT Plus and Dakota Quad Cab SLT both with 4.7L and two wheel drive. My Durango has had several overheating problems and my Dakota has always ran in the normal operating range. Since there are no numbers to indicate operating temp on the gauge, normal operating temp on my Dakota is about a 1/3 from the left side. If it is a hot day (100 degrees or so) in slow traffic, it will creep up to the halfway point but not beyond that point. The three biggest differences in these vehicles related to cooling are that the Durango has rear heating and cooling and the Dakota is equipped with the towing package. The Durango has the standard green coolant while the Dakota has red coolant. The towing package comes with a two core radiator and transmission cooler. Without the towing package you get a single core radiator and no transmission cooler.

    The first time the Durango overheated, I was going up the grapevine on a warm day (about 85-90 degrees). I had the vehicle for about two years at the time. I was able to get the Durango cool and continue my trip.

    The next year I was making the same trip and did not want to encounter the same problem, so I asked Dodge to install the towing package cooling system. After driving the Durango home I could smell coolant. I took it back to Dodge the next day. Immediately, one of the mechanics stated that the auxillary water pump needed to be replaced. I believe 2001 is the first year for rear heating and cooling. The auxillary water pump pumps water to the rear heater core.

    About two years later, my wife complained that a strange smell was inside the vehicle. When I smelled inside the car, it smelled like stale air (like when you let out air from a tire). When I tried to find the source of the odor I could not find any problem. A few days later, I noticed a small puddle of coolant at the rear of the vehicle. When I opened the back of of the Durango and looked in the storage compartment, I found it full of coolant and quite a bit of the carpet was damp. Again, I took it into Dodge. They said the rear heater coil had sprung a leak and needed to be replaced. So I had it replaced.

    A couple of months later, the Durango started running warm and leaking coolant from the front of the vehicle. I found a small leak in the radiator. I went to the auto part store and bought some sealant for the leak and poured it in. It stopped the leak and the vehicle continued to run great for the next year and a half.

    This year in May on a very hot day, my wife had just had the oil changed on the Durango and on her way home the Durango got hot and the "Check Gauges" light came on. I found the coolant low and filled it back up. When I test drove the vehicle I found it reaching the halfway point in about 10-15 minutes. When I was at a stop lights it would start getting warm and when it was moving it would continue to get warm at a slower rate. The only way I could bring the temperature down was to run the heater. Of course, this is not a desirable way to cool your car when its 100 degrees outside. At this point, I figured that the water pump needed to be replaced. I decided this time that I would work on the vehicle instead of Dodge. When I removed the water pump I noticed that the water channel around the water pump looked slightly damaged. I didn't think much of it and continued to remove the thermostat, since I was right there I might as well change it, too. When I removed the thermostat, I noticed some grit in the housing. I stuck my finger in the thermostat housing and found a jagged hole. The hole went to the ports of the rear heater. I realized at this point I would have to change the entire timing chain cover. For those of you who do not know, Dodge runs the water inlet and outlet from the radiator through the timing chain cover, which the water pump is attached. I ordered a new timing chain cover, which comes with a new water pump and thermostat. I installed the new timing chain cover, upper and lower radiator hoses and drive belt. When it was complete, I test drove the vehicle, it took about 45 minutes for the temperature to reach the halfway point. When the vehicle was moving the temperature seems to stablize. While this seemed to be part of the problem, there was still something wrong. I thought that maybe the sensor had been defective and replaced it, but had the same result. Finally, I removed the radiator and had it tested. It was clogged. The radiator shop, infomed me that I needed to flush the system very good before installing the new radiator because he believed something was very wrong with the vehicle to create such a clog. Obviously, something was very wrong if the radiator was clogged in 4 years and had been flushed twice in that time frame. I decided that to completely flush the system, I would use a vacuum pump to pull out as much debris that I could from the system. I happened to have a vacuum pump that would pull about 25 psi. I connected it up to the inlet and the outlet and drained as much as I could. With just having put new coolant in the system, I was expecting to see fairly clean coolant. The coolant that came out of the vehicle was very dark and dirty. I decided to flush the system again with water and then redrain it with the vacuum pump. The process took about 3 hours. I reinstalled the radiator. When I test drove the vehicle it ran cooler than it has in a long while.

    I have read several posts of people who have replaced nearly everything that I have and have even some who have had to replace motors. I have read other posts that state you should just flush your radiator every year or two. I have also read posts about installing a bigger better electric fan. At one point, I considered installing a bigger better fan and even possibly installing an oil cooler however, the fact of the matter is that I have two vehicles that are nearly identical and one overheats and the other doesn't. I just couldn't buy into installing something to fix the symptom and not the problem. If you are thinking about installing a bigger electric fan you should know that the fan turns on at the halfway point or when the AC is on, unless you rig it to turn on at a lower temp or have it running constantly. If you live in a very hot climate and find your vehicle getting hot when the AC is running, then installing a bigger fan is probably a good idea, otherwise you are waiting until your car is runni
  • sdoutsdout Posts: 23
    Sorry this is so long, here is the rest of my post.

    running warmer than it should to get the benefit of the electric fan. Everytime Dodge has worked on my cooling system they had to flush the system which turns out to be about every couple of years. While I think that regular maintenance is great to keep your vehicle in top running condition, flushing the system every year or two seems a bit excessive. The reason I say this is because Dodge states that red coolant for my Dakota be replaced every 100,000 miles. For the Durango with the green coolant it is 30,000. I don't quite understand why they both have different coolant colors, but because of it they are on different schedules. I guess, if you put a lot of miles on your vehicle than maybe flushing that often falls within the maintenance parameters. I think that the corrosion in the timing chain cover is happening to more people than just me, yet I have yet to read a post about anyone else replacing this item. I think this is the reason that people are having to flush their systems every year or every other year to keep their vehicles running cool. I think the debris from the corrosion on my own vehicle lead to the heater core and radiator leaking and then to clogging up the radiator to the point that it was ineffective.
  • I am definitly experiencing the same problem of the engine overheating when idling. Tomorrow I am replacing my water pump to see if this solves the problem. I will post my results on Monday.

    Also, I noticed above that a user reported one hose was hot and the other was warm. Check your thermostat again, that is most likely the problem.
  • sedro67sedro67 Posts: 1
    Have an 04 Durango with 4.7 and 50000 miles.....follow maintenance schedule regularly. Dodge recommends flush at 5yrs/60000 miles for schedule A...even later for B....too late! Had to replace mine today as it was clogged with sludge. What else should I know???
  • sdoutsdout Posts: 23
    Since I have changed my timing chain cover that was disintegrating, which included a new water pump and thermostat. In my opinion, the disintegration of the timing chain cover was causing the clogging of radiator. I was concerned that the grit had contaminated the system. To remove as much as possible, I used a vacuum pump to completely evacuate the system. I didn't think anything was wrong with my radiator at the time because I radiator had been replaced a couple of years before (usually I would expect a radiator to last more than a couple of years). When I put the truck back together and it still got warm (not as fast as it was before) I knew something else had to be wrong. I was surprised when I had the radiator at a local radiator shop (I wanted an independent opinion) tested and found it clogged. I bought one for about $175. After I installed the new radiator, the Durango has not overheated and runs as cool or cooler than my Dakota. Again, this year I took the family to Disneyland and over the Grapevine the Durango ran cooler than it ever has on that trip.

    This is my experience and while I don't know if this a problem with all 4.7s, it might be a place to start or at least have it inspected. However, one thing is for sure, if you are replacing a radiator because it is clogged, installing a new radiator may temporarily relieve your symptoms, but it hasn't solved your problem unless the radiator has itself is disintegrating and causing the clogging. I may still end up with the same problem because I don't know what is caused the timing chain cover to breakdown. It is my guess that there is some kind of PH or chemical reaction that is causing this breakdown resulting in grit or sludge being produced. Since it's been less than a year that I have performed this repair, I'm optimistic that the problem is solved, but I still don't know why this problem started in the first place.
  • pudge22pudge22 Posts: 1
    I too have a dodge durango thathas been overheating. The problems are the exact same; when driving the guage goes down but when slowing down or even at a stop the guage goes up and heats up fast. As of today; on my way to work it over heated so bad that it actually smoked clear white smoke for at least five to 10 minutes.. I do not know anything about automechanic's duties but I will say Is there anyone out there that can HELP ME!!!!!!! PLEASE!!!!!!!
  • besmith3besmith3 Posts: 2
    I may be ableto be of some help to your cooling system issue. I have a 2001 5.9 Durango, and over a period of 5 months, my entire cooling system failed and had to replace parts as they went bad. First, check your coolant level. If it's OK, then most likely your issue is with the waterpump, since your vehicle is requiring more RPM's to cycle coolant through the system. If you get a Haynes manual, it's easy (and cheaper) to be replaced by you. In regards to the white smoke though - that is a sign of a coolant leak. Run your engine and see where the smoke is coming from, and inspect any hoses (after you allow ample time to cool the engine) for holes or cracks. If coolant is splashing off of the radiator fan and onto the engine, therefore causing the smoke, look under your vehicle to see if the coolant is leaking from the weap hole on your waterpump. The vehicle needs to be running and warmed up to identify this leak. If it is the weap hole leaking, then obviously as stated above..replace the waterpump. I have a good feeling this is your problem, but I would like to know where the smoke is coming from if it is not... hope this helps.
  • Last summer my 2000 Durango over heated. I took the head to the machine and nothing was wrong with it. I replaced my radiator, water pump, heater core and thermos stat. Now, my Durango is doing it again. Are there any new suggestions out there to try other than getting rid of the thing?
  • sdoutsdout Posts: 23
    I think the first thing I would be concerned about is the white smoke. If you are getting a lot of white smoke out of your exhaust then your overheating is a symptom of a different problem. If you have been experiencing overheating problems for a while then your problem just got worse. White smoke generally means that water is getting into the combustion chamber. Since the piston is tightly in the chamber, the movement causes a vacuum that sucks water into the chamber. The pressure from the compression and heat from the engine force some of the water through the system and it comes out as steam. The air and gas let in through the valves may push through the coolant system causing coolant to drain out of the overflow. The scenario I have described happened to me on another vehicle, but the problem was due to a head gasket blowing. More specifically, the water jacket from the gasket ripped to the combustion chamber. However, the same kind of problem can happen if a vehicle overheats and the head(s) warp(s). In this case, the temperature gauge will jump to hot. If your vehicle was getting hot before and this has happened or starting to happen then you have two problems. The first is the original overheating problem and now some kind of head problem. You would also likely find your coolant contaminated with oil.

    Perhaps, I'm reading too much into the white smoke problem. If your white smoke is coming out from under the hood then you have a completely different problem. There is a good chance that the car getting hot is causing the coolant to boil over. When it gets hot enough it will create some steam. If the coolant comes in contact with the motor then of course it will cause a white smoke especially since you already know its hot.

    Here are a couple of things I would look for.

    If the car gets hot quickly at about the time you would expect it to reach operating temp, then there is a good chance the thermostat is stuck closed. If you turn on the heater to help cool the engine, then the heater air is likely not warm.

    If the car starts creeping up in temperature and then you put the heater on and can slow or stop the overheating then I would guess the problem is a plugged radiator, although a faulty water pump could also cause the problem.

    If the car gets hot only when under load or takes a long time to overheat then I would think the problem is a less plugged radiator or a stuck open thermometer.
  • sdoutsdout Posts: 23
    Much like you I had several of my cooling parts replaced. When it overheated again, I started looking at parts I hadn't replaced. The only part that I hadn't had replaced was the water pump. Up to this point, I had all the work done by Dodge. I learned more about the cooling system than I could have imagined. When I removed the water pump, I found some corroding. I decided to remove the thermostat. When I removed the thermostat, I found more corrosion. I decided to replace the timing chain cover, which came with a new water pump and thermostat. When it was all put together, it was better, but not fixed (see one of my previous posts for more information). Since I had seen so much gritty junk in my system (and had used a vacuum pump to remove it), I figured the radiator might be to blame. When it was tested, it was plugged (it was only a few years old). I installed a new radiator and it has been running great since. I think that when you installed the new radiator there was still some grit in system and it has now plugged your radiator again. I would take the radiator down to a local shop and have it tested. If it turns out to be plugged, I would check the timing chain cover. If you decide not to do that then I would completely flush the cooling system (without the radiator installed) or use a vacuum pump to remove any debris or grit in the system. In addition, I would install a two core radiator, instead of one (if that's what you currently have). It should help cool better and take longer to clog, showing less dramatic symptoms if it should happen again. I still don't know what caused the timing chain to errode or if it will happen again, but so far it seems to be working.
  • palenakapalenaka Posts: 1
    Hi, My daughter too has one of these lovely pieces of ... a 1998 & every summer it starts to overheat when the daily temp is 100 and she is running her a/c. I'm going to back flush the system and replace the thermostat today to start. I was thinking about installing a 160 thermostat but I haven't seen anyone mention this. Also, when you all replace the radiator caps are you using a 14-16 psi as I believe is recommended or a 18 psi? The radiator is new but after sticking my finger (gritty, rusty) in it I'm sure it's clogged. As a grandma with all her tools at home...I would love your help in a plan of attack for this disaster of a truck once I bring my tools down. I'm thinking the water pump needs to be changed as it's the original but how about the heater core? It seems to me it could be filled with crud too.
  • sdoutsdout Posts: 23
    I think you are right about the radiator. I would remove it and take it down to a local shop and have it tested. If it passes great, if not then I personally would upgrade to a two core, if it doesn't already have a two core. With the radiator out, I would completely flush the system (as I stated before I used a vacuum pump to pull the gritty junk out, but whatever you have a available to flush the system thoroughly will increase your chance for a longer lasting repair). Then I would put it back together, if you don't see any damage to the timing chain cover. Since my Durango has rear heating (an option not available in '98, I believe) you may not have the same corrosion issue at the thermostat that I had. It couldn't hurt to change the thermostat and the water pump if everything looks good. I installed the stock thermostat because it came with the timing chain cover. In addition, the electric fan is programmed to come on when the temperature gauge hits half-way. I kept the stock radiator cap on the truck. I did the work on my durango about a year ago and it's been running cool, even at 100+ temperatures. Hope this helps.
  • kacey22kacey22 Posts: 4
    Well, my durango 5.9 was bogging out and I ran a diagnostics on it, it came up o2 censor (high voltage) bank 2 sensor 1. Ok, so I had the o2 sensor on driver side before cat changed but my car is still overheating and the engine light still comes on. The scanner didnt show anything but that sensor. What could it be?
  • sdoutsdout Posts: 23
    While the O2 sensor might help with the "bogging" and cause an engine light to come on, I don't believe there are any sensors that will tell why your car is overheating (unless all of mine are defective). The only indication that it is getting hot is the temp gauge and if your are unfortunately enough there is some other indicator that comes up when the engine gets really hot. My wife saw this indicator come up, and from what I've read most people are buying new engines if this indicator comes up. Anyhow, not knowing the year of your Durango and much about the 5.9 engines, if they are anything like the 4.7, then I would have the radiator tested by a shop that specializes in radiators. Depending on the shop, you might have to remove the radiator or pay extra to have them drain and test it. If it comes back clogged, I would have the cooling system thoroughly flushed before installing a new radiator. I'm guessing this first, because it has been a problem for me, however I would have to know more about the overheating symptoms to give a more accurate idea of what could be wrong.
  • kacey22kacey22 Posts: 4
    Thank you for replying. my durango is a 2001. Well it all started when it lost power and bogged at lights and stops, then after we let it go for a couple months we noticed when we used the air conditioner it started to heat up to like the 3/4 line on the temp gauge. now I have a baby due in 2 weeks and I cant even use my air. I ran the diagnostics and it said bank 2 sensor 1 but no other code. I keep getting mixed answeres on where bank 2 is. Some say driver side some say passenger. I dont know which one to change to start with. It seems like we never really have to put water in the radiator so i dont know if that is normal or not. Now I noticed something leaking under the front passenger side under where the shocks . Im just at a loss and I dont know what to do. I dont have money for a mechanic so I am trying everything I can to research what I could check.
  • sdoutsdout Posts: 23
    The O2 sensors can be a little confusing. I can't remember exactly, how they are numbered but here is my guess. On my Durango, there are 4 O2 sensors. Bank 2 is likely the passenger side and sensor 1 is the one before the catalytic converter. I had one go out but I think it was bank 2 sensor 2, there was no real performance difference just a code and engine light on. I don't know if the sensor before the catalytic converter would cause bogging. If the water from the passenger side is clear and does not smell like antifreeze then it is probably condensation from the air conditioner (not a problem, most cars do it). Getting back to your overheating problem. Have you checked the coolant level? Do not remove the radiator cap, especially if the car has been recently driven or started. You can check the coolant level from the resevoir. There is a dip stick in there. If this is low or empty your problem may be fairly simple. If it is full, then I need to know a couple things like how long does it take to get over half way on the temp gauge? Is it a couple minutes or does it happen after about a half hour of driving. Does it get hot while moving or at a stop or both? I can warn you that if your car is getting 3/4 warm it is getting dangerously close to causing a major problem. When a car gets hot repeatedly or even very hot just once, it can warp the heads which will be the cause of a major repair (usually into the thousands, likely 4 or 5 thousand dollars). If you see your car getting over half way hot, put on the heater to help the car cool down. If you can't stand it in the front and don't have passengers in the back, put the rear heater on and see if that helps to control the overheating. If this seems to help, I would think your problem is radiator related. It could be other problems too, like the thermostat sticking or the water pump. If the vechicle has several miles on it a new belt may also be in order. If you can find someone to work on it that you trust and is mechanically inclined to change the radiator, water pump, thermostat and put new coolant in should cost about $400. If you have the dealer do the work it will probably be closer to $1000. If you get back to me with some more symptoms, I'll try to give you my best guess.
  • kacey22kacey22 Posts: 4
    Well it takes a about half hour to start going over the middle. If we have the air on it will heat up alot faster so we haven't used it. My car has like 120,000 miles and the belt squeaks sometimes but can that cause heating? It seems okay when we go short distances and go to like the store and back but when we have to run errands or have appts. it heats up when we have to be gone for a while. the radiator itself under the cap never needs water but the overflow sometimes needs water. My air conditioning works but we just cant use it. So you dont think the bad sensor would cause the heating? I just went to say thank you alot for taking the time to help me. You have helped me so much more than anybody else I have talked to. You sound like you know what your talking about. By the way when the scanner said sensor was high voltage, would anything make it run high or does that just mean it is getting bad?
  • sdoutsdout Posts: 23
    The O2 sensor is probably just bad, I would just replace it. I think the one I bought for mine was $75 - $100. They aren't that hard to replace. They can be a little difficult to get a wrench on, but once they are broken free they usually come out fairly easily (I think they use anti-sieze compound on the threads). I don't think there is anything to be overly concerned about the high voltage. I think it is reading higher than its normal range, or a higher voltage for longer than it expects indicating that it is defective. On the overheating part, because it is taking about a half an hour to get to the middle and can somewhat be controlled by not using the air conditioner then, I would say its not the thermostat. While I don't trust the radiators on these vehicles too much, there are a couple other easier and less expensive things you could try. First I would change the belt ($25-$35). If it is slipping then the water pump isn't turning as reliably as it should. In addition, the fan clutch isn't turning with the speed it needs to draw in air over the condenser and radiator. This brings me to the next thing I would change. The fan clutch. Autozone has them for about $55. Both the belt and the fan clutch are fairly easy to change. If you have never had the coolant flushed and drained then I would also get that done. It is fairly easy. Generally there is a stopcock at the bottom of the radiator to drain the system. You will need a big container or a couple 1-2 gallon containers to get all the fluid out. After it is empty, close the stopcock and refill at the radiator cap. Once full at the radiator, fill (don't over fill) the coolant reservoir. Start the car and monitor the coolant reservior. If it goes lower or is drained, replenish the supply until it is steady at full. Generally, you want to use 50% antifreeze and 50% water. You can buy this mixture, but it cost more than mixing it yourself. Generally, I like to do about 60% antifreeze and 40% or so water. If you have questions on changing out the fan clutch or belt you might be able to get a book (Chilton or Haynes) from the library or your local automotive store. Some of the automotive stores have "How tos" on their websites that can be very helpful.
  • kacey22kacey22 Posts: 4
    well, thanks to you telling me the RIGHT side bank 2 was on, i changed that sensor and after 34 miles still no engine light. thank you for your help really!! The only thing is it didnt heat up but it did fluctuate, it probably went to about a lil over halfway but went back down. Well lets just say dont go to mechanics in bakersfield haha they dont know what they are talking about. Thank you again though! Now my new baby will have air conditioning :)
«13456
Sign In or Register to comment.