Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Sunfire Starting and Stalling Problems

jeremy2jeremy2 Posts: 1
edited January 19 in Pontiac
I have a 1998 Pontiac Sunfire with a rough idle. I have replaced the spark plugs, the plug wires and the coil are good. There are no fault codes and I still have a rough idle. If you may have any idea to what the problem may be please email me.
«13456715

Comments

  • rob32rob32 Posts: 1
    I am having the same problem with a 98 sunfire GT. Did you figure out the problem
  • cindy10cindy10 Posts: 3
    I have the same problem with my '95. I tried fuel injector cleaner and it's helped a little but it's still rough. Anyone else have a suggestion?
  • euphorbiaeuphorbia Posts: 14
    I have a 96 Sunfire 2.4 (4 speed automatic) with 140,000 miles on it. It has been an awesome car since new. Recently it has been stalling when I brake from high speed and make a right turn. I notice that the tach falls below 500 rpm at those times and I can hear a clicking sound coming from the engine compartment (sounds like it is coming from the firewall just right of center). Does anybody have any experience with what might be the cause? I have replaced the throttle position sensor with no change in condition.

    Euphorbia
  • Claire@EdmundsClaire@Edmunds Chicago areaPosts: 968
    Hi, euphorbia,

    You might also want to post your question in the Idle or Stalling Problems: All Vehicles to see if the folks there have any input.

    Claire

    HOST

  • euphorbiaeuphorbia Posts: 14
    This is an update of message 61. I have a 96 Sunfire 2.4 (4 speed automatic) with 140,000 miles on it. Recently it has been stalling when I brake from high speed. I notice that the tach falls below 500 rpm at those times and I can hear a clicking sound coming from the engine compartment from inside the car. I have replaced the throttle position sensor and tested and cleaned the Idle Air Control (IAC) valve and the condition didn't change. I have also checked for vacuum leaks and found none. The OBD II code checker indicates no service codes. Does anybody have any experience with what might be the cause?

    Euphorbia
  • euphorbiaeuphorbia Posts: 14
    Thanks for the "heads up". I learned that a vacuum leak could cause my problem. I checked and didn't find that to be the case on my car. I posted the issue on the Idle or Stalling Problems page.
  • Claire@EdmundsClaire@Edmunds Chicago areaPosts: 968
    Hi, Euphorbia,

    You might also want to ask your question in the Idle or Stalling Problems: All Vehicles discussion.

    Claire

    HOST

  • My sunfire has been giving me problems over the last few months. It's a 5 speed and when I have the air con running I find that the RPM's are jumping up and down when I am in a stopped position. Sometimes they jump and then fall so low that the car stalls. Also when I start up from a stopped position I find that the car is lagging and not getting gas. This also happens when I make a right or left hand turn. I have had it looked at by two GM Dealers and they have found nothing wrong with it. The fuel filter was changed and diagnostics were run twice. Any suggestions??
  • Hi All,

    I've recently bought a 1998 Sunfire SE with 95k on the clock. She was fine until about a week ago, now whenever I start the engine it fails to start sometimes, it fires but almost seems like it's stalling straight away. There's also a very odd niuse coming from the steering column area, almost like a kind of buzzing but not quite. After one, two or maybe three tries is fires up and if I apply gas starught away she fires up and should be fine. This happens 9/10 times I start her up!

    Also the horn doesn't work :sick:

    Any advice would be greatly appreciated!

    S x
  • Please help.... I have a 1997 sunfire. It will start, but immediately dies out. If I keep the starter engaged it will continue to run. As long as the key is in start position. Let off key and car dies.. I cannot aford to take it to the shop. I have to fix this myself.
  • Claire@EdmundsClaire@Edmunds Chicago areaPosts: 968
    Hi, rhartford,

    If you don't get an answer here, you might try asking the folks in the "No Start" Problems discussion. Even though your car starts, it doesn't seem to want to "stay started", and the people there may have some insight for you.

    Claire

    HOST

  • I have a 2000 Pontiac Sunfire, that has been having starting problems for about 3 weeks. The car started having an error message, "locked stereo" message and all my dash board lights showed up. I then had it sitting for about 6 days, and then it wouldn't start. Finally got it started and it drove perfectly fine with no error messages for about two days. Then when out in the morning to start it and would not start. It will turn over for a second or two then stalls. I noticed it does this when its damp/rainy out..Any thoughts?
  • jcarbojcarbo Posts: 1
    Hey people,
    I have a 2002 2.2L Sunfire with 85km on it. Recently [as recent as today] the car has not been starting. This has only happened twice in the last month or so. I took it to the dealership and they say they can't find anything wrong with it??? It started right away when they got their hands on it. Today the cars starts an stays on for about 1 second then dies..? Anyone with any ideas? 2 Months ago I had the fuel pump replaced and the dealership said, nothing wrong with it.
    Thanks
  • Anyone had any luck with this one??? Happening to my '99 SF now and is a PAIN!
    Thx.
  • It might be an ignition problem. I read on the recall page that there is an ignition switch recall. If its that then its free. It might be an ignition coil, but I don't even know if they have those in these cars. I know I owned a accord once that needed one. But check with your local pontiac dealership to see if its a recall. They might even be able to tell you exactly whats wrong with your car, the service managers are good like that. Just don't ever bring your car to a dealership to have work done that you have to pay for because they will rip you off with the price.
  • sounds like an electrical problem. Sometimes they work themselves out and sometimes you need to go to a shop. good luck.
  • my dad has a 92 accord and it has problems starting if it is parked in the sun and when its really hot out. try parking it in the garage or in the shade it might help you with the problem. If problem consists then it needs more tests. good luck.
  • Hi everyone. I am new at this and just found this site by trying to find out what the heck is wrong with my sunfire. I own a 1998 Sunfire GT. Everything on it has been great till the last month. First the heater module went on me. $110. Then a week later...my car stalled while I was waiting at a red light. For no reason at all. It has never done this before. So I started it up again and had no problems startin it. Then a week later it did the same thing. Started again no problem. So I took it back in and they said I needed a tune up. So I got a $450 tune up. Now after that $450 tuneup...I have a clunking noise when I turn the steering wheel, and it still stalls. I took it back in and they put it on the computer and entered the codes and did what they could and can't figure it out. So now I am goin in for an oil change tomorrow...and yesterday and today it stalled again . Starts right up no problem...but it keeps stallin more and more now.

    Does anyone out there know what the problem is? Any suggestions? I was thinking the fuel injection? When I try to not let it stall and I give it gas, it doesn't want to go.

    I love my car so much, and have only owned it for a yr. I really want this car to be good for another few yrs...what can I do?

    Confused in Ontario Canada
  • Claire@EdmundsClaire@Edmunds Chicago areaPosts: 968
    Hi, sid_jr08,

    Another place that you might want to post about your problem is the Idle or Stalling Problems: All Vehicles discussion. The folks there are likely to have an answer for you if you don't find one here. Hope you get this solved quickly :-)

    Claire

    HOST

  • I to have a 99 sunfire that wont start randomly. It started about 2 years ago and is frustrating as heck. You can run into a store and come back out and it will not start. It will crank over and sometimes fires but dies right away. Have had it towed in 3 times and when it gets to the mechanics it starts fine. Had the fuel pump tested for pressure and it is right up to speck, when you turn the key on you can hear the fuel pump going till the pressure is up and then it stops like it is suppose to but the car still doesn't start. Have had the fuel filter replaced and it doesn't matter the weather conditions or how much fuel is in the tank it will not start. You can walk away from it and come back in a half hour and it will start and run fine. Someone mention maybe the crank sensor might be the problem. It has had the update done by GM for the ingnition recall but made no difference. Anyone have ANY input on this?????
«13456715
Sign In or Register to comment.