Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Sunfire Starting and Stalling Problems

1910121415

Comments

  • i have a 2000 sunfire sedan. i just did a long road trip from canada to florida. didn't have problems before. but now my car has problems starting cold and doesn't real speed up when pressing the gas. the engine light is on. the motor still runs quit but u can hear the sputter from the tail pipe and my motor shakes. i had already changed the spark plugs and wire harness. it ran great the whole drive. just the next morning i started having that trouble. what can it be...?
  • Yes i have had my 96 sunfire do the same thing found out it to be the PCM i replaced it and all my troubles went away (its located on the passenger side in the wheel well)
  • Seriously, I would go with the ECM/PCM theory first. Don't be afraid of this, because dealers will make you think it will cost a fortune to get one.
    Not true, http://cgi.ebay.com/ebaymotors/2000-Pontiac-Sunfire-Engine-Computer-ECM-Programm- ed_W0QQcmdZViewItemQQhashZitem35a72ce64aQQitemZ230438004298QQptZMotorsQ5fCarQ5fT- ruckQ5fPartsQ5fAccessories
    $83 shipped on ebay, and already flashed to your vin number.
    It's very easy to replace compared to the countless other items we tried fixing first.
    Once you get it, you need to follow these instructions:

    In order for a theft deterrent vehicle to run, a password is communicated between the Instrument Panel Cluster (IPC) and the PCM. If a PCM (ECM) is replaced, the new PCM (ECM) needs to learn the correct password of the vehicle. When the new PCM is installed, the EEPROM calibration is flashed into the new PCM and the vehicle will learn the new password upon initial ignition ON. If the IPC is replaced, the PCM needs to learn the new password from the PC. The password learn procedure is as follows:

    Attempt to start vehicle, then leave the ignition ON. The THEFT SYSTEM telltale will flash for 10 minutes .
    When the THEFT SYSTEM telltale stops flashing, start the vehicle. Once the vehicle is running, the password is learned.
    -
    There's a good chance this is the problem, and if it is it's really a simple fix, we've all just be taught to think "car computer problems" must mean spending a fortune on fixing!

    Good luck- let us know!
  • monaemonae Posts: 1
    Until 2 weeks ago my Sunfire ran great (almost 30 MPG) and gave me no problems. It has less than 70,000 miles (25K more than when I bought it 1 1/2 ago). Twice it acted like it was starting, not hesitating cranking sounds, but nothing happened. It was like I hadn't turned the key. Then last week after making a turn it just died. On the third try, it started and drove fine the 7 miles home. I took to my mechanic and after 45 miles, several starting and ideling for 30 minutes, they could find nothing. Oil and fuel pressures perfect. All connections fine. I drove less than 1.5 miles and it died again. And again started on second or third try. I have been told everything from fuel pump to short in the car somewhere. Has anyone else had this problem?
  • trpd5trpd5 Posts: 1
    I would check for bad wiring down by your PMC
  • vickiecvickiec Posts: 3
    it was running fine yesterday quit today Help
  • vickiecvickiec Posts: 3
    It was running good , So I thought it just will not start today I dont know what could of happend over night but it did.. I am A single mom with one car if some one could Help I would be Thankful..
  • vickiecvickiec Posts: 3
    some one said it could be the brain is that true...
  • i parked my lastnight and when i started today morning it is not getting started. i tried jumper cable ,if my battery is not good but didnt work. Gas tank is half full.
    can anybody help me? i really dont know ABCD of Auto.
  • The main problem is we have now replaced the Catalytic Converter 2 times now in this care. One time in Dec 2008 and just today. You can be driving the car and all of a sudden it starts to spudder then will shut off, the weird thing is it will start right back up? We had to have the Catalytic Converter replaced this time so it would pass inspection, we were told that since engine light was on and computer said this was the problem it had to be done to pass inspection. Has anyone else out there have problems with 2000 Pontic Sunfire? If you did please let me know what you did to fix this. We are about ready to get rid of this money pit soon. We only drove it about 1200 miles in the last 2 years.
  • tremorztremorz Posts: 2
    yesterday my 03 sunfire started sounding a bit gurgly when at an idle, to it down the highway and it performed well. At the bottom of the exit ramp heard the gurgly and a bit of a jerky motion will sitting with the brake applied, reached my destination in less then a mile and there was no clearing out the gurgle and the slight jumping it was doing , and yes i could see it in the rpm gauge it almost never bounces , but it was slightly.\r\ngot back in it an hour later and the low idle gurgle and jumping was still there took it back down the highway and performed just fine, same issues at the next exit. took it home and had another person move it for me and it was progressivly worse, had a neighbor look at it and we listened to the engine, sounds fine under the hood, but not in the cab, he suggested that it go on a machine and see if any codes are coming up on it , no dash lights appeared .
    decided to move it up on the driveway , which has a slight incline to it and as i was backing it up it stalled out. now it will not start at all , but cranks over like it wants to. i had no choice but to drag it down to an auto shop and have it put on a computer this morning and no codes are coming up on it and no dash lights are coming on, no check engine, oil, etc...it appears from the computer check and my problem guages that it has no issue, but will not start, and yes there is over half a tank in it. not sure where to go next from here ??!!?? the plugs were found to be fouled out and were replaced but still will not turn over.... :confuse: any ideas?
  • I have this 2002 sunfire which was sitting for about 6 months. I put some gas in it as well as some gas tank cleaner stuff. Then I charged the battery because it was dead, and turned it over fine. Got insurance for it about 5 days later and then went to turn it over and nothing, so I checked the battery eye and it was dead. I bought a new battery yesterday and it turned over just fine, I ran it for about 10 minutes and even drove it down the street. I turned it off and 1 minute later turned it back on no problem. I went upstairs for about 45 minutes and came down to go get dinner and nothing, it wouldn't turn over the dash lights were all blinking dully and then I noticed the light switch was on. So I turned it off and turned the switch off and tried again, but I still didn't hear the fuel pump engage nor did the starter click at all. Even if the lights were left on for 45 minutes there is no way in hell the battery should be dead it is brand new. When I turn the key I get nothing at all now. Can someone please help me as I have no idea what to do?????? :mad: :cry: :sick:
  • cpeliscpelis Posts: 1
    edited May 2010
    i have a 95 pontiac sunfire 2.2L 5 speed manual that needs an exhaust. I have had problems with it idoling funny and extra loud when it is hot outside. it also spudders and shakes when im driving like it is running out of gas. i just replaced the fuel filter and no luck. sometimes if i excellerate very slowly it wont do the shaking and spuddering.... any ideas whats wrong???
  • I have a 1997 Pontiac Sunfire that stalls when the outside temperature gets to high. It is a 2.2L, 5 speed, with 235,000 miles. I have had a computer plugged up and only saw a misfire on the codes. I have replaced all plugs, wires, and coil packs. The engine runs perfect until the temperature outside gets hot, maybe 80 or better. During winter months it is fine and at night also. It is a very strange mystery. When it stalls it trys to keep running but it sounds like a engine that is choking down. When you cut it off and let cool for 10 min or so it will crank and run fine till it warms up again. Any suggestions would be greatly appreciated.
  • dulinaadulinaa Posts: 10
    Sounds electrical. Does the car just stall the engine, or cut all power completely? The heats causing an open circuit somewhere. with the high miles, i would check for any engine control relays(i.e ignition, injection, ECU, main) and replace them, fairly cheap. Is the Check Engine light on? Scan it. After that, a possible sensor is breaking down from the heat, take it to a trained professional. worst case is the Engine Control Unit is malfunctioning.
  • jeffs47jeffs47 Posts: 2
    First the battery light, then the abs light, then the gauges going crazy, then the stall, a new battery and 2 good hours before the final shutdown. Is it an ecm or an oxygen solenoid sensor, or should I warm up the bike?
  • jeffs47jeffs47 Posts: 2
    I've had the same problems. Who knows how to do the antitheft key turns? Can it be disabled? How much does it cost. Too cheap to buy a new car.
  • ladyvicladyvic Posts: 1
    I have an 05 pontiac sunfire with a little over 50,000 miles on it. About a month after I got it, which was at about 5,000 miles, The ABS, Trac light and service light started coming on. Took the car in at least 15 times, the only problem they found was the wheel sensor. Still having the same problem til this day. The car will sometimes sputter or shut off when backing up while turning the wheel. Nobody can seem to find the problem. I'm tired of paying $40.00 each time for diagnostics. Also if I slam on the brakes which happened to me twice, the brakes seem to act like they're not in the right position as I feel it thru the pedal. I don't know what to do anymore about it.. of course the warranty is over... Please help someone :cry:
  • gmcustsvcgmcustsvc Posts: 4,057
    Hello Ladyvic,
    I apologize that you are still experiencing a concern with your vehicle. Can you please email me your VIN, current mileage, contact info and dealership so I can look into this further? You can get my email by clicking on gmcustsvc. Thank you,
    Mariah GM Customer Service
  • sam1971sam1971 Posts: 1
    I have a 2 door 1999 sunfire which I just replaced both oxygens sensors only to still have the same problem, Rums like a charm till you go to take a turn ot apply the break. then shuts off. sometime you can smella burning smell like coolant and the temp gauage goes up and the ets light comes on before stalling. Does anyone know what the problem could be?
Sign In or Register to comment.