Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Windstar Problems

1105106108110111124

Comments

  • just wondering, had to have my tranny rebuilt in 99 windstar, two weeks later o/d light flashing, ford says it's the speed sencer and has nothing to do with the tranny repair, i figure it must have been effected by the rebuild some how ???
  • selooseloo Posts: 606
    After Ford replaced the bottom half of my engine, I developed the following problems:

    CEL stayed on
    Loud Spark Knock
    Rough Idle
    Oil Leak
    Clicking Noise from engine (driver's side)

    Back to the Dealer:

    Found Code P0171

    Fixed the following:

    Intake manifold leak, plugged EGR ports, replaced isolator bolts, 6 gaskets, new value cover (silver not black) and gasket, fuel pressure regulator vacuum hose.

    So far all is well, with the exception of some spark knocking at the higher end of the 3rd and 4th gear.

    Cost $0 Ford Extended Warranty (Only 3 months left)
  • selooseloo Posts: 606
    After the recent repair (message 2219), I have noticed a vibration in the gas pedal at different times in the operation of the van (mostly in the first and third gear).

    Any ideas?
  • selooseloo Posts: 606
    After further investigation, I found that the dealership left off a support bracket on the throttle cable. Once I re connected the bracket to one of the studs on the top of the driver's side strut the vibration disappeared.

    That is a very sensitive cable. While doing that I found the female portion of an electrical connector (near the wiper motor). I am still for its mate.
  • :confuse: check engine light
  • alcanalcan Posts: 2,550
    It's an amber warning light which is illuminated by the engine control computer when a fault is detected.
  • Hello, to all the experts on a Ford Windstar,
    I live in Germany and just recently bought a Ford Windstar, produced in 1998.
    The car is running smoothly, but there seems to be a constant problem with that TRAC OFF light that ever so often flashes although the Ford dealer has tried to solve the problem. They replaced that control module (ABS), replaced the cables from the break cylinder and cleaned all the cable ends. But without any proper result.
    Can anyone help on that problem???
    Ford Germany is obviously at a loss here.
    Please, help me, as I still got guarantee on that car, which is great fun to cruise in.
    Enjoy your holidays and have a happy New Year.
    Reinhard from Germany
  • Thanks, we got it back going but at times it still wants to cut off. We'll try the suggestions, thanks!! :)
  • I have a 2000 SEL. After taking my foot off the accelerator the vehicle continues to run at the same speed. After the car is stopped the tach reads about 1000 rpm and will slowly drop to about 800 (with foot on brake while in gear). My mechanic replaced the idle air control valve but the problem is still there. We are both stumped as to where to go next.
  • ron49ron49 Posts: 1
    I am writing to see if anyone has had a problem with airbags on 2003 Ford Windstars. My mother had a serious potential problem with a head on collision. A young kid went left of center around a corner, and hit her head on in her lane. She saw him coming, and got as far to the right as she could. Any further, and she would have gone over a fifteen foot ravine. He hit her head on from the center of the van over to her drivers side. She had four other passengers also in the van. All were taken to the hospital.

    The bumper was all the way back to the tires, and the air bags did not go off. The engine also did not shut off, as it was supposed to. The person that hit her had skid marks 150 feet long, and hit her really hard, probably totaling both vehicles. Luckily, no one was injured very seriously.
    Everyone had injuries. Has Ford addressed this problem with both the airbags not deploying, and the engine not shutting down as designed in an accident? In addition, she has had continuing problems with the transmission not shifting correctly, and no one has fixed this problem.

    This vehicle is not a safe vehicle for my mother, who is 70 years old. I don't feel safe having here drive this vehicle, and wonder what Ford will do about this problem. We have gotten no where with Ford.
  • flj168flj168 Posts: 12
    Hi Folks,
    After a 800 mile drive over Christmas, my "95 Windstar's windshield wipers and front power windows stopped working. I checked the fuses, they look okay. Does anyone know to resolve this electrical or mechanical problem?

    Thanks,
    Fred
  • Hey, did u ever get that tensioner off, I am going through the same prob with my 1995 STAR. I have all the bolts off but can budge the large on going through the center of the tensioner.
  • alcanalcan Posts: 2,550
    If the tensioner has to be rotated counterclockwise to release belt tension, the centre bolt is usually left hand thread.
  • Have the same problem. Have found a vacuum hose that is disconnect but am unable to find where to plug back in,must be somewhere in back of engine block but it is almost impossible to see back there even tried using mirror. Anyone know where connection is.
  • I HAVE A 2001 WINDSTAR. IT SEEMS TO BE RUNNING GREAT, BUT LAST WEEK THE ENGINE LIGHT CAME ON. THE DEALER WANTS A COUPLE HUNDRED DOLLARS JUST TO DIAGNOSE. IT HAS ABOUT 45K MILES ON IT. I AM NOT SURE WHAT ALL THESE POSTS MEAN WHEN THEY SAY "WHAT CODE"? tHIS IS THE YELLOW LIGHT THAT IS A PICTURE OF AN ENGINE. ANYONE HAVE ANY IDEAS OF WHAT IT MAY BE?
  • selooseloo Posts: 606
    Check the simple things first: Replace the Air Filter, then fuel filter, PVC Value. After that check on the vacuum hoses in the back on the engine.

    If it is not something simple, then the intake manifold gaskets or EGR ports maybe the problem.

    Good Luck
  • alcanalcan Posts: 2,550
    "I AM NOT SURE WHAT ALL THESE POSTS MEAN WHEN THEY SAY "WHAT CODE"?"

    They mean which stored diagnostic trouble codes were retrieved from the engine control computer when a code reader or scanner was connected to the vehicle's diagnostic port.

    "THE DEALER WANTS A COUPLE HUNDRED DOLLARS JUST TO DIAGNOSE."

    AutoZone will retrieve DTC's no charge.

    "ANYONE HAVE ANY IDEAS OF WHAT IT MAY BE?"

    No, and neither does anybody else without the trouble codes.

    Btw, please turn off your CAPS LOCKS. It's the internet equivalent of shouting.
  • jeffyscottjeffyscott Posts: 3,855
    If that is the current version of the "check engine" light, I'd check with what other dealers in your area charge. Nearest one to me is down to $70 for that diagnostic charge.
  • an engine light is most likely a sensor ex. m.a.p,o2,egr valve if you have an auto zone in your area they do the diagnostic for free.
This discussion has been closed.