Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Windstar Problems

1115116118120121124

Comments

  • chrisrkochrisrko Posts: 2
    I also have a 2000 Ford Windstar with the same problem. Does anyone know how to replace the pressure switch? I know that it is attached to the master cylinder. Will brake fluid leak out if I replaced it myself? Please advise.
  • chrisrkochrisrko Posts: 2
    I have a 2000 Windstar. Does anyone know how to replace the pressure switch that is connected directly under the master cylinder? I know that the switch operates from the pressure of the brake fluid. Do you have to empty the reservoir before replacing or can I just unscrew the old switch and quickly screw in the new switch without too much brake fluid leakage?
  • wsharpewsharpe Posts: 2
    I have roughly 93,000km on this used vehicle I bought a year ago. The problems were minimum and up to now the most expensive fix were the brakes on all tires.

    (This all happened at same time) Ok, I have my ABS light on, my air conditioning does not work, my cruise control does not work, and my odometer and speedometer does not work. Now, I replaced fuse 10 in the fuse panel just left of the brake pedal. Everything works except for Cruise Control :confuse: .

    After while The fuse would blow again, I tried this a few times and there is no pacific time it does go. So, I checked all the wiring, that I could see (I do not know much of anything about vehicles - I know how to change a tire, hehehehehe) nothing seems to be broken or frayed. Also, I looked for leaks, like the master cylinder leaking on wires and melting the sheathing down till they short, but nothing there, everything seems pretty dry in there. (Under the hood and down by my feet).

    (Is this True)
    Then, I was told it could be a relay in the fuse box in the cab. I was told to replace the blown fuse (10), then start the vehicle and turn my A/C up full blast and to make sure to monitor the relays for how hot they might get. Supposedly a bad relay will get hot before it blows a fuse. I did this and one got a little hot (R2) and the one above it got Hotter(R1). So, if I replace this hot relay will that stop my fuses from blowing?????? Is this all true or hog wash?

    I still have now clue how to fix my Cruise Control, but, I am not worried about it, as long as I get my speedometer and odometer fixed.

    I am new to this forum, so any help is greatly appreciated.
    Thank You

    Wayne
  • stamastama Posts: 2
    my 02 windstar has been wonderful i have never had any major issues and have had just regular maintence done on it. Now the brakes have failed and the pads and rotors are in normal condition and there is also normal brake fluid. Had it taken to a ford dealer mechanic who after they checked everything told me he took it for a test drive and all is normal. i asked him to keep vehicle and rec check it as i dont want this to be a recurring problem. Any help?????????????
  • jimskinsjimskins Posts: 11
    I have an 02 Windstar currently in the shop for brake problems (see posting # 2412). It has been at the dealer every week for the last three weeks. My problem is that the rear brakes and/or emergency brake engages when backing up and the brake light on the dash comes on. A couple of times the brakes were grabbing while driving forward. The dealer has been on the Ford hotline multiple times. They have just put on new shoes and resurfaced the drums. I doubt this will help, though. Just be careful driving as I have heard other issues where the brakes fail altogether. You may want to check mycarstats.com
  • aceladyacelady Posts: 10
    okay, i thought i had gotten a good deal when my trusty plymouth voyager bit the dust, now I'm not so sure. I paid $750.00 USD for it and have spent about $600.00 in repairs. The windshield needed replaced, the lock actuator was bad on the drivers door, the rear wiper motor didn't work, there was a brake job, the cylinder switch for the speed control. Some of the things I was able to take care of cheaply (least expensive being the .80¢ repair to the drivers door the fix the switch the previous owners had disconnected, I had to have it because stupid me leaves the lights on and I had been jumped 3 times)

    Now the ac isn't blowing cold and I am wondering if I can use a recharge kit from autozone to fix it? I don't know what type of refrigerant it has? Any thoughts?
  • ramjitramjit Posts: 1
    I had that problem and it turned out to be a broken piece in the upper intake ( the black piece that you see as soon as you open the hood)you could replace it yourself for about $200 to 300. you have to get it from the dealer.
  • mlpntrmlpntr Posts: 61
    I paid $600 for my 1995 Windstar. Then I turned around and spent $2100 to rebuild the trans with custom (non Ford) parts. Have a 3 year warranty on it so it's not all bad. Rear wiper doesn't work. Previous owner said it quit working after it went through a car wash. You can hear the motor working, though. All doors are fine but also had to replace a fuel injector, plug wires, coil pack, and computer. Not too bad yet. Sway bar is busted but it's an easy fix and the junk yard has one for $45. Engine was rebuilt 2 months before I bought it.
    As for the AC. I recharged mine and it blows 47 degree air. You can go to Auto Zone to pick up the R134a and a filler hose. I recommend one with a guage. You shouldn't put more than 2 cans in unless it's bone dry. Walmart also has the stuff for cheaper than auto zone.
  • mlpntrmlpntr Posts: 61
    It does need to relearn but that shouldn't take long. 3 drive cycles should do it. Bring the van up to 60 and then drop it to 40. Do that 3 times and it should be fine. If not then you may have a bad computer.
  • mlpntrmlpntr Posts: 61
    Mine did the same thing. You can pick up an injector at Auto Zone for $32. Easy to replace.
    However, the injector didn't fix the problem. I replaced the computer and it was fixed. 3 weeks later it did the same thing and said misfire #4. I drove it for another week and it stopped. I'm thinking another bad computer but I could be wrong.
  • mlpntrmlpntr Posts: 61
    Go to a Ford dealer and ask for a "good faith" repair. Or call Ford direct.
  • cptpltcptplt Posts: 1,075
    I had an acura and a chevy which did that with intermittent brake failure, it was the master cylinder both times.
  • jasong1jasong1 Posts: 3
    Hello,

    I have a 2000 Windstar SEL that has recently run into Brake problems. I don't know exactly what symptoms you are having but mine started with a little brake fluid on the garage floor followed by the brake light coming on EVERY time we stepped on the brake. I took it to my Uncle's repair shop where they replaced a switch that is right below the Master Cylinder due to a leak. He ordered the part from Ford ($20.00) where the delivery driver from Ford indicated that he is delivering about 20 of these per day; which indicates that there is almost certain to be a recall on this part soon...so save your receipts and the bad part for reimbursement.
  • wsharpewsharpe Posts: 2
    I replaced the relay and it now works fine. I noticed that the brake warning light came on after I fixed the initial problem, I checked my lvls and it was only a tiny bit below the minimum, so I top it of at the max and it works fine. So it is 3 days now and it is working fine..... Hopefully that is the end of that problem.
  • gergsgergs Posts: 1
    My 01 Windstar with 52k miles has the abs and brake light constantly on. What is the problem?

    Thanks!
  • helpeehelpee Posts: 2
    Did you ever receive any suggestions as to the cause of the problem with your 2001 windstar not starting? I have a 2000 windstar currently sitting at our church parking lot with what appears to be the very same issue. Any help would be greatly appreciated. Thanks, Tom
  • helpeehelpee Posts: 2
    I have a 2000 Ford Windstar. Some days, mostly hot days, the van will not start. It turns over but won't fire. I leave it sit for some period of time then it starts. It appears to be a fuel pump issue (I'm guessing) but, from what I'm reading on the net it appears others are having the very same issue and the solutions don't directly point to the fuel pump....

    Any ideas on what may cause this problem?
  • bkbeldenbkbelden Posts: 1
    Wayne,

    I have a 2000 windstar LX and Mine just did the EXACT SAME THING. Were you not able to control the rear blower? In my van, the Rear AIR blows air, not cooled air. I have to reach over the passengers side sliding door and tun off the blower. It is not able to be controlled from the front.

    Can you tell me what relay you replaced?

    Mine has just come back from the FORD dealer where I had them look at the Cruise Control (Amongst other things)Funny Huh. It was going to be a $350 fix. Needed a Speed servo and a couple of other things. :-) I told them nah for now. But surprising that you had the exact smae problem.

    brad
  • trobartrobar Posts: 2
    i am the second owner of this van which at this time has 120,000 miles on it i was extremely satisfied untill lately i have just paid 1800.00 dollars to have the transmision rebuilt but being as reliable as it was i saw no problem with spending that amount even though it was all we had set aside at that time now three weeks later the engine light comes on and engine dies on highway with my daughter driving the light comeing on and the engine dying happened at literely the same time she had the van towed to my house as it would not start i thought the alternator was bad so i removed it and had it tested it was ok while i was doing that i put the battery on charge thinking no alternator no juice when i got home i reinstalled the alt and tried to start still wont turn over so i removed the starter and battery to test both of them again both good and engine still will not turn next thought wsa timing belt i havent done any more after starter/ battery i would appreciate any input out there as where to go next or if my next step is correct in process to fix the other steps were basicaly simple and with the side mounted engine this would be more hard and time consuming
  • mlpntrmlpntr Posts: 61
    You need to find out what the code is on the check engine light. Either get it to an Auto Zone to have it tested or buy a OBD2 tester. You won't know the problem until you do. Once you have the code post it here.
This discussion has been closed.