Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Windstar Problems

1118119121123124

Comments

  • mlpntrmlpntr Posts: 61
    Had the same problem on my 95 and it was a bad computer. Do you get a check engine light?
  • telfordtelford Posts: 2
    Thanks so much for the help-I will give it a try!!!!
  • jessie23jessie23 Posts: 3
    no engine light on, i had that problem awhile ago n had a computer chip replaced under warranty
  • redbaronsredbarons Posts: 4
    :( Have a 99 Winstar with approx. 90,000 miles & the check engine light is on ( again ) code states - Left & Right Bank TOO LEAN !! Ran Fuel Injector cleaner through and reset the light . Everything went great for quite a while ( almost forgot all about it ) but now it is back again . Car runs fine , smooth & same power !! Anyone have any problems with engine light with a TOO LEAN CODE ?? What did you do ? Seems that a cleaner should do the job ...
  • aaron01aaron01 Posts: 3
    hey Wayne,I finally decided to get online to research for answers to the same problems you are having with my 2000 ford windstar sel-speedometer,ometer,air conditioning,not sure on cruise,but I also replaced #10 fuse on drivers side and fuse immediately blows no time for a relay to get hot,I was just wondering if you were able to fix your problem any helpful information would be greatly appreciated,the windstar sel is a cool looking and comfortable van but after replacing transmission already and now this I am considering selling mine and it is way too hot with no ac right now,very frustrating problem and i just cant seem to figure it out,thanks for any help,Aaron
  • littlemomlittlemom Posts: 5
    I had the same problem with my 2001 windstar. It turned out to be a problem with the intake manifold. The bolts holding the manifold down had loosened over time, allowing air to come in. Watch the intake manifold while having some on press on the accelerator. If the manifold cover moves, it is allowing air to come in and will cause the check engine light problem you are getting. Hope this suggestion helps. :)
  • mlpntrmlpntr Posts: 61
    You would think but not the case. There was a tech bulletin released on the too lean and too rich codes. Replace your MAF sensor. It's very easy to do. It's right behind the air filter houseing and is in line with the air intake. It's the thing with the wire harness attached.
  • mlpntrmlpntr Posts: 61
    Have the computer checked. It's behind te glove compartment.
  • aprendizaprendiz Posts: 17
    I have the master lighting warning on, have not manual and dont know even what it mean. Any info? How to fix?
    Thanks
  • mlpntrmlpntr Posts: 61
    What do you mean by master lighting?
  • aprendizaprendiz Posts: 17
    May be I'm wrong, but is the name as found in other Ford owner manual. It's a warning icon, like a "lamp on" with an "!" inside.
  • mlpntrmlpntr Posts: 61
    Ah, that would be the master cylinder. Your brake light.
    First, check to see that your emergency brake is released. Next check the brake fluid level. If everything there is fine then change the brake pads (if needed). Next to check would be the brake lines and master cylinder. You maywant to have a technician check the brakes, brake lines, and master cylinder unless you have done it before.
  • aprendizaprendiz Posts: 17
    No it's not Brake icon, brake is red one and I know it. My unknow light is lightly yelow and it is in the right lower corner of the instrument cluster (windstar 2001). In a Taurus 2003 owners manual is referred as Master Lighting switch but my lights and sw seems to work properly.
    Thanks for the help
  • basem37basem37 Posts: 4
    hi i have problem with my windstar 2001 LX. the airbag light and ENGINE LIGHT is not on all the time. when i turn on the start key only these lights is not on. can anyone help me please with this problem. and please can anyone tell me is the 2001 ford windstar LX is good car or no. i just bought this car from 2 month ago and i'm scare if this car give me problems later. thanks
  • mikandjenmikandjen Posts: 2
    we had been having this problem as well. took it to a local shop who sent us to an electrical shop. they thought it was in the cluster as well.So we took to the dealer. turns out there was a stuck (broken) vaulve in the master cyl. that was causing fluid to drip onto the wiring causing everything to short out. Seems that they had seen it before as it took less than two hours to find and fix. $230 total with tax.
  • aprendizaprendiz Posts: 17
    Brake lights!! I have no brake lights at all! Any wiring around for a windstar 2001?
  • aprendizaprendiz Posts: 17
    Any fuse chart? or at least fuse code for stop light fuse?
    Thanks in adv
  • aprendizaprendiz Posts: 17
    Fuse and switch are ok. There is any relay in this system?, any wiring?
    Thanks
  • mrjjpmrjjp Posts: 1
    Every so often when I shut off my Windstar the cooling fans stay running and will never shut off. I disconnect the negitive cable from the battery and re-connect and it keeps running.. No one can resolve this.... Help???????????
This discussion has been closed.