Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Windstar Problems

1118119120122124

Comments

  • matilematile Posts: 1
    THANK YOU SO MUCH. I believe this solution also solved our Fuse #10 repeatedly blowing (takes out odometer, speedometer, air conditioning, and ABS light comes on). We followed your advice and replaced the brake pressure switch with the redesigned switch (SW-6351 XW7Z-9F924-BA Brake Repair Kit) and so far the fuse has not blown. This part cost about $25.00 through the Ford dealer.
  • remi96remi96 Posts: 5
    Its at the dealer now. first they replaced the coil assembly, the van was misfiring, thats all fixed now. they reprogrammed my computer or updated it... now they are checking the transmission. Oh boy am I ever sorry I bought a Ford Windstar.. never again. only 30,000 and I can't tell you how many things have been fixed or replaced.Its irrelevant that I have my own extended warranty and a great plan too.. its annoying and I dont trust the van at all. :lemon:
  • bclaytonbclayton Posts: 2
    My speed control just QUIT, anyone delt with this problem?
    TIA Bill
  • remi96remi96 Posts: 5
    I recently brought in my van to the dealer (30,000 miles) cuz it was misfiring, and at 38 mph + it was shuttering. They replaced the coil assembly, updated my computer, now the other problem they say is the torque converter. they have to take everything apart for my extended warranty company to get more info on what they will approve. If the torque converter is replaced, does that mean the whole tranny needs to be done or what.. totally confused and annoyed that this is in the shop AGAIN. :confuse:
  • pepper4pepper4 Posts: 10
    Hi

    When you first start the van it will run rough for 30 seconds and runs fine and idles fine then and i do not get a check engine light. The van has 114,000 miles on it.

    pepper4
  • mlpntrmlpntr Posts: 61
    Chances are that the torgue converter is clogged with bits of metal due to a damaged piston. You will likely need a complete overhaul. Mine has been through 3 and is a 1995 with 130k. First one was at 50K.
  • remi96remi96 Posts: 5
    thats great news, well before i go on my 2nd round, i will dump this and get something and not a ford thats for sure
  • aceladyacelady Posts: 10
    I have finally gotten to the point that I have cut a piece of electrical tape over the check engine light because I am tired of it flashing at me. I think it does it just to mock me.

    The code says there is a misfire on one of the injectors, the injectors have all been replaced within the last two months, as has the alternator. I've also replaced the spark plugs and the wires.

    Any ideas? My van is a '96 GL and I really do like the ride, am not crazy about the gas mileage, but it serves me fine ;) :) :)
  • bclaytonbclayton Posts: 2
    Hi
    I recently had a similar problem with the kids 2003 van, Check engine light was flashing, took it to Auto Zone and they checked it on there hand held computer. It said check wires, plugs, coil, injectors.I replaced wires, plugs and coil and had same code show up. Finally took it to dealer who checked the injector, which were ok. They did a compression test and found a broken exhaust valve spring on #3 cylinder. This caused the engine to run rough. Replaced the spring now everything is all right.
  • Hi everyone; its my first post here but I was very active on CarTrackers until it went dead. I have read a few replies for this problem and I think it has been answered but I will add my 2 cents. The heating/air conditioning switches have small vacuum lines going to them and some of these lines go into engine compartment. The default situation when one of these lines develops a hole or leak of some kind is DEFROST only. So to fix, one must carefully examine all these lines to find the break. You may wish to start at the 3 dash switches. Escapes me right now how this panel is removed. A helpful hint-did someone just finish working in the engine compartment? Anyways, glad to be abord. SHADETREE 98 Windstar with potential ABS/Trac Control module problem
  • my3girlsmy3girls Posts: 1
    The ABS light is coming on intermittently. My local garage says it's a relay. They used to be able to replace relays but now it's a whole part replacement. Anyone have any ideas? I'm told it's safe to drive even with the light on.
  • mlpntrmlpntr Posts: 61
    Could be arelay but these wonderful vans are famous for the ABS light (among other things. Ther is an issue with a ground wire that causes the ABS light to come on and Ford offers a fix kit for $10.00. Save your money.
    It's safe to drive with the ABS not working as long as you remember how to brake a car before ABS was a feature.
  • mlpntrmlpntr Posts: 61
    Driving for a year with CEL on was very, very bad. You probably needed an injector. Check the oil and smell it for gas.
    Chances are you blew the engine.
  • remi96remi96 Posts: 5
    Mine has been going on and off for two years and i dont see any reason to spend anymore money than I already have on this car. i dont see any difference in the braking either ;)
  • aaron01aaron01 Posts: 3
    so your saying your speedometer,o-dometer,air cond,abs light was all disfunctional and your valve was stuck causing fluid to leak on a wire and short everything out,no offense but either your disfunctional or an all day sucker cause whats the chances of a wire being exposed without its protection on,and leaking fluid on that same exposed wire,theres a sucker born every minute you either work for Ford or just trying to be funny,thanks for the humor,if your serious you got took because this is definately a relay problem or brake switch prob of some sort which is much easier and cheaper fix,two hours to find it took them maybe two minutes incase you havent noticed alot of these people have this prob,while you where waiting for your vehicle for the other hour and 58 minutes,they where ordering lunch,ON YOU!!!!!!!!!Ford Windstar-SUCKS NEVER AGAIN!!!!!!!!!!useless van good for its looks and thats it
  • basem37basem37 Posts: 4
    Hi.. i have the airbag and engine light is not on when i start the car so i check my car on the computer and it's show code and i need to know how to fix it if anybody knows please thanks
    code : B2499 (COURTESY LAMP OUTPUT Failure) :cry:
  • mlpntrmlpntr Posts: 61
    Could be a fuse or the bulbs.
  • mlpntrmlpntr Posts: 61
    OK, it's 12:17 in the afternoon. I've had 3 hours sleep (just woke up) because from 9pm until 9am I was changing a fuel injector on a 95 Windstar 3.8L. All I want to know is who designed this stupid van? Not only do you have to remove the alternator and bracket. To do that you have to remove the serpentine belt. Then you have to remove the throttle body. Oh, the serpentine belt was so much fun even with the special tool. Well, to remove the throttle body you have to remove 4 bolts that you can't get to unless you are a 1/2 inch tall elf. Then once you get all of that off you have to remove the fuel pressure regulator. Yeah, that was a treat. Then you can't even lift the plenum all the way off because there is something blocking it that you can't remove. Oh, and to get to all of that you have to take off the antenna and wiper arms so you can remove the upper and lower cowl. So I was stuck with not being able to get the plenum all the way off and had to change the injector with about a 1/2 inch clearance. Try and remove the clip with that much space. So now the injector is in and it's time to put it all back togather. It was much easier taking it apart.
    I will never change another injector in this stupid van. I will pay someone $500 to do it for me just to save myself the blood(and lots of it), sweat, and tears. I even had the man helping but his arms were too big to reach some of the bolts. He's 250lbs. Even my arms (and I'm 5'4" and 120 lbs) were slightly too big (that's where the blood came from). So unless you are a very small 5 year old with an genius knowledge of cars I would suggest paying the shop.
    12 hours for ONE lowsy fuel injector.
  • basem37basem37 Posts: 4
    :confuse: i don't know i see many people dosne't like ford. but the same time i see too many people have ford cars. and i know ford not a cheap cars . so i don't know who should i beleieve people have ford and they love it or people hate ford :confuse: :confuse:
  • aaron01aaron01 Posts: 3
    let me tell you something about Fords-the f-150,mustang and a few other are decent but my 2000 windstar,I paid $8,600 beginning of year and had to put a new tranny,battery,now this speedometer,odometer,ac,abs light-disfunctional probs,the van looks and rides good but if you want a Ford,I got one for you cheap $6500 will buy it and Ive got well over $10,000 in it and thats recently so if you want a Ford Windstar with a new tranny buy mine ,BEFORE IT GOES OUT AGAIN!!!!!!
This discussion has been closed.