Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Windstar Problems

1646567697083

Comments

  • brd3brd3 Posts: 6
    User777,

    Thanks for the tip. I'm going to bring the car to a Ford dealership that someone the family knows to have this problem looked at again. Unfortunately they are about 30 miles away and scheduling is difficult. I don't mind paying to get a broken part fixed, I understand things don't last forever, but after experiencing an $ 800 dollar oil change "Plus a bunch of stuff I didn't need or ask for" at a Ford dealer I'm a little apprehensive using Dealer repair shops.

    The seat belt buckle involved 3 trips to the dealer, without a car for 5 days and I was told they had no idea what was wrong after consulting directly with Ford about the problem. The distrustful side of me wonders that no one is really looking for the source of the false readings because of the "Repair Bonanza $$" it brings the the Dealership repair shops.

    Hopefully all will be fixed on the next (I hope and last) visit to the Dealer.

    Thanks for your thoughts
  • MOTORIZED SLIDING DOOR - Another Suspect

    First, thanks for the fix. :)

    Another potential problem we found was in the door gasket area. :mad:

    Located at the top of the van's sliding door opening is a gasket that had shifted forward when compared to the other door. The end of this gasket was trapped against the pillar (between the sliding and front doors) when the door closed. The gasket bulged out at the end causing it not to latch properly.

    We re-adjusted the gasket (OK, we just slid it back into proper position..a little) and while it wasn't a 100% fix, it is closing more frequently now.

    We'll try your uplifting door experience/experiment. Maybe then we will experience 100% 'closure'. ;) We'll let you know.

    Just say no to FoMoCo,

    Clint
  • The service engine soon light has been on for a year. The van runs fine, and I am not going to waste any more money having it "FIXED" only to have the light come back on with in a day or so.
    How can the service engine soon light be disabled????

    HELP!
  • jeffyscottjeffyscott Posts: 3,855
    I once had another brand of minivan that was in bad enough shape that I did not want to spend much on repairs. I took care of the service engine light with black electrical tape. Then eventually the light burned out. :)
  • I picked my 1998 windstar up for the mechanic today. After paying $450 last week and $790 today to get the check engine light to go off. If this was the only problem, there wouldn't be one. Since I've owned the van, July 2000, I have had problems with that light. My first mechanic, would fix the problems, reset the computer, the light would go off and within the week IT CAME BACK ON AGAIN!

    This happened over, and over again. Until he just disconnected it. No problem until last year. Our state required an EMISSIONS TEST when the car is inspected on models 1996 and older.

    The check engine light had to come back on, and the real problems began. I had two 02 sensors replaced, along with some other sensors. within two weeks because the light kept coming back on and I had to continue to take it back to the mechanic. After paying $1,000 (Sept 04) I thought I was through. But before I could get it inspected, :mad: the light came back on. I just left it, no inspection, and took it back in last week. IN about one year I have spent $2200.

    Is there any end to the check engine light problem????
  • user777user777 Posts: 3,341
    the flippant answer is to find another ride.

    seems like it's possible it may be mis-diagnosed by your mechanic... if you want to stay in the vehicle, i suppose i'd bring a record of everything done to it, and take it to someone else.
  • ClairesClaires Chicago areaPosts: 976
    Brinda, you could always ask the people in the "Check Engine" Light discussion -- they might have some ideas.

    MODERATOR
    Need help getting around? claires@edmunds.com - or send a private message by clicking on my name.

  • I am attempting to trade my 02 Windstar SE. I received a very low trade value on it. Can I get a candid assessment of its value?
    2002 Windstar SE (53,000 miles)
    All Standard equipment
    Dual Power doors
    Rear entertainment package
    adjustable gas and brake peddles
    power driver seat
    quad seating
    one accident (over $4000 damage)
    clean well kept interior

    Thanks
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,539
    You need to post this question HERE:

    Real World Values

    Be SURE to follow the posting format suggested at the head or tail of the page!

    Host

    MODERATOR

  • Our 2000 windstar lx experienced the same thing at 103,000km. My wife was stopped at a red light when suddenly she heard a loud clunk (as if some one had ran into her front end) and then only reverse gear. I had it towed to the ford dealership because I had purchased an extended warranty when buying it (120,000km -7yr.). It is waiting for analysis but thet seem hesitant to honor this warranty due to the fact I had not followed the maintenance requirements to a tee. Any help would be appreciated.
  • I also have the same problem on my 96 Ford Windstar ... All air will go out of the defroster vents and will not direct to the front vent ..etc ... Can anybody tell me how to fix this problem ? The Dealer wants $600 to fix it ... I think its a switch or vacuum line ,,thx
  • mark80mark80 Posts: 3
    We just had a fuel injector replaced after a chugging cold start and the service engine light going on.
    Now after a $240 repair, we had another chugging cold start (engine is missing)
    and the service engine light comes on.
    Any ideas for what to do, would be appreciated.
  • mark80mark80 Posts: 3
    You are here: Forums Ford Windstar Ford Windstar problems (In All Boards )

    Welcome to the Forums!
    To get the best response to your questions and comments, please post in an existing discussion about your vehicle or the automotive topic you wish to discuss.

    Looking for a Discussion?
    Use the menus on the left: Browse by Vehicle, Browse by Message Boards or Browse by Topic

    If you don't find a discussion that fits your vehicle or topic, please Search the Forums or ask in the discussion Forums Discussion Finder: Get Directions Here

    Ford Windstar problems

    2066 messages, Last post on Oct 04, 2005 at 4:33 PM

    This discussion is part of the Vans & Minivans Message Board.
    Your Host is claires

    What is this discussion about? Ford Windstar, Van

    Get a price quote on a Ford Windstar Be the first to rate this vehicle.



    We just had a fuel injector replaced after a chugging cold start and the service engine light going on.
    Now after a $240 repair, we had another chugging cold start (engine is missing)
    and the service engine light comes on.
    Any ideas for what to do, would be appreciated.
  • alcanalcan Posts: 2,550
    Start by retrieving any stored diagnostic trouble codes and posting them.
  • mark80mark80 Posts: 3
    The stored diagnostic code was # P0306
    Just a week ago we had replaced the # 6 injector which cost $65 for the part and $170 for labor.
    Now, we are having rough cold starts, and once the engine started missing.
    We added an injector cleaner to our gas tank, and on the next start our check engine light went off.
    Any ideas for avoiding another $235 repair?
  • my 99 WS check eng light came on an I found out it is 1507 but I don't know what to fix to get ride of it its not idelling good ether
  • next to the drivers seat to the left is a safety device that prevent vehicule spill gas in an accident. If malfunctioning it will block the gas feeding ramdonly when driving normal
  • I put in a new transmission last week in my 99 windstar. After I got it back my check engine light came on with a H0135 and H0133 code. Any relation or is it a coincidence. I took it to the trans shop and they looked it over and cleared the code. After 10 miles it came back on. They are scheduled to take in in on Thurs. Should I suggest anything or expect anything. Thanks in advance.
  • As I posted earlier I had a new tranny put in last week. I noticed this weekend that from a stop position, if I am making a left or right turn, forward or backward, I get a thump / clunk sometimes, although its hard to duplicate. It sounds like it is coming form the passenger side wheel well. What should I look for?
  • rollerroller Posts: 1
    2000 windstar sel 55,000 kms. Van just died waiting at a red light will crank over but won't start ( slightly raining that day). Theft light flashes quickly and airbag light is on when cranking engine. Called Ford they said it was bad key try the other key and it started. Put supposed bad key back in and it starts too?!!! Went to dealer and was told $69 to pull code to try and diagnose problem. I said no and van has died 2 more times since, both at idle, in drive and all 3 times were on slightly rainy/drizzle days. Sounds like a common problem reading some of these messages. Anyone have a fix?? Is it water related or just a coincidence. By the way, the PCM was replaced with a recall when van was 2 months old along with all the other recalls.
  • alcanalcan Posts: 2,550
    There's no such thing as "H" codes. If you mean "P" codes, here ya go:
    P0133 O2 Sensor Circuit Slow Response (Bank 1 Sensor 1)
    P0135 O2 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1
    Either they didn't re-connect one of the O2 sensor wiring harnesses, one of the sensors got damaged, or Murphy was around and decided to nuke the sensor. Your call.
  • alcanalcan Posts: 2,550
    "What should I look for?"

    The phone number of the shop which did the repair and your invoice.
  • 2000 windstar se with 51000 miles, the right side power door will only open app 12 to 14 inches by using the power switch, will close properly. If you manually open the power door, it will open the whole way. Also some times when coming to a stop or slowing down for a turn, the transmission will down shift and act like it is skipping or missing the lower gear, making a clunking noise.

    Anyone having the same problems, and what has been done to fix the problem. Any help would be appreciated.
  • Been there done that, along with many other issues on my 2000 Windstar. Just had ABS module replaced and now a week later it looks like the Blend Door Actuator problem has come up on my Windstar. I'll never buy another Ford.
  • Hi,
    My 2001 SE has the turnsignal arrows in the side mirrors. The passenger side arrow is continually lit at about 1/2 brightness. The drivers side is working OK. I've checked all the bulbs, turnsignals etc all seems to be OK. This is the 3rd time this has happened, the last 2 times it's disappeared itself. When I do use the the passenger side turnsignal it does blink, but otherwise is on whenever the headlights are on.

    All help and suggestions appreciated.
  • selooseloo Posts: 606
    Gang,

    My 2000 SEL (89,000) just returned from the shop. It required a new engine program to address spark knocking; a new ABS control mod and valve ASY to get rid of the ABS light; and a new crankshaft and bearings to address an engine knocking issue. While they were there they replaced the spark plugs.

    Total Cost: 56.70 for the spark plugs.

    The Ford ESP Premium is the best extended warranty in the market place.

    That $850 investment had paid for itself about 5 fold; plus I always get a free rental!

    Highly recommend it for Windstar owners.
  • ccwebbccwebb Posts: 1
    My 2002 windstar SEL just started acting up. The running lights won't turn off (intermittent). Took it to the dealer, who can't find any problems. So far, it has only happened at home, but I am sure it will strand me somewhere with a dead battery. Anyone else having this problem? Suggestions? Other than buy a Honda? This is our third Ford, and I will NEVER buy one again. :mad:
  • I noticed alot of posts about the front coil springs. Anything about the rear springs out there? My 2000 Windstar has the same squeeking noise everyone is talking about. My husband took apart some stuff to grease it up. While doing this, he took off the spring and noticed that it was broke in two. We don't know how long it has been like this. I noticed there was a post about the front coil spring. I haven't found anything on the rear. Anyone else have this problem or know anything about it? I called to find out price, and they said a total of about $400 to get both replaced.
  • I have partial lighting on instrument cluster and no lighting now in climate control area of 1998 Windstar LX. Is it possible to fix at home or do I need to take it to a garage. any help appreciated
  • I thought I had a brake problem took to mechanic replaced front brakes and rotors said fine, still had same problem 537.00 later, feels like I have no brakes, the ABS is kicking in as soon as I hit brakes I guess, feels as if I must hit petal to metal to stop yet all brakes fine. Had code ABS light but goes off and mechanic said no code reading. He suggests I disconnect ABS, sounds scary. He says sensor is 1000,00. I had the ABS sensor on wheel replaced 2 years ago. He says this is computer maybe??? Anyone have this problem ?
This discussion has been closed.