Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Impala: Problems & Solutions

1525355575885

Comments

  • etcarrolletcarroll Posts: 87
    Just may be the way to go.
  • My wife had the same problem with a '95 Geo Prizm. It was the starter motor.
  • dwilmadwilma Posts: 1
    I have a 2001 Impala. About a week ago the day time running lights were not working. As I was confused about this I pulled on the headlight switch in the car and I had no headlights at all. The parking lights work and also the bright lights work, but nothing else. My husband has been a mechanic for 20 years and he has been working on this problem all week. He change the BCM ( I think that is the name of the computer) and the pull switch on the inside of the car and still no lights.

    Has any one else had a similar problem? What can we do to fix this problem!!!
  • charlief1charlief1 Posts: 10
    On my 2002 LS at around 16000 miles dealer replaced instrument cluster due to noisy tachometer and did the lube fix to the ISS. When I got the car back there was a rattle on left side of dash that only occurs at certain temperatures (30-50 F)and can be cured by giving a good rap to the bottom of dash on left side. Could this be due to something done wrong on the ISS fix or the instrument cluster replacement?

    Now at 33000 miles and just weeks left on warranty the tach noise is back, I still have the rattle at various times and I have a new problem: a squeak that seems to be coming from engine compartment on right side. The squeaking seems to go away after driving car a few miles but also doesn't occur at all if someone is sitting in passenger seat in front. Makes me think it may be suspension related. A bushing?

    Anyhow, I will be trying to get some resolution to these items at dealer in next couple of weeks but wanted to see if anyone in forum has any experience with any of these problems.

    Other than the various noises the car has been excellent in all other respects.
  • bh628bh628 Posts: 100
    Hi,

    I got my '04 Impala in December, base model. Really enjoying it.

    However, I found that whenever I go in or out (especially out) of a driveway, the front of the car will hit the pavement unless I go extremely slow. When it first happened, I thought it was because the tires needed air (which they did). This didn't happen in other Impalas I rented or test drove.

    After adding air, the problem lessened somewhat. However, it hasn't gone away completely. It's scary to have to go very slow backing out of the parking space of my doctor's office, onto a busy street. You need to go slow not to hit the car on the pavement, but the quick oncoming cars necessitate your needed to leave fast.

    I spoke to the mechanic I have seen for the last 13 years (fear of going to the dealer) and he told me that Impalas have a low profile. He said what I am hitting is the air deflector, and not to worry. He said to go slow, and try to exit/enter steeper driveways at an angle.

    Anyone else have this issue? Have you solved it? :confuse:

    Thanks so much for your help!
  • hchu1hchu1 Posts: 17
    I have a 2000 LS, I believe all Impalas are like this. You either have to take the air deflector off or learn to drive slow in and out of driveways. Think of the air deflector as a warning strip, it's just plastic and the noise tells you to slow down to prevent you from doing real damage to other areas above it. It's annoying, but it is really good for you. :)
  • charts2charts2 Posts: 618
    Just confirming post #1135, the air deflector like on most cars catches air and directs it to the bottom of the radiator for cooling.......the 2000 - 2004 Impala's is a bit low and it is not a concern, just an annoyance.......Chevy changed the design on the 2005 Impala deflector, it is a couple inches shorter and on more of an angle, less likely to scrape going in and out of driveways......in winter driving when there is more then 4" on snow on the road it acts like a snow plow which really becomes annoying...
  • You're the only person on the internet who has even suggested a knowledge of how to top off the power steering fluid. I have been a "shade tree" mechanic for 30+ years and I CAN'T FIND THE RESERVOIR FOR POWER STEERING FLUID ON MY 2000 LS -- Boy does that make me feel stupid!! I have looked in every nook and cranny of the engine compartment and still can't find where to add PS fluid. CAN YOU GIVE ME ANY CLUES?? I have the original owner's manual and it says "passenger side near the rear of the engine compartment". If that's a clue, it's a lousy one. HELP!!
  • i am new to this, but, here goes. my 2001 impala ls has a problem no one can figure out. the "traction active" light comes on and i feel a "pressure" against my brake pedal. it happens when i am stopping from a slow speed or am taking off at a slow speed. the traction control and abs lights intermittently come on, and i am sure that i don't have tire slippage. there is also a sound that goes with it. it sounds like a motor running or a pump running. i hear this sound when i feel the pressure in my brake pedal. took to the dealer and they said i needed a speed sensor. replaced that one as well as the other side. still have the problem and it seems to be getting worse.
  • pablo270pablo270 Posts: 1
    Hi, I have a 2000 Chevy Impala, and have the exact same problem with water on the right floor when it rains. I went through the same procedure as you also. I had a windshield replaced by a glass dealer, and at some point after that, the leaks started. I took the car back to the glass dealer and he told me it was common for leaves and debris to plug up the water drains. He took off the fender well and the plastic cowl assembly that is between the hood and windshield. He assured me that it was now fixed. I took the car home and ran the garden hose on the roof and let the water flow down the windshield. Within a few seconds, water was running out onto the floor inside the car. I immediately called the glass guy and he told me he did everything he knew to do, and he would refund my money for the work he did. My question to you is, did you ever get anyone to figure out why the water was leaking into your car? Thanks
  • lostwrenchlostwrench Posts: 288
    The air deflector does not direct air to cool the bottom of the radiator, but rather it forms an area of lower air pressure behind it which is filled by air flowing through the radiator above, thus causing a higher volume of air to flow through the radiator resulting in more efficient cooling. This counteracts the area of higher air pressure which forms under the front bumper area which partially passes through the front wheels. Notice how the front wheels are dirty with brake dust from the air flow going from inside the wheel to the outside, while the back wheels are always cleaner because the air flow through them is from the outside of the wheel to the inside.
  • charts2charts2 Posts: 618
    That makes sense.....the 2005 Impala deflector is much shorter and on an angle, how does that afect the air pressure behind the rad? Its half the size of the previous deflector......it definetly eliminates the scraping going over curbs anyway.
  • bh628bh628 Posts: 100
    Thanks for the info!

    The irony is that I had a choice between getting a 1SC (more options than 1SB) right away or having an '05 built. They don't make the Impala 1SC package anymore, it also has sedan sport pkg. I wanted the more options over the Onstar. Always pros and cons to every decision. I do love this car, though!

    Thanks for all the info. :shades:
  • emonteemonte Posts: 4
    Hey all - new member. I have a 2000 Impala with about 96K miles - obviously, I drive a lot. I have just starting experiencing a hard idle with inevitable engine failure (random) and also a hard shift when the automatic goes into 2nd gear. I also sense, at times, there is engine failure which corrects itself at high speeds (interstate driving).

    I did find some TBS announcements online but wanted to learn more about specific parts and if someone had a fix. :sick: link title
  • sgitlinsgitlin Posts: 1
    Greetings, all!

    I just purchased this car (used) with 13990 miles from the same dealer of my previous new car (2000 Malibu - 6 cyl base model) - recently totalled in a rear-ender.

    One thing that has surprised me is the ride quality which seems harsher than the Malibu - I feel every little bump in the road. Dealer says this is normal for this car and Pontiac GrandAm. It is the base model so the sport suspension should not apply. True?? Tires are the Uniroyal Tigers-Paw.

    Most postings I've read seem to comment positively on the smoothness of the ride. I'm not feeling vibrations in the steering (steering seems tight and positive), but in the entire car.

    No, I did not test drive the car. Was happy with the Malibu and felt this would be even better. Price was $11550. CarFax said OK. Car came off a one owner 3 year lease.

    Also, first thing dealer had to do was cut the rotors - brakes pulsated.

    Any suggestions, please?
  • nosirrahgnosirrahg Posts: 870
    There was a recall on many Impalas related to a fuel regulator, which might be the cause of some of your stalling/hesitation issues...mine got a little hesitant to start about the time I got the recall notice, and once I got the recall repair performed, the problem went away.

    I also had some hard shifting problems maybe a year or so ago, and as I recall there was some type of module that had to be replaced in the transmittion which solved the problem (seems like that cost @ $500).
  • lostwrenchlostwrench Posts: 288
    I wouldn't be concerned. If there was no deflector there, I would be.
  • jopuvajopuva Posts: 4
    My engine starts fine in the morning when it is cold. However, during the rest of the day, it konks out on the first attempt to start it but will then run on the second try. Anyone have this experience and what was the solution? (2001 base, 3.8 liter engine, 65,000 miles)

    Thanks!
  • emonteemonte Posts: 4
    Thanks for the reply. I did have the fuel regulator replaced due to recall - and hoped that would solve the problem - but it hasn't. I have never had a start up problem. Each time the engine shuts off - I can restart the car instantly. (knock on wood)

    I'll check the transmittion module - thanks for the tip.
  • help please--when I purchased my 2001 Impala the cigarette lighter/charger/adapter--whatever its called--in the front did not work but since I am not a smoker and the charger in the back did work did not concern me overly. problem is now that charger in the back does not work either. my husband has looked at fuses and nothing is bad. not sure where else to look and sure do not want to take it to the dealer and pay some outrageous fee to have it be something small we could have done. thank you in advance for any suggestions you can give us.
This discussion has been closed.