Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Impala Lighting/Electrical Problems

11617182022

Comments

  • hank164hank164 Posts: 2
    Shannel - The stalling while idling of the 2000 Impala was fixed by GM through a Bulletin which increased computer controlled idle speed.
    Hank 64
  • sbehling1sbehling1 Posts: 2
    Thank u:) I just got my Cadillac Converter and my starter fix. So I thought the problem was behind me but yesterday will out I when to start my car and it woundn't start for about 10-15 mins. I'm getting to the piont to where I want to sale it but I love it to much. Was it an electrical problem that chevy fix? Also do you mind if I ask how much it cost?
  • kaatje03kaatje03 Posts: 2
    I have a 2004 as well with low miles and mine is doing the same. I found that it tends to fix it self after I alot of driving around and parking.. Like I went shopping one day and i went to several stores.. After each time I parked and got back in the car a few minutes later the spedometer would go down a little. I havent had to take it in yet to get fixed as that seems to fix the problem when it happens. Which it has 2 times.. I'm thinking of getting rid of the car as I have a few other issues.. I think the 2004 must be a bad year..
  • cobcob Posts: 210
    It is not just the 2004 that the instrament panel needles stick. I found on my 2004 that the speedometer and temp gages stick when the instrament panel gets hot. I drive at night with the dash lights dim to keep the dash from heating up. Another trick is to close one of the dash vents on either side of the I/P and run the A/C. This keeps the I/P from heating up and the gages work properly. You can also take the instrument panel out and have it rebuild for around $170. There are several sites on the internet that will do the work. It appears to be a common problem on many GM vehicles not just Impalas.
  • revjim64revjim64 Posts: 77
    Does any one have any problems with there engine cradle on the 2002 Impalas?

    Click on Link: http://www.angelfire.com/oh4/gmlemons/

    The issue seems to be with the 2000 and 2001 models. I have a 2002 model. Does anyone know if GM fixed the problem??? :confuse:
  • IM having a problem with my 2000 chevey impala, after i shut the ignition off, my parking lights wont turn off, i checked my fuses, i took the head light switch out and put it back in, BTW that is one complicated switch, i lost my instrument panel lights as well, my mechanic is even stumped. any help?
  • I have the same problem. Mine does it when its cold. Once the motor warms up and I come to a complete stop and then take off it will work. I have had it not fix itself on two occasions and actually go all the way around 1.5 times! This has gone on for the last 2 years. For about the same amount of time the passengers windshield wiper will begin to flop and stop working. I have to tighten it up to get it to work for a short time once again. Now the new problem is the car not starting. Looking like electrical problems. Once I put it in neutral and try starting it a few times it will start. It doesn't have that many miles to be having this much trouble. My 97 Ford F150 has 189,000 miles and less problems!!
  • Wow! You described many of my problems I am now having on my 2004!!! Thank you for your post. I figured electrical. Hopefully I can bring this up to mechanic and check it out!
  • I am having the same problem with my remote so if anyone has a solution please let me know. Is the problem with the receiver? I have replaced the battery but the problem persists. We have 2 remotes...same problem with both.
  • No matter the amount of gas I put into my car the gas light comes on I do not notice any leaks, but my gas hand never worked it always showed empty but just recent my gas fuel light will not go away. I do not know what to do.
  • The same thing happened to me when my "fuel level sensor" went bad. In my 2001 Impala I was able to replace it without removing the gas tank due to an access panel between the trunk and back seet under the carpeting. I think I bought a replacement sensor only rather than the entire system that it is connected to. It cost 25$ after shipping from rockauto.com. I know I found some directions doing a google search that had pictures and stuff. Best of luck!
  • i have a 2004 impala ls as well and iv been having problems but with the gas and rpm gauges. it did this since the day i got it then about 4 months ago my heat on driver side stopped working and the gauges didn't act up. but then my heat started working out of nowhere about 2 weeks ago and the gauges acted up again. it doesn't bother me. after i turn my car off i let it cool down then when i turn it back on its back to normal.
  • ambieambie Posts: 2
    I noticed that when the weather started getting colder, the car was slower to start. I replaced the battery and it seemed to help. After about a month, it started doing it again. All the lights work, key fob, horn, everything. It turns over a few times very slowly, then nothing. If I wait a few seconds and try, it will turn over again a couple times. Finally after trying it it will slowly turn over then start. It only seems to do this when it's cold (today it was 65 degrees out and it started fine). Any ideas? Could I just need a stronger battery or is something more?

    :cry:
  • When you had the battery changed was the charging system checked? There could be a problem with the alternator charging the battery properly and not bringing it up to a full charge. Without a full charge it will be harder to turn over the engine on a cold day. If at all possible have a mechanic where the battery came from check out the alternator.
  • ambieambie Posts: 2
    The person that put the new battery in said they took the terminal off with the car started and the car stayed running, so the alternator is working. But what you're saying makes sense, the problem is only when it's cold out, never once has it happened when it's warmer.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,421
    Testing an alternator that way is not a good idea. Don't let them do that again. Damage can result.

    MODERATOR

  • We are having these same problems since the car was 2 years old,my husband was told you had to pull the dash,can you tell us how to get to it and where it is? I am so annoyed with this car,I bought a new car because my old car kept breaking down,I am still breaking down paying 480 a month plus full coverage insurance,I am so annoyed. :lemon:
  • where do I email my VIN number,I am continuing to have problems and GM dealer says nothing is wrong with it,even though,the battery is going dead,the radio goes on and off,back defroster goes on and off,I hate it! Its a lemon. :lemon:
  • Thats,what I thought was wrong with mine but the dealership says no,they say its my battery ,which I have had 2 ,only 6 months since last one,advance says the battery is fine,they also say my radio is bad and that my back defroster works(which it doesn;t) :cry:
  • I know this is an old post but I am having the same problems,my radio goes on and off,back defroster goes on and off,my battery goes dead at times,thought it was BCM but has never been confirmed,mine started around 40,000 miles,I am so angry! I have always been Chevy but I am starting to hate them ! and I am telling everyone I know not to buy them. :mad: :lemon:
Sign In or Register to comment.