Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Impala Lighting/Electrical Problems

1161718192022»

Comments

  • I have a 2001 Impala.
    It runs perfectly fine, until the temperature reaches about 25 degrees Celsius.
    Then the ticking happens. There was a ticking on the passenger side, which would cause my cabin lights to flicker. But I figured out that it was the battery relay in the panel.
    But there is still a ticking and if feels like it is coming out of the steering column. I can feel it in my steering wheel when i have my hands on it.
    That ticking causes my radio to not work. a message shows up saying cal error and then locked. Also, my running lights flicker unless i turn my headlights on, then it stops and when i am driving there is a loud tick unless i put my foot on the break. And the biggest problem this causes is that my fan to cool my engine stops working, and i need to drive at least 60 km/h to keep if from overheating. If i am stuck in traffic on a hot summer day my car will over heat.

    I hope someone knows how to solve this problem !!
  • nealwnealw Posts: 2
    I now have a similar problem with my 2003, but is is intermittant and effects the AC and cruise control only, as far as I can determine. Do know if I pull the 10 amp ac/cruise fuse the blower will run in the #5 position?

    Based on your experiences can you give me any ideas?
  • nealwnealw Posts: 2
    After much head scratching I have come to the conclusion that there must be one or more loose ground connections. Sometimes the problem goes away when I hit a bump in the road. Does anybody know where the G201 and G202 grounds are physcially located?
  • I have a odd question about my Head/Fog lights for my car. I was sitting in my house late at night when I saw what I think was my fog lights since they were more yellow kind of like if it was my turn signal or fog lights when they started to flicker by themselves. Now a little back story I have been having issues with my turn signal not working and to get them to work I hit my hazards and then my turn signal will start to work again. Not sure if the two are connected but the lights just randomly flickering by themselves is new. Has anyone experienced or heard about this happening?
  • So my 2001 impala is having some problems electrically (I think). At first when I would crank the car up it would say service engine soon. When I would go to put my blinker on, a sound from the instrument cluster would start and suddenly my abs, my parking brake, and air bag light would come on. I replaced the hazard switch and the turn signals are still not working but the hazard lights work. It has new front brakes and plenty of brake fluid. The brakes work just fine. Yesterday the headlights had come one when they weren't suppose to and the interior lights weren't working for about a minute. The Seat belt light also lit up long after I had already put it on. This hasn't happened again since yesterday. Could this be a problem with the instrument cluster itself?? HELP!!!!
  • Are you drivers having any start problems? Car security reset issues? Have the vehicle's BCM (body control module) checked out. Normally you have to change it. Cost about $400. The BCM controls most of your lighting and cars electrical functions. Hope this helps somwhat.
  • cobcob Posts: 210
    Change out the turn signal lever. It will solve your head light and turn signal issues
  • Wsp guys i have a 2002 police impala v6 3.8l everytime i put in a blinker fuse 15a it keep on blowing out. Anybody know why?
  • The clinking i hear in my impala is a fan thats connecting to a faulty belt.. i have not gotten it fixed yet, i found the fan myself when the car was off, (it was still running)
  • Just bought a Impala for 500 bucks, obviously it was going to have problems lol. I can't pin point the exact problem, I'm hoping for some help.

    After buying the car, the car needed a jump to start. I bought a new battery, when the mechanic tested the battery he said it had a bad cell, i figured cool 1 problem down.... HA.

    So, the next day she starts up dandy. I went to the bank to cash a check, literally in and out, i try to start the car but its dead. wtf. My friend comes and gives me a Jump and charges the battery for a couple minutes, i was then driving to the post office and she starts over heating?? The battery light flashes on & off on the message board, And the red hot coolant starts flashing as well. I Immediately pull over and open the hood to find some smoke but not a lot.. There was also a very loud clanking sound after i shut the car off.. It lasts a few minutes then stops, i eventually found where it was coming from, a cooling fan, not sure which one but i saw it turning and hitting the car. I let the car cool off, jump it and take it to the shop again for a coolant flush and alternator. Still dies and overheats, I'm thinking it has something to do with the wiring the past owners did? Or if maybe a jump blew a fuse or cable.. maybe a power surge through the car? Not sure what's going on here... going to get a free diagnostic and quote hopefully saturday. Every thought helps [=
  • Could be a bad fan or a bad head gasket. The running hot and after run may indicate that you need a head gasket. If you flush the radiator and find oil in the antifreeze or if you check the oil on the dipstick and see evidence of water than you need new head gaskets. How many miles and what year is this Impala? Hey for 500 dollar car it may be worth putting a 1000 into it!
  • I have learned to live with my 2008 because no one seems to know how to fix it.My radio works at times and at times it doesn't. I take my keys out and it will ding like they aren't out( also comes and goes) randomly an air bag light or service engine light will come on.At times my back defrost works and at times it doesn't.I don't want to buy another car so I will live with it.SO frustrating when I finally bought a new car this happened <after only 3 years,I should have bought a used car.
  • I have a 2011 chevy Impala with a rather peculiar habit. Twice since I've owned it the heating switch, Rear window defogger switch, fan switch, and anything to do with the A/C goes completely dead. If I shut the car off and start up again everything works like nothing ever happened. Any ideas ? No codes or anything come up.
  • wohler15wohler15 Fond du LacPosts: 1
    I just got the BCM replaced on my 2002 Chevy impala and that was the result of anti theft, flicking lights upon start up and radio locking. We thought it was the wires that could of chewed my a mouse by it was the computer! So if your lights flicker when start, get the computer changed!
  • fhaasfhaas Posts: 1
    I have a 2005 Chevy impala LS. I went to turn my car to the "ACC" position and noticed my instrument panel cluster lights were dim and my information center kept displaying all the warning lights ( Battery, Low fuel, service engine soon, etc.). Also I heard a loud clicking sound underneath the dash next to the emergency brake. The headlights would flicker on and off as well. All of this kept happening even after I took the key out.

    Is this an issue with the BCM? Or is it related to the battery?

    Any information would be much appreciated!
    Thank you
  • berniejbberniejb Posts: 1

    Have '02 Impala, 6c, auto. Periodically, when using turn signal, there is a buzzing noise, the airbag light blinks and the door locks will open and close Ignition switch? Today, I can't start it. Electrics work (radio, lights, gauges) Battery OK, as is gen and start. ??????

Sign In or Register to comment.