Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Avalon Engine Questions

1246712

Comments

  • Tranny fluid: Some of today's transmission fluids slowly change color with use from red to dark brown. This is normal and not a sign of a problem Therefore, the color of the transmission fluid not being red is no longer an absolute indicator fluid needs changing. However, at 90k miles, it was a good idea to change the fluid. NOTE: My Toyota service manual says change the fluid if it smells burnt or is black.

    As long as the proper transmission fluid was used and the transmission is shifting normally the cause for your mpg loss is probably elsewhere. You didn't mention changing the engine air filter.

    Agree with fin.
  • I've tried K&N filters and noticed no difference in mpg or performance compared to a reasonably clean OE air filter.
  • z44z44 Posts: 1
    Can anyone give me the size of the 1MZ-FE gasket head size??
  • gazer1gazer1 Posts: 2
    OK. I am back again.
    I did
    - Spark plug change. --> It didn't fix.
    - Brake check -> It was moving OK.
    - Transmission. --> Probilt said it looked OK.

    The issue is MPG AND the power. I knew how powerful the Avalon was. Now, it is like a UHAUL truck at uphill.

    I begin to suspect
    - the HESS gas station where I went before it happened. Any wrong additives?
    - mis-timing (firing) due to slipped timing belt? The belt is original but it is FINE. Can spilted oil make it slip??

    Once thing I recall is
    - The same power loss was observed WHEN the check engine light came on last month. Then Dealer changed the Charcoal Canister as I said earlier. After Charcoal canister was replaced and dealer reset the computer, the power came back. Someone said that "Changing charcoal canister CAN'T affect power". Is it true ????????

    If so, can resetting the computer make the difference? can it be computer problem??? As I said, 'check engine light' is NOT on now.

    I had no problem so far with any toyota engines. Any similar experience or advice would be appreciated.
  • mikes.mikes. Posts: 335
    My families 96 Avalon and 01 Solara both suffered like this, especially the loss of power, until we had the Mass AirFlow (MAF) sensor cleaned. Went to Jiffy-lube, I think it was, and for about 60 bucks they fed a can of injector cleaner thru the brake vacumn line directly into the running engine. They also added a can of cleaner into the gas tank and most importantly they physically swabbed out the MAF by hand using some kind of gel on a sponge with a long handle. The sponge kinda reminds you of a Q-tip.

    This made a noticable improvement on power, don't remember a loss of mpg though.

    MikeS.
  • 2 Cents worth: Even though the "dealer" replaced the cannister, is it possible they left an air leak or other vacuum connection problem?
    Poor accelleration and performance can also be from the vacuum system, such as leaving the EGR engaged, etc. Also might check any electrical connections near or at the cannister location.
    Just worth checking....
  • finfin atlantaPosts: 588
    You are getting good advice here. The problem may well electrical/emissions even though there is no warning light. Do the warning lights all work? Take the car to a good Toyota dealer or a good independent and have the car checked. You will find the problem - get a print out - and can quit guessing. Post what they find so all who read here may benefit. Hope it is something minor. But let the forum know. Great cars, these Avalons....
  • bigonebigone Posts: 1
    i have same problem does it hesitate
  • 54gradsteds54gradsteds Posts: 102
    Hi,
    I've got a '95 Avalon with 158,000 miles on it, and I'd like to keep it for another year or two. Dealer tells me my valve-cover gaskets are leaking, and the fix will cost $700, including materials. Seems like a whole lot of money to me, at $80 per hour. Is this something I should entrust only to the dealer, or can any competent mechanic do it? If the latter is a possibility, about how much should I expect to pay in the suburban DC area?

    I'd like to have a new Limited, and She-Who-Must-Be-Obeyed has okayed the release of funds, but I'd feel better about waiting for another year or so, just in case there are some "kinks" in the new model. Besides, I think the colors offered now are REALLY crappy!

    Thanks----Phil
  • 54gradsteds54gradsteds Posts: 102
    Zone1,
    Thanks for your input..my sentiments exactly...at $60 for parts, that leaves a $640 labor charge, @ my dealer's $80.00 per hour rate. It just boggles the imagination that Miller Toyota in Manassas needs to take 8 hours of a qualified mechanic's time to do what I consider to be a Mickey Mouse job!!!!

    p.s. I just did a quick check of my service record receipts, and nowhere have I found that my pcv valve was ever replaced, even after 159,000 miles....could that be the culprit, or is it better to just blame the mileage?
  • 54gradsteds54gradsteds Posts: 102
    FYI Zone1,

    I just talked to my old, reliable, honest and competent independent shop guy, and he's going to do the job on Monday for $450, which is a saving of $250 over the dealer's guys.
  • dbowedbowe Posts: 6
    I just want to comment that I brought my '96 Avalon in to the Toyota dealer in B'ham, AL because of gasket leakage (I mean, how can you miss it! Any moron who opens the hood can see oil leaks!) and they replaced the oil pan seal. fAt the same time I also had them rotate my tires, and the technician didn't bother to thread on the lugnuts. Later when I got a flat tire I could not remove the lugnuts and ended up breaking off 3 lug bolts. Thanks Toyota! Am jumping with joy over that one (ref to lame commercial). Another friend of mine noticed that after wheel repair, the SAME dealer didn't bother to reattach lateral stabilizers, resulting in some interesting noise while turning. Luckily he could fix that himself, but the B'ham Toyota dealers are horrible...and it sounds like this is pretty much the norm for the whole country.
  • 54gradsteds54gradsteds Posts: 102
    When I arrived at my long-term independent shop (24 years) to pick up the car, my guy Archie handed me two spark plugs, saying that he had to replace all six, and asked if I noticed anything different. What he had given me was a regular plug and one with TWO electrodes, which he said aren't called-for in that year's engine. The whole point, however, was the fact that there were two DIFFERENT plugs in his hand, proof, he said, that the last time the dealer performed major service (at 120,000 miles, which called-for new plugs, etc., was that the dealer DID NOT CHANGE two of the most difficult-to-reach plugs near the firewall and underneath the manifold. They were the two plugs which were different from the dual-electrode plugs, and were burned-down to the nub of the post, which looked like the sharpened stub of a pencil, but only barely visible. In addition to that, my PCV valve had NEVER been changed, even though I now have more than 159,000 miles on the car. I confirmed the latter by looking through my service records. How's THAT for putting faith in a dealer? You'd think that for $80 per hour, one could expect a little more honesty and professionalism, no?
  • vvv7373vvv7373 Posts: 4
    I bought a Toyota Avalon very recently.. .. I love the CAR. It's awefully smooth. Everything's fine, except that it smokes when ever I start it after it's been parked for a couple of hours. It smokes for roughly a minute.

    I took it to the mechanic to ask for his opinion. He couldn't say much for it was not smoking then. I need to park the car for a couple of hours to reproduce the same problem again. It's kind of a White smoke...

    Does anybody have any idea at all ??? Any clue would be greatly appreciated..
  • jrct9454jrct9454 Posts: 2,363
    Find another mechanic. You don't have to witness this behavior to know what's going on. White smoke at startup usually means a blown head gasket [coolant leaking into the oil]. Gray or darkish smoke could mean the need for valve work, but what you describe sounds like one bank of the V6 has the need for a new head gasket - not unusual for this engine, just incidentally.
  • vvv7373vvv7373 Posts: 4
    Jrct9454:

    Thank you for you advice. Another mechanic tells me to get a engine tune up done before anything. Do you thing I should get that done ??? Also, would you have any idea how much it would cost me to get it done ..

    thanks,
  • finfin atlantaPosts: 588
    You might start by asking for a spark plug change. Examine the plugs after removal. Most mechanics know what plugs should, and should not, look like. You may find the answer right there. If not, ask for a compression check. Most of the time, but not always, a blown (leaking) head gasket will show up as lower compression pounds psi in the test.
    Also, if the head gasket is leaking coolant in to the engine you should be adding coolant every so often. Are you?
    And, if you have a major problem here..how much do you like the car?
  • vvv7373vvv7373 Posts: 4
    Thanks, FIN:

    Nope,I haven't added any coolant yet. I asked the mechanic and he says I have enough..... Everybody tells me not to do anything to the car. They always say " It ain't broke don't fix it " .... For the negine tune up the mechanic is asking $200.. is that how much it costs??
  • mikes.mikes. Posts: 335
    700 sounds quite high to me. This is something any decent mechanic can do, actually I've done several on older cars myself it really isn't a hard job. As to what to expect to pay all i can say is to get several quoted from area shops. I live North of Winchester, VA and my local mechanic charges 40 per hour. They do nice work and are always busy. When it come oil change time I take it to them and they charge me a flat 10 bucks for labor. I provide a toyota filter and Mobil 1 oil. My Tacoma they even grease for that price plus they'll check the tires for wear and pressure on all my vehicles.

    MikeS.
  • rockrochrockroch Posts: 2
    Hello, everyone. I am having the same problem here. I have a 1996 Avalon. It emits a chunk of white smoke whenever started. It will disappear in a couple of minutes. It seems to have trace of blue smoke in it. This bothers me a lot after I read through this website about this problem. I am wondering if this white smoke thing could be completely fixed. And how much would it cost to replace the head gasket. Any advices from anyone will be greatly appreciated.
  • vvv7373vvv7373 Posts: 4
    Hi Rockroch :

    How long have you had this problem ??? I am taking it to the dealer this saturday and will let you know what he has to say..... Have you been loosing oil at all ??? or have you been loosing coolant ??? these are some of the things that you might want to check... when was the last time that you got a engine tune up done ???? people say it might be as simple as "Tune up" to replacing your head gaskets...
  • rockrochrockroch Posts: 2
    Hi, vvv7373:
    Thanks for your reply. I just bought this car. I have three months of waranty on engine and transmission. I also purchased service contract on this car. I have talked to the dealer about this problem. He said it is perfect, just a few seconds to warm up the engine. As I did not drive much (I commute on subway), only found this weekend that there might be some leakage on the top of the engine, also the smoke seems to get worse. Everytime I started the engine, I will see a lot of smoke (blue and white) coming out the tailpipe, but it disappear in less than 1 minute. So far I don't know if it is losing ail or coolant, but I think I have to talk to the deal again.
    Let me know what the dealer said about your car. Thanks, and good luck with your car.
  • jrct9454jrct9454 Posts: 2,363
    I can only repeat: the car is most certainly NOT perfect. No car should put out any amount of smoke at startup, not for a few seconds, not for a minute, not while warming up...NOT AT ALL [I'm not talking about water vapor/steam that will be there for awhile before the catalytic converter gets fully warm].

    I think this thing has a cracked head gasket on at least one bank of the V6. If that isn't it, then it's something else, but whatever it is, it is NOT the way it should be. No warranty is of any value if the people involved can't or won't find and solve your warranty-covered problems.
  • ontheroad1ontheroad1 Posts: 1
    I have a 1998 Toyota Avalon with 80,000 miles. The engine will run OK from 0 to 55 or so. If I drive the car at 70 mph for a short or long distance, it will run rough went the car slows down for a turn or a stop sign. I changed the spark plugs, the PVC valve and added injector conditioner to the fuel tank. If I step on the gas peddle in when the car is in neutral, the engine seems to smooth out at higher rpms. Can you suggest what I should check to correct this problem.
  • finfin atlantaPosts: 588
    Here's a guess: replace the fuel filter. They cause funny things to happen when they begin to get clogged with trash....
  • mikes.mikes. Posts: 335
    I concur, fuel filter. Toyota claims it is a lifetime filter....But please??? You may have gotten some real dirty gas.

    MikeS.
  • rzrsegrzrseg Posts: 3
    Hi all,

    Recently I've started hearing what sounds like my valves clicking. I thought it may have been pinging so I ran a couple tanks of Premium in it with no change...so I'm assuming valves. A mechanic I met said he's seen it before and it's caused by a plastic part in the valve train that gets messed up if the engine overheats. It's easy to replace. I did have the sludge problem at about 24,000 miles (about 24,000 miles ago) which the dealer took care of free of charge (it was out of the 3 yr warranty by that time).

    Anyone else heard of this problem...or solution...or have any advice? I've never dug into this engine but i've dug into plenty of others and don't have any qualms about popping valve covers off and tinkering around inside.

    Thanks in advance. :)
  • Two weeks old 2005 Avelon limited with 185 miles. It had 10 miles on the odometer when I bought it. It was smooth and started without any problems about half a mile on the road it gave a knocking sensation for about 5 seconds and stopped on the road. Before stopping it lost steering power and brake power. I was lucky not to get in to an accident Car was driving at about 35 miles/hr on auto mode at that time. I had to tow the car to the dealer. They are yet to look in to the car. Do you know what could cause this. I feel uncomfortable with this car after going through the above. What can I do?
  • sararno9sararno9 Posts: 2
    I am ready to buy a 95 toyota avalon xls with 177,000 miles. The owner said the only thing that may need to be fixed soon is the gasket seals. Is that expensive and do yall think I am getting a good deal or is that too many miles?

    Thanks,
    Sara
  • mikes.mikes. Posts: 335
    Sara, are they talking about the head gasket seals? From what I've seen they shouldn't need replacing yet.

    I have a 96 XL with 160K miles and the head gaskets show no sign of leaking.

    Do you have an independent mechanic that you trust? Run it by them and have them look at it before you buy.

    177k miles isn't too bad on these cars. A lot of them have well over 200k and are still going strong. Unless my daughter wrecks my 96 I expect to see 300k and maybe even more.

    Do the normal maintenance, oil & filter every 3 - 5K. A new air filter about every 12K. Tranny fluid drain and a new filter about every 36K miles. A new timing belt every 60K. Although we went 95K on the 2nd belt before we replaced it.

    Check tire pressure at least monthly and have them balanced and rotated about every 5K miles.

    MikeS.
Sign In or Register to comment.