Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Avalon Audio Questions

124678

Comments

  • patpat Posts: 10,421
    Let's talk about your thoughts and questions on audio capabilities here!
  • bwiabwia Boston Posts: 1,298
    For the last couple of weeks I have been having a bad aural experience with XLS. The sounds from the JBL speakers are muffled even at the lowest volume level.

    So far I have changed all the settings: increase/lower the base, trebble, fade etc. without any success. Does anyone have any idea why the sudden bad fidelity? Since the car is out of warranty the dealer will charge an arm an a leg for a diagnosis.
  • tjc78tjc78 JerseyPosts: 5,025
    My first guess would be that the tweeters in the dash are shot. I assume you have a 2000-2004 car since you say its out of warranty. Put your ear up to the tweeters on the dash, (look for the JBL logo) if you hear nothing that is the problem. I remember from my '03 that the door speakers in the front do not carry any highs, the rear door speakers do, but they could be bad also.

    1999 Chevy S10 / 2004 Merc Grand Marquis / 2012 Buick LaCrosse

  • bluesman3bluesman3 Posts: 202
    I'm curious about the factory XM radio on an Avalon, I've heard that the PIO XM places the antenna on the trunk lid. Can you get XM from the factory and is the installation better? Would I be better off going to the local XM outlet for installation?
  • 3puttmax3puttmax Posts: 119
    bluesman3 -

    I bought the Toyota XM kit from a dealer, then had a stereo shop install it. Had them use a smaller (Terk) antenna that mounted inside at the front windshield/dash top juncture. Practically invisible. The reception may not be quite as good as with an external mount, but I've found it quite acceptable. I'm glad I did it this way, rather than have an external box on the trunk. There's a picture of it on main 2005+ Avy forum, post no. 5279.

    Max
  • bluesman3bluesman3 Posts: 202
    Thanks for the tips! I'll check that out.
  • finfin atlantaPosts: 589
    My '03 XL has a JBL sound system and it is by far the best radio and CD/tape player I have ever enjoyed in a car. Not really in to music but this thing sounds wonderful. All the notes my ears can hear and probably a few I can't. It came in the car and is worth every penny. The '06 can't be any better, or is it? audiophiles...??
  • bluesman3bluesman3 Posts: 202
    All I can say is the stock stereo sounds like mud..... It's flat, the sound isn't full and there's no power.

    The JBL on the other hand really sounds good!
  • tjc78tjc78 JerseyPosts: 5,025
    The JBL in the '06 is a little better (IMO). I just came out of an '03 and am an avid audio nut. The '06 system has better imaging and to me a flatter response. It also plays louder and is a bit cleaner at the high volumes. The earlier system could be a little boomy. However, I must say that prior to my '06 that system was the best I ever had in a car without putting in aftermarket gear.

    1999 Chevy S10 / 2004 Merc Grand Marquis / 2012 Buick LaCrosse

  • bwiabwia Boston Posts: 1,298
    My first guess would be that the tweeters in the dash are shot. I assume you have a 2000-2004 car since you say its out of warranty. Put your ear up to the tweeters on the dash, (look for the JBL logo) if you hear nothing that is the problem.

    Thanks tjc78 for your input.I don't know what happened but suddenly I can hear all speakers crisp and clear. By the way the car is a 2000 XLS.
  • jwhagenjwhagen Posts: 4
    Thanks, Bob. The installation is complete. The antenna is mounted inside of the third brake light and works great. I did have a couple of times where the reception fell off for 5 seconds on a 600 mile trip. You can't see the antenna and to me, it's worth the few times of drop-out.

    John
  • The satellite system is retrofitted and delivers constant dropouts. Thats's almost as frustrating as the defective (with no fix) GPS System. $3,000 down the drain and they treat us cuctomers like we're the idiots! Read my full review at www.gadgetguru.com It is very detailed on these two points as well as what Toyota does to break your soul and ruin the customer experience.
  • jimtranjimtran Posts: 2
    Hello everyone,
    recently, i became a proud owner of a 1998 toyota avalon xls. there is one problem that bothers me all the time and that is the cd player. the cd player is a factory type-3. sometime early in the morning i insert a cd and (if i'm lucky) it plays for about 1 minute and 30 seconds or so and then give a an error "err1" or something similar. after i ejected the cd and insert another one it went in for a few seconds and spits it back out. the am/fm radio and cass works fine, but the cd player drives me crazy. thanks in advance.
    ps: sorry i posted on the wrong place
  • oilcan2oilcan2 Posts: 120
    why not replace it,check on ebay,I just checked and there
    is one for $150 with a year warr.
  • fjacksfjacks Posts: 2
    I added the XM to my 2006 AV LTD. The antenna is sitting inside the back window and is barely noticeable. I get great reception and wouldn't be without my XM. The controls, however, leave something to be desired. For $400 it should have display capability greater than the $99 XM you can buy anywhere. I can't figure out why the information center(the blue screen) wasn't programmed to display more info.
  • shawn4818shawn4818 Posts: 6
    Last week, we started to hear buzzing noise from the sub woofer behind the back seat. The noise is not always on. It only happens when the sub woofer sounds (or pounds). Is this a problem with the sub woofer or something comes loose inside or near the sub woofer? Thanks for any suggestions or advises :confuse: .
  • whilstwhilst Posts: 19
    Hi. Yes,the subwoofer is "blown". Dealer only= $275 abouts.!
    I just "re-glued"my daughters' w/3M Weatherstrip adhesive.
    $5.00. We'll see how long it lasts.
    What happens is the foam surround of speaker cone cracks,detaches from base.
    I tried a JBL 8" subwoofer GTO series,but there's not enough power going to that speaker and output was very weak.
    Cheers,Jeff.
  • shawn4818shawn4818 Posts: 6
    Hi Jeff,
    Thanks very much for the info. I guess I will need to spend some money and time to fix this. What may be the reason for this to happen? My college daughter came home for the summer and has been driving this car, and she likes to turn up the volume a lot when playing those music with heavy bass - Could this be the reason? How to avoid this from happening again? By the way, I have not done this kind of replacement before. Should I try or should I get some more skilled person to do this? Thanks again!
    Shaw
  • whilstwhilst Posts: 19
    Not difficult really.
    Taking the time to do properly=1.5 hrs.
    The speaker cone seperates due to usage and heat from sun drying the glue out.
    Mine seems to be working after repair.How long?
    It's daughters' car as well.
    They seem to last 5 yrs.
    No way to avoid.
    Cheers,Jeff.
  • tjc78tjc78 JerseyPosts: 5,025
    Has anyone used the USA-Spec Ipod interface on an '05 or '06 JBL equipped Av without Navigation? I really want to pull the trigger on it, and would like some feedback. I know it doesn't display the artist and title but that isn't a big deal for me. Thanks.

    <a href="http://www.crutchfield.com/S-djZwBHbO7pk/cgi-bin/ProdView.asp?search=USA+Spec&i=581PA11TOY"

    1999 Chevy S10 / 2004 Merc Grand Marquis / 2012 Buick LaCrosse

  • We just bought a 06 Avalon Limited with 6 disk CD changer. When we listen to the AM/FM, the bass is good and strong but when listening to CD, (either burned or store bought) the bass is almost nonexistent. I went to the dealer and put my store bought CD into another Avalon and it sounded the same. Any ideas.
  • dclkdclk Posts: 8
    max,
    thanx for sharing the pics. one reason i don't have an avalon yet is because of that nasty black xm box on the trunk. is that the best they can do?! please tell me they've come up with something better for '07! anyway, your mod gives me hope that a workable and visibly appealing soln exists.

    DClK
  • niteoneniteone Posts: 41
    "max,
    thanx for sharing the pics. one reason i don't have an avalon yet is because of that nasty black xm box on the trunk. is that the best they can do?! please tell me they've come up with something better for '07! anyway, your mod gives me hope that a workable and visibly appealing soln exists. "

    yes, it's now on the rear deck next to the 3rd brake light.
  • cms1528cms1528 Posts: 45
    The SIRIUS antenna is mounted to the windshield behind the rear view mirror. You can put that XM antenna just about anywhere yu want to inside the vehicle as well.
  • For those who have 2005-2006 Avalons w/Nav and are looking for an iPod integration solution, Vais Technology has a promising device and they just need some help testing.

    The SLI iPod adapter promises full integration with the Avalon head-end: audio, steering controls, song titles, etc. Their device works with non-Nav systems now but they need an opportunity to test the system in an Avalon w/Nav.

    Vais Tech is located in Denver and their website is www.vaistech.com. Someone willing to give up an afternoon for testing might talk them into a "deal" on the device (they didn't say this, I'm just guessing.) :-)

    I would go but 2200 miles is a bit far for me...

    Tom

    P.S. Pat, I know this belongs in one of your other new forums but I think lots of folks are still watching this one. Copy this if you wish, but please leave one copy here. Thanks.
  • Sounds like the optical pickup [non-permissible content removed]'y inside the CD player is either dirty or weak.
  • UPDATE: Vais Technology is offering a FREE iPod adapter (about $300) to anyone with an Avalon w/Nav who will let them do some testing.
  • I have a 1998 Avalon and I have been experencing the exact same issues. My problems started over a year ago. First the radio looses power/presets. Then sometimes the compass and AC will not work either. All are intemittent problems. The dealer said it was the altenator or battery. Both were replaced and the problem went away for 6 months and now they have re-surfaced. Both the battery and altenator have been checked, and are in perfect working order. I'm looking for some clues on maybe what might be causing this. I'm going to test the fuse block for loose connections this weekend.
  • Guys i got 05 avalon limited fully loaded but too bad it didnt came with navi system :(
    anyway whats the easiest way to buy/install ipod ( BRAND/COMPANY ) ?
    I live in Bahrain whichs overseas and i would like to order the whole package to work on my car but with everything the sound should be clear and clean as cd player !

    any feedback would be greatful :)

    ALi
Sign In or Register to comment.