Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Avalon Electrical Problems

123457

Comments

  • wwestwwest Posts: 10,706
    In my experience some of the cars with headlight off delay will allow you to bypass this by opening the driver door before turning the ignition off.
  • rjnnrjnn Posts: 1
    So I purchased a 2002 Toyota Avalon XLS and everything was going fine. Great buy but then.. My AC and heated seats and everything controlled bellow the CD player wouldn't work..
    Pretty much I have nothing working bellow the CD player.

    Could this be a fuse problem or?? Please help me.
  • tjc78tjc78 JerseyPosts: 5,025
    Its on my carspace page as a guide. Just click on my user name.

    1999 Chevy S10 / 2004 Merc Grand Marquis / 2012 Buick LaCrosse

  • Any ideas on what could be causing this? Any help is appreciated!

    Background:
    I have a 1996 Avalon that was recently involved in a wreck. It was hit from the rear and then the front hit another car. The damage *looks* mostly cosmetic. I drove the car for a day without issues, then the next day it won't start.

    Symptoms:
    Put key in ignition: Dash lights up, regular "beep beep" when key is ignition.Good signs.
    Turn key to "acc": Dash lights up, radio works, clock comes on, e.t.c. Good signs.
    Turn key to "on": Dash dims. Multiple, rapid "click click click" appearing to come from under dash near glove compartment. Accessories/lights dim and come on with clicking.
    Attempt to start car (not pressing brake pedal): Clicking stops, dash lights dim till amost off. Engine will not turn over.
    Press brake pedal, with key in ignition but not trying to start: Dash lights dim till almost not visible.
    Fuses checked: Main ones look good. Ignition fuse has light "browning" on it through the viewing window

    Misc: The battery has full charge (tested it) and does not appear to lose it after sitting for days. When I first thought it was the battery I was able to get the car to start (only tried once) by jump starting it, though starting was difficult (solenoid clicking, but started didn't want to turn very well). I drove it around a bit and the dash/headlights dimmed whenever I stepped on the brake.
  • I have a 2000 Toyota Avalon XLS. The dash board display lights and gauges are completely dead, but the car is running just fine like it has not missed a beat. Any ideas?
  • geo123geo123 Posts: 33
    Check your battery and connections. I had the same problem ane it was the battery. Replaced battery and cleaned connections, and the dash lights worked fine.
  • I have a 2000 Avalon with about 180k miles. Starting a couple months ago, I noticed that a couple icons on the dash remained very dimly lit after I took the key out of the ignition (oil, brake, and ABS). Then, randomly, the car alarm started going off. One night it went off 11 times before someone banged on my door in the apartment complex and told me about it (it was parked a ways off). Plus, the clock and calendar all reset to Jan 1, 1999. All of this happens rather randomly, but I've become rather hated in the complex. Any ideas? Please???
  • ecujennecujenn Posts: 1
    I have a 2002 Toyota Avalon with about 100k miles on it. It runs like butter except for in the last 6 months or so I will crank the car and when I shift into drive the car will shut off. Normally it has restarted right away and I can go along my merry way. My mechanic has tested everything he knows to figure out the problem and has not been able to find anything. The problem seemed to go away for a while after pouring fuel injection cleaner into my gas tank, but last week I had to crank the car 8 or 9 times before it would start. The problem is very intermittent which is one of the reasons my mechanic has had a hard time finding any problem. Hopefully someone else has had this same problem.

    Thanks!
  • avaloonavaloon Posts: 1
    Just had my 2000 Avalon detailed. It looks great, starts & runs fine, but seats, windows, locks & other electrical things have all stopped working. Any ideas? Thanks!
  • tjc78tjc78 JerseyPosts: 5,025
    Start checking the obvious things like fuses. Possibly while cleaning they got some connectors wet and blew the fuses.

    1999 Chevy S10 / 2004 Merc Grand Marquis / 2012 Buick LaCrosse

  • my dash gauges (fuel, speedometer, odometer, temperature) stopped working. it doesn't appear to be a fuse problem. any ideas? is this a major problem that has to be fixed by dealer? will a mechanic need special tools etc. to fix? an expensive fix?
    thanks
  • Suddenly the unlock portion of the switch has stopped working. The remote works and the lock works, but both the driver and passengers switches will not unlock the locks. Can anyone tell me what's up with this. To me it seems weird that only the unlock will not work. Thanks
  • Do the rear door switches work?
    What happens when you have all four doors locked, come to a stop, and shift to Park? Do any of the doors unlock automatically?
  • There are no lock switched on the rear doors, just to two front doors. When you put the car in gear the doors lock, but they have never unlocked when you place the car in park. I don't think that the doors are supposed to unlock when parked.
    Also, I noticed something else. The trunk release on the dash seems to be tied to the door locks as it stopped working at the same time. Just noticed this. All this seems very strange to me.
  • wwestwwest Posts: 10,706
    Not so strange to me...

    The trunk lid wiring goes through one of the trunk hinges and is often pinched enough to blow fuses.
  • Sorry, I thought the shift lever lock/unlock actuator might be a place to look for trouble. There must have been a change between your model year and mine (2007) because my doors do unlock when shifting into Park.
  • Have your idle air controller checked for carbon buildup. Have it cleaned or replaced. My Avalon did the same thing and that's what the problem turned out to be.
  • xxagonxxagon Posts: 6
    This is good to know. Is the idle air controller and the intake air controller one of the same?
  • My Avalon started by having strange battery problems. Parked to pump gas for about 5 mins and couldn't start. Needed to jump start two times thereafter even though headlights were turned off, and no known battery draining devices were on.

    AC started acting out of whack next. Shut off for a few seconds and turned right back on. Sometimes, AC wouldn't work at all. Mechanic changed AC relay and suggests it's the AC control unit. Am a student and need to think twice before spending that much money.

    Can anyone please suggest possible diagnoses and fixes? Thanks a million.
  • fraxinusfraxinus Posts: 1
    In the last 2 months, I have had to jump start my 2007 Avalon three times - keyless ignition. I seem to remember that on all 3 occasions I turned off my car while in drive and not in park. Normally, I turn off the ignition while in park.

    On each of these occasions, the battery was drained when I next tried to start the car ---- I had the battery checked at 2 places including a Toyota dealer and each time the technical readout said the battery was fine.

    Is it possible that turnoff off the car while in Drive instead of Park could be causing this problem? Anyone else having a similar problem? --- Thanks for all replies.
Sign In or Register to comment.