Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Nissan Quest/Mercury Villager Starting & Stalling Problems

1161719212226

Comments

  • I have a 2006 Nissan Quest 3.5 SE that was purchased new in Jan. of 06. The original Nissan battery gave out this month (March 2011) and I purchased a new 800cc battery (Exide brand) from Strauss Auto here in New York City. The battery was installed, but the indicator light was still coming on, so the mechanics tested the electrical system and found I needed a new alternator. So that was installed along with the new battery. This was last week.

    Even with the new battery and alternator though, the battery indicator light was still coming on (and the brake light too). This would happen after starting the van up in the morning. About 20 to 30 minutes later those lights would go out. I figured maybe something was going on with the indicators being off. Then last Friday (3/23) about 30 minutes into driving in the morning, I had lost acceleration. The battery and brake indicators were still on, but the engine was still running – I just had no acceleration.

    After pulling over (using the van’s inertia) I let the engine stay on. After about 15 minutes the battery and brake lights went off and I had acceleration again. I went to a nearby garage where they tested the NEW battery, and they said it was a weak charge – basically saying this supposedly “new” battery was bad.

    After putting in their own battery, the charge was stronger. I took the Strauss battery back to the store where they tested it (out of the vehicle) and claimed it was a good battery. I put the Strauss/Exide battery back in and again; this time no battery or brake light comes on.

    Only after sitting for a few hours or overnight do those lights come on again. I then took it to another Strauss store – this one with a garage (the first Strauss store had none) – where they tested the battery and claimed it was good. So now I’m wondering what’s going on? Is it the battery or something else?

    Fast forward to today where on my way home, the van stalls again; engine still running, but no acceleration. I keep the engine on. I call my insurance for roadside assistance. While waiting I try to accelerate – the engine would rev-up, but no acceleration. When the tow truck arrived, the mechanic had me put it in reverse. THEN it decides to accelerate. The difference is though that the “Service Engine Soon” light now comes on. The mechanic told me that it’s either the battery, or there could be an electrical short somewhere that’s draining the battery while everything is supposedly “off” (I do make sure everything is indeed off – lights, heat, radio – EVERYTHING)

    I’m going to take the vehicle to the Nissan dealership and have them look at it (at more expense because the dealership in Manhattan is VERY expensive for service), but I want to get to the bottom of this. In the meantime, if anyone here has any idea as to what’s going on with my van, let me know. Is it the battery that’s defective, or is there a power short somewhere in the electrical system? Or is it something else?
  • The problem seemed to be the dirty throttle body, especially the edge of throttle plate. (see this http://minimopar.knizefamily.net/idleproblems.html#toolow ).

    The solution is just simply clean it, just a few easy steps. (see this http://townhall-talk.edmunds.com/direct/view/.ee93b52/1443#MSG1443 )

    The root cause seemed to be "overfill the engine oil" and cold time oil gets thicker, harder to startup, and when you see "blue smoke" that means oil leak to and burn by engine.

    A simple solution is change oil (as suggested) and add Engine Restorer or the like to thin up the engine, and because my Nissan Quest 94 leak out oil as well and I just simply add a can of Engine Restorer without changing the dirty oil (I did not change oil and filter since 2008, 3 years! well, I did not change because engine oil leak out, every 3 to 6 months I add a quart of 5w30 when LOW OIL light on), the problem relief after first drive and gone after second drive, and magically, the bad smell of engine gone, and engine became quiet, and engine oil gets CLEANER!)
  • When you have the problem: the engine would rev-up, but no acceleration. It often tells your transmission may have problem. That's why the towing guy tried to shift to reverse to see if it work. Nonetheless, it may work sometime and not working sometimes depends on if transmission gear up, and that all needs "strong electricity". When your battery not supplying enough electricity, any good car may start behaves odd.

    Therefore, always keep in mind that "electricity" is often the root cause of problems came from "no problem car", and it seems you problem all came from a "dead battery".

    The "dead battery" not necessarily a dead one, it often because the charging system not charge enough or died, i.e. the alternator. In any case, you can check yourself very easily, saving all the trips.

    You get a voltmeter at auto parts store, very cheap, and do the following simple measurement.

    1. just measure the battery voltage to see if it is 12.66 at cold.
    1a. measure the battery, put one plug on "connection to red pole" and another on battery black pole. (if red connect bad, you see it is not 12.66)
    1b. do the same thing but on black pole connection.
    1c. if you see your voltmeter do not have steady reading, that means your connection is not fully connected or corroded, need to clean. If you only got about 50% connected that will give you non deterministic result, sometimes car work, sometimes not, also your charging system (alternator) may not be able to charge 100% back to your battery, soon or later, your battery will die, but it may take a long time. (it will make you feel somewhere "leaking electricity", but is NOT).

    2. turn on the engine and do the measure again to see if your alternator is charging your battery. If it does, the reading should be something like 14+ depending on temperature and state of your battery.
    2a. b. again measure the way stated above to see how stable your charging system charges your battery, or at all. The alternator is NOT that easy to die (e.g. my Nissan Quest 94 still has original alternator; I bought it new and 17 years passed!), but is expensive to replace, so many inexperienced or dishonest auto services love to direct you to change your alternator at your panic.

    3. You may often find your alternator is good and battery is bad because your "connection" is corroded and not 100% conduct the electric current either from your battery to dozens places in your car that need it, or not allow alternator 100% charging your battery, eventually run low the battery. Even worse, that creates non deterministic behavior of your car. e.g. when battery low, you may see your dashboard half lighting, half ok, and/or your left turn signal light not flashing ...etc. Keep in mind, nothing wrong with your car, just not enough electric current.
    3a. get an electric charger from auto parts store, very cheap, and charge your battery for 15 minutes or so, it is back to normal but run low. Better charge overnight and it became a good one again. If you let your car charges your battery back full, it may take over 2 hours of highway run in day time, without letting headlight on.

    p.s. I went to UC Berkeley both under and graduate major in electrical engineering and computer science. I got top score at Circuit Theory there.
  • sam1995sam1995 Posts: 3
    My 1995 Villager GS just around 125,000k runs good during winter or cold weather ,but in summer if i turn my A/C for few times(20 minutes every hour) or/and drive around busy traffic Van will stall with out any shake or reason !!! Van never over heat , have full battery power, coolants,enough gas . it will start again but die in few seconds with symptoms of spitting,chocking . if engine start to runs again but won't move as i shift to drive or reverse and seems like not getting enough gas or power to move. Then wait 15-20 minutes without trying to start any more then Van runs fine again. Did Changed spark plugs and wires,distributor cap,new fuel filter,air filter but it still happen every time if use A/C in hot days. Some day its runs fine but its not all the time.I really have no luck to figure out and when ever i take it to mechanic its runs fine ! Family with kids its really scare me all the time when i drive . Please help me out if you know what i am trying to explain about my Van and the symptoms. Thank you all for your time,help and advice.
  • It seemed to me your van is good, except your battery is NOT fully charged. During winter time when day time is much shorter and people drive to work or back from home need to turn on headlights that did not allow more charge to battery, so when spring comes, especially after a few winters, battery may be low, and when summer comes and a/c turned on, may cars may have battery died, use up the last bid of saving of electricity.

    Now, coming to the van, when my Nissan Quest 94 battery with low reserve, it often can still crank, but it will kind of prioritize which part to use the electricity and which part to wait like PSE&G in NJ to maintain electricity use. For example, the turn lights may blink very fast and normal when sufficient electricity, but when lower, it may blink slower, and when even lower electricity, it will just blink a few times and at the very lowest electricity, it just light up once and no blink.

    It may sounds non deterministic or fell like lighting system problem, but it is not, it is all because low electricity in the battery. So, to cure it, I just get an electric charger to charge the battery for a few hours, the battery gradually coming back normal, and all other problem all gone. If you charged a barely die battery to a full normal, it may take 4 or 5 overnight charge.

    Now, coming back to your description. In winter time, you did not need to turn on a/c which drain lots of electricity from your battery which may need to charge. In summer, not only you start using a/c, the busy traffic also cause lots of electricity on "brakes", when you hit break, say, at traffic light, you use lots of electricity, e.g. your 3 break lights all ON, and continually ON as long as your break not release, say, at red light, and, you may not realize that your "alternator" is not generate back electricity as low RPM at idle.

    When you say you have "full battery power", I believe you only got enough to crank your engine, just like a bank account has only $100 all the time, it is sufficient to do simple shopping, but when you need to do big ones like a/c, you are not enough, you may charge it up to $10,000, as when it is new. Battery really need maintenance to charge back every year before winter and after winter to keep it up like cell phone battery that you never want to run at just one bar, but regularly charge up to full or 4 bars.

    When you say your engine spitting and chocking, it is because your battery low and current not flow stably. Keep in mind, it take 3 things to run your engine, "fuel", "air" and "electricity". We run a free AAA function in our town to save every car stall on roadside free, and, once in a while, car died because run out of fuel, but most are due to lack of electricity, i.e. battery die or just connection no good, about 75%, and your battery sounds about to that stage.

    Many cars like Nissan Quest has feature to not letting engine move if it detects the battery current is not stable or insufficient. As said, the spart plugs need to fire to burn gas vapor mix of gas and air, and if your electricity is not strong enough, it may spitting or chocking and eventually died, and when it die on the road may or may not start again, so the computer just simply do not let yougo, stay where you are, more safe.

    You did good on tuning (i.e. change new spark plugs, wires, and distributor cap) which often make but that would not help much if your battery is weak, if any. Air filter change is often good to give you some more miles and fuel filter to make your fuel flow better, but these two things are like oil filter change, not a dominant factor, only let A become A+ or, in your case, D to become D+.

    My solution is simply get an electric charger of, say, $29, do not need fancy one, and do overnight charge every weekend and any weekend you have time for 4 or 5 times, you will see the major difference. I was kind of curious of what the micro change of battery and impact to the whole van, so I just charge 2 hours each morning before I realize my 3 year old battery losing power, and every day it behave better and better. And I realized lots of other facts.

    For example, if I only drive the van during day time, because I have extra 2 hour charge, it gets stronger, but if one night I drove a lot, i.e. turning on headlights and a/c, and possibly local, crowd and hit lots of brakes, it became weaker the next day, so after a week or two, I only charge 2 hours in the morning I drove previous nights. When my battery have sufficient electricity, just use volt meter to measure to see if 12.66V before start up engine, I feel everything is normal and great. If you see 12.50V or even lower, you can still crank up engine, but you know not sufficient electricity. Just charge a few hours more.

    One other thing about the van is that many family use it a lot in summer time when travel, but winter time often seldom use or just drive locally and due to day light shorter, that implies less charge back battery. And, it is particularly harmful if van not driving for a week or two or longer, even park nicely in garage, and that harmful, one came from electricity not charged back, and many overload circuity in van drain little by little even not turned on. You did not say in your question, but I can guess as it is very normal to many van owners.

    You can replace a new battery, but there is no need to, as I have charged my battery from DIE to now alive and strong again. My van had all your symptom and eventually it went even odder. e.g. while driving at night, stop at red lights, the dash board may have half light and half dark, when start again on green, it may not move as it should, did kind of delay move ... Well, now, after weeks of experiments, I know that all because battery low.

    When battery low it is hard to tell because when you measure it may be 12.30V vs to normal 12.66V, but that .36V is NOT little lower, if you look at the curve, it is about 90% lower, it can crank and once start, your van use up most new electricity generated from your alternator, but little or none charged back. Imagine charge 2 hours with electric charger while van part in driveway is like charging 2 hours in driving WITHOUT turn on anything to consume electricity at the same time.
  • Just a FYI: My 1999 Villager with the same miles had the same major problems that your describing- I don't know about the winter part because we never made it that far!! :( After months of checking everything, and changing, replacing and cleaning everything.....it still didn't work. FINALLY, a Nissan dealer said it was the distributor.....a common problem, he said, with this particular van. It has ran wonderful every since I had that simple part replaced. Just a thought....just in case everything else fails. Good Luck! :)
  • sam1995sam1995 Posts: 3
    Thank you very very much for your time and very helpful details advice. I really appreciate the time you took for me to answer step by step .its nice to have a good and well informed person like you to help us all. I will sure give a try about battery maintenance and charging steps. It was hot close to 95 degree Temp today and i had to turn the A/C ,cus couldn't bear anymore .well 12pm to 3pm Van was running fine with on and off using A/C but around 3:30pm Van stalled. I just waited around 10 minutes then turn the key on ,van ran good for next 10 more minutes without A/C on then stalled.Then i wait 20 more minutes ,no more A/C on and Van ran fine till i back home 7pm. I use this van for local delivery which means i drive 20 to 40 mins then 5-10 break(parked) then again for 7-8 hours everyday.
    I seen another post /advice about my Van to change distributor ! I sure will try to look at battery maintenance 1st to avoid $200 for new or rebuild distributor.
    Well thank you again for all your help and i do really appreciate your time and advices.Wish you all the best.
  • sam1995sam1995 Posts: 3
    1st of all i really appreciate your time and advice and thank you very much .I just read the post form a nice person who step by step explain lots of things about the problem.I will give a try to follow his battery maintenance methods hope it will solve my problems. i faced same situation this hot after noon ,Van stalled then wait 20 mins then it ran fine with out using A/C any more.
    Yes i would like to change the distributor as you mention you had same problem but it cost over $200 which is kind of out of my reach now but if i have to then i might do it in future . Wish i knew how much you paid for the distributor and the place or site you bought it from. Its 95 degree almost everyday here in summer , i am just praying the Van will not stall when kid and family in the van. Just one thing hard to figure out , why the Van start back after stall but won't move a single inch and stall again till wait 10-20 minutes?
    Well thank you again and all the good people here who you all helping us with your time and advices. I really do appreciate every one's kindness and help.Wish you all the best.
  • Well, when your battery is very low, you may be able to start, and as soon as it starts, the charging system, i.e. the alternator, is charging back your battery.

    However, if your battery is very very low, and if you tried to move at the moment, you may not have sufficient electricity for your engine, so it stall again. It happened to my Nissan Quest 94 early this year, and I realized the battery did not have sufficient electricity, so I start "charging back" over night with "electric charger".

    In hot temperature with a/c on and driving at traffic, many cars may stall. e.g. Kia Sedona 2002 has this well know problem, and the original alternator may die due to "overheat". If you look at "alternator", it has a circuit board to regulate the current from ac to dc, and any chip, including computer chip, has operating temperature range, when exceed that, it won't work.

    And, keep in mind, while your a/c giving you cold air inside the van, it generate much more heat under your hood, and if it is hot temperature like 95, you know under you hood is extremely hot that impact the efficiency of your battery and your alternator at the same time.

    So, Kia Sedona 2002 Van has a trick that deal gave to prevent the van died at the situation "driving slowly at traffic while turned on a/c and temperature is extremely hot". It can be used at Nissan Quest van as well. When you are at that situation, turned off a/c and open windows.

    On the other hand, if your battery is well charged over night, even at that situation when your alternator may not be functioning as you wish, your a/c still very cold and slow traffic is not a big deal.

    If you ever wonder why service vehicle NEVER shut off engine while waiting, it is because even if they are delivery and stopping, while engine running, the alternator is charging back the battery. This extra electricity charging back to battery is a big help to people doing delivery often driving in traffic and may be hot days and need to turn on a/c.

    Some people have no patient to charge their battery, so they just replace a new one every 3 to 5 years. Another extreme, I know a guy just bought a brand new BMW, and he charge his battery every night. When battery is always in the state to be full, it is less likely to be corroded and last for longer.
  • tony2005tony2005 Posts: 2
    edited June 2011
    1) Just change the rotor (which is about $12). The rotor is inside the distributor. To access, remove two screws on distributor cap, then remove distributor cap. You will see the rotor sitting on top. Then remove one screw at the side of the rotor. If rotor screw is at in "bad" position and you can't get screwdriver in, put distributor cap back on (without screwing back the distributor cap), then crank engine for 0.5 second. This should turn rotor 180 degrees for easier access to the rotor screw. Remove cap, remove rotor screw, remove rotor. Reinstall new rotor.

    2) Or if you can't get a new rotor, just spray the top of the rotor with WD40, scrape metal top with fingernail, wipe clean and reinstall distributor cap. The old rotor of mine was very oxidized.

    I installed a new rotor for my 99 Villager today and it purrs like a kitten now.
  • It seems to me your dad's 2002 Villager losing electricity on the battery. Always remember it takes electricity from battery to run the engine because the spark plugs need to fire at the combustion stage to burn the gas vapor.

    When your Dad ran up RPM that does not change the voltage of alternator charging your battery, however, it shall increase the current flowing into your battery which, I believe, was running very low. Just like if your ATM card has very low balance, and you may be able to buy milk or egg, and you deposit $20 every so often, but once in a while you get rejected when buying bigger item, but you can deposit $100, and you would be fine again till next time hit the big ticket item.

    This is typical to low battery which has been "dead" and jump and alive again, people often just replace a new battery, or get an electric charger to jump over night each week, and about 4 or 5 times, your battery shall be close to new, and it makes sense to charge your car battery every quarter to maintain it; alternator charging often not enough in winter time when excessive electricity used such as head light in the morning to work and also in the evening back home, and heater fan, and traffic hours stop and go for the brake (when you got stopped at red light, while you holding brake, your 3 break lights are ON!)

    Eventually when your battery so low, you will either take many cranks to start up or NO able to at all and need jump start from other car or jump starter. As a no brainer, if finally can crank up, let engine run 15 to 20 minutes without turn on any light, radio, fan, heat, a/c, ...etc, your own alternator may charge back some electricity back to your battery, which would be good for driving again, and when you arrive destination, turn off lights, fan, release brake, ...etc first BEFORE turn off engine, at that moment, your alternator still generating some electricity back to your battery, so you are sure to have sufficient to crank when you need to start the car.

    Now, you may realize why service vehicles like UPS, FedEx, ...etc, their truck or cars often do NOT turn off engine while delivery. It is because their vehicles often do stop and go and local driving does not allow alternator generate enough electricity for the consumption, so, here and there, that habit, although, may appear waste gas, but it does guaranteed battery won't die on them, or the situation you mentioned happened, this is especially important in winter time.

    So, what you should do is get an "electric charger" at Walmart, Sears, Target, Pep Boys, Auto Zone, Advance Auto Parts, ...etc, about $29, and charge your battery. Before you got the electric charger to give your battery extra electricity, you always want to let your car "warm up" and run for a few minutes before you turn on anything or go to make sure you have sufficient electricity to go, and turn off fan, headlights or a/c, ...etc. whenever possible, especially, approaching to traffic light when RPM down to about 800 RPM and alternator charging less current back into battery. And when you stop and park, always shut off engine last, and let it run for a few more minutes to generate extra electricity for your next crank up.

    #367 of 380 2000 villager lurching by mike1811
    Dec 07, 2010 (12:39 pm)

    My dad owns a 2000 villager and around 1 month ago it started lurching really bad going down the road so he shifted into second gear and ran the RPM's up to almost redline for a few seconds and that cleared it up. however from that point on it does the same thing, You will be going down the road and running good then all of a sudden it will do the same thing. Now just the other day Dad was driving to work and it started acting up again. Well this time it stalled and would not start. Now that it is home it starts only after cranking and cranking. After it starts it spits and sputters. We where told that the mass air flow sensor is the problem so we got on and it made no change. Could this be a vacuum problem? What should I look at next?
  • Have you checked your alternator, the charging system back to your battery? Basically, battery died for only a few reasons, but if your alternator is not charging back, even if you got a new battery, will eventually died.

    The battery supposed to have 12.66v and even if it is 12.30v it is very low already. I often applied electric charger to charge my battery when it is not 12.66v. It is very handy to have an electrical charger to charge up the battery, and you can measure while engine on to see if the voltage is 14+ volt, if it is, that means your alternator is working. Sometimes, it could be the connection problem from alternator to battery that is bad and letting alternator charging the battery 100%.
  • It seems to me that your van loose electricity, and, I believe you and your boss may not have maintain your battery. e.g. get an electric charger and charge over night every quarter or at least once a year. Because van often have lots of electronics and usage of electricity often more than alternator can supply over period, especially, old vans when wires are not conduct 100%, some power loss here and there.

    When you died and would not start, if you wait for a while, you may be able to start again with the last amount of electricity, and if you let engine run for 15 to 20 minutes, you may have your alternator charging more back, before you can move and drive the van again. If you move right a way, it will be likely to quit because your battery at that moment had very little surplus to run the van.

    When you replace distributor, your auto shop may have been charging your close to dead battery with their higher power charger, and that's why you got an illusion that replacing distributor the van work fine, otherwise, why it died again? And, even need to replace distributor again?

    You should get an electric charger to charge your battery overnight once in a while, and I believe your van should be fine, many odd problems will be gone and it is very cheap solution. Or you may get a new battery which is easy and quick, but years later you may running into same problems when battery dying ...

    But with an electric charger, you can always charge back like your charge your cell phone every night or two.
  • It seems to me your starter was fine. When you can not start, it has nothing to do with oil change either. Your mechanics may have done a wrong guess and did the unnecessary work and charged you, then find out your van still had problem, so continue to proposing more work that he just guess and not sure if it will cure the problem. Since you disagreed, so the problem of your van remains, except your mechanics did two unnecessary work for you van which can only make it better but no harm, except cost you money.

    Keep in mind, it takes 3 things for your engine to run, the electricity, fuel and air. If your van has been running fine with electricity in your battery, the problem could only be fuel system. From what you describe later when you trying to drive the van out of mechanics parking lot, you seemed to get the "bad gas" from cheap gas station that has water in it.

    When your gas has water in it, you may not notice till later one day when your gas gone and reach more water in your gas tank. Remember, the gas and water is not uniformly mixed, the gas is lighter and will be on top and water will be heavier and will be at the bottom.

    When you tried to start the van at that moment, you did not get gas but water, so the engine will not start. If, for any reason, you can start, and your fuel pump gives you gas and water, your engine will run when fuel injector gives you gas vapor, and the next cycle when you got water vapor, your spark plug could not light up at the combustion state, so you got engine knock.

    This is very non deterministic situation when you got a bad luck to get bad gas when many old car owners trying to save money on cheap gas. Most auto mechanics can not understand either but based on the computer read out to ask you to change many things one set at a time, hopefully to make computer happy, but often can not because the reason is the bad gas, nothing to do with your van.

    What you need to do is go to parts stores like Pep Boys, Auto Zone or Advanced Auto Parts, ...etc. to buy "Dry Gas" bottle to feed into your gas tank. Some brand like yellow bottle Heet about $2 will do the great job immediately. What it has is also heavier than gas called methanol that sink down to mix with water in your gas tank and became burnable, but the bottle will simple telling you it "remove water" ...etc. So now you know why it is so cheap, just $2, but it is not, it is just methanol to bind the water in your gas tank.

    Hopefully, next time you do not get cheap gas, and get some better gas with more octane grade, or get an STP Octane Booster, the orange color bottle to feed into your gas tank. You may do this for a few weeks, and it may be fine again.
  • It seemed to me you also got the bad luck of bad gas with water in it.

    Keep in mind that when you can run 90%, meaning your battery and electric system is good. And that also implies your air system is fine, so only the fuel system has problem, and that's why your mechanics guess on your fuel pump, but it was a wrong guess, but having a new fuel pump does not hurt but cost you.

    All you need to do is go get a bottle of "Dry Gas" such as yellow bottle Heet that has power of "remove water" and as soon as you feed into your fuel tank, you shall find the magic of your van driving perfect again. Why is that?

    Because inside your gas tank, gas and water not mixed well, gas will be on top because it is lighter, and water heavier going down to bottom. Initially, when you fill up the tank, your van should be good to hit gas all the time, if you got check engine light solely for this will go off. Then when you run out more gas, you got more chance to hit water. As your fuel injector spread water, the spark plug could not burn water at combustion stage, so you got engine knock.

    Anyway, this Heet or the like has methanol that sink down to bind with water in your gas tank and produced burnable liquid so shall "remove the water" and "reduce the engine knocks".

    In the long run, do not get cheap gas, or at least get more octane grade gas, and treat your gas to remove water by using "Dry Gas" like Heet bottle. It depends on how much water you got and accumulated in your van for all these years, but, soon or later, all shall be removed if no more water get into the tank.

    Another quick fix is to fill the tank with expensive gas such as Moble, and never drive down to close to empty gas tank. i.e. whenever you gets knocks in your engine, go fill up good gas again. Now, you may recall the myth: never drive to close to empty tank of gas.

    An analog is when you ate bad food and need to run restroom, it has nothing to do with your body, you do not let your surgeon to replace your stomach, ...etc. Don't you think auto mechanics are like surgeon? very costly and last resort. you may tried Auto Pharmacy first like "Heet" in this case. Or even better, monitor your Auto Diet, i.e. Auto Nutrition, don't get bad gas at the first place.
  • It seems to me you got two problems. one is the bad gas, another one is the low electricity in your battery.

    You can start and run fine means your battery and electric system is good, but intermittently just dies that implies your fuel system problem, but it is so odd that has to be non deterministic bad gas, aka gas with water.

    If you look inside your gas tank that contains the fuel pump, after all easier to push than pull the gas of the pump, you know if your gas has water in it, gas is lighter will be on top and bottom will be water. However, when you go down hill, your fuel pump may pump more water that fuel injectors spread water spark plug fire can not burn "water" so combustion stage can not carry out, and engine stall.

    It is non deterministic, at least appears to you as driver, because once you fill up the gas tank, you may run fine for weeks with no problem because you have NOT hit the water in your gas tank. Remember gas does not mix with water evenly, gas lighter will be on top and water heavier at bottom. Till your lucky days ends, and you finally hit your water, you got engine knocks due to water not burnable, and eventually die.

    When you say worse in summer. It has another problem of low electricity of your battery, and it is common when people seldom maintain their battery, after winter when night time longer, more often using head lights, ...etc, when spring come, battery has lower electricity, and when summer comes, you turn on a/c, so you see many cars died on not able to start during that time of each year.

    You may want to get an electric charger, $29?, and charge your van often, like I do every day 15 min to 2 hours depending on how battery react. e.g. It starts adding 6 amp when battery is not full, then it shall go down to 5 amp 4 amp, 3 amp ... to 1amp that doing trickle charge and last over night if you want.

    Keep in mind, you need to have electricity, fuel and air to get your engine run well, so once you make sure your battery is always good, you can easily identify other problem.

    You need to get a "Dry Gas" bottle like yellow bottle Heet to feed the tank to "remove the water". Basically, Heet got methanol that will sink to bottom of tank to meet with water and bind with it to become burnable liquid. One bottle to treat a tank, and I often add it when the problem starts emerging because when I fill the tank, the first weeks are fine like your case due to it not yet reach the water in the tank. Continue treating your gas tank "i.e. remove water", soon or later it shall be great!

    But, you may want to avoid the cheap gas that may occasionally give you bad luck on gas with water.
  • Believe or not, it has nothing to do with your transmission; I mean your transmission is good.

    The problem seems your tank has water needs to be removed. When you are bad luck to get gas with water, especially in cheap gas station, you got what you described. So, what next?

    To remove the water get into your tank, you need to get "dry gas" bottle like "Heet" yellow bottle to feed your gas tank that has methanol to sink down to bind the water into burnable fuel (i.e. remove the water).

    Now, why it has anything to do with your transmission, especially 1-2 geer? Because when your fuel injector got gas vapor and spark plug fire at combustion stage will give your engine power, where as when the following cycles may hit water spreads that can not burn, your engine got knocks. Depending on the ratio of fire and knocks, you may find your transmission need "higher RPM" to finally able to move up to 2nd geer because some knock cycles give no power.

    Why your idle became erratic? as you can now guess, your engine got some knocks, i.e. can not burn the water vapor. If you got too many such knocks, your engine may stall or die.

    Throttle Position Sensor has nothing to do with this; it has something to do with your idle air intake, and that often will still not replace TPS but clean your throttle plate if your engine can not idle well. e.g. every time stop at traffic light and your engine may die at idle, but it is not what you described.

    Other symptoms you did not describe, but you know you are loosing power when you push the pedal, but the root cause is that you got the bad gas that you need to get water out.
  • It seems to be your battery and electric system is fine, so what you have done replacing many things simply with better and new parts, which is ok.

    I feel your fuel system may have some problem although over 75% of not able to start engine has something to do with electric system. When was last time you change your "fuel filter"?
  • It seems to me you got water in your gas tank. Your van is fine; do not replace anything unnecessarily.

    When your engine got "gas vapor" from your fuel injector, it runs normal, however, the water vapor came, the spark plug fired but not able to burn water in combustion stage, your engine knock, and of course, your knock senors sends signal to your computer.

    When your computer got many abnormal signals coming in, the check engine lights one, but next moment when it burns no water, it is normal again, the light off. When you accelerating, it runs up the RPM, and your fuel pump may not be able to pump enough gas to support but intermix with water vapor as well.

    You may have gotten the bad gas from cheap gas station, or may be due to your seldom drive situation. The van or any vehicle may catch water moisture after raining days, and if seldom drive, eventually, this may happen.

    Go to part stores like Pep Boys or Auto Zone to get a bottle of "dry gas" like "Heet" yellow bottle and pour into your gas tank to treat your gas, i.e. "remove the water". How? Heet contains methanol that will also sink down to the bottom to meet water and bind water into burnable fuel and will be burned out when fuel injector spread out, and you shall see much fewer knocks. Engine will run smooth again.
  • Keep in mind, the OBD II scan just gives you a snap shot of what the engine state was, and in your case, you got a knock due to fuel injector spread "water" instead of gas vapor, and spark plug fire not able to burn the water vapor, so you got an engine knock. Be aware, it does NOT mean your knock sensor has any problem, do NOT let your mechanics talk you to replace your knock sensor.

    When this water vapor can not be burned, and it happened in your cylinder 3, and spark plug fired but not burn anything. This does NOT mean you need to replace your spark plug or fuel injector. Unfortunately, many mechanics saw the code will tell you replace all spark plugs, and wire, and other things.

    As said, your gas tank got water, and water vapor not burnable, and you need go get "dry gas" bottle like "Heet" yellow bottle to pour into your gas tank to treat your gas "i.e. remove water" since Heet contains methanol that sink down gas tank to meet water to bind into burnable liquid that will then be burned and no more knocks. i.e. make your knock sensor happy and spark plug no misfire, and therefor, your check engine light not on.
Sign In or Register to comment.