Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Safari/Chevy Astro Transmission Problem

1234568»

Comments

  • Did you determine what was the problem?
  • How do you know for sure if it is failing? Would a code be stored for it?
  • iceguyiceguy Posts: 2
    i have recently changed my trans. and just drove it 300 miles 2 day ago everything went smooth then today drove home it seemed ok but when i popped my hood i had tranni fluid all over place took it to car wash came home and cant get it to leak it still has plenty of fluid in it but wont leak any ideas
  • 1998lincoln1998lincoln Posts: 108
    Two things to would check, did you over fill the trans, if not, check the lines to raditor, might be stopped up !
  • iceguyiceguy Posts: 2
    lines to the radiator are to hot to touch, could this be a result of a plugged line , if so how would you go about unplugging the line
  • spike99spike99 Posts: 239
    edited March 2010
    My local transmission specialst tells me that ALL GM van transmissions run hot. Especially within the Safari/Astro design - that doesn't reflect the wind very well (compared to today's smaller mini-vans). He recommends ATF aux cooler (LPD Design) be installed in all Safari / Astro vans - even non-towing vans. For example, Hayden 678 or 679 LPD design.

    re: http://www.summitracing.com/parts/HDA-678/

    If wondering, I installed Hayden 679 in my prev AWD Safari van and installed Hayden 678 in my wife's smaller size GM mini-VAN. re: http://i178.photobucket.com/albums/w251/Spike99-Pictures/Montana%20Van/AuxTransC- ooler-UpperSupport-2.jpg & http://i178.photobucket.com/albums/w251/Spike99-Pictures/Montana%20Van/AuxTransC- ooler-LowerSupport-1.jpg

    As a suggestion, install the LPD aux cooler design (re: Tru-cool or Hayden 678 or 679) in your "running hot" GM van. These ATF coolers work great in my GM vans...

    .
  • lind777lind777 Posts: 7
    Hi,

    I have a 2002 GMC Safari van. My wife went outside to try to start but it would not start. She tried a little while later and still would not start. I tried a few hours later and she said she pushes down on the gas to start so I thought that was the issue since it is electronic fuel injection.

    When I started it up the turn signals would not work and I found that fuses 1 and 16 were both blown. I researched the issue and thought it was the multi-function switch so I bought a new one off of eBay from a reputable guy who had old dealer stock. It looked brand new. I installed after a very difficult process and when I pressed on the brake pedal it blew the fuse again. Putting the turn signals on also blows the other #16 fuse after blinking on and off for 3-4 iterations.

    I removed all the dual filament bulbs and the top brake light and pressed on the brake pedal and that also caused the #1 fuse to blow.

    I removed the brake signal switch and opened it up gently and made sure the front two contacts would be coming open prior to the last contact touching. Everything looked good in there.

    The van does have a connection for trailer lights and brake controller. I reviewed those and they are all clean.

    I removed the top brake light and everything looks clean there too. The resistors all look good.

    I opened the sliding door just in case something was shorted in in there as well but that had no effect.

    Any suggestions on how to test the actual connector sockets into which the bulbs reside?

    I really thought it would be the multi-function switch but that was not it. Please ask anyone you know who may be able to help on this one as have a $4,000 boat anchor right now.

    THANKS!
  • The transmission went out in my 96 Astro Van (reverse and 2nd gear). It had about 260,000 miles on it. I picked up one at a junkyard today (from the same year van) but had a quick question. The guys I had to deal with were a real PAIN, and were pulling all kinds of CRUD since I'm a woman. They said I'd have to have the transmission reprogrammed/reset, and if I didn't it wouldn't work right. Now, I've messed with several transmissions, but all older stuff...like 67 & 70 Mustangs and a 68 Cougar---never any of this "new stuff"...... Were they telling the truth, or just trying to pull one of my already long legs?? Would someone please let me know. I can't seem to find anything about it online, but just wanted to double check.
  • pcvanpcvan Posts: 2
    just pulling your leg; swap it and go
  • Did you ever find out what was wrong? I have a 2000 astro and your story reads almost exactly to what mine is doing right now. I have replaced the computer, throttle position sensor, speed sensor, engine coolant temp sensor, and even put new ends on all the grounds. I had my tranny rebuilt about 7 months ago and the shop tested the transmission as well, but the tranny keeps going into safe mode, which only lets it run in second and third gear. I have run out of ideas of what else to do to try and fix it. Please let me know how your van turned so i can at least know what direction to try next. Thank you.
  • 1995 astro changes all gears at high rpm. Rebuilt trans but engine has to rev higher than should to change. When it warms up it does better but should change quicker. What wd cause this?
  • I have a 97 astro van (2 wheel drive ) that started leaking fluid from where the cooling lines go into the radiator. I had to drive the car so I kept on adding fluid to it so it didn't run out. I only had to drive it a short distance but in that time it started it started to slip. There is so much fluid all over there front of the engine and front suspension that its hard to see where its actually leaking from. The upper line is clean so I figure its the lower line. How do I fix this? Do I need to replace the entire line? did I mess up the trans by running it and if so is that an easy fix? I dont have alot of $ right now and need this van for transportation. Any help would be greatly appreciated
  • rich2767rich2767 Posts: 1
    Ive got a 98 astrovan, and when the temperature outside is above 40degrees the van slams into second gear. when its freezing out its fine? any help??
  • spike99spike99 Posts: 239
    Like most 2 x hoses in the same location (especially of older age), when one blows, the other one blows soon after. With this in mind, if you replace 1 hose, I would replace both. Especially if you plan to keep your van longer.

    To clean the oil off the eninge / transmission, do investigae GUNK. I use this stuff on my motors and it works great. re: http://www.gunk.com/prod_photo.asp

    Hope this helps...

    .
  • datkins1datkins1 Posts: 4
    I would like to have more information about this fix please... email me at jjrudy65@aol.com

    Thank you...
  • i have a 2001 chevy astro all wheel drive with 151000 miles on it in June driving from my parents house came to a stop sign went to take off the van would not go. tried twice then tranny let out two big bangs then it took off, going down the road the tranny shifted funny and it would not go into overdrive, i got it home and went to leave with it, it had lost reverse. so i called my tranny shop and they said the valve body went. they quoted me $1800.00 to $2000 to rebuild w/a 12month/ 12000 mile warranty. to let you all know don,t do it. i found a place out of Arizona on ebay that sells brand new rebuilds for $625. The tranny is dyno tested and comes w/ a 2 year warranty and unlimited miles. I have read all this people who have spent big time money having them rebuilt and still having problems, I had this tranny shipped right to my tranny shop and had them put it in for $600.00 and got a year warranty on their work Overall i"m very pleased with the work and I got my van back quick When you buy the tranny they recommend you change the torque convert too or they won't warranty the tranny cost of $175.00. They charge shipping fee depends on where you live, mine was $400.00. The shipping is two ways. To your door step and then to ship core back to them. Overall it cost me for everything $1800.00 but was worth every penny. I would do it this way again before i would go to the dealer or have a tranny shop rebuild one..... I'm a mechanic of 25 years and didn't have the time to do it myself, just became a truck driver, better pay !!!. If i was going to do it myself I would still go to this place and get the tranny you are not going to get a better price or warranty.. Call them at 1-888-996-6378... They will work with you to the tee.... They do trannys for all vehicles not just Astros
  • If the transmissoin is from the same make and model they well chang and you don't have to have the transmission reprogrammed
1234568»
Sign In or Register to comment.