Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Bonneville Electrical Problems

12346

Comments

  • can the maf sensor cause my car to shut off and stall when trying to start ? i just dnt want the run around paying for this and that. my funds are short and i need to no the real problem lol! did the ignition control module start after you got the sensor replaced or was that also a problem from the start ? whats the ciol housing? thanks
  • where was the switch located? i no you have a 2000 and mines a 1997 but i would like to check for that also? thanks
  • azuazu Posts: 84
    Disconnect MAF sensor. If the car doesn't stall then you have a bad MAF sensor. Just note that the car will run a bit rough and a check engine light will light when doing this.
  • ok i have a big problem right now can some one please help i mite repeat some things but i want to give all details for best help!
    PROBLEMS:

    1.car starts then shut off after a couple seconds (symtoms)-run hard kind of shakey then turn off.
    2.some times power goes out also then come right back on after couple minutes whenit shuts down
    3. my tail lights will not go out
    4.autozone test came back maf sensor
  • jdowgjdowg Posts: 1
    Hi i can prob help you with the windows not working, but the a/c i am not sure mine just stopped working on my car its 2004 bonneville but anyway i left my windows down when it rained and it shorted out the side door panel modulator i went on ebay and found it for 15 bucks its the drivers side one it has the door locks and everything else i replaced it and bam everything works now! i always remember to leave the windows up now lol hope this helps, also did the mechanic say the fan blowers fuses blow did they test it cause its really ez to check yourself under the backseat in the jumper box even there are 3 fuses i think one for blower and two for a/c maybe give them a look remember to disconnect the bat before messing with the fuses,
  • azuazu Posts: 84
    Replace the MAF sensor. If you have to you can disconnect the sensor to get around a bit. The tail light problem may be the brake light switch sticking or went bad.
  • Ok I was told it was my fuel pump I thought that a bad fuel pump can only stop the car from turning over or starting.. My problem is when I try to start it it do turn over for a couple seconds then cut off the power also then u wait a couple minutes then it some times start right up and stay on or as soon as I press the breaks it shuts off again I'm lost I'm go replace the sensor to day but u think it mite be more then one problem I want to take it to the shop but they always do stuff to your car to come back I'm sure if it what can I do?
  • just wated to share thatthe car cutting off with these symtoms:power off at start,shut off after seconds started with power turning off also.. it was the starter wire it was running hot had to be changed now doesnt shut off. as for the parking light problem staying on i had a switch put in to turn on and off as i need. so far so good right now
  • hcbrhcbr Posts: 1
    I have a 1997 Bonneville - was running fine. Went to bank, came out and it would not start. The dash lights come on, but nothing when the key is turned. You can jump it from the starter, and will run 2-3 seconds and just die. Suggestions??
  • There's a 2nd positive wire that runs from the battery + side to the center of the cowl area. Generally, you can move that connector around (at the battery) to get it running. I eventually replaced that cable (approx $45 at GM) and all starting issues went away.
  • mdeciphermdecipher Posts: 9
    I had a Pontiac do that years ago = fuel pump was failing

    Although your problem does sound more electrical
  • jefferyodjefferyod Posts: 2
    edited July 2011
    my battery has been going dead last couple of days or so I thought, I tried to charge it today wouldn't start, was still dead...jumped it wouldn't do anything, all of a sudden gauge went to fully charged started and drove fine...drove about 10 mins gauges went nuts, a/c quit, running rough now won't start again...checked battery is fully charged and good...checked ground by battery under back seat and the one on the frame by starter...am I missing something I have to get to work in the morning PLEASE help! :cry:
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,535
    edited July 2011
    Your car is 2000 and newer...

    Check the ground on rear floor. Remove and clean then retighten.

    Check the connections on fuses in the holders under the rear seats. i recall some have found loose connections there--might do that with the ground wire removed...

    Check same on the fuse holder in the front... Doesn't the power wire go there and then to the starter?

    Could just be defective battery-post cracked. Bridged inside.... How old is battery?
  • jefferyodjefferyod Posts: 2
    2001 checked ground on rear floor one up front changed battery still same thing
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,535
    Check for tightness on the back floor fuse set on the clips that the fuses go into. I don't know if you unbolt the box and lift it to get to understide or how. I recall someone men tioned that as source of their problem in Bonneville long back.

    The gauges and things going crazy sounds like a drop in voltage symptoms some people have when the battery gets old or bad. But you have replaced battery. Check the end of the positive cable to be sure battery acid didn't seep into it from the battery post and corrode something.
  • I would check the 2nd positive cable going from the battery to the top of the firewall. I had intermittent issues until I replaced that cable. Since then, no issues at all, except finding a brake caliper mounting bracket to convert from drum to disc on the rear of my SSEi.
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,535
    >I would check the 2nd positive cable going from the battery to the top of the firewall.

    Is that on a 2000+ model that has that cable? I know the 92-99 models had one going to the Relay Center for fuses and relay power!

    The main cable on 2000 and up goes to the front fuse relay center by the AC accumulator--right fender near front. I need to look into how the power goes from there to starter and others.
  • I have an1997 Bonneville with the same problem,I was just wondering did find out what problem was.
  • I have an 1997 pontiac Bonneville that won't start,was working fine,all the lights come on when I try to start it up but nothing happen,I can jump it from the starter,but it goes off after a few seconds
  • Hi - I have an '02 Bonneville with 90K miles. For the last 6 months or so it has been giving me trouble when trying to start the car. The problem definitely seems tied to the electrical system, as the dash lights often will not come on when I turn the key, and if they eventually do, only then will the ignition engage and start the car. We used to be able to "trick" it into starting by turning on/off the radio, rolling down a power window, or locking/unlocking a door--seemingly "waking up" the electrical system. That no longer works, and now it's taking sometimes 3 or 4 minutes of waiting to see if the thing will start. I'm afraid I'm going to get stranded any day now. She's my only source of transportation with 3 kids...anyone else had similar issues that can help me figure out what the problem might be? Needless to say, I'm not rolling in $$$ so I'd like to avoid a trip to the mechanic if it's likely a loose something-or-another or a part that I can troubleshoot/replace myself. (I'm a gearhead in disguise.)

    Thanks!!!
  • I also tried my other 3 regular keys and the Valet key, same result, so I know it isn't the transponder in the key. The only light that comes on in the dash is the "P" (Park)...and sometimes the security light flashes but not consistently. I do have a water leakage problem in both front floorboards and the trunk...typical Bonneville. :-/
  • My speedo, tach, turn signals, and DIC have stopped working on my 2000 SSEi. I took a couple of dash panels out to get to my Cig lighter to see why that wasn't working. After that the speedo and tach quit working.

    Any ideas?
  • did u ever figur out the problem? i em haveing the same problem with my 97 bonneville ssei
  • tfensketfenske Posts: 1
    Hi - after trying everything we unhooked the battery (positive and negative) and let it kind of re-set. (we had taken the dash apart, disconnected the security system, etc - pulled our hair out!) Bingo - it worked. Hope it works for you!
  • tcaldertcalder Posts: 1
    JUST REPLACED DRIVERS DOOR MOD AND EVERYTHING WORKS UNTIL I SHUT THE DOOR AND THEN NOTHING WORKS.
  • Keyless entry only locks and unlocks fuel door, no power to auto locks but windows do work and all fuses check out good. no horn beep from locking with keyless no door chime from the dash. seat doesnt always move to set position, back up lights didnt work, lights wouldnt flash with keyless and so on.

    I trouble shot and found the broken wire that controled the locks/seat memory/alarm/lights flashing/ect. little purple wire under the seat coming out of the carpet to the wire loom that connects to the slider that moves with the seat. everything works now.

    hope this helps someone. almost everything is tied to going under the driver seat.
  • santrellacsantrellac Posts: 3
    edited December 2012
    3 months ago my blinkers started blinking slow and then stopped..what could that be? now this week my dash lights and break lights went out changed the fuse worked for a little while maybe 20 min then blew this happened 2 times what could that be need help
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,535
    Slow blinking may be corrosion on a bulb base or poor connection there. Remember there are some running lights on certain H-body models that are part of the circuits so check those bulbs and holders as well.

    As to the brake circuits blowing a fuse..., that might be related if you're getting a short to ground through corrosion on the bulb holder. Time for thorough inspection of the whole set of bulbs on the front and rear.
  • ok thanks i will try all bulbs tom when i inspect what should i look for new to this trying to fix my car on my own money low
  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,535
    Looking for corrosion in the socket or on the bulb metal.

    The bulb holders twist about a quarter turn to remove and then the bulbs push into those holders. On the rear, the taillights have little nuts on studs holding the taillights onto the body. Remove those, the taillight unit pulls out, and then twist to inspect each bulb in its holder.
Sign In or Register to comment.