Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Grand Am Security Passlock Problems

17810121343

Comments

  • it take 40 mins to reset!! you have to , put key in switch attempt to start but not start and leave in run position for 10 mins then turn to off for 5 secs after light goes off do this 3 times and the car acually works fine now. thank you for the quick reply but i paid a guy 30 bucks at firestone he pulled it up for me on mitchell online
  • Well i don't know what's up with your security light. But the rest of 'em trac off and service vehicle Abs light could be your wheel hubs in the front my '01 grand am is the shop right now and that what is wrong with mine. I had the same lights on in my dash.
  • For your information the Passlock system does not work well in other cars...I have a Saturn Ion and it has been a nightmare for me. Now I can't even start my car at all...I have read easily over a hundred such complaints from Ion owners alone, but also various other GM vehicles. :lemon:
  • You are right, Passlock doesn't work on a lot of cars. My car is a low mileage Grand AM GT and it is in the shop again. I told them I thought it was another passlock problem but they act like they don't want to admit there is a problem. There are other discussion boards that talk about passlock problems on other GM cars.
  • jasdvajasdva Posts: 2
    Well from what i have read in the past few weeks about problems with the security passlock system.....i to have had some problems for a while. read the handbooks, talked to numerous dealership mechanics, and numerous people around town about their grand ams. i'm having my car worked on tomorrow 1/29/08, and the mechanic i'm taking it to said he has numerous customers with the same problem and will be booked up with at least 5 grand ams a month for the rest of the year. he told me that it IS the ignition (tumbler). for some odd reason after a few years they start to go bad. imagine that. American car breaking down when you have hondas running on forever. lol.
    i'd like to share a website for everyone to go to. don't know if it will help everyone or anyone at all. if it does help ya'll out...then use it. if everyone that has had problems with their grand ams, send pontiac a message telling them what has happened. if there is a ton of us against them..then they have to do something about the problem. if not..then the BBB, good morning america, or this particular business magazine (i cant think of right now) will have to help us americans.
    Heres the website. http://www.pontiac.com/divisional/contactus/contactus.jsp

    Good Luck Everyone!!!
  • mkapasmkapas Posts: 2
    i have a 95 grand prix how do you get around the security thing
    :confuse:
  • mkapasmkapas Posts: 2
    i just bought this car and we put a battery in it and it wont start because of the security thing is there any way to fix this :lemon: :confuse: :cry: :mad: :(
  • See my previous instructions. By replacing the battery, you cut the current, reactivating PassLock. For my method to work, you will have to get the car started again BEFORE cutting the data wire. You can try the wait-ten-minutes technique (key to ACC), but if that does not work, when you remove the casing from the steering-wheel post (3 screws), try jiggling the data wire when you try to start the car. The problem with mine apparently was corrosion in the data-wire leads; since disconnecting the wire, via the toggle, I've had no further incidents other than the red light not going off. Installation of the toggle is highly recommended precisely because of this described problem. It allows the data wire to be reconnected easily after a battery replacement (needed to start the car).

    RBC
  • I have a 2001 pontiac grand prix, its been a great car but every since I got it (used, about a year ago) the ignition switch at times will be very hard to turn over, you have to wiggle the key just right, keep trying, taking the key in and out, turing the key over until it finally will turns over. I have never had a problem with the key not coming out.
    But for the last 2 months or so it stopped doing it, I was so use to having to play with the key that I noticed it right away when it stopped.

    Today when I cranked the car to let it warm up, it started fine, how ever as I was driving to the grocery store I did notice the security light was on, its been extremely cold here lately -23 this morning, at times the car has been prone to have issues with system lights coming on for no reason, then going off. Dome lights will stay on longer then they should.

    I have had it all checked when I had the car weatherized, they said pontiacs are pretty famous for this and they usually go off by them selfs. Even after I had the engine serviced they had a hell of time getting the service engine light to go off.

    Of all the times....I spent 300.00 in grocerys and got everything loaded in the car, it would crank up then a few seconds later just shut off, it acted like it did when my friend tryed to use the spare key to crank it.

    I pulled out the manual and read and did the whole 10 minutes thing, Im freezing in the bitter cold, but finally find someone to call, finally got it towed to the mechnic and he thinks its the switch too, but we don't know for sure. I did notice that while this was happening the electric window barely went up.

    After reading all theses post about this being a ongoing issue im worried. I live in alaska and you can't afford to get stranded here, it can be the diffrence between life and death depending on where your stranded.

    Does anyone know if there has been some kind of recall becasue of these issues with the ingition switches? :sick:
  • i have 98 sonoma where this week i replaced the turn signal switch. after i finished repairs the passive 2 lock system came on and will not allow me to start truck. i know the repair was fine because the swith works just the security light is on constant. i have read all the ways to bypass the system or reboot all have failed. one question i have not seen on here is why or is possable to bypass the system futher down like where the computer sends the command to the ingectors. is there a way to cut a wire close to the motor to stop the injectors from being shut off. any help would be great its ethier this or spending 500 600 hundrend down at gmc for them to fix
  • Put your key in the ignition and turn it, put the car in gear and crank it over.

    First, did you mean put this in gear. Second, will this work for a 2001.

    I mean this in humor, It makes me feel better that im not the only one going through this **$&.

    I have paid for two $400.00+ dollar computers for this. Helped temorarily, although i think the POS mechanic was just resetting it. The reset helped for a while, but now it wont work at all. Starts up then dies. What im seeing different at this point is mysecurity light is staying solid and not blinking.

    I believe im going to try this permanent pass lock assuming it works for 2001. :mad: :mad: :confuse: :cry:
  • Apologies, I don't check this message board that often anymore because it appears that my problems with the passlock thing is resolved. You said that you live close to Midland, MI...if so then contact Bob at Auto Technicians in Midland, provide them with the instructions in nobullchitbids posting here:

    nobullchitbids, "Pontiac Grand Am Security Passlock Problems" #209, 16 Sep 2007 6:43 pm#208

    Any updates on your situation anyway? I'm curious to hear if you ever got this fixed. I still drive the Grand Am, it's still a piece of junk and now there are all kinds of other problems with it (things that can be fixed normally) but I can't wait until we decide to trade this [non-permissible content removed] in.

    Best of luck, let me know how it all goes,
    TK
  • I have a 2004 Grand am.I bought it with only 16000 miles on it{May 2006}.I had it for 1 month and the security started acting up.It would not start at all.I had to have it towed 4 different times since then back to the dealer ship.I was stranded at the state fair with my 2 kids 100 miles from home until a tow truck came.I did not get home til 4 am.The dealer ship blamed me for the problem.After threatning marks from my husband,the deciced to fix it.After 3 weeks it did it again.Another tow job.They told me it was the battery.A month later,same thing.As at this present moment it is at the dealership again.They put me a new ignition switch in and a new computer system.Just waiting to see what that bill is.
    Will fill you in when I get it back.
  • Since my grand prix had been sitting at the dealership waiting for the new security system to come in and them giving me every excuse under the sun about the delays, I just decided to trade it in, with the understanding they cover the 700.00 repair bill. Being in Alaska and going to the remote places I do I simple do not trust it no more. I traded it in for a Mercedes-Benz ML430 4x4 Its alot better for what I need anyways and its sweet!!
  • I know how you feel. I had the dealership fix mine, and it was fine for a good year, and now it is doing the same thing, won't start half the time and leaves me stranded. BEWARE: I too got a new ignition switch, and they did something to the passlock as well, but I say beware because it will eventually leave you stranded agian. It may not be for a month, or a year, but it will happen again because Pontiac does not make a good piece to fix this. They won't recall it, nor will they try to come up with a way to fix it because it is not a safty issue. Good luck...
  • all the things that has happened to my car has. i have a 2001 pontiac grand am. when all of this security passlock crap happened....i was baffled. i had it towed to a garage down the street. the mechanic (which is an awesome guy) has had quite a few grand ams with the same problem. he replaced the ignition switch along with the computer chips in my car. that cost me $300 to get that all fixed...supposedly. then the inevitable (spelling) happened once again. i was like omg...after $300 put in the darn thing, i thought it would be all ok. only this time...i got it started then turned my heater on...and everything died. i was like hummmmm. it took me another 15 minutes to get it started. go figure. lol. i told the mechanic what happened this time...and he said that pin pointed everything. it was the electrical part of the ignition switch. the first time being fixed, it just wasn't getting a spark when turning over. that is the reason why my "service enging soon" light didnt come on. so if you guys go and have the switch replaced, make sure you tell them to replace the tumbler, computer chips, and the electrical part of the switch. it's the only way to fix the problem. he told me also that the dealerships are stocked up heavily with al these parts, becuase they know it is happening all over!! but yet, GM/Pontiac isn't going to make a recall....well for now anyways. till then i will keep my reciepts and will send them the bill. oh yea..before i forget....this second thing that happened...it cost me another 300 bucks. so a grand total of $600.00 will fix your problem. they just dont make cars like they use to anymore. it's better to go with a toyota or a honda.....that way at least you'll know it will last forever, but the downfall...the cost when it breaks down is costly. i had a honda when in school and about 4 years after high school, that sucker just ran and ran and ran with no prblms what-so-ever. well i hope all of this helped anyone or everyone. GOOD LUCK YA'LL!!!
  • ok i have a pontiac grand am gt 04 and i have a problem with the security as well. i had my car towed to a friends garage they messed with it for 3 days and figured it out. the security light flashes when the car wont start right keep you key in on acc and wait for your security light to stop blinking then crank it itll work it has happened to me since about 3 times :confuse: it will take about 10 min and its annoying but at least itll work afterward i promise save your money
  • tripower1tripower1 Posts: 25
    You have more then just a passlock thing going on. My daughters 03 alero would fail to start every now and then, she would get in the car and try to start it and nothing would happen and the Security light would be flashing, she'ed wait the 10 min, the light would go out and it would start then the Security light would stay on.
    Now what I found it this. If your security light stays on then you have a bad connection between the ignition and passlock computer which is no problem until it get a good connection then it locks you out and the Security light is flashing.
    I followed the directions and cut the wire and installed a switch. I'll let you all know how it works out but so far it's good to go. :) :) :)
    :)
  • burdawgburdawg Posts: 1,522
    This will work for a while, but your not correcting the problem, just re-setting the security system. Eventually it will not reset. The most common reason for this failure by far is the Hall-effect sensor mounted on the ignition switch, which requires replacement of the switch or the bypass procedure that has been discussed here before.
    Occasionally the problem has been found to be corrosion in the connector on the BCM (there's no Passlock "computer"), or a problem in the BCM itself.
    One thing to watch for is if the security light is illuminating while the car is running. Not flashing, solid. If this happens then a security system fault is being detected.
  • hgosinskihgosinski Posts: 22
    I had the hall effect sensor replaced 8 months agoa, now my car is doing the same thing, starting when it feels like starting. They are telling me that there is no good sensor, and it needs to be replaced all the time. Pontiac charged me 600.00 to repair that...I can't afford that every 8 months! :mad:
  • burdawgburdawg Posts: 1,522
    And I assume the security light is flashing when you try to start?
    I'm on my third Grand Am, in over 300K miles between them I've only had this problem once. I suspect moisture may have something to do with it, it's usually very dry here in the southwest.
  • xteceaxtecea Posts: 1
    I am starting to have the same security lock problems with my car. I just contacted GM about the issue and I think it's a great idea for other owers to do the same. It will take less then a minute and it will let GM know this is a common problem not just a few out of thousands, so please take a minute and do this also.
  • dcheiteldcheitel Posts: 11
    A month or so ago I emailed GM about this. I got an email back as well as a very professional phone call apologizing for what im experiencing but this is not something they are aware of.

    What BS, its so surprising that a large company like this can play so blind to its consumers. I have this no start problem a good amount of the time and its so infuriating.

    Hopefully if more people report it, they may actually do something.
  • mwmoldmwmold Posts: 1
    I know this is really hard to believe,66000 miles, after reading all the messages about this issue, but now I too have the same , Security light flashing, let it sit for 10 min. and then it will start Hall effect sensor probs.I first checked everything from fuel press.(60 psi.) at the rail to spark at the plugs, disconnecting the Bat. and checking the fuel cap for tightness,Fuel pump, etc... I learned more from burdawgs' comments than any other, and I think he may be the authority, Thank you, I agree and I sent Pontiac a note describing the prob. and asking will they issue recall or do we have to pay, and/or get used to this aggravation? I own three vehicles, a Honda and a Toyota, no satisfaction could equal a Pontiac for Sale! Waiting for price now on Dealer repair estimate, would not using the remotes help? Thank you.
  • burdawgburdawg Posts: 1,522
    Using the remote or not using it won't make any diffference.
  • hgosinskihgosinski Posts: 22
    Well, it hasn't quite been a year since the hall/passlock sensor has been replaced, and the car is doing the same thing. Starting whenever it feels like it. I can't afford 600 bucks again. This is the third time now. I have to do this about once a year. I am still afraid to have the wires cut...I am so afraid that it just won't ever start again if I do this. Maybe I have no other choice, because their faulty parts are breaking me. Pontiac called me back, and said the same thing they told others. That they were not aware of the problem. BS! :mad:
  • tripower1tripower1 Posts: 25
    I was afaid to, cutting the yellow wire was a hard thing to do even though it was my daughters car. I got tired of hereing her complane about waiting the 10 min so I did it and boy was I glade when the car started. I put the switch in and told her about it and that it was there if she ever had to change the battery or it went dead.
    gess what, she called me last friday and told me the car wouldn't start, after several questions I found out that she had no power to any thing evern her remote door locks, battery dead because she left the lights on. The battery was completly dead and after charging it up with my van it started with no problem
    Do it and you'll love it
    :D :shades:
  • If you have ice on your sidewalk, and you know there is ice on your sidewalk, and you do nothing about it, and somebody slips and falls, who pays to mend the broken bones?

    Of course Pontiac will deny knowing there is a problem. Quitcherbitchen and cut in the switch -- I'm still goin'.
  • mkirby5mkirby5 Posts: 2
    I just wanted to say Thanks for this web posts and to tell those who are in the situation of having your security light come on in your Grand Am and then you car not starting that..... THIS WORKS! Luckily yesterday, after my car wouldn't start and the security light had been coming on and off for a few days before, I went online and just googled my problem and happened upon this website. After reading the posts and seeing that I was not the only one having this problem, I took the advice of burdawg and cut the yellow wire last night and saved myself a tow and repair bill for something they probably wouldn't have fixed anyways!

    It was fairly simple to do (my husband and I have NO car knowledge and are generally not too handy about fixing things.) But, we opened the radio area, took out the radio, cut the yellow wire and taped it up and now my car starts and starts and starts. I'm fine with having the anti-theft protection off, if someone really wants to steal this piece of crap car, go for it!

    So, thanks again! And for those of you in this boat, just do it and save yourself the money and time of taking it into a repair shop........
  • tripower1tripower1 Posts: 25
    Don't forget that if your battery goes dead or you change the battery you'll need to reconnect the yellow wire to start your car, that's why the switch was advised so you didn't need to take the radio out again.
    good luck
Sign In or Register to comment.