Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Grand Am Security Passlock Problems

1313234363743

Comments

  • Yes, you can use the non-solder fix. The wiring is exactly the same in the two vehicles. It states at the beginning of my article that this fix applies to the following vehicles:
    1999 - 2004 Oldsmobile Alero
    1997 - 2003 Chevrolet Malibu
    1999 - 2004 Pontiac Grand Am

    These are all Passlock II systems. If you are able to find the wiring bundle with three wires in it, and you have identified the yellow and black wires, you are all set to go.
  • I have been having problems with this GA starting then dying for about a week now. Two years ago, someone unplugged the 3-wire connector to the Hall Effect sensor, disabling the Passlock. I reconnected it and installed the 2.2K ohm resistor in place correctly, worked for a couple of days. I pulled out the resistor, installed the toggle on the yellow wire; still intermittent. Fuel pressure is 46 static, 40 running. Sometimes, I can get it to stay running by holding the key halfway on after it starts. That would indicate to me a faulty switch on the column, correct? I am starting to go NUTZ, as this car is my gf's, and she is ready to dynamite it. It is in cherry shape except for this and a heater core bypass. We don't use heaters in Phoenix, anyway!
  • This sounds more like a tune-up problem, or an intermittent connection somewhere on the ignition switch. (because of your experience with holding the key partly on)
    I believe you can trace your problem to the correct defective part by following the troubleshooting procedure in the shop manual. I don't have a manual for that particular year Grand Am, but you should get one if you intend to do your own repairs. It will be well worth the money you spend on it.
    By the way, are you stating your fuel pressure in PSI or KPA?
  • The FP is stated in PSI. I am considering "hotwiring" around the switch to confirm a positive start every time by taking it out of the loop.
    My other consideration is the microprocessor controlling the Passlock system, shown in the wiring diagram to be on the back of the instrument cluster. A trip to the local Buick dealer was unproductive in trying to pin down the shape or exact location of this MPU. There are several "97 Grand Ams in the wrecking yards, maybe a cluster from one of them might solve it (?)
    The $125 for the shop manual is not unreasonable, but the 10-day wait will drive someone batty. Of the hundreds of cars owned by myself and my family members, I have done all the repairs since 1976, when I got my degree in auto tech. When they break down out of state, I just tow them home and fix them here. I believe the manual would be a lot less than a tech with less experience than me will want to charge to solve this problem.
  • You said:
    I believe the manual would be a lot less than a tech with less experience than me will want to charge to solve this problem.

    Good point!
    My manuals have saved me literally thousands of dollars. I got manuals for my two cars when I bought them new, and I "borrowed" my Grand Am manual from the shop at GM Proving Ground where I worked. There are other sources. I've used online manuals from http://www.alldatadiy.com for just $27/year. They aren't exactly like the manufacturer's shop manual, but they're good enough to do most everything that a shade-tree mechanic would want to undertake, and it's easy to print out the pages you need and keep them for reference later on.
  • Thanks for the tip about ALLDATA online. I have used their products at the city libraries and found them helpul. I am used to using Mitchell's or Chilton's professional shop series of manuals, and I kept a few thousands worth of them when I sold my shop in '92. Nothing beats a factory manual- I use them all the time when repairing Benzes.
  • I replaced the ignition switch on a hunch to save time- $ wasted, it was a red herring. I can start it sometimes by jiggling the wires going into the Hall Effect switch. Otherwise, it might start and run for 2-4 seconds some of the starts.
    The gf is getting ready to call the junkyard to haul it off. It's a shame, under 100K, no dings or rust. AZ car. I need to go out of town for a few days for a family emergency.
  • I have read through all the posts and just want to get your insight on my problem.

    I have a 2002 Grand am GT, Automatic Transmission, 75,000 miles. My parents took my car on a weekend road trip and when they got back i went to start my car and the security light was bright red and solid on my dash. I drove it around a little bit and after my last stop I shut car off and tried to start again and I have lights, radio, etc. but the car would not start. The car had no clicking of the starter, nothing other than what i wrote before. It was if the battety was completely dead. (New battery) I did the 10 minute reset and the car started up and light is gone and has started the last 10 times I tried, but i haven't drove anywhere in it yet afraid that it will do it again. Has anyone had any luck that this was a one time deal and didn't happen again? Plus will this Passlock make the car engine sound like it is working harder? And will this make rpm on idle be 1200? What sound the engine sound like in a Grand Am GT? Loud? Smooth? Should it be at 2200- 2500 rmp at 55 miles an hour? Just wondering if it's okay to do new disable of system or if something else is cause?
  • burdawgburdawg Posts: 1,522
    The security light on SOLID when it's running indicates a problem has been detected in the security system.
    From your description it sounds somewhat like an ignitionswitch or related circuit problem was the culprit when it wouldn't start, but that's just a guess.
    Passlock won't make the engine work harder.
    It won't effect the idle (other than the fact it won't run if it's tripped).
    It should sound somewhat louder than a standard GA due to the exhaust but it's no big difference. The big difference is in the final drive gearing in the GT.
    The rpm's at 55mph is determined by the load. If it's in overdrive that sounds a little high, but under power or going uphill that could be normal.
  • When i was doing the 10 minute reset the red security light was blinking until 10 minutes was up and it went off, that when I was able to start. I drove around last nite for awhile and the light didn't come back on. I may have to find a blog for te idle thing. Could be many things. At 55 the rpm was at 1500 with overdrive kicking in at 55. The car is just making a whinning noice like the engine is working harder.
  • Something other than Passlock caused your car not to start. Passlock DOES NOT disable the starter motor. If you tried to start the car and the starter did not work, you should go through the diagnostic procedure for that symptom. This could be an ignition switch problem, as Burdawg said, but not the part of the ignition that is associated with Passlock II.
  • After reading all the posts by Alexandjojo, Gus, Nick, & Nick2, I decided to try try something different. I had already done the yellow wire cut & toggle switch, the 2.2K ohm resister bypass + a 4.7K ohm bypass ( I measured the resistance at 4860 ohms. I did the 10-minute and the 30 minute resets numerous times. It got to where it would start once every 4-6 attempts, and then only while I wiggled the wire going into the Hall Effect sensor. S0- I went to the self-serve junlkyard, snagged the lock cylinder/Hall effect switch AND the instrument cluster from the same vehicle. I got lucky- the key was in the ignition! So- I installed them and did the 10-min reset. Started every other time, did it again, CAR FIXED!!!!! Cost from the junkyard- $40. BTW, there are about 7 of these 96-99 GAs here if any one needs any parts, just let me know. There are about 4 older ones also.
  • burdawgburdawg Posts: 1,522
    Sounds like you may have more than one problem. The security light blinking when trying to start indicates a tripped passlock system, and the 10 minute reset worked, so that is one. The other issues aren't directly related to it though.
    1500 rpm at 55mph in overdrive sounds about right to me, but normally it would engage overdrive around 40mph unless your pushing it hard.
  • birdy3birdy3 Posts: 1
    You might have figured out the problem by now, but I know my car did the same...The Manual instructed that I turn the key and leave it that way for about 10 minutes (meanwhile the security light will be flashing, when it stops after about 10 min. or so you turn it off and back again and it should start) Good Luck!
  • This weekend, I received a letter in the mail from a person whose initials are C.S. in Wisconsin. (I'm withholding the full name for the sake of their privacy) The letter was in connection with my instructions on repairing the Passlock problem on GM cars at http://www.bergerweb.net/PasslockFix

    Here is the text of the letter he sent me.

    I can't afford to give you as much as I would like to, but your information was the greatest of help to me. I was working on my daughter's car. I am just one of the many struggling Americans right now. But thanks for all your help, hard work, and research!!!

    C.S. I want to thank you for your kind note, which I appreciate more than any amount of money you could have sent. It pleases me that on these forums, we can be of some help to others who are experiencing problems with their transportation. I hope that our posts can be of help to many more people just like you.

    Dick
  • Kirstie_HKirstie_H Posts: 10,830
    Wow, that's a very nice "thank you." As you said, it's nice to know that your time & efforts are appreciated. I know they are appreciated by many here - I'd love to be able to calculate the total $ amount that your fix has saved people in our Forums (not to mention the aggravation).

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • I found factory service manuals for '97 and '98 Grand Am ( & other N bodies) for $10 each at a local used bookstore. Funny thing- when I worked heavy line at the dealership 30 years ago, we rarely consulted them!
  • lovemygrandamlovemygrandam Posts: 330
    edited August 2011
    Car Surgeon,
    Since you now have shop manuals for 97 and 98 Grand Ams, I wonder if you would mind taking a look at the wiring diagram for the security system of the 98 grand am, and let us know the difference between that circuit, and the one posted on my website, bergerweb.net/PasslockWiring It could be of some help to people who own earlier model Grand Ams.
    By the way, I have no qualms about posting wiring diagrams of GM cars that are no longer built by the NEW GM, since the company that built them went bankrupt. That GM no longer exists, therefore, no "rights" are being violated by copying those service manuals. Just sayin'
  • My car has been having the problem with not starting and the security light coming on. It does start after doing the 10 minute reset. So tonight I decided to to the Passlock Security Fix from the site: http://www.bergerweb.net/PasslockFix/index.shtml

    The problem is I cannot locate the 3 wires to the left of the radio. I have the Haynes Manual for the 2003 Grand Am and the wiring diagram does not show the 3 wires. I am an electrician so I do have knowledge on reading diagrams and working with this type of stuff. I also do most of the repair and maintenance work on our cars. I am very disappointed to not be able to do the repair tonight.

    Does anyone know if the wiring is different in the 2003 Grand Am? I know the diagram on the web site is showing a 2002 but was it changed for 2003?

    I really do not want to go to the dealership for this repair. Any help would be appreciated.
  • About 2 years ago my 2002 Pontiac Grand Am started requiring me to do a security reset. I'm tired of waiting ten minutes about 6 times a week. Also, withing the last six months every trouble light on my dash is constantly lit up. Does anyone have any idea what I should do to fix one or both of these problems?
  • One more question. Tomorrow I will look again at the wiring. Could be that it is a harness setup like what is in the Alero. If so, can I still use the resistor and no soldering method?
  • lovemygrandamlovemygrandam Posts: 330
    edited September 2011
    The wiring is the same for the following cars:
    1999 - 2004 Oldsmobile Alero
    1997 - 2003 Chevrolet Malibu
    1999 - 2004 Pontiac Grand Am

    I am informed by someone who did the mod on a 2000 Saturn that there are slight differences in the wiring. The colors of the wires are different, as follows:

    Grand Am . | Saturn
    Yellow . . . . | Yellow
    Black . . . . . | Orange/Black Stripe
    White . . . . .| Red/White Stripe

    Thanks to Ron B.

    Dick B.
  • I am unable to find the wires at all! There is one bundle of wires that is wrapped with tape. I removed the tape and could not find any small wires in the bundle. After removing the radio I searched all of that area and did not see any wires going to the ignition. I'm wondering if I look under the dash if they may be down there. I am completely stumped as to where they are.
  • lovemygrandamlovemygrandam Posts: 330
    edited September 2011
    Very strange. Has someone installed a remote starter on your car? If so, they may have messed with those wires and somehow re-routed them. I have not run into this problem before. I've done the mod on a 2002 and 2004 grand am, a 2003 and 2004 alero, and one Impala. Always found the wires in a small bundle of three coming off the main ignition switch bundle just to the left of the radio cavity. Can you also post all your model specs, Year, GT or LE, etc, Engine? Auto/manual, Bose radio? That stuff might help.

    You might try to access the wires at the BCM, which is located behind the kick panel, under the glove box. See the instructions on my website at
    http://www.bergerweb.net/grandamsecurityfix.htm
    You can use the "no-solder" technique there also.
    Dick
  • I will try accessing the wires at the BCM. Won't have time to look at that until Monday. We've been the only owners of the car and there's no remote starter.

    Here's the specs: 2003 Pontiac Grand Am SE, 3.4L, V6, automatic, standard radio/cd/cassette that came with the car when purchased.

    I also found this diagram through a link posted earlier in this thread.
    http://www.bulldogsecurity.com/bdnew/newsite/pictures/instdiagrams/46.jpg
  • pia2some,
    Very few of the manuals available at Auto Parts Stores contain any information about the Security Systems. I think for some reason, they think they might run into legal problems if they publish the information, even though every car thief in the world already knows more about these systems than the average mechanic. That said, if you don't mind spending $28.00 for a subscription to the shop manual for your 2003 Grand Am at http://www.alldatadiy.com/ here is how to get to the BCM connector diagram in their online manuals.
    Go to ...
    Vehicle » Diagrams » Connector Views » Body Control Module
    and you will see the wiring list for the three connectors of the BCM. The Passlock wires are probably on connector C2. The two wires to cut are circuit #1835 (black wire), and circuit #1836 (yellow wire).
    Once you cut the wires, connect your resistor between the two ends that go into the BCM. Just insulate the other two wires (black and yellow) and leave them disconnected.
    If you think it's any help, you can look at the connector diagram for my 2002 Grand Am here:
    http://www.bergerweb.net/PasslockFix/BCM-Connector-C2.gif
    Note that the two wires you need to cut are on pins A6 and B6. I cannot guarantee they are on the same pins on the 2003 Grand Am GT, but it's a good probability, because GM liked to make their expensive parts like BCMs interchangeable.
    Hope this helps.
    Dick B
  • Still can't get this to work. I tried using going to the BCM end of the wiring and working from there. My wire colors do not match up with any of the diagrams. I purchased the manual for our car on the alldatadiy.com site. I felt sure I had located the correct wires and I placed the resistor on like your instructions show. The car would not even turn over. Nothing. So there was no way to do the relearn. Ended up rewiring everything back to the way it was and at least the car is running.

    I don't know if this will help, but here is what I have on my BCM (central connector):

    Row A (1-12): Pink, X, X, Lt. Blue, X, Black, Black, Pink, X, Yellow/Black, White, X (X means it is empty)

    Row B (1-12): Green, Black/White, Lt. Blue, Pink, Brown, X, Yellow, X, Dark Blue, X, Green/Black, Orange

    Any more thoughts or ideas?
  • lovemygrandamlovemygrandam Posts: 330
    edited September 2011
    Hehehe.... almost the same mistake I made the first time I did this mod. Look very closely at your connector. On the side that plugs into the BCM, the pins are numbered. You may need a microscope to read them, but they are numbered. On the "A" side, pin 1 is blank. On the "B" side, Pin 1 connects to an orange wire. You are reading the pins from the wrong end.
    Here is the connector wiring, along with the color codes to help you figure out which end to work from. Connect your resistor from the yellow wire to the black wire directly across from it.
    image

    Right click on the image and choose "Save Image as" to get a full size copy. Hope this helps.

    Here is a close-up of the receptacle, with the pins numbered. Take notice of the locations of the guide notches along the bottom of the connector.
    image
  • Dang! I was reading it backwards. This was making my brain hurt because it didn't make any sense at all. Now I get it! I had the correct yellow wire but I had the wrong black wire. Dang. I couldn't figure out why the yellow was on the wrong pin. Now I see that it wasn't on the wrong pin, but that I was reading it backwards.

    I have the same diagram you posted. But for some reason it never clicked that I had it backwards. Thank you so very much. Now it makes sense and I should be able to do it without any trouble. Still can't find any of the 3 wires near the ignition. Couldn't even find them by looking up from under the dash. Very strange.

    I feel so stupid now. lol. But thank you.
  • What I had was the Trunk Release Switch for the black wire and then the correct yellow wire. So I was close. lol
Sign In or Register to comment.