Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Pontiac Grand Prix Climate Control/AC

etcbetcb Posts: 42
I have a 2005 GXP with 18K miles of problem free driving. I live in Virginia where in the winter the outside tempatures can get quite cold. <40 degrees. However, when I use the auto climate control and set the cabin temp to a comforable 70 degrees the air condition (AC) light always comes on. I sometimes turn the AC off which has no noticable affect on the inside climate. Is the AC light "on" normal when using the auto climate control? Nothing is mention of this condition in the owners manual. :confuse:
«1345678

Comments

  • srmackinsrmackin Posts: 1
    Hey fellas, new to this site, but have been feeling the Grand Prix pain for 2 years now. Actually, my 2000 GT coupe is a great car, except for one big problem: yep, that stupid leak in the passenger floorboard.
    Now, I've seen posts on this before. Under the plastic cowl is solid, that sucker is sealed to the windshield, and the weatherstripping is great. Someone told me the plastic cowl may be warped and I should get a new one. Dealer said it was $82.00 a side!!!!!!!!!!! But I really don't believe that's the problem.
    Someone else told me about the rubber grommit for the wiring harness under the carpet where it comes out just below the dash. The grommit wasn't flush, so I sealed that up good. But I don't think that's the problem, cause that's where the subframe connects, and wouldn't the car have to be moving for water to get in there?
    I've heard about holes in the firewall. DOes anybody know anything about that, and where it is? I had my glovebox out the other day and I was contorted under the dash, couldn't see crap there's soo much up there!!!!!!!!!!!!!
    Any help would be great. Like I said, the car's great besides this. But this problem is very annoying and the carpet is on it's way out. Only $120 for a new carpet, but I need this problem fixed. I was soo pissed at this the other day that I went to look at the new stang (they're still crap!!!!!!!!!!!!!!!!!!!!!!!!!).
    Guys, don't let this push me to get a Toyota. IF anyone has an answer, your help would be appreciated.
    Thank you in advance.

    Scott M.God Bless you on this Resurrection Sunday!!!!!
  • 97redgp97redgp Posts: 2
    I have the same problem a lot of GP owners have. This problem just started this last winter. The passenger side floods when it rains or snows. I checked the drains...poured water in my sunroof bin, and also in the vents by the wipers. All the water pouring resulted in it draining out the bottom of my car near the wheel wells. So those seem good to go. The car floods just sitting there.
    Any other ideas or quick checks to figure it out? My fan (a/c and heat) has crapped out too. It currently only has 2 settings: off and super high. I checked the fuses and they seem to be in proper working order.
    Any cheap suggestions would be awesome. I am currently trying to save up some money so I can afford to fix the problems once I figure them out.
    Its a 97 grand prix gt with sunroof.

    Thanks everyone.

    - Shawn
  • Check your water diverter just behind the lower part of the windshield--I had to call a windshield guy because I thought it was the seal. You just lift the hood, take off the hard plastic shield where the windshield and wipers are look behind it. If there is a big piece of rubber hanging, just push it back up and onto the frame (it fits like a glove) and you are good to go. My mechanic couldn't figure it out and they thought it was my AC. As for your fan, it might need a lube.
  • I had a flooding problem to with the AC on. The mechanic told me there is a valve on the firewall that gets plugged and overflows.
  • I had the same problem in my 2000. Pieces of a maple tree got stuck in a valve as part of the AC on the firewall. A GM mechanic told me just to take of the hose and clean it out. It had been plugged and with the AC on, it overflowed into the passenger side of the car.
  • mytfastmytfast Posts: 2
    I have both a 97 Gran Prix GT & a 98 Gran Prix GTP. The heat/cool blower motor on the 97 went up last year & the 98 is just now starting to act up. I've found the best source for replacement blowers is AUTO ZONE. I've also bought rotors & pads from them. They have a decent web site and offer the best availability to a large number of parts with really good prices & warranties! I have 7 cars (including 5 vintage) and use to buy from Pep Boys for over 25 years but they started reneging on their warranties & only relented after a class action suit was brought against them. As a result, I'll never buy from Pep Boys again & now buy from Auto Zone & in some cases from Advanced Auto Parts
  • storm3storm3 Posts: 2
    I had this same problem with my 99 GTP. I'd get a couple of inches of water on the floor board. There are 2 weather strips that you have to check. The one that caused my leak is about 16 inches long under the vent cover that is under the wipers. I had to use a small gear puller to get the wiper arms off after I removed the nut that holds them on. I'm sure there is a better way, that is just what worked for me. The piece of weather strip is press fit over the edge of the firewall and is supposed to divert the water to the sides of the fan opening. Mine was lying on the fan. It is a very weak press on fit. I glued it back on with silicon and have not had a leak since. Just make sure to mark your wiper arm position when you take them off. Now unfortunately it took me so long to fix the leak my blower motor is fried. All it does is squeal when I try to use it. I guess that's what I'm working on next weekend. I hope this helps. Good luck.
  • gsethi1gsethi1 Posts: 1
    Hello,

    Sorry if this question has already been answered...but my auto climate control reading is almost always too low and thus my AC will not blow very cold air. I've replaced the sensor that is mounted on the back of the radiator...What else could be wrong? Are there other sensors? ANy help would be greatly appreciated.

    Regards
  • gmfan007gmfan007 Posts: 77
    My '98 GT sensor was replaced a few years back for the same reason. As I recall, the NEW sensor did not work correctly either for several miles. I called the dealer when I got home and was told it would take some time to set itself. Sure enough, the next day it was fine.

    And just a couple of weeks ago, it did it again. It was in the 90s here, but the sensor said it was only 26 outside and therefore would not let the A/C come on. I even tried to fool it by putting on the defroster, but the compressor would not engage. I tried shutting off the engine and re-starting after about 30 minutes in hopes it would reset somehow. I got home and was all set to take it to the shop the next day. After letting it sit all night, it must have reset itself because it was okay the next morning. It seems to work fine if I remember to shut off the A/C before shutting off the engine. It's as if the sensor wigs out occasionally when starting the engine and the A/C is on .... (for what it's worth).
  • kwebbkwebb Posts: 1
    I am having the same problem with my 1998 Pontiac Grand Prix GTP. Everytime it rains I get a floorboard full of water on the passenger side. :cry: I called GM and they told me they have not heard of this problem. Stacy at GM told me that people need to call GM when they have this problem. Please Please Please....if you are having the same problem or had the same problem call GM and complain. The number is 1-800-762-2737. I have even been told that they have been known to fix problems passed warranty. I have had my windshield replaced, sunroof checked, drain tubes blown out, the rain deflector underneath the cowl glued in place and still taking in water. I have replace a A/C fan motor already and this one is starting to squeal. I took a look at it and you could see a water line. So water must be getting into it too. Be prepared....the girl said you really sound frustrated...have you thought about trading your car in for a new one...I could transfer you to a salesperson. I told her I wanted my car fixed. I only have 84,000 miles on it and if I was going to buy a new one I would not be inclined to looking at a GM product. Does this only happen to owners with a sunroof???? I would appreciate all comments!
    Thanks everyone!
    Kym
  • I have a 2000 Grand Prix GT with a similar problem. I notice water on my passenger floorboard sometimes but do not check every rain.

    I just finished replacing the fan blower motor for $100 and had manually fixed 2 pieces of broken stripline in the reostat module (used for the 5 fan speeds) to save me the 35 bucks for a new part. The GM engineers designed the fan blower with a rubber hose that comes out of the bell housing to drain any condensation that builds up and the runoff is what drains out to the passenger floorboard. This is a poor design in my opinion. The original fan I pulled out that is five years old is pure rust. I looked deep up under the dash for possible ways for water to come down as I had my winsheid replaced 2 years ago but could not see any water lines.
  • rscorbrscorb Posts: 1
    hello all
    I have a 1995 pontiac grand prix GTP with a 3.4 My Climate control under the radio is not working right..The AC air will blow out from the defrost and lower vents by your feet. But will not blow out of the vents in the center on both sides..What is causing it to not switch to the center vents??
    Thanks Randy
  • Just bought a used 1999 grand prix gt with the same leak problem. One day I found 1" high of water in the passenger front rug area after a heavy rain. Later a found out this a problem is apparent in all grand prix cars.

    There is a drain tube from the ac/heater that removes the condensation and any excess water as it rains. The tube leads into the engine compartment where the end gets plugged with debris. As the water builds up in the ac/heater, this water runs down the blower motor into the passenger rug. If you do not have water on the rug then the water held in the motor will short it out. In fact, remove the interior panel under the glove box and you may find green mold.

    To fix your problem:
    You will locate the end of this tube on the fire wall in the engine compartment about 1/3 the way down on the passenger side. Remove the 90 degree rubber elbow, clean it and re-install. Your problem will be gone.
  • del_64del_64 Posts: 2
    2002 Pontiac Grad Prix. A few weeks ago my climate control fan only worked in the 3, 4 or 5 position. Now the fan has stopped completely. I still get cool air or heat but no fan. Any suggestions.
  • I just found water on the front passenger side today. I have a 2004 GP GTP. Is the tube in the interior of the vehicle or near the engine (under the hood). I need a little guidance in finding it, thanks for your help.
  • I am having the exact same problem with my 2000 Grand Prix GT and I do not have a sunroof. I have also installed a new blower moter and my new one is starting to make noises.
  • robert718

    the rubber elbow for the drain tube is under the hood on the fire wall on the passenger side 1/3 way down.
  • del_64del_64 Posts: 2
    I changed the blower motor resistor (also known as a blower motor module). It is behind the fan motor, up under the passenger side of the dash and against the firewall. If you are looking underneath the dash, you will see a little black box. It is being held in by 3 hex screws. You can get to it by dropping the fan motor. The blower motor resistor is about $20 - 25. Plan on 1 to 1 1/2 hours of work.
  • I have a 2000 GTP and the blower just stopped working. I checked the fuses and they seem fine. However when I first checked the fuses there was none present in the HV/AC ctrl(blower) slot. I put a 20 amp fuse in there and still no air comes out. Do you think its blower motor resistor or the fuse?

    Thanks!
  • zn1102zn1102 Posts: 2
    It's probably the resistors. Had mine changed about 6 months ago on a 2000 GT. There already is a post here on where the resistor pack it is located.
  • tyrodtyrod Posts: 1
    I have the same problem that many people have had with debris and junk plugging up the drain resulting in a soaked floor and even worse, a soaked foot! It seems as though the problem arises when I use the AC and defrost.

    I took of the tube that leads into the engine and it was fine, clear as a whistle. So I tried shoving something up the pipe that the tube connects to and it went in a few inches but then came to a dead stop. What would work, in theory, is to hook up a drill and drill through the debris. The bad thing about that would be that the engine is in the way for any kind of drill.

    Is there any way to unplug the debris from the inside? Or would it be possible to drill a hole in the area that it collects in and let it drain out into a bottle or something? Or do you have any other ideas?
  • HELP The climate control does not work all the time and i live in Canada and is rely cold and without heat i can't drive
    HELP PLEASE
  • Did you ever find out the reason for this problem?
    I have the same problem with my 98 GTP.

    LP
  • Hey guys,
    Today I went out and started my car (2001 Grand Prix) to let it warm up. I turned the defrost on to high #5, and went inside for a few minutes. When I came back out, the blower was no longer running, but the knob was still on #5. All other settings, 1-4 still work but not 5. I believe numbers 1-4 run through the step transistor, but for the high setting, it by passes the transistors and goes straight to the relay. Could my relay be bad? Or the switch? Where are the relay and switch located?
    I also have been noticing a small whining noise after driving my car for more than 30 minutes. After shutting it off and starting it again, it goes away. Any suggestions?
    Thanks
  • Unfortunatley I can't answer your question! But I am having the opposite problem with my 01 Grand Prix.

    1-4 are not working, but 5 is! Is this caused by the step transistor? Do you know where the step transistor is located and what it looks like?

    Thanks.
  • Same problem with my 01 GT, only 1 and 2 speeds don't work, rest are fine. Just started happening this weekend, anybody have any idea's yet.

    Thanks!!!
  • I have a 1998 4dr GP GT. It recently started to squeal and now vibrates and reves the engine anytime i put the heat/ac on and it's very loud.
    It does not matter if i put the fan on high or low. It keeps vibration and squealing.

    Any help or advice will be appreciated.

    Thanking you
    Adrian
  • Is this prevalent when idling?? May want to check the Idler Air Control Valve (IACV).
  • I have a 2001 GP and there is a fuse box on the right side of the glove box. Remove the plastic box and there will be fuses in there. There is a 30amp fuse for the HVAC/HI on the lower section. If that fuse is blown, speeds 1-4 will work, but not 5. I am having a problem that with that same fuse in there, my 5th speed won't shut off, even with key off and removed. Any ideas?
  • My blower only works on 5. Help! I'm roasting to death. Any ideas or help would be appreciated!
«1345678
Sign In or Register to comment.