Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chevrolet Impala General Care & Maintenance

13»

Comments

  • I have a '05 base, 3.4L, and the engine keeps wanting to overheat. I have a full resevoir of Dex-Cool, but to no avail. I had to put in a gallon of dex-cool a couple of weeks ago (thought that was kinda strange, but went with it, since we've driven the car quite a bit since the last time I had it in for routine maintence). Noticed today that it was going over the middle line of the temp gauge (something that's not normal, at least not for my car. The temp gauge usually stays right in the middle, or below, between 1/4 and halfway). Stopped, got another gallon of dex-cool, filled the resevoir to the fill line, and thought that might do the trick. Not so much.

    I remember my dad talking a couple of years ago about another chevy model he had (I believe it was a trailblazer, but not totally sure) that had a seperate radiator cap from the resevoir cap. Does the '05 Impala have such? Has anyone had this happen to them?

    I'm stressing out. I can't afford a new car right now (nor do I want one) nor can I afford costly repairs. My husband is the only one working right now, as I try to find a job. If anyone has any info, I'm begging for help!

    Thanks

    Melissa :( :confuse: :sick:
  • wesleygwesleyg Posts: 164
    The main radiator cap is on the radiator, look in the owners manual and it will show you where its at. Remove this cap only when the vehicle is cold as it is pressurized.

    You will want to carefully check your oil on the dipstick to make sure antifreeze is not getting into the oil from a manifold leak or some such thing. If you noticed that antifreeze is getting into the oil, you must take immediate action or you're looking at replacing the engine which is as you know a BIG problem. Please let us know if you need further.
  • jsannerjsanner Posts: 2
    My 05 chevy impala has 2 of the 3 guages partially working.
    Fuel guage is fine, Temperature and speedometer work only 5 minutes of shifting into gears. Read on another link there is a recall on the fuel line itself, could leak fluid or false reading on guage, may cause fire.
    Wiper fluid freezes ever year when temperatures get close to freezing. This is the only vehicle I have ever had trouble with.
  • the_big_althe_big_al Posts: 1,069
    Don't get wax on the grainy plastic parts ??? :P

    JK - when I was a young first learning driver, I thought I would do my Grandma a favor by washing and waxing her Lincoln Towncar after she let me borrow it for a date. I ended up getting wax all over the plastic trim and it forever stayed there - she neve said anything, but I am sure she noticed it. I would like to think that she was more grateful that I would be thougtful enought to try and return the vehicle in better condidtion that when I borrowed it in. :D
  • Did you find out what this was? We have had many of the issues I have seen on this sight and you are the first one that I've seen that includes the rusty looking substance in the radiator like I have. My 2005 Impala LS says it is overheating but actually is not, the radiator fans wont kick on and it has been having shifting/jerking issues for two years that is only getting worse. It has been so sad since we had decided to spend money on a "new car" and ended up with all these problems. My car has been parked fro twomonths now. Please let me know if you found out what it was and what caused it. I am on low income budget right now and can't afford "exploratory surgery." Thanks.
  • I have a 2000 Chevrolet Impala and it was working fine until I had got a callback from the Chevrolet dealer for the fire compartment engine to be fixed, after they fixed that a couple weeks after that my battery light would come on chime for 3 seconds then the car would shut off the steering wheel would get stiff to the point i cant turn it and when i tried to crank it back up it want crank it has to sit for a couple hours or minute then it would crank up. I found out it was the fuel pump I had got that fixed the same day i drove it again i had the same problem so i took it too the shop they were like it was the censors to the car. I had got the gaskets a new battery that done under my hood of my car, so it worked for a couple weeks then it started shutting down again the battery light pops up the car shuts completely down, so i found out my fuel pump was no good so i got that replaced but i haven't driven my car since then because when i crank up the car the battery light pops up, the people that fixed my car is really good friends with my family and he keeps telling me too drive the car it want shut off but i'm afraid that it will shut off again in the middle of the road, he says all i need is a regulator to the car because everything under the hood is good.
13»
Sign In or Register to comment.