Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler Town & Country Warning Lights

2

Comments

  • brad54brad54 Posts: 5
    Could anybody tell me what codes 0442,0455, and 0466 mean? My minivan seems to running fine.
  • My wife and I own a 96 Town and Country LX with a 3.8 engine. It's front wheel drive. It stalls at Idle and bucks during upshift of its A/T. I did the ignition self diagnostic on-off thing and the Check Engine light blinked 5 times. This P.0.S. blew three transmissions in two week intervals since we got it and it's about "that time" again. Is there a permanant fix or should I tell the dealer we are paying for it to shove it where the sun don't shine? please help! :mad: It had no waranty(should have been a red flag) but it looks nice, has no body rust. We feel stupid for buying this :lemon: that came gift wrapped.
  • It is the gas exhaust recirculation sensor.
  • Have the code 1491 coming up on my 2003 T&C. Could someone help me with what it means? thank you
  • My wife's oil light is staying on... it has oil it in.. there are no rattles or signs of low pressure..... Help... or she drive it until it blows up....
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,679
    Hmmm, if it is not low, then my first suspicion would be oil pressure. It might be worthwhile to hook a pressure gauge up to it rather than relying on the dummy light.
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
  • Possibly the clock spring in the steering column under the wheel. There was a recall on them, but do not know if your year is affected by it. If you call any chrysler dealer or chrysler HQ, give them the last 8 digits of your VIN, they will tell you right away if you need the RECALL REPAIR. Mine is a 2000 and my light came on suddenly, and my horn stopped working. Just took it to a dealer today and had it changed. Picked it up at 4pm and drove home. No more airbag light, and the horn now works. BUT driving home, :sick: I turned the wheel while braking, and making a left turn, and the radio died then came back on, but the stations had been wiped out of the memory settings! I am guessing it is a bad connection from something they did, because my model has radio controls on the steering wheel at the back od the air bag & horn cover. Anyone else have this problem or hear about it? :mad:
  • Hook up a oil pressure guage(the kind with numbers on it) to it and watch it for a while as you use it to see what the pressure does. It is possible your oil pump is on it's way out! Happened to me, and I learned the hard way.
  • brandycbrandyc Posts: 1
    I have a 03 Chrysler T&C and I just had my transmission serviced 1 month ago. I have 65,000 miles on it. Last night my check engine light came on and the van would not down shift as I drove. This morning, it seems fine, shifts normally. However, the light is still on. My error code is P1684. Can anyone tell me what this means?

    Thanks in advance
    Brandy
  • srs_49srs_49 Posts: 1,394
    From Wikianswers.com-

    P1684-The battery has been disconnected within the last 50 starts
  • munsonbmunsonb Posts: 2
    Hi- we have a 2005 town and country touring van that pretty much everything has been replaced including transmission ( last year right around 59,000 miles).. anyhow our latest issue was we noticed that the floor underneath the passenger side is wet. We took it in and were told that there was a part actually missing completely that goes to the a/c unit to pump out the water. so we bought this 90 degree looking tube and sure enough water started piling out underneath. well 2 days later the check engine light when on and took it back. Now they tell me my gas cap wasnt on tight enough. all the lines look fine, etc.. so now the next week is here and Im still have some issue with the floor and over on the driver's side also.. It clear fluid, no odor so Im assuming its condensation?? there is no issue with plugged clogs either.. any help would be appreciated.
  • captainibccaptainibc Posts: 6
    The check engine light came on. I was told that it may be a problem with the gas cap. I changed the cap and things were fine for about 100 miles. The check engine light came on again. The code that comes up on my car is for an evaporative emmission code. Does anyone know what is wrong. My mechanic can't find it. They checked all vent tubes and cleared out the codes. The engine light came on again. I tried the on/off ingintion and these codes came up on the odometor: P1684, P0442 and P0456. Does anyone know what may they may be? Will this cause the car to brake down. I'd hate to go to Chrysler and get ripped off.

    Thanks for any assistance.
    Captain IBC
  • srs_49srs_49 Posts: 1,394
  • captainibccaptainibc Posts: 6
    Thanks for the info
  • carvirgincarvirgin Posts: 1
    My 2005 T&C 53K miles on it just had the engine light come on yesterday. I read a few things on-line, some people said contact Auto Zone - I did but they won't check the car. Okay. Called the dealer and he said give it a few days, might be the gas cap. So I took care of that. Light still on. Tried to find the code using everyone's advice - nothing's coming up.

    Trying to figure this out myself because I don't want to take it to the dealer but getting frustrated.

    I will go back and re-read how to find the code but any other advice besides taking it to the dealer?

    TY! ;)
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,679
    Buy your own code reader! They are less than $150, and once you use it twice, it paid for itself versus taking it to a shop for a "diagnostic," which typically costs around $80.
    2010 Subaru Forester, 2011 Ford Fiesta, 1969 Chevrolet C20 Pickup, 1969 Ford Econoline 100, 1976 Ford F250 Pickup, 1974 Ford Pinto Wagon
  • srs_49srs_49 Posts: 1,394
    I agree about getting an OBD-II code reader. You can get an Accutron unit for around $50.00
  • Turn the key 2 0r 3 times wiothout starting the car and look at the odometer the codes will pop up there. write them down then turn the key on and off again without starting the car. i hav ean 02 T&C limited and this works. hope it helps
  • did the key triuck and got code p1684. I left the neg off the battery for 15min and then reconnected the battery light goes out for 2 days then comes back on. I dont drive that m,uch during the week so sometimes it doesnt come on for 3 or 4 days after I fix it. I would say I do anout 100 miles beofer the liught comes back on. any help would be great. SHould I get a new battery ??? mine is only 1 1/2 years old.
  • I have the little red circle on the dash, it wasnt there before the car wouldnt start. Now, turning the key will not engage the starter. The starter has been checked and is fine, battery is fine, lights come on. How do I replace the anti theft module, or what ever it is called? I understand it needs to be programed to the key as well.
  • weitangweitang Posts: 2
    Hi guys I have a 01 chysler town and country, couple days ago my engine light came on, and I'm sure that the oil and everything was fine. So I restarted the engine light, it was good for a couple days. Today it pops up again, I also smell somethings funny around outside of the car. Is like something is burning. I pop the hood and everythings in there looks just fine. I'm planning a 5 hours trip tomorrow, was wondering is it safe to drive. The engine light is not flashing, but it seems like when i turn the wheel shakes a little bit. Please help guys.
  • weitangweitang Posts: 2
    I also check the gas cap it was tight.
  • srs_49srs_49 Posts: 1,394
    Unfortunately, without knowing what the OBD codes are, most of us would just be speculating.

    OK, I'll speculate - burning smell and CEL on could mean the catalytic converter has gone south.

    Try to get us the codes.
  • Had the code P0601 come up and I think that is the main computer which I had replaced with a brand new one just over a year ago. Can it really be bad already? Should it still be under warranty?
    I also had a lot of corrosion from battery acid build up on the battery terminals. Could that have possibly threw off the diagnostic reading? I did clean the terminals really well, started the car and the engine light did not come on. Then a couple of hours later when I started it the light came back on. What should I expect that this is?
  • try your OBD code reader by turning your key forwards and back to the off position then back forward then wait a few seconds and look were the speedomotar is and the codes should come up then look them up on the internet
  • Your problem is almost certainly the printed circuit board being the gauge cluster. I had the same problem with my 1998 LXi. The fix cost me just under $700 at the dealership about three years ago. I've been told you pull it yourself and try to re-solder cracked connections if you have the mechanical aptitude.
  • Hi...my CEL came on about a month ago and turned off after a couple of days...week went by and came back on...then intermittently between engine starts and nothing for the past week. Should I be concerned? Also, can I still get the codes to come up if the check engine light isn't presently coming on? Thanks!
  • srs_49srs_49 Posts: 1,394
    Should I be concerned?

    If the van is running fine, I would not be concerned.

    Also, can I still get the codes to come up if the check engine light isn't presently coming on

    Any OBD-II reader/scan diagnostic tool should be able to pull any stored codes, even if the CEL is not currently on.
  • Good news! Thanks for responding so fast.
  • turn the key 2 or 3 times and look at the odometer it wiull give your the codes, you will get p1684 and maybe 2 or 3 others which are for the evap system, I have had it fo 2 years on my car with no problems. there is a leak in a hose somewhere and the only way to find is with a smoke tester. also check under your hood at the front left (by grill)by the fan belt there are 2 hoses going into a small container i forget the name, ill find out for you. see if that is detached or those hoses have a hole in it. could also be your gas cap.
2
Sign In or Register to comment.