Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler Town & Country Warning Lights

13»

Comments

  • my 2001 Chrysler T&C has engine codes PO601,PO122.PO123.PO118,PO106,PO206,P1478,P1496 it was running fine all day and suddenly started bucking and surging missfiring and has a burning smell outside the van are most of these codes because of the engine control module also can smell raw fuel coming from tailpipe HELP
  • wcgreerwcgreer Posts: 1
    I have pulled the trannny to put a new torque converter seal in. I put it all back together and it wont start. It was running fine before, just leaking fluid. The only code to come up is p1684. I bought a code reader and it says no codes but the odometer reads p1684. can anyone give me any advise as to how to fix.
  • john593john593 Posts: 1
    1999 T & C. Service Engine Soon light on. OBD II reader says no codes. Light won't turn off. Ideas??
  • KCRamKCRam Mt. Arlington NJPosts: 3,516
    P1684 just means the battery has been disconnected within the last 50 starts. Not an error, just documenting the event. You likely disconnected the battery when you pulled the trans.

    kcram - Pickups/Wagons/Vans+Minivans Host
  • billgrissombillgrissom Posts: 15
    edited March 2013
    Did you put the crank position sensor back? It sits at the top of the tranny bell-housing and you must have at least unplugged it. If you didn't remove it, you might have damaged it in getting the tranny out. You won't get any fuel flow without it because the injectors fire from that signal, similar to how you wouldn't get spark in an old car without the distributor turning. The sensor tip needs to sit very close to the slots on the "toner ring" since a magnetic "Hall-effect" sensor.

    When you pulled the tranny, you should have checked the flexplate. Mine was cracked all around the bolt holes and rotated ~20 deg, which you wouldn't see without removing the clamp ring. I understand a common problem. My engine had ~170K miles. Indeed, I would always replace the rear engine seal during this job, so you would have seen that.
  • Engine starts up as usual, except all the dash gauges go all the way to the right then return to normal position.
    Also, radio/CD does not work. And remote door lock does not work, and the door lock button does not work unless engine is on. All other components work as usual.
13»
Sign In or Register to comment.