Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge-Plymouth Neon Electrical/Lighting

13567

Comments

  • yea actually i know how to fix that, mine did that a while ago. I clean mine now about once a week and they really work. You got to remove the headlight itself. When you pull it out and pull the light out, if you take a cleaner such as greased lightning or simple green or even just normal dish detergent and a long thin toothbrush, you just scrub it out. the more frequently you do it, the better they look but i know you will see a difference after the first time u do it. i also do my blinkers too. those are easier to remove and clean but even thought the headlights are kinda a pain to take out, you'll be glad u did after they look better. If it still looks a little dull, try buying brand new headlights, maybe even investing in those halogen lights. i have those and my lights are so bright, they look fantastic! hope i helped!
  • I was driving into my work and I accidentally drove over one of those cement planters in the parking lot..I would estimate they are like 6 " high. The front end went up then *BAM* back down.
    After looking around to see how embarrassed I should be, I looked as good as I know how under and around the car everything looked fine.
    I drove home about 6 miles away when I got off work.
    The next day when I drove back to work, I went through a huge mud puddle.
    The car died.
    The next day we tried to jump it..nothing.
    Then when I had it towed home, when they were lowering it down my brother says oh here's your problem and had a quarter size piece of metal in his hand. He said it was from the oil pan.
    Ok..well the week before I was driving and without notice, it just shut down..everything died! All instruments not the engine. There was some sort of weird code "nobus?" was the only thing visible. I pulled over turned off the key.
    I sat for a few minutes and then it started but the MPH gauge wouldnt work after that but everything else did.
    Also it was a new battery.
    Also prior to this I was blowing fuses like every other day. I couldnt play a CD and run the heater or any 2 things together or they'd blow.
    I haven't had enough money to have it professionally looked at.
    Today though - out of curiosity, I checked the oil and it was on the add mark...visible oil on the stick.
    If it was the oil pan or engine block? wouldn't all of the oil have leaked out?
    So I put 1 quart of oil in it and a sheet of plywood under the engine..and no oil came out.
    I checked all the fuses AND took the positive cable off.

    I charged the battery after that for hours and some things worked.

    The anti theft alarm sound is weak.
    The radio wont work.
    The instrument panel and heater were operating.
    The car doesnt turn over but there is a distinct click click click sound.
    Then it died completely again.!!!
    The battery light illuminates and also a round red circle(DOT) in the upper right panel shines.
    Thank you so much for your time.
  • klopez12klopez12 Posts: 2
    Waz up .... I'm having a problem with my headlights....

    when i turn on the lights one side always is on high lights and the other side is low...

    so i don't know what i should do....

    maybe i should replace the fuses or the wire harness.... ?????
  • ne0nne0n Posts: 1
    Background: Bought my 1998 new. I've got 117,000 miles on it, and it's been a great car so far. This is my first brand new purchased car and I'm glad I've gotten almost 10 years out of it, I enjoy saving money not having car payments and the fuel efficiency is great!! (38 MPG!!!)

    Replacement parts: headgasket, motor mounts, oil pan gasket, spark plugs 3x, water pump, timing belt, PCV 3x, fuel filler neck, radiator 2x, brakes, battery, rear lamps, headlights, and some body parts --damn deer!

    Recent undiagnosed problems:
    » I'm driving down the road and my airbag light will come on, then go off.
    » Occasionally my radio presets will change without warning.
    » This past winter when letting the car warm up then returning to it, there's a heavy smell of burning electric something (happened a few times).
    » When the fuel filler neck was replaced we found a wire that was exposed near the gas tank.
    » When stopping at stop signs or lights the car will quit at low RPMs (this happens so infrequently it's hard to pinpoint ).
    » My factory CD player no longer plays burned mix cds.

    Considerations: It's been involved in front and rear collisions, and superbly patched up.

    If you've got any solutions or suggestions for any of the above recent problems, I'd love to hear from you. :)
  • dukereecedukereece Posts: 2
    I just bought a 1997 Neon, and the gauges don't work. We knew this when we bought it, and the shop that we bought it from thought that they diagnosed the problem. They said that it was the Powertrain Control Module, but when we replaced the PCM, it didn't do anything different. Does anybody have a possible solution for this? The shop that we got it from didn't know what was wrong with it either, so if anybody can help me...I would greatly appreciate it.
  • dukereecedukereece Posts: 2
    ok...I might have an answer for a few...first...I know that on my 97 neon there was a recall on the airbag control module, saying that it could cause the light to go on, or it could even cause the airbag to go off upon ignition of the vehicle! I don't know if this is the case on the 98. I don't know exactly what the problem is with the car dying at low RPMs, but I had the same problem w/ my 89 buick regal...the problem can be just simply the fuel injector system getting old and coroding, and it can be helped simply by upping the idle on the car a little. Note that this will not "fix" the problem, but it will keep the car from dying at stop signs. As for the factory sound equipment. Those just go bad easily...theres just corroding on the inside of the head unit (the stereo itself). If you want to fix the problem I'd say you replace it. You will probably be experiencing problems with sound quality as well along with speakers going out one at a time or all at once.
  • Hey im 16 years i have a 1997 plymouth neon i love working on the car but i have come to a dead stop im trying to get it inspected so i can have my own transportation but the backup lights will not work its a 5 speed and i have tested all the way back to the termonals and the test light will light up but the lights wont i have changed the bulbs sevral times just to see if the new bulb might have been faulty still nothing can anyone help me ?!?!?!?!
  • melissa8melissa8 Posts: 2
    I have a 1995 PLymouth Neon with about 60,000 miles on it. Whee! What a loser. At any rate I have a problem. Last summer I dealt with the dreaded head gasket. I replaced the water pump and the timing belt. This summer I have another problem. About a month ago the car started running rough...stuttering when idling, having trouble accelerating (more so with the air con on) etc. Then the check engine light went on. My boyfriend checked the error code and got a 43. So we have chagned the spark plugs, air filter, ignition coil and the fuel filter. So far things get better for about a half a day and then start all over. Hard accelerating when cornering with the air con on seems to be the worst time. Any suggestions? Oh and we used the fuel cleaner stuff too.

    Thanks
  • tjoristjoris Posts: 1
    I'm trying to install indiglo face gauge on my instrument cluster. I need to know where the wire parking lights are so I can splice into it to get the gauge to light up when I switch on my parking lights.

    Can anyone help?
  • does anyone know where the oil sensor is on a 2001 neon?
    thank you

    xxxooo :mad:
  • dssrondssron Posts: 1
    I have the same problem, any help out there? :(
  • chat2mechat2me Posts: 1
    I have a 1996 Neon and had the same thing happen. I found the solution on wikiAnswers.com. And it works! The fix is to pull the intrument cluster - which is very easy and the whole fix takes no more than 15 - 20 minutes.
    Here is the fix:
    You need to resolder the connections to the two large plugs of the instrument panel.You will need to lift off the dash board,just lift or pry it up. There is four Phillips screws that need to be removed,now with a gentle pull the panel should come out.Now you`ll need a torx screw driver to remove the circiut board to get to the printed side. Resolder all the connections going to the two large plugs and that should fix your problem. See the artical at the following page: http://www.neons.org/modules/news/article.php?storyid=18
  • Where did you purchase your fuel filler neck from? Mine is leaking gas and I need to replace it asap but I don't want to pay $300 the dealer is quoting me for it. So I was wondering if you were able to purchase it from somewhere else cheaper. Thanks!
  • neon101neon101 Posts: 1
    I have a 98 Dodge Neon, last night when I got home I noticed that my highbeams where on (didn't turn them on). Tried to turn them off but they wouldn't shut off. (Interior highbeam indicator and actual Highbeams where on). Took the switch off, lights still on (car is off). Eventually had to take out fuse so they would turn off but obviously I need to fix this because I can't drive at night. Anyone else have this issue? Any ideas?? Please help! Thanks!
  • I have had my 2000 plymouth Neon for 2 years now. Bought it with 72,000 miles. It's now at 97,000 miles. The problem started a year ago, the fuse that controls the back-up lights and rear defroster blew and kept on blowing.(10amp) Replaced it one time to many. (I have packets of fuses just laying around in my car). In the winter I had to replace the fuse just to defrost the back windshield, and then it would blow after I put the car in gear.

    The recent problem started this Sat.8/4/07.

    The fuse for the the turn signal blew.(15amp) I replaced it several times since then, but it still doesn't work. The signals would work for 1-3 mins, then blow again. (Yet again I have to carry packets of fuses in my car).

    I have dealt without having any back-up lights for a year but not having any turning signal, is ridiculous. I just can't deal with that. I have tried everything to get it to work, but have not had any luck. If there is anyone out there that can give me ANY advice, it would be greatly appreciated.
  • Matthew,

    Did you ever get any answers to your question, I have a 1995 Plymouth Neon with a similiar problem. Thanks in advance - Pete
  • neon04neon04 Posts: 2
    i got a quick question does any one know the correct way to install fog lights... i have them on my car which is an 04 but i replaced the bumper to the one with fogs and i just need to no the correct way to install them if u can help me out i would appricate it you can email me at rbeicht@hotmail.com
  • Had this problem with the wifes neon, finally found the problem of the pins behind the cluster, vibration had broken the connection of the pins to the board. A small soldering iron to the breakes did the trick... worked good untill my daughter totaled out the car.
  • i have a 1999 plymouth neon expresso ((sp?)) and sometimes there is a dinging noise like the one when you dont have your seat belt on. it comes on randomly and there is nothing you can do to stop it. eventually it turns off. Another problem is sometimes my speedometer will flicker then die. somethings it comes back after a few seconds, but others it just stays dead until you turn off the car and restart it. Any idea's what is wrong?
Sign In or Register to comment.