Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge-Plymouth Neon Overheating

13»

Comments

  • My 97 plymouth neon is running hot but it doesn't overheat.No over flowing of radiator fluid.I changed out the thermostat but it still runs hotter than it should!!! Any ideas?? thanxs Gina
  • beaudsbeauds Posts: 1
    Where to start, I have a 1997 dodge neon and something is defiantly not right. If i have my car on for about 10 minutes my temp guage will start to rise, and eventually will be at H, but then it will slowly randomly spike back down to mid, and then spike back up again, back down, back to H, and so forth..If i turn my car off with it being all the way at H, and turn my car over to just the guages having power, or even being all the way on, the temp guage goes to about mid. If i leave the car off for awhile, the engine cools like normal. Ive tried replacing the whole cluster unit, and also tried re soldering my old one. Didnt fix it. Since ive noticed that when the car goes to H, my radiator fans dont come on, nor do they ever, thats a problem it self. Also i just replaced the radiator cap and thermostat. When the car goes to H, the therm. doesnt always open. The other day i was letting my car idle and i saw smoke coming from my hood, it was only coming from the side where the overflow tank was and the radiator res. is. And i drove it home quickly to find out all my anti freeze leaked out..weird back pressure perhaps? I told a guy who works solely on neons the symptons and he thinks its a headgasket, anyone else have any ideas?

    Thanks
  • fan doesn't kick-in when it sits and idle gauge will start to rise toward Hot,they told me its the relay so I replace the relay in the fuse box.still the fan doesn't kick-in.
  • i have a 95 as well i had the same problem, its actually fairly common its just the thermastat and housing replace both and it should be good if not do as suggested and check for bubbles and signs of a headgasket failure
  • i had same exact thing, turned out, for some reason, being a crappy ground from battry to car..bolt was hot...replaced cleaned fine
  • tonioltoniol Posts: 6
    Wiggdogg,

    I have a 99 neon coupe sport that does the same thing as your symptoms describe. I have learned in the past that when you replace a thermostat it best to get it from the dealership of any make of car. I done that but I dont know why a OEM thermostat works better. I have flushed the radiator. Checked all the fluid levels (oil) included. I am the second owner of the car, I bought it from a family member. It has 208000+ miles on it. There are no leaks. As I type this and after reading some other posts. I am going back to check the radiator cap. I know you said your car is a 97 model, but we both have the same symptoms. I would like to thank you in advance for any advice you might have to help solve my problem.
  • tonioltoniol Posts: 6
    Wiggdogg,

    I read this as well before I posted my symptoms and reading it again and see it was from you. I am going to try this as well....wow... Just didn't pay attention to the posts. And you are saying because of a corroded connection from battery to body of the car would make the engine over heat? I will definitely check this out...Thanks again in advance.
  • Hi
    I've been having the same problem with my 99 neon- did you try the battery clean up that wiggdoff suggested ... & if so did it work?
  • tonioltoniol Posts: 6
    I couldn't find the person that posted this therefore I copied it out of my email and hope he/she will see it.

    #74 Re: 1997 Dodge Neon Overheating [beauds] by gvalley1 Aug 29, 2011 (11:36 am)
    Hi I've been having the same problem with my 99 neon- did you try the battery clean up that wiggdoff suggested ... & if so did it work?
    View/reply at: Re: 1997 Dodge Neon Overheating [beauds]

    All connections to battery are clean, posts and the ground to the body of the car, but it seem strange a corroded connection to the body of the car would make keep spiking up and down between halfway of the temp gauge and to hot. I think I am going to try a complete coolant system flush. Hopefully that will work, but if there some reason that corroded connection will make it run hot then I will look at it again and hopefully check the connection to the starter, but it really don't seem logical.
  • hello, i have a 95 neon as well. a couple months ago it over heated for the first time since i got the car, so i replaced the thermostat and it ran fine for about 2 months. and about 3 weeks ago it over heated again, then the next day it was fine. im not sure why it would just randomly over heat like that. but again, it ran fine for another 2 weeks, and then started over heating again!!! its like the car is having mood swings or something lol idk. but this past weekend i drove it home to arizona from california and even going 80 on the freeway it over heated, so when i got here i took it to the shop. i guess the entire radiator was corroded and the fluids werent circulating correctly. so yesterday i picked it up after they put a new radiator in it. and today i was stuck at a stop light and it got hot again! im not sure what is going on here. i took it back to the shop and they did all the tests again and test drove it and it ran FINE im so irritated at this point. i hate having this 50/50 chance of my car over heating every time i drive it. obviously when it starts getting warm i turn the heater on full blast, but come on i live in phoenix and its still summer! this is not right....

    PLEASE any advice or suggestions would be GREATLY appreciated!!!!!
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,501
    Neons are notorious for head gasket issues so you folks better look into that. You can test for it.

    MODERATOR

  • that was the first test i got done. and the head gaskets are completely fine. when i took the car back today, the mechanic even tested it again to make sure.
  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,501
    Okay...do you know how he tested for it. Best way is to pressurize the cooling system, then, while it's still under pressure, pull the spark plugs and look for coolant on them. Also you can test for combustion gases in the coolant by adding a chemical to the radiator.

    I'm always suspicious of Neon overheats, so that's why I mentioned this. But sounds like you're ahead of me on this one!

    MODERATOR

  • Hi in response to your post.... I have did everything I know what to do replace the thermostat, radiator cap, water pump and now I have a radiator for the car now that I have read your post and you said you replace the radiator hell I am about scare to try it. And if I take it to the dealership it might cost out of the ying yang and they aren't going tell tell what the problem might be, just bring it in we go to look at it...right. After all the work I have done to it I guess that is what I am going to have to if the radiator replacement don't work.

    Getting frustrated!
  • i wouldnt replace the radiator until you get it checked out and see if it is corroded really bad, if it is just plugged get it flushed before you replace it. i would have flushed mine but i couldnt, it was so bad it was like falling apart since it was the original one. BUT even with the new radiator in my car it still got hot. so i dont really know what is wrong with it. im just saving up as much as i can to get a new car, I AM SO OVER NEONS!!!!!!!!!!!!
  • Jesshold,

    I replaced the radiator and it seem to be working just great. I have a 99 neon sport, I am just going to keep an eye on it
  • when i took my car back to the shop after it got hot again after i got a new radiator, my mechanic installed a plastic shroud on the bottom. its been running great ever since! BUT i got a whole new problem now haha. was turning into a gas station the other night and my car completely shut off and my steering wheel locked up. got a few different people to check it out. one says its the o2 sensor, one says its the fuel pump or filter haha. WHO KNOWS. like i said before, im so over this car. im pouring more money into it than its actually worth.
  • Great idea! about the rewiring of the fans! LOL
  • I replaced everything but the fan relay. I am going to look at the fuse again in the relay box. I got rid of the overflow container cause all it did was leak anyway and it was in the way when I replaced the head gasket. I heard the coolant temperature sensor was what was causing the overheating. Now I used to have a leak but I found that and that was what I thought was overheating it but after repairing the leak. It overheated again so that's when I tried the coolant temperature sensor. The leak was a bit of hose behind the intake manifold that goes from the head to the heater core. Now I know where the fan relay is. Occasionally I hear them run but I have not noticed when it overheats because I am driving it. I am going to look at the grounds again because I found one that was not connected at all when it should have been. As far as the gauge cluster it seems that when taken apart it just rests on top of the plugs for the gauges. I just wack it till it works again aparently the plugs don't hold it tight enough. I was toying with the idea of putting some screws into the gauge cluster to hold it tight but haven't felt like taking it apart again since the overheating started.
  • Mine did the same thing it was the fuse box. I bipassed the fuse box, ran a wire from my fans to my battery and onto my ignition switch( incase i forgot to turn em off ) and toggle switched it right on my dashboard. works like a charm
  • Low and behold I think I have the solution to all your problems. THe problem I narrowed down to being the coolant temperature sensor not sending the right signal because I had heard they go bad and become defective after a while.
    What I actually discovered is that the sensor is in a bad location and difficult to get to. In order to work on these new front wheel drive cars you actually need to remove some parts to get to the parts you need to replace. In the proces the wiring is also often removed. The problem is is this causes wear to the wiring.
    In this case the plug that goes into the temperature sending unit. The plug often needs to be untwisted because often it is twisted to plug it in properly. The problem with twisting it is that it causes wear to the wires connected to it so that the insulation gets damaged and the bare wires touch one another. My plug was actually twisted around so bad that all 3 wires going into the plug were wrapped around each other sending or not sending a false signal to the pcm or the computer for the car.
    I called the dealer and they could not supply me with a new plug so I carefully untwisted it so the wires would not break. Now I Could get another plug from the junkyard if I found one good enough to replace it or I could supply it with new insulation to the wires because they were just bare and undamaged. So I Chose to try to insulate it as the most time and cost effective solution. Now we are dealing with a sensor with uses vey little voltage. Actually not voltage at all but ohms. It doesn't use enough electricity to be measured in voltage only ohms. So there would be no danger from arcing like it would if it was in the ignition system which uses thousands of volts.
    Since the wires were so small and close together it would be nearly impossible to use electrical tape to insulate them. What I needed was something to coat them. I had some gasket maker in a tube. I squeezed enough of that to the cover the bare sections of wire and to creat a durable repair. I then waited about 20 hours for it to dry. It fully cures in 24 but you can use it immediately if you have to in the case of gaskets but in this case I waited 20 hours because I wanted it to be nice and firm when I plugged it in.
    End of story is the car no longer overheats, the check engine light is out, The temperature gauge is not erratic. The car starts right away when it is cold or hot and the car runs propelry at idle. This sensor is very important for the rest of the engine management system and it controlled all those symptoms listed above. Thank you for listening.
  • tonioltoniol Posts: 6
    Rick that sounds very very logical but can you give me some insight on why would the coolant reservoir would fill up and it seem like it purges it self... I was reading another here stating that there is a coolant hose that comes from the heads if I am not mistaken that goes to the heater core that cool be doing some leaking, however could there be air in the system? Coolant in the reservoir seem like it boiling but no high temp gauge displaying. I did release the pressure the cap and had it like 98% but when I press back on the cap the reservoir would seem to boil but I think it air is being expelled to the reservoir. Replace the thermostat a second time still the same. I was think about going to get a pressure test for air in the system and trying to locate this leak it only leaks when I drive a while. Insight please and thanks for you findings on this issue. I was leaning toward the temp pressure switch or the item you mention just that I have go out and buy it.....

    THANKS!
  • Okay when a liquid overheats it expands and there is the hose from your thermostat housing to the coolant reservior. When the liquid expands from overheating it causes a lot of pressure. Ideally the cooling systme runs at 16 psi but when it overheats the pressure goes up higher and the radiator cap is supposed to react to that presssure and open so that the coolant goes into the reservoir. Now the Neon is supposed to run on a 50/50 mix of water/coolant. If you do not have enough coolant in it it will boil at a lower temperature and expand at a lower temperature. Now if you add more coolant when the reservoir is full you'll get more out when it boils again. THe overflow reservoir is just that an overflow reservoir. I do not know how you're suposed to get the overflowed coolant from the reservoir back to the engine. Some people say that the coolant willl be sucked back in. Now that is the case with a degausse bottle but the overflow reseroir we have on the neon is not that. The problem isn't that the reservoir is full or not full the problem is that your car is overheating in the first place because only overheating will fill the coolant reservoir. Now I chased this overheating all around my car I thought the radiator leaked because I saw a plume of smoke coming from it I thought. Turned out it was a small piece of hose that was not the correct length behind the intake manifold next to the thermostat housing. I had thought that is was leaking then overheating becuase of this when it was actually overheating causing it to leak. That's what I think is happening to your car it is overheating causing it to fill the reservoir. But why is it overheating? FIrst thing to check would be the thermostat they go bad about every year or two depending on the mileage you put on the vehicle. IF you do not have an automotive manual for your car I suggest you get one. They are sold in most auto parts stores. There they have a list of symptoms and possible causes for those symptoms that can help you narrow down your search for the problem. With mine I was getting a code saying that the coolant temp sensor was faulty. I didn't have a scan tool at the time so I had to take it to the local autoparts store to get it scanned for free. I scanned it because the check engine light came on that means that there is a code in the computer for you to look at. Now I had heard these sensor go bad or become defective so I bought a new one. After that the gauge read hot all the time. So it looked like now it was the gauge the whole time but when it overheated before I ever replaced the sensor for the gauge the gauge read accurately so I unplugged the new coolant sensor and plugged the old on back in. The same thing happened the gauge read hot. So now I know that the problem lays between the gauge and the sensor. That means the wiring in between had a short. Now the reason I replaced the sensor was that it was not telling the cooling fans when to turn on. When I looked for the short I started taking the old crumbling conduit that protect the wires in the engine compartment off. I started at the beginnnig at the plug for the sensor it wasn't until I had moved further and removed more that I found the problem. I was going to plug the sensor back in when I saw bare copper at the very end of the plug where the wire was sticking out. It has 3 different wires to it the sensor does and all three were wrapped around each other without insulation causing it to short out and cause the gauge to read hot at all time. Before I replaced the sensor it was probably wrappeed around enough so that 2 of the wires were wrapped together causing to short out and not turn the cooling fans on. Like I said that sensor is in a difficult spot and you have to bend and twist the plug around slightly to plug it into the sensor. Apparently I twisted it too much or two far when I replaced it but it was already partially twisted from whoever worked on the car before me because it was twisted at one full turn to get the wires to wrap around like that when I had only twisted it a little bit.
  • anyway for you to post a pic of the wires and sensor
    if you send it to my email put neon pic so i know what it is for

    as for the head gaskets
    thinking this is the same thing as the olds bumpers that fell off
    two metals that dont get along together
    same thing for the ground wires

    all the relays are the same trade the fan for the horn beep the horn if it works its good for the horn anyway in case it was over heating it

    thanks for the Forum

    the car i have is 96 neon with only 51000 miles on it
    just had the head planed today it did not take all the pits out of it
    now i wish they still made copper paint like they used to

    john
  • neonrangerneonranger Posts: 1
    Seem common for neon to overheat after loss of cooling fluid or work involving the cooling system. May I suggest you try jacking up the passenger side as high as you can remove coolant cap run till thermostat opens you will get a small amount of air out of the system.
    Had heating trouble after I replaced a bad head and this solved it cost nothing but time
13»
Sign In or Register to comment.