Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Windstar Electrical Problems

17810121318

Comments

  • Message center jut up and quit. I am referring to the digital readout of fuel mileage, compass and a multitude of information on the how the systems are working. Does anyone have a suggestion on what may have caused it and just what controls this message center. Thinking it could be the computer, need help.. Thanks much... Art
  • gigi4224gigi4224 Posts: 1
    Had the cruise control recall repaired last night. Drove home approximately 4 miles home and 2 hours later, my car won't start. Had it jumped, and now no electrical works inside or outside vehicle. Headlights, blinkers, every light is out, but the ABS light on the dash is lit. Limp it back to the dealership and the car won't go over 40 mph. They had replaced some wire harness for the recall but obviously something wasn't done right. Ideas?? Suggestions??
  • a1mike1aa1mike1a Posts: 9
    gigi4224
    I replaced my brake switch on the master cyl which is what they did to yours.
    I cleaned off the brake fluid from the wiring first.
    Try looking at the main fuses and breakers under the hood.
    They must have let the brake fluid short your wiring.
  • hlotzhlotz Posts: 2
    I have a 2002 ford windstar with the following electrical problems: speedometer does not work, brake warning light is on, a/c is not working, speed control is not working, brake release warning light is on, overdrive light is flashing on and off. IT seems that all of these problems must be related to some major part and the dealer wants to charge individual diagnostic fees for each problem that i cannot afford. Accordingly, I would appreciate some help.
  • a1mike1aa1mike1a Posts: 9
    Take your van to your Ford dealer for the brake switch warranty repair.
    This should take care of most if not all of your problems.
    The old switch leaked brake fluid down the wiring harness, causing a lot of electrical problems. I replaced mine for about $15.00 before the warranty campaign started.
  • that is absolutely ridiculous! you could buy the dang diagnostic reader and do it yourself for cheaper probably. Try checking the computer that is located in the trunk of the van where the jack is located, on the side compartment. it controls a whole but load of stuff. i had to replace mine, got one for 80 bones at a junk yard. dealers didn't know what the problem was but my hubby figured it out on his own and the Lord's direction. Thank the Good Lord! I am sure the dealer would have charged us an arm and leg and possibly or first born! ;)
  • 99 Windstar LE- Has taken to temporarily shutting off while driving, tack goes to 0- instruments fluctuate- engine refires, then after several seconds, tach comes back to life- and we go on down the road. Like everone else have had all sorts of electrical issues- some solved -some not- but this one is dangerious.
    HELP!
  • davisalodavisalo Posts: 1
    Help!! I have a 2003 ford windstar luxury edition with every electrical gadget you can think of. There seems to be too much amps coming in to the wiring system and it blows up some things. Example: when we put the ignition on and try to put headlights on or on AUTO, lights flash everywhere (radio too). We have a pop-up tent to hitch at the back but the tailgate lights don't work. We have been to the dealer, he put in 2-3 hours of work but couldn't find the problem.

    HELP PLEASE!! Thanks
  • john458john458 Posts: 1
    edited June 2010
    I have a good one. Any time the cab gets over 100 degrees. (vehical left out in the sun with the windows shut). The van will not crank. Leave the doors open for a while, then it starts. New battery ,starter checks out. can anyone shed a light on the problem
  • jmeadsejmeadse Posts: 1
    Hello, I am having similar issues. Did you get that figured out? Also on mine the passenger headlight won't work.
  • My passenger window will not work. I removed the door panel and removed the motor, hit the switch and the motor works fine. Replaced the motor and window worked fine for 1 day. Removed door panel again and was mad so I hit the end of the motor with screw driver and it worked for a little while and quit again. The motor seems fine, what could be the problem?
  • Ok so last night I take the family to see a movie. We come out and the battery is dead. I get a jump, get the van home, and replace the battery today. As soon as I connect the battery every single light on the van lights up. I mean every warning light, headlight, taillight, dome light everything and that is with no key in the ignition let alone turned on. Now I know why my battery went dead. Of course it is Saturday and no mechanic is working. Anybody have any thoughts?
    justinswyfe do you know what the name of that computer in the back of the van is? If I knew what it was called I could look for the part better. Maybe that is my problem too.
  • johnw99johnw99 Posts: 2
    My 2003 Windstar has an intermittent instrument cluster problem. Intermittently, when the engine is started, the tach, speedometer, temp, and fuel gauge needles go crazy, jumping up and down. This typically lasts for 10 - 15 seconds. Afterwards, everything works just fine. I have pulled the instrument cluster assy and checked the connectors and contacts for any indication of corrosion or other issues, but found nothing. Getting ready to replace cluster assembly if no other solution is found.
  • hlotzhlotz Posts: 2
    John , the last thing that i did was to obtain used parts pricing on the ABS MODULE. BUT THEN I STOPPED THERE AND AM ATTEMTING TO SELL THIS VAN AT A DISCOUNT.
  • My 02 SEL does the same thing but only when I kick down the tranny into passing gear. As with John mine only lasts a few seconds then back to normal. But at the same time my battery display comes on & the info center says " check charging system. I am having my charging system checked as I type. also I have the sevice brake & Abs lights on all the time. Have been told this cvould be as simple as a slightly warpped rotor. Will advise upon completion of alt replacement.
    Holtz, where is the ABSmoduale located? Thanks. Angela. :confuse: :confuse: :sick:
  • My 99' Windstar has been doing the same. Needles slam into each other. I just bought the Chilton manual and tried to find a common electrical component. Nothing yet. My emergency brake light will also come on, especially when going down a steep hill. It goes of within a few seconds. ABS light is almost always on. These may be different issues.
  • johnw99johnw99 Posts: 2
    Angela,
    Any luck finding the cause of your instrument cluster issues?

    John
  • i have a 2002 windstar . i disconnected the negative battery cable , reconnected it , found my radio is now dead . i checked fuses under dash and they r fine. would could my problem be.. where else can i check?
Sign In or Register to comment.