Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Chrysler Town & Country/Dodge Caravan Door & Window Problems

1356714

Comments

  • I seem to have a similar problem w/ my 2005 Dodge Grand Caravan SXT. Several times for no apparent reason my key remote will not lock/unlock my doors? If I keep tapping the lock button, the lights flash and horn beeps letting me know they are locked, so I know the remote is working. I tried to find the fuse in the fuse box - but it isn't listed on the cover!!! So I find that if I pull ALL the fuses and reseat them - the locks work! Can someone tell me what fuse is for the locks? I think memartinez needs to go and get a refund.
  • wcs6wcs6 Posts: 2
    Did you have your airbag recall performed prior to this problem? I just had my recall service performed and the very next day my locks quit. We have an 05 T&C.
  • ezjimezjim Posts: 9
    My locks quit working again the day after I posted the dealer fixed it using computer.. I too had the airbag sensors replaced the day before this occured. Trying to get cancer surgery and worried about my door locks was bad. LOL I hope someone figurse it out real fast. Goos luck all.
  • Interesting ... I just had the same problem ... inside electric switches and remote on the key didn't work ... lights would blink, locks wouldn't work ... dealer "diagnosed and reprogrammed the body control module" ...$54.40 Also had them do the airbag sensor replacement recall work at the same time, so that wasn't the cause of the lock failure ... :(
  • Hello, I have an'01 Grand Caravan I have a couple of questions about. First, when we lower the driver's side window, we have to wait several minutes to raise it. The used car dealer I bought it from three years ago replaced the switch when this was happening before. Does that sound like a reasonable solution. Second, the van has 109000 miles on it. The trans fluid has been neglected and needs replacing, but I'm not sure when it was done last. Like an idiot I listened to the tech at a major used car chain where I bought it. He told me it was maintenance free. Manuals all say otherwise. To the best of my knowledge, this is the fluid that was replaced at 35000 miles. Should I drop the pan and change the fluid and filter, or leave it alone. No leaks, shifts normally. Also, did Chrysler ever fix their transmission issues. I don't see too many posts about vans of my vintage, but lots on the mid to late 90's vans. Thanks for your help.

    KEith
  • Solution: On my 2005 GC SXT, reseating the one fuse labeled IOD fixed the issue. This fuse was located at the front right as you stand in front of the vehicle, yellow 20A. Yes, I did just have my airbag recall done last weekend as well, and just noticed this issue yesterday. Good luck!
  • I went out and took my iod yellow 20 fuse out and then blew on it and put it back in and know my car doors and locks are working.

    question: do we think the fuses is going bad or is it the connection to the fuse?
    Stacey :)
  • buzsolobuzsolo Posts: 2
    ..we have the same 2005 Town & Country Touring Van with ~ 67,000 miles. About 2 weeks ago I came to this site for advice on this exact same problem. Our door locks stopped working. The lights would flash but that was it. It does appear that everyone is having pretty much the same issue (ie: dealer needs to reset the computer, update software, etc..). I've also seen where this is costing people ~$100. Well.... for some reason, this morning when we were out shopping with our two kids (and the lock issue was really bugging us)... I thought - "why don't I just try to disconnect & reconnect the battery and perhaps this will reset the computer". THIS WORKED!!!!!!!!!!! Hopefully this will save many of you some money!!!! Funny thing - the only other thing I know how to repair on a car is replacing the air filter. I'm not a mechanic at all and this worked. Good Luck!
  • wcs6wcs6 Posts: 2
    This is helpful. I hope everybody gets a chance to read this thread before they go pay a dealer $$$ for the computer hook up. I am going to print this off and take it to my dealer and see if I can get my money back for the computer reset fee. Good luck to everyone else. Chrysler definately has a problem that they are not paying attention to.
  • buzsolobuzsolo Posts: 2
    ....yeah. Trust me. The way I figured out that this was an easy fix was through these posts and through my conversations with the dealer. The dealer wanted a $96 "investigation" fee to look into the problem - and then - if it was needed, repair the problem then this amount would be applied towards the repair costs. Well.... Once I saw that most people were paying about $100 (and one recently paid ~ $46) I thought to myself that it must be a pretty simple 5 minute issue to deal with. Any repair charge less than the dealer fee tells me that the "shop" was glad to have you in that day. Some people are also "pulling out and replacing - or blowing off - the fuse" - Well in my opinion and from what it sounds like... this simply resets the whole same d*mn thing. Either way appears to work just fine.............Now..... let's don't begin to talk about the brakes...... Otherwise ... a great van. Buz Solo .....one more item - Last week in researching this, I did call me dealer and asked if I could request a computer refresh and not be charged the "investiation fee". They did tell me they could do this but the work would not be guaranteed. yeah....my van is ok now.... no thanks.
  • john197john197 Posts: 1
    The electric window on drivers side of my 2001LXI stopped working. Any one have any suggestions on Why or how to correct?
  • We have an 01 DGC EX we bought used from a Chrysler dealer back in Sep. 2003 w/37K. We had window problems right after purchase with both front windows not going up or down when using the switch. Come to find out, we needed a window motor and regulator for each window. (Was covered under warranty.) As for your trans. fluid. I'm not sure witch would be best for you. A trans. flush, draining all 14 qts. of trans. fluid out and replacing it with fresh new fluid. A trans. filter change, drain only 2 qts. out of the trans. and replacing the filter and 2 qts. drained. I would only go to a daimlerchrysler dealer to have the trans. serviced, since they are the only ones that sale the fluid for your trans. Put the wrong trans. fluid in and your trans. will die over time. :shades:
  • I pulled the fuse that you suggested and the locks worked again. But the next day I noticed that the locks won't automatically lock after driving away from a stop. Has this happened to anyone else? I will pull the fuse again but I think the results will be the same.
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,511
    The auto-lock feature is programmable (on or off), with the factory-set default being "on." I am not sure how to switch it from on to off and vice versa, but it is something that can be done.
  • maybe as easy as disconnecting the battery? or pulling the right fuse? I'll get the 9 volt hookup to the cig lighter to save the presets on the radio. If that doesn't work I'll disable the 9 volt too.
  • There is a procedure listed in the manual for turning the car on (not starting it) 4 times, then hitting the drivers lock button to enable/disable the locking feature. Might try it, as I did initially a few times before 'finding' that super-secret fuse.
  • Today I unhooked the battery and turned the key 4 times ,then reconnected the battery. The auto lock feature would still not lock the doors when I drove away. I'll try the 4 times then hit the drivers lock button. Now it seems like I read that in the owners manual.
  • where is the super secret fuse? the yellow 20A?
  • ezjimezjim Posts: 9
    I want to thank whoever figured out the fuse deal. I just tried it and it worked for me too. I had 2 dealers check it and it cost me $40 with one and nothing with the other. I'm gonna go try to get my $40 back. This 2005 Town & Country LX is a good van tho. thanks again whoever
  • I have done the fuse but i have noticed that ever couple of days I have to keep pulling it to reset [non-permissible content removed] to work. is anyone else having this problem? If so do we think the fuse is going bad or is it the connection?
    :confuse:
  • xwesxxwesx Fairbanks, AlaskaPosts: 8,511
    Mark, I think you will need to keep the battery connected while performing the procedure.
  • When I pulled my fuse, I noticed it looked corroded , all but the tip. I cleaned the corrosion and replaced it. I have had no problem since. Good luck
  • I Pulled the fuse and put it back but everyday i am having to do this otherwise my locks don't work. Is anyone else having this problem? Has anyone just replaced there whole fuse yet and if so does it still happen?

    Stacey
  • I've pulled this fuse out a couple times as well and after a short time, my locks stop working. My lock button on remote and drivers side door do not allow to lock / unlock the doors. It's pretty annoying. I haven't found a labeled fuse that deals with door locks which would be too helpful. I will try replacing the fuse altogether but the fuse doesn't look bad. Any ideas or help would be appreciated. Thanks. 2005 Dodge Grand Carivan SXT. I'm starting to think this should be another recall item?
  • I was hoping someone had the answer to this as I've pulled and replaced my fuse 4 times so far which does fix the locks until I get in and drive somewhere and then they quit working again. This is getting ridiculous. I'm very disappointed in the quality of these Dodge Caravans. We've also had problems with the automatic doors. argh..
    I don't think you should see these problems in a 2 year old van. Any help would be appreciated. Thanks in advance.
  • I emailed Chrysler about this problem. I also stated that it sounds like recall time. Let's see if they even respond. Jim
  • I got online tonight searching for help as I have had my 2005 Town and Country Touring in for this lock matter 6 times!@!! We would take out the fuse and clean it off and put it back in and it would work for a couple of days, then it got to where that didn't work. We then replaced the fuse. This worked for about 1-2 weeks. Then, taking the fuse out would not work at all. So, we finally took it to the dealership. They said it was the BCM, but this was very unusual. So, they replaced it. It worked for about a day. They wanted to see it again (trip #3 as the BCM part always has to be ordered). We switch all 3 carseats over to my husband's car (VERY tight fit!!) and take it back in. They said it was the BCM again. We said they need to find what is causing the BCM to blow and fix it. They need to order it again! Another week goes by (it has now been a few months) and the part is in, so we switch car seats yet another time and take the van in. They replace it and it fails them as soon as they test it. They said they talked with Engineering and THEY said a new BCM is needed (not a rebuilt-we were never told we were getting rebuilts!!). AGAIN we said they need to find the cause for the BCM's to be blowing. Engineering was supposedly overnighting the new part. 8 days later I called them and they found the part there (magically!). So, we brought it in for the 6th time! This time the service manager and my husband were brought back to test it before we left with the van. It worked. My husband drove it from the dealership about 15 minutes and parked it. I went over to it about 2 hours later and the doors were not locked, so I tried to lock them and they don't work!!!!!! I called the dealership immediately and they said they really don't know what to do. They need to see it again and talk with Engineering. I left a message for the service manager today that I would be willing to bring it in to them one more time and leave with a loner so they will keep it until it is fixed. This was early this afternoon and he did not call me back. I am at a complete loss. The next nearest dealership is almost an hour away. OH did I mention that I purchased the extended warranty and paid the $50 deductable the first time, but have never been offered a loaner vehicle as they have never kept it overnight. On the one hand I am glad to see I am not the only one with this problem, but unfortunately, no one seems to have an answer! Thanks for letting me rant!
  • It has been several days now and still no reply from Chrysler about this problem.. Sure seems strange that a problem that is affecting so many people doesn't get solved. I think maybe we should contact our representives and just maybe we can get some action.
  • Add me to your list. My 2005 T&C locks stopped working yesterday. They don't work after while driving in excess of 15 mph like they should, nor do they work from the remote or the door controls. I have 53,000 on my van & bought it brand new. Of course, I was told "not under warranty". In addition to this, I've already had to replace the power steering resorvoir (sp), front brakes & rotors at 40,000, new tires this summer, new rear brakes this summer AND a new EGR valve replacement. NOW THIS!
  • I've had the same problem at about 55,000 miles. I've had it to the dealer, and they could do nothing. I replaced the BCM, and nothing. This really NEEDS to be a recall. Also the EGR valve issue. I had to replace that as well! What do we all need to do to get this recalled???
Sign In or Register to comment.