Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Dodge Charger Transmission Problems

13»

Comments

  • They won't buy it back, but it's a Mercedes Trans let them fix the problem they are doing good and have the money. I was going to buy an SRT8 instead I purchased a Mustang at least there not going anywhere.
  • 06 Charger SXT 3.5HO w/ 5speed auto. First AND LAST time Dodge owner.
    This is the GERMAN tranny.
    Like so many of you, I too am starting to notice this shimmy in the tranny. I can't believe they never put a dipstick in these trannies. My issue: my tranny lines run right next to the power steering pulley (as yours do) which eventually wore them out because they were so close. I was cooking down the highway doing 70 when it happened. I saw nothing but smoke. I pulled over, had it towed only to have the dealership tell me they need to get the part ordered. 2 weeks later and 3 attempts they tell me that they can't get the part. So now I'm stuck with a car payment and an immobile car. Being a backyard mechanic, I am very tempted to say the hell with it and fix it with a rubber hose replacement.
    So my warning to all check the lines that run up the driver's side to the transmisson cooler in front of the radiator to make sure they are far enough away from the pulley so you aren't stuck without a ride like myself. Does anyone know who actually manufactured these lines so I can order them direct?
    :mad:
  • I have a 2007 Charger 5 speed that I bought in Dec./07 and the reason I bought it was because of how few problems there is with these transmissions. I figured that 27 posts by Dec/07 was excellent compared to most other vehicles that you read about in these forums. Sorry to see that some have had problems, but all makes have problems and after 100,000 or so chargers sold in 2007 then a couple bad ones isn't bad. Mine has 40,000 on it and no problems with tranny at all. Did change the cheap break pads and rotors for better quality at 32,000 and oil changes is all I have done. Yes I would buy an other one. ;)
  • 08blackrt08blackrt Posts: 10
    My 08 R/T will, unless something changes drastically, go down as easily one of the best, if not the best, most trouble free vehicles I have owned in over 35 years of driving. I just turned 16K, and the problems have consisted of a rattle in the dash, fixed in a few minutes when getting my oil changed. That's it, nothing else! My last vehicle, a 2003 Dodge Ram wasn't trouble free, but it nearly was, and in the nearly five years I had it, it was in the shop for one day. The dealer, Charlie's Dodge in Maumee, Ohio, gave me a loaner, and have always treated me very nicely, for the 26 years (on and off) I've been dealing with them. When I want to test drive something, I get to take it for like half a day! All it costs me is gas. I'm going to miss Chrysler/Dodge if they go away. Out of six Mopars I have owned, 5 were at least good, and a couple of them were great.
  • Having a good dealership is the most important part of owning any make of car. Way too many dealers screw the customers and treat them so bad, that they never want to buy that make of car again. Some of their mechanics are more interested in doing the job fast instead of doing it properly. If the big 3 made most of their dealerships treat their customers properly, then they wouldn't be in the mess they are in now. Glad you are having good luck with your charger, because they are a nice car. I tow a 2 thousand lb. trailer with mine and you wouldn't know it was there until you put the brakes on and then you feel the extra weight.

    It seems that everytime a Chrysler product has a tranny problem, then everyone says they are all bad. I have had 6 Dodge products and never had tranny problem.
    :)
  • 2007_tundra2007_tundra Posts: 10
    I am 6'8' tall. This is by far the most comfortable car I have ever owned. And being handicapped with low back issues, I have more than enough leg and head room. The heated seats are a plus. especially in the winter when it's cold outside. The ride and performance is outstanding. Diamler put this car togeather just right. I have to say that this may be the best vehicle I have ever owned. I had a cop ask me some time back How fast does it go? Because it looks really fast. I told him 55 or whatever the speed limit is posted. LOL He told me that I was being a smart azz. Yep!! I'll never tell. By reading the other posts here of the people that have problems. I am wondering if maybe it is because this Daytona was made in Germany and assembled in Canada with different parts. Or does it have different parts? And maybe work ethic here in the U.S.. Who knows? Sorry to those that have been having the troubles.
  • benny14benny14 Posts: 1
    I own a 2007 Dodge SRT-8. From day one the transmission has had a shutter. I have taken this vehicle back many times for repair. They always tell me the same old Bull. It's the computer. If that is the case why don't they just replace the Damn thing? Instead of giving me the run around. They replaced the transmission, so they say. But the problem is still there.
    I bought this car on 9-11-07 and from then until now the car has been in the shop 115 days." A HUNDRED AND FIFTEEN DAYS." I tried the Lemon Law way. But that did not work. My only recourse is to get me an attorney and sue their [non-permissible content removed].
  • michelle35michelle35 Posts: 4
    I'm ready to buy a Charger SXT. I live in Cleveland. Has anybody driven their dodge in the snow? If yes, how did the car handle? Is there any reason I shouldn't be buying this Charger?
  • paulseidpaulseid Posts: 1
    I started to notice a drop in shift quality between 1-2 in slow moving traffic situations after 30000 miles. Computer has been reset, fluid exchange performed, and now a road test at a dealer by the leading tech supervisor of tranny and his asst who will drive the car tommorow will hopefully get to the bottom of this.The check engine light has not turned on. I am hoping they dont just find nothing. but that is what I am coming to expect which is what i fear. The cars tranny computer has been flashed fresh three times now and a quart of tranny fluid was added - but no change to the general feeling that the fluidiity of the hydraulics between gear 1 and 2 is in the process of going and the car doesnt feel tight tranny wise. Tranny wise it is more like a dodge caravan from whence this tranny apparantly had descended from.. It is intermittant, not on all gear shifts. I am worried that its is a quality issue of the 4 speed which is apparantly the weakest link in this car. Any luck on your end???????????
  • junkyardogjunkyardog Posts: 44
    I have driven mine for 2 winters and we have 5 months of snow each year. The first year I left the all season tires on and it was hard to get going in deeper snow so the second winter I put Nordic snow tires on the car. The difference was like night and day for handling and traction in 12 inches of snow. I have driven front wheel drive cars since 1970 and would put the charger with the snow tires against any one of them that I have owned. Mine is 2 wheel drive so I would think all wheel would even be better.

    Can't really think of any reason not to buy a Charger anymore then any other car. What people buy should be their own choice if they like it or just want it. Good luck on your decision. ;)
  • charge_itcharge_it Posts: 5
    Ok, I have been on here for a while now trying to figure out the "shimmy" with the tranny...well I just noticed that now I have some kind of fluid leak coming from the rear end. Will be taking it to the dealership within the week. Anyone else notice this? I mean it is not enough to drip on the ground yet, but it is definitely all over the rear end!
  • drkjstr69drkjstr69 Posts: 1
    Ok, from what I was told on another forum, there was a recall on our trannies for an O-ring defect. I am getting ready to take mine in just to avoid potential issue now that Chrysler is going belly-up, plus means a free tranny flush... lol :P . This may explain your leak as well.
  • 2007_tundra2007_tundra Posts: 10
    what year charger has the O ring issue?
  • junkyardogjunkyardog Posts: 44
    The earlier 300 and Magnums had O ring issues, but I think that was all fixed before the Charger came out. I don't think there is a recall on this because recalls are on safety issues and a small fluid leak is not a safety issue.

    There isn't even a TSB on the O ring for the Charger but there are a couple TSB's on transmission shudder that (Charge it) should have the dealer look up for him.
  • charge_itcharge_it Posts: 5
    What is a TSB?
  • junkyardogjunkyardog Posts: 44
    Technical Service Bulletins---Which are sent to the dealers so the mechanics know what to look for with certain problems with the vehicles. When a customer has a complaint and the mechanics can't fix it, they are suppose to check and see if there is a TSB for that problem or at least the service manager should. There are too many of them that don't care or can't read and this is hurting the manufacturers more then anything. Too many bad dealerships and sloppy repairs.

    http://www-odi.nhtsa.dot.gov/tsbs/----Try this web site and maybe you can find something that will help you. ;)
  • Larry, if you still check these forums I'd like to know what your resolution was. I also have an '06 3.5L Charger now with 47k miles. The same problem (wouldn't advance beyond 2nd gear and no autostick capability) just happened to me about an hour ago. I've since dropped it off at the shop but am fearing a blown transmission.
  • Did you finally fix your shudder on your charger and what was the issued?
    I have a 2008 and it kicks from 1 to 2.
  • Did your ever find the problem that causes the shimmy. Ours does it right arounf 4th gear. I think it has something to do with the torque converter
  • Has any one had a problem with the charger momentarliy lossing power. Mine has started doing this in the last couple months. Has almost 47,000 miles on it. It seems to happen when exceleraing from a stopped position and the esp light comes on at the same time but does not stay on. It goes off once the vehicle picks up power again.

    Have taken it in to the dealership twice now and because it does not throw a "code" they tell me there is nothing they can do. They were able to recreated the problem once. It is quite dangerous as I pulled out the other night and lost power and the oncomming car ended up beside me when he got stopped.
13»
Sign In or Register to comment.