Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Ford Crown Victoria/Mercury Grand Marquis Electrical/Lighting

16781012

Comments

  • swrbooswrboo Posts: 3
    Ok, I am still having electrical problems but I have narrowed it down to what I see might be the culprit. I keep blowing the big 40 amp fuse under the engine compartment that controls the headlights, parking lights, dome light, clock, and cigarette lighter and power point. BUT, I also have noticed that it seems to only blow when I leave my GPS plugged in. After a few days I can tell its getting ready to blow because the power light on the GPS goes out first. I have replaced the cord for the GPS and have plugged it into the power point rather than the cigarette lighter but still the same problem. I am thinking I have a short in the cigarette lighter somewhere. But does a short there affect the power point too? And if this is the case, where do I start to look for it? It doesn't blow the fuse in the car, just the one under the hood.
  • I had the same exact problem and i can assure u that it the head light control module(lcm) the part cost 511 new but i got a used one for 50 dollars!!!! I drove my car almost two years before i fixed it, i just drove holding the bright lights which worked just fine until i fixed the problem.
  • I found the problem to be a defective relay within the lighting control module. My dealer will replace the module for about $900.00, first diagnostic, then program the module and install it. The part can be obtained from Mouser Electronics online for under $6.00. If you can solder it is a simple task, just locate the module which is found mounted under the lower dashboard to the passenger side of the steering column. Three plugs must be removed after you slide it out of the mounting tray. Open it up and you find four identical relays. The headlight relay is on the side opposite the long heat sink and nearest the vehicle connectors. OEM p/n NEC EQ1-11111S. There is another post here with great photos which guided me. Look for discoloration on the PC board from the heat generated by the arcing contacts.
    Good luck.
  • I have an '03 Crown Victoria and the power door locks button quit working last night along with the dome light, clock, & overhead display. The radio works but the buttons do night light up for it and the temp control buttons do not light up either nor do the ac, defrost, etc. selection buttons which means no heat or ac right now (or defrost). This is the second time this has happened. First time mechanic had it 5 days and couldn't figure it out (checked all fuses and they appeared ok). A random guy from church looked at it next and got all working other than overhead display but didn't tell me what he did. Cigerette lighter works still but even the lights on the visors are out. UGH! Any help is greatly appreciated!
  • I cant find the other post you mentioned that has the great pictures and I was hoping you could tell me what number post to look at I am trying to fix this same problem on my dads car and would really like to see the pics before I begin. thanks in advance for any help you might provide.
  • I HAVE A '00 VIC P71 & HAVE TO UNHOOK BATTERY AT NIGHT OR POSSIBLE NO START IN THE MORNING. BATTERY & ALT. TESTED GOOD IN & OUT OF CAR. FUSES GOOD. HAS ROUGH IDLE IN THE MORNING TILL WARM. SCANNED & GOT NO DATA LINK MESSAGE. ALL LIGHTS WORK BUT THE RED ONES ON THE DOORS & DASH LGHTS ARE DIM. COULD THE COMPUTER UNDER THE DASH BE THE PROB OR WHAT??
  • Found the Light control module right behind passenger glove compartment. How do I remove???
  • I want to thank beachbob remarks. He explained rather than pay $511 for a LCM light control module quoted from my dealer 12/15/11. Replace the relay. He was correct you will have to know someone who can unsolder the old relay and replace with new relay. The relay on my 2004 grand marquis is back ordered from -Mouser in mansfield,tx. part # 551-EQI-11111S. I found a comparable one from Well Gain electronics on the internet. The part # MR301-12HSL . The relay was under $10 plus shipping all said and done for under $20. beachbob is correct. The LCM is to the right of the steering column with 3 harness jacks. The size is about 4"wide x 7"long. After you take off 2 different under dash covers it is mounted flat on a slidemount clip to a metal housing. It's fairly easy to remove. To dismount out of open metal housing I pushed the LCM box upwards till removed from metal housing. Once you have the LCM removed you will need a star screwdriver for 2 screws and also pressing inward on the side tabs. As beachbob mentioned
    you will see yellowish/brown discoloration around the relay indicating which relay is the one to replace. I want to say thank you to beachbob for being a stand up guy in helping others in need. I didn't have the $511 for the LCM nor money to "code" the new LCM nor probaly $2oo more for the mechanic all in all arounr $800-900 dollars. I also want to thank Edmunds for a forum like this one.
  • Kirstie_HKirstie_H Posts: 10,824
    Glad you were able to solve your problem much more cheaply than anticipated!

    And we also thank beach_bob for sharing his solution. You never know what solutions might turn out to be a life (and wallet) saver for other owners.

    MODERATOR
    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.
    Share your vehicle reviews

  • I have 2004 Grand Marquis! As I was putting in my remote start I ended up touch the main 12v wire(green) to the metal under the dash; ground it out. I need help founded the fuse? Also, I have a number of fuses in my control panel under the dash that is not getting power. I checked and replaced fuses but still no power!

    What should I try next?
  • ct45ct45 Posts: 3
    I have not been able to find the pictures on the LCM repair either.

    Are they still available?
  • Many Thanx to Everyone That offered this Info about the relays. I just repaired the LCM on My Wife's 2005 Gran Marquis with about 70,000 miles on it. It has the adjustable gas pedal and had to be unplugged before it would come out around the gas pedal motor. The soldering was fairly easy, The hardest part for Me was unplugging that single connector on top. after I figured out how to get it off the rest was a piece of cake! The Dealers DID NOT get My $$$. ;)
  • Did you try taking off your driver door panel and disconnecting the keyless entry touchpad? The buttons corrode and cause the domelight to come on whenever.
  • downtowntaxidowntowntaxi Posts: 2
    edited February 2012
    .I have a 2004 crown victoria p71. out of no were my head lights turn signals interior lights dash rear defrost wiper motor and horn stoped working. ran scaner got dtc codes b1352 and b2498. check them out to be fine. giving head light switch clean power from an outside power sorce head lisght and parking lights light up but no turn signal. could go into further deatail but seeing if anyone has had a simular problems with there car. any help would be greatly apreciated.
  • I am in the process of removing the LCM from an 05 Crown Vic.
    I have the box hanging down but am having trouble getting the largest of the 3 harness connectors removed. Any suggestions? Also, when I disconnected the first two harnesses, the lights came on and would not turn off until I replaced the harnesses.
  • Thanks to you and beachbob. I have the box hanging down but am having difficulty getting the largest of the 3 harness connectors out. Any suggestions? Also, is the part number on the relay?
  • jvpeachjvpeach Posts: 2
    Does the Lighting Control Module (LCM) effect the a/c fan operation and/or is it tied to the same relay as the LCM? I have an '03 Crown Victoria and the the dome light, vanity mirror lights & overhead display don't work. The radio works but the buttons do night light up for it and the temp control buttons do not light up either nor do the ac, defrost, etc. selection buttons which means no heat or ac right now (or defrost). This is the second time this has happened. First time mechanic had it 5 days and couldn't figure it out (checked all fuses and they appeared ok). A random guy from church looked at it next and got all working other than overhead display but didn't tell me what he did. Cigerette lighter works. UGH! Any help is greatly appreciated!
  • i have a 95 grand marquis gs i found a problem on lcm i bougth another one with same part number f5ab-13c788-ae and i cant make my head ligths to turn on or interior .do i have to reset something to make the car read the lcm that im replacing? please if u had this problem before help me get this fix . :sick:
  • bigrich52bigrich52 Posts: 3
    07 Grand Marquis
    Door locks, rear defogger, interior light and alarm work intermittently. Checked wiring in all 4 doors nothing appears to be broken. No response when jiggled. When it rains all system work.. almost like a short of some kind but unable to locate it. I have played with the actual locking mechanism by locking and unlocking to simulate door opening / closures i did get everything working for a short time.. might have been a fluke. Can it be a computer module that works intermittent? If so what is the name of this module that controls before mentioned. Is there a home test that can be performed to single out the problem..? :confuse:
  • bigrich52bigrich52 Posts: 3
    I just did a manual reset to my car that i believe also pertains to your yr as well.. Disconnect neg from battery. Then take the black negative cable and touch your positive side this will not short the car but it will clear the memory.. Hope this helps
Sign In or Register to comment.