Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Cadillac DeVille Electrical/Lighting

12346»

Comments

  • h2hh2h Posts: 3
    I had the same thing, plus check engine lights. I replace the battery and all was corrected. I got the battery from Walmart for 75.00 and they installed it, but I had to remove back seat 1st. Change the battery... hope this works for you.
  • searimdsearimd Posts: 1
    my headlights stay on all the time, the only way it will go off is by pulling the fuse. Also the enterior light dont work at all. What is the cause of this?
  • I am having a hesitation problem with my 1994 deville concourse. This doesn't occur every time that i accelerate, however, 2 out of 4 times it does. I Just had the motor manufactured and I am still having the same problems. The alternator has also been replaced. I am starting to wonder if this is an electrical problem. If anyone has any advice on what the hell i need to do I would greatly appreciate it.
  • I changed the ign control module, spark plug and wires and the camshaft sensor that is under the distributor cap and it still hesitates and even stalls. I also changed the fuel filter.
    I am stumped. Any other suggestions out there? Please help.
  • I had the heater coming on for no reason and would not shut off even after turning off the engine. It was a bad Body Control Module. I found one at the local salvage yard for 30 dollars. It has not done that since. You must take the chip out of the old BCM and put it into the one you are going to install. The chip is unique to just your car.
    The same with an ECM, you must put in the chip from the old one into the new one. Good luck.
  • Hi All!
    I have a 1998 Cadillac Deville, base model, and the cluster lights just went out on it. Just the center section where the fuel gauge, speedo, coolant temp, and all that stuff in the middle is at. The lighted panels on either side works fine. I checked the cluster fuse in the trunk and it appeared to be fine.
    I tapped the dash a few times, figuring it would jog something, nothing happened.

    I took someone to the bus stop and when they got out and shut the pass. door it seemed to try and light for and instant.

    Do I need to replace the cluster or is there something else that may be the problem somewhere. Also are those things, clusters, hard to take out
  • how do I reprogram my key which has a chip in it and reset the security system. My 1999 cadillac deville had given me a couple of dash warnings that my theft system problem car may not restart
  • I have the same problem on my 2000 dts. Hve you been able to solve this dilema.
  • My brake lights work properly when the headlights are off. All three of them come on, and no bulbs are out.

    With the headlights on:
    When I turn my headlights on, the third brakelight (above the license plate) does not work. The license plate lights are extremely dim, not really illuminating the license plate at all. The light-up pattern of the taillights is different also. The entire taillight is lit, except for the lower inside quarter of each taillight (not applying the brakes). When braking, they light up properly, and they blink properly with the blinker on. If I disconnect the third brakelight, the normal taillight pattern comes back (a thin stripe on the outside edge of each taillight), but all other problems remain.
    The trunk courtesy light is always dim. When it is removed, the license plate lights go off. The license plate lights also go off when the trunk release is disconnected.
  • Hi, do u remembered what rhe other things were when u had them replaced? I may have the same exact problems. The hubby changed the Alternator, I went and replaced it again because it wasn't charging the battery, everyday I had to jump start the Cadillac. Its a 97 Deville that has been kicking my butt since we move from Orlando, FL to New JErsey. The car dash board computer has the service engine soon light on, it also reads, limited to 90mph and when I try to give more gas, it will not go over 20mph and there's a popping sound when I hit on the gas to go faster, which it isn't going any faster. Im sick and tired of the car, and the husband refused to dump it. Battery is dead, my front tires are losing air, I have to spray inside the Hood to get it to start when I'm getting a jump. It will not start on winter, summer, no seasons at all. What can you suggest?
  • Had the same problem, checked the internet. The solution is there. Built a bypass resister chain to match the resistance in the key chip, hooked in on the steering column wires under the dash and cut the key out of the loop. Car would not even start before, now starts fine and doesn't need security key. Cheaper than replacing the ignition switch and I could care less if the security system works. There's another way to bypass the security module if need be. Cost me $5 for the string of resisters you can buy at Radio Shack.
  • I had a similar problem on a 90 Seville. Checked out the wiring harness in the trunk area, found no problems. Replaced the tailight bulbs with new ones and the problem went away and never came back. Worth a try and cheap! I figure, I don't care if they whack the problem with a magic stick as long as it fixes the problem.
  • nitarednitared Posts: 1
    hello all i just purchased a 2000 deville from an auction and the front left headlight is dim i have changed the top and bottom bulb and it is still dim, i don't know what the problem is the right side is strong and bright but the left side looks as if its going out, can someone tell me what may be the issue or what i need to do, also where can i find a radiator overflow tank?> thank you for your help
  • 2001dts2001dts Posts: 6
    explain the vin codes, I was told mines was a "9"
  • All my interior lights, door and compartment stopped working suddenly. Is this a fuse, relay, or circuit breaker issue? 2004 Deville
  • bolivarbolivar Posts: 2,316
    It's probably a 'short to ground' problem, that then blew a fuse.
  • recorderrecorder Posts: 8
    Yes I have a 2002 DeVille and I have the same problem the rear door and the windows do not work from either place. In the manual it does say there is a fuse for this but It does not seem to be the problem. If anyone has a solution let me know as well.
    Recorder
  • recorderrecorder Posts: 8
    I have a 2002 and it happened to me and my mechanic found out that the relay for the accelerator wire is too short and the gas pedal cable sometimes push this connection and it makes the car stall. The cadillac dealer diagnostics for $78.00 did show the part and the problem. So go and get this done they should tell you what it is. if no help I will try to fing the part number and you can ask them to look at that area.
    Good luck,
    Recorder
  • alimo130alimo130 Posts: 1
    To " Recorder"I can only tell you that I also had the same problem which turned out to be in the wiring that goes from the door to the B pillar, seems that the wiring gets stretched and then either almost breaks or completly breaks, hence sometimes the windows will work with the door shut ( not fully broken wire ) or will cease to work altogether ( fully broken wire ) as a note, one side on mine broke within the rubber covering between the door and pillar and the other side actually broke inside the door pillar ( which was harder to repair). In your case I suggest that you look either side of the rubber cover and if its not failed there then splice the cover to see if it has broken inside.
    Hope you find that its the problem.
  • temj12temj12 Posts: 450
    I purchased this car recently as a used car. It was driven by an older guy who took good care of it. The problem that I am having is oil consumption. I have only driven the car 1000 miles since I got it. It had 65,000 when I bought it. Is this common with the Northstar engine of that generation? If so, what causes it?
  • bolivarbolivar Posts: 2,316
    Carboned up, stuck rings from people 'taking care' of it. The Northstar needs to be driven aggressively occasionally to not have and/or cure this problem. Stuck rings will cause massive (a quart every 600 miles) oil consumption. And, just driving it fast (70mph on the freeway) will not cure it, and will not keep it from carboning up.

    Take the car out on a highway with light traffic. You don't have to be stopped, a rolling start at 5-10 mph is fine - then floor it (keep it floored, make it shift at redline) thru two upshifts - you will probably be going 80+mph at this time, so a ticket is your problem, don't complain to me. Then let the car 'coast' back down to 10 mph, and do it again. Do this 4 or 5 times and you will probably break a lot of the carbon out. And reduce the oil consumption by a lot.

    I had a 95 Concours with the Northstar and it suddenly was taking a quart in 600 miles. And it developed a 'carbon knock' which sounds exactly a stuck lifter. A carbon knock is when the carbon in the piston get high enough to actually strike the head (or a valve) at the top of its motion. A few of these Wide Open Throttle (WOT) runs took it back up to about a quart in 2500 miles and the carbon knock went away.

    Cadillac has a service procedure for this problem. It involves removing all the plugs and pouring in a solvent and letting it sit for 2/3 hours. Then sucking it out with a special tool. Then they take it out and run it aggressively, and then give it an oil change. I don't know what they charge for this, but it will not be cheap.

    I know this sounds like a 'shade tree mechanic' fix, but it works. And it shouldn't hurt the car. If you break something, it was about to break anyway.

    The Northstar was designed as a 'sport car motor', and puttering around in one, using premium gas which is actually harder to ignite than regular, will carbon up the motor badly.
  • recorderrecorder Posts: 8
    boliva thanks will look at the door boot.
  • plzngodplzngod Posts: 1
    edited July 2011
    Just purchased a 1992 Deville. Both brake lights came on, then the check engine light. Called the dealer and they said it was nothing to worry about. A week later the car stalled and I had to coast to a stop. When I turn the key the engine ignites but will not stay on. Ended up being towed home. Does anyone know what the problem could be?
  • Did anyone ever come up with a solution to this problem. I have the exact thing going on with my 2002 Deville. In addition, my traction control light is on.
  • I have a 2005 DeVille. I had my traction control light come on several months ago. I could not turn it off manually with the button. At first I thought there was something wrong with the traction control. Took it in to dealer. There was a short in a wire that goes to the truck for the third brake light. I guess opening and shutting the truck will eventually pinch the wire. Hope this helps some.
  • I have a 2002 DeVille and had similar problem, it was the harness connection which sits in the engine compartment. I will look for the name of the part but according to GM the wiring to this part was too short and sometimes it pulls slightly and the connection does not make full contact and it gives off false reading and it stalls the engine
    I will get back to you .
  • I Have a 1995 Deville. My dash lights suddenly went off. car will run, but roughly. also the blower motor comes on and blows air harder than it ever has. I have no control over anything on my dash. can anyone help?

  • Mr_ShiftrightMr_Shiftright CaliforniaPosts: 44,854
    edited December 2013

    First thing to check when many items go haywire at once on a modern car is the battery and charging system. A drop in voltage will cause all kinds of disruption, bad connections at the battery cables, corrosion in electrical connectors, etc.

    MODERATOR

  • imidazol97imidazol97 Crossroads of America: I70 & I75Posts: 18,184

    @mjanus said: ..., but roughly. also the blower motor comes on and blows air harder than it ever has. I have no control over anything on my dash. can anyone help?

    I'd start with grounds. If the battery is under the hood, check for corrosion on both ground and positive connections. Be sure you've turned the HVAC controls to off before turning your key OFF. If your car has multiple positive connectors check between them for corrosions. Check any small wires for ground running to fenders from the battery. Clean the connection area on those at the fender.

    I do not know if the wiring setup in your car is similar to the Park Avenue/lesabre 92-95, but it may have ground busses under the doorsill like Park Avenues and other H-bodies had until Park Avenue changed--was that in 96? These ground bars are under the plastic of the door sill bottom and the carpet. Water from shoes and rain corrode them.

    I think of those grounds, or a ground under the dash, because the HVAC system should default to defrost, the AC compressor and radiator cooling fans came on at high speed, and the HIGH blower motor for safety in case of electrical problems. That's what my 93 leSabre did occasionally before I traded it in. And the power door locks would not work. I knew it was the ground bar but never got around to fixing it.

    Do some reading and searching in Cadillac repair-oriented forums for that kind of problem.

12346»
Sign In or Register to comment.