Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Caravan/Voyager Suspension

135

Comments

  • masterpaul1masterpaul1 Posts: 421
    Heater hoses do not "corrode" Hoses are made of rubber. Perhaps they meant that on one of heater lines the fittings or lines that are not rubber corroded?

    Correct me if I'm wrong, but aren't all these lines made out of a non corrosive metal? (I can see a hose failing before the metal lines would.) Usually, these kind of problems can be caught before they become a really big problem, by inspecting them a few times a year. You wouldn't believe how many people never even look under the hood of there vechicle, except when there is a problem. It seems that we assume since cars are made better today, that they can just take care of themselves. We have systems that tell us when to take are vechicles in for service, tire pressure, etc. Don't get me wrong, there all good, but bad at the same time, because it makes us lazy. When I had my 1977 Ford LTD II and 1985 Lincoln Town Car, I had each for over 5 yrs and put over 70K on each, I had to do a lot more of checking the fluids, hoses, belts and lines then what I have to do with our 1998 Pontiac Sunfire and 2001 DGC EX. I do still check all the fluids once a month, at least in our 01 DGC EX since I'm the primary driver and every three months on our 98 Pontiac Sunfire. I just believe that with regular maintenance and a little work of inspecting things on our part, a lot of these small problems that we hear about can be avoided. ;)
  • user777user777 Posts: 3,341
    the monroe homepage suggests replacement at 50K ;) i wonder why?

    maybe when he got his struts replaced, they also replaced the springs?

    i'm not sure how struts fail myself, but might you guys have a terminology thing going on as "struts" to some may mean the entire assembly (including the springs and all mounting HW), and to others, just the inner-most hydraulic or gas cylinder and rod?

    i would think a "strut assembly" may require replacement without the strut proper cylinder showing signs of leakage, but i admit to being very nieve about the topic.
  • 97xpresso97xpresso Posts: 249
    You wonder why?? To sell more struts!
  • MrShift@EdmundsMrShift@Edmunds Posts: 43,688
    A lot depends on the quality of the replacement struts, too. Some brands are pretty mediocre quality and this will show up in a shorter lifespan.
  • dodge01dodge01 Posts: 12
    I had that problem with my 99 caravan se sport when it was just 2 years old. It was the sway bar links and bushings. Although still under factory warranty this was not covered since it was considered and "normal wear item"

    I believe they charged me around $275 to fix. The parts were not that expensive but they nailed me for 2 1/2 hrs labor.

    It is starting the clunk again
  • engr2go1engr2go1 Posts: 10
    I guess I agree with shipo. My struts appear to be in good condition, they are not leaking and seem to be not too different in bounce from a van on the showroom floor. Having not been convinced otherwise, I will get a wheel alignment done (at a Toyota dealer because our Dodge dealers rig is temporarily closed) and new Michelin Harmony tires installed. Thank you all for your much appreciated input !!! :)

    Joe
  • Did anyone have a knocking noise coming from underneath the front passenger?

    I bought 2002 T&C AWD with a known broken strut on the passenger's side. The steering also kept pulling to the right. I replaced both the front struts with the Monroe Reflexes and did a wheel alignment. The new struts fixed the noise problem. But strangely, the minivan still kee pulling to the right even after the repeated alignment sessions and after the tire rotation.

    After about 6 months (8000 miles) the noise seemed to return. It's not as loud as before, and can be heard only while going over the big bumps. The mechanic checked the struts and didn't find any problem.

    Thanks!
  • vchengvcheng Posts: 1,286
    ... top of the struts checked. There is a bearing there that is a separate part, and if defective, can cause the problems you describe.
  • hayneldanhayneldan Posts: 657
    Have you had the front sway bar bushings checked out?
  • Thanks for your suggestion regarding the front strut(?) noise in T&C. Checking the sway bar bushings is a good idea, but my dealer actually replaced the sway bar link kit about 6 months ago. Do you think it could get loose or worn out after 6 months/8,000 miles?
    Thanks.
  • Thanks for your suggetsion to check the bearings at the top of the strut. My mechanic actually checked the top of struts first. He claims they are good. He says the noise is coming from a much lower point, perhaps from under the floor board. Any other idea? Thanks.
  • vchengvcheng Posts: 1,286
    The sway bar links are another possibbility that is a well-known problem point in these vans. They are relatively cheap and easy to replace too.

    If that doesn't fix it, I would suggest better troubleshooting rather than throwing parts at the problem. It may be well worth the cost to go to a dealer with a diagnostic machine called "computer ears" amongst other names. Basically they put wireless microphones on various components to pinpoint eactly the source of a noise or vibration.

    As an alternative, your mechanic will need to check ALL front components including tie bar and lower ball joints etc. Good Luck!
  • chuckgchuckg Posts: 69
    A good mechanic will put your vehicle up on a lift and start pulling and pushing on the suspension and other parts looking for that noise. A good mechanic will find it.

    Also, some of these replacement sway bar links have grease fittings in them. Do yours? It could be as simple as getting that van lubed.
  • mfahey1mfahey1 Posts: 419
    We had the links replaced late last year on our 2001 and the replacements are clunking again. I had it done at an independent mechanic so I don't know if he used OEM or aftermarket but 12,000 miles is pretty poor life in my opinion.
  • ntbillntbill Posts: 20
    I had a knocking sound even over small bumps. I had my sway bar bushings replaced at dealership and the noise was gone, this was at 18K miles. The right one had 1/4 left, and the left one had 1/2 left. They were in bad shape. Price = 0$ under warranty. The problem began on september, but the noise was just beginning, so I waited for my next oil change which was at 30K Km (around 18K miles). I can tell you that the noise was more frequent, and that I can ear it over small bumps too. A repair was welcome.
  • Can somebody tell me how easy it is to replace the front links and bushings? I would like step by step instructions and if any special tools are needed. The dealer want's around $400 to fix. I believe this is something that I can repair on my own. Our van has 81K now. This is the second time replacing these parts. Thanks :)
  • I was wondering if anyone has experienced a vibration coming from I believe to be the front end. I seem to only fell it when making right turns. So far, it is intermittent, but I can't pin point exactly what would cause this.
    I just had the sway bar links and bushings done due to knocking in the front end which made the van quiet, but still get this vibration.
    The van is a 2005 Grand Caravan SE with 72000 kilometers or about 45000 miles.

    Thanks for any advice.
  • I have 2002 dodge Caravan, and am getting the shaking, has anyone helped you by answering the question.

    thx
    windy city5
  • Windy City5,

    I was messing around with the van the other day and found a couple loose lug nuts on the front wheels. Not loose enough to fall off or anything, but I guess enough to give me that vibration. I tighened them up (especially the locking wheel nuts - they were the worst) and so far so good.

    I haven't felt it since, and I have been trying to duplicate it by taking sharp corners and accelerating harder through the corners.

    Hope that helps.
  • iyariyar Posts: 1
    I am here in the northwest of canada and am extremely frustrated.
    My dodge caravan is a 1994 with a 3.3 engine with overdrive and over 175,000 miles.
    I noticed a couple of months back that the right passenger wheel seemed to start to shimmy at about 30 - 35 mph and then would disappear as I speeded up.
    I drive the highway daily in mountainous terrain and am becoming more concerned with this issue as the condition is worsening.
    I have been to several garages and get so many opinions.
    I have installed 4 brand new tires and no change. I have had the uv shaft replaced and still no change.
    The garage then referred me to a transmission shop as the mechanic noticed a drip from the transmission.
    I went to that shop and he said that it would be 600 - 700 dollars to take apart the transmission to see if there is a cracked torque converter, pump problem etc. that is causing the drip; however no guarantee that it will fix this "shimmy".
    I went home and phoned BCAA who I have been a member of since 1962 and they referred me to another garage as they said that they only do visual checks and that this matter needed a drive by a mechanic with me to advise of the problem.
    I drove with the mechanic and he noted that the "steering wheel" had no vibration but both he and I felt the shimmy in the seat.
    I asked what that could be and he said something in the back although the shimmy is in the front passenger wheel area.
    No one will offer to put the van on the rack and inspect any area and suggest what the cost of an hours examination would be.
    I am totally frustrated and want to get the issue repaired as i don't like highway driving in the mountains with such a problem exacerbating. especially as the highway is known for bad accidents. it is the sea to sky highway in vancouver bc where the Olympics will be in 2010.
    Has anyone experienced such a problem as I really want to go into a shop and have another test drive and see what the mechanic says and be able to have an intelligent discussion and get the mechanic to do an hours work to research the problem and then go from there.
    BCAA said that the transmission drip is highly unlikely to be the culprit of such a problem.
    I really would appreciate any and all suggestions. i don't want to take it into a garage and say here find the problem and get a 7 hr bill with an inspection and no resolution to the shimmy.
    Thankyou. BTW, I would appreciate ball park areas of cost to fix this problem if anyone has ideas, thankyou again.
Sign In or Register to comment.