Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2007 Toyota Camry Transmission Questions

12324252628

Comments

  • mcdawggmcdawgg Posts: 1,667
    Check this again - the time to repair is listed as 1.9 hours on the TSB. That means they probably could do it in an hour. I'd go to a different dealer. Even at $90 per hour labor, you have $180 labor, plus the solenoid is $128. It is not a replacement of the transmission at all. Go back to them, point this out, and see what they say. Or call Toyota, if you really want to get them in action. Bad dealer!!

    "Plus this is TSB is date 4/15/2008 to include the 2009 models. So they knew they had a problem and sold the cars anyhow. "

    Well, 2009 models came out in early 2008.
  • vizyovizyo Posts: 35
    Hello sunilv,
    How do you describe the jerk? I have 2007 LE 4cycl camry with only 14,000 miles on it. The problem I am having is that my car does not shift from 1st to 2nd gear smoothly. When the engine is cold, I do not have any problem. But after driving it about half an hour and do "stop" and "go" driving it does not shift to 2nd gear smoothly and there is a weird noise coming from the transmission. It is like shifting directly from 1st to 3rd gear and the car does not move smoothly and shakes. I took it to the sevice. They first replaced the solenoid. It was better for just a day, then the problem returned in the next day. I took it back to the dealer. A technician took snap shots with a computer and reported it to Toyota. I have been going through this for the last 3 months and still waiting for Toyota to get back to the service with a solution. The last time when I talked to the service, they told me that if they have to replace the tranmission and the same problem occurs again, they do not have anything else to do and I will have to make myself get used to it as the car operates like that !!! There are a lot of stop signs where I live and the car is definitely not drivable with this condition.

    I am also having a lot of vibrations with my car. At the beginning it was occuring between the speed of 65mph and 75mph but now it randomly vibrates almost at every speed. The whole body and steering wheel vibrate. I had the ECU reprogrammed with TSB 0068-08. It helped for the hesitation problem but it did not fix the vibration. Then I found out that Toyota issued a new bulletin TSB-0106-08 for the vibration problem. You can find the description of this TSB below. Because I knew that I would be told in the service that it would be due to tire balance or it is normal to have such a vibration and etc, I first did a few test drives myself and took vibration data with all detailed information. Then I took the car to the sevice with all proofs that the tire balance was not the cause. After doing a test drive with their technician, they found the TSB in their system and decided to apply it. I am still waiting for the tranmission problem to be fixed first then they will do it after. I am sure there are a lot of Camry owners out there having the same problems but they are probably not aware of them at all. I have stopped counting the number of times I took my camry to the service since the first day I bought it. The problems that I have listed here are just a few of them. I had too many more .... After driving corolla and matrix for a long time without a major problem, I just relied on the same quality. It was a huge mistake. Big shame to Toyota !!! I am now thinking of getting rid of this car and never ever buy a Toyota again.

    "TSB-0106-08: Toyota: front suspension- some 2007-2008 model year avalon, camry, camry hv, and solara vehicles may exhibit a steering wheel flutter and/or a body vibration (floor or seats) at highway speeds (approx. 65-75 mph [105-121 km/h]). "
  • comuscomus Posts: 24
    It is good you have had no problems, I am now on my 4th Transmission2007 Camry XLE V6 12/31/09 4th Tranny BLOWS by comus
    Jan 02, 2010 (12:02 pm)
    Save | Reply | Edit | Delete
    This will be my fourth Transmission and 2nd 2007 Toyota XLE Camry V6. The first one was replaced by Toyota under LEMON LAW. I have taken the car back to where I purchased it , Carmax, Laurel, MD. I just had the car towed there on a roll back, Happy New Year. SO NO THE PROBLEM ON THE TRANSMISSIONS ARE NOT FIXED. Toyota Corporate told me it was FIXED. Right now, Toyota has left me with NO CAR. I make my living driving
  • comuscomus Posts: 24
    Here ya go.
    2007 Camry XLE V6 12/31/09 4th Tranny BLOWS by comus
    Jan 02, 2010 (12:02 pm)
    Save | Reply | Edit | Delete
    This will be my fourth Transmission and 2nd 2007 Toyota XLE Camry V6. The first one was replaced by Toyota under LEMON LAW. I have taken the car back to where I purchased it , Carmax, Laurel, MD. I just had the car towed there on a roll back, Happy New Year. SO NO THE PROBLEM ON THE TRANSMISSIONS ARE NOT FIXED. Toyota Corporate told me it was FIXED. Right now, Toyota has left me with NO CAR. I make my living driving
  • Same problem here, Only I have a 6 cylinder.
    Transmission has been replaced, driveshaft replaced and torx converters replaced.
    New software also loaded.

    Still no fix.

    Never buying a Toyota again. (Even though I liked the cars)
  • emilyb28, Have you got anywhere with the class action suit? I ask because like most people on here my transmission has failed after the warranty, but it has had problems since 10,000 miles. I even found a service bulletin where Toyota admits to the transmission being defective. They want me to pay $5,135 to have it replace with the odds that it will go out again from what i have been reading. Please let me know if you have started a suit, i would like to join. If not i will start a suit of my own and you and anyone else is welcome to join in. My Car is the 2007 XLE V6 which from what i have learn is the model with this issue. Anyone with the same issue please email me (dlecompte21@att.net) with your contact info if you will like to join in on a class action law suit. I'm sure the more people that file at one time the better the odds of winning.
  • Thank You for posting this message. Yes,We too have the very same problem amongst other things thats wrong with this vehicle. Our car is at the Toyota dealer this very moment and we just got a call from them and they said that there's nothing that they can do because it's not doing it to them and it's not showing the symptoms that we described and they are releasing the vehicle because there are no problem found,and it's really not fair because it doesn't happen everyday but it does happen alot and it's scary,I posted a message earlier,I hope everyone will read it. Thank You.
  • chuck28chuck28 Posts: 257
    I've been hearing that same response from Toyota for over 3 years. I wish they would address in congress how many owners have heard the reply can't duplicate the problem. The problem is they don't have a fix yet and they don't want to buy back the cars. I'm still hoping the truth comes out which I believe is a software problem.
  • radiowomanradiowoman Posts: 1
    edited June 2010
    dlecompte: How did you resolve your 2007 XLE V6 Transmission problem? Did Toyota resolve the issue for you? Or did you have to pay for the repairs yourself. I am now in the same situation. I have a 2007 XLE V6 with 77,000 miles and my transmission just went out. The dealer also quoted $5100. Please help!
  • ewe2ewe2 Posts: 20
    Ours was a 4 cylinder. The replacement of the valve body worked for us.
  • on3danceon3dance Posts: 1
    I am sorry, but mine was not a transmission problem. My Toyota Camry had a fuel unit.............NOT TRANNY...Good Luck! I will tell you this. You really need to go to the top with Toyota.............keep on going right up the ladder.......keep notes and who you talked to ...............Don't give up!
  • arcidiac1974arcidiac1974 Posts: 4
    edited July 2010
    My 2007 Camry V6 SE has 74,000 miles,still has 3/4 flare. Its now been over 3 years. Does anybody know if there is a fix that works yet? My other question is can it just stay that way without ever breaking down.
  • How many miles did you have on it when they replaced everything.
  • How did you make out??
  • How did you make out??
  • chuck28chuck28 Posts: 257
    Save Reply Edit Delete #5245 of 5245 Ignition coil by chuck28 Dec 18, 2010 (1:09 pm)
    It's been awhile since I posted. I have a 2007 Camry SE V-6 which has had all the transmission issues and shifting problems beside numerous other issues.

    I'm witting today to let people know I had an engine warning light come on last weekend which also included mt VSC and traction light. I took it to Auto zone to have the code read which they do at no charge compared to Toyota which wanted to charge $110 to hook it up on it's computer.
    After confirming I had a bad ignition coil I bought a replacement for $85 from Toyota and replaced it myself. The front coils are easy to get at compared to the back. I was fortunate to have my bad on in the front. It took me 2 minutes to change it, One bolt and one plug. Toyota wanted $300 for the whole job.
    That being said my car has much better pick up and doesn't seem to hesitate anymore.

    IS it possible that this coil has been defective from day one and now has finally showed up on the computer as this coil worsen.
    I'm still test driving the car as I have only got to drive short distances to work and back but it feels like day and night. I'm also hoping my MPG's get better which has always been a problem with this car.
    Unfortunately The coil is only covered under the 3 year 36,000 warranty.

    Feel free to offer any of your thoughts or use the for your own experience's

    My Camry
  • I have an earlier production 07 Camry and I have this flare problem. My car has about 48k on it and the warranty runs out this month. Luckily I brang it in already once for this issue last week and they said they fixed it blah blah blah... Well it is actually worse than ever. I now have a hard shifting issue and a flare in 2-3 and 3-4 (worse in 3-4). I have been in touch with the dealership and they wanted me to pay for a rental this time around. After going back and forth with the "service advisor" I decided to take it to the top (GM) and send him a nice professional email entailing the TSB and all the information I know about it (just about everything). I am now awaiting the response to get an appointment scheduled and another loaner. This is by far the worst experience I have ever endured with Toyota. My entire family all own Toyotas. That is the sad part. With having owned an 05 Corolla XRS that had Tranny issues, this does not make me a happy camper.
  • I too experienced transmission problems. It started out as various lights appearing on my dash and slight lag in my transmission. I didn't put the two together at first. I took my car in and Toyota told me that there was a "manufacturer paid-for" reset or update kind of thing with a sensor that communicates with the transmission. They supposedly did it ( they said it would have costs me $250, but since it was a "service issue" from Toyota, I didn't have to pay). Toyota kept my car for almost a week to complete this and "check out any other issues". When I returned, they said "EVERYTHING checked out GREAT! We test drove it and all is fine!" (As a BIGGG side-note, I checked my odometer before I left my car there. They had driven my car LESS than a mile total) When I picked it up they said, you owe nothing, ALL is good and working and the lights NEVER came on in the "test-drive". (Again, was less than a mile) HOW-EVER!!!!!!, they said . . . IF the lights come on again after this, THEN it is truly a transmission problem and then you need a new transmission - A.K.A. $4700!!! They brought my car from the back, I signed papers for their "fix-it" and got in my car to leave, drove maybe four parking spaces and - HA! ALL lights were still shining. Went back inside and they said, well they weren't shining before, when we test drove it so you just need a new transmission - AKA $4700!!! REALLY?????
    It is now 2012 and my car is still not running properly, but I don't have an extra $5000 laying around to fix THEIR issue!!! I have been a trusting Toyota owner for almost 2 decades but am now SERIOUSLY considering changing things up a bit. "Boo Hiss, Toyota, I don't like this one bit!"
    Any suggestions???
  • chuck28chuck28 Posts: 257
    I have had all the trans issues too. Don't think you need to trans. This is a sensor or solinoid issue. Could be fuel ratrio sensor too which I just replace.
    What are the light trhat are coming on? Have the codes checked for free at Auto zone. You may want to try another dealer. Have you called Toyota?

    I understand your frustration. My car has never been rihgt from day one. ( 2007 V-6)
  • killjoykilljoy Posts: 20
    edited March 2012
    Sorry to say, it takes about 30mins to an hour to load the software update...They kept your car a week because you weren't screaming enough...They do bill Toyota for the time spent with your car but they moved you to back of the line...If you sat there screaming where is my car you would of gotten it back that day...First they didn't do you any favors...Toyota sent out a memo to fix, via upgrade the software...So they couldn't charge you anything...Second, you don't need a transmission...IF you did get a new one you would have the same problem because it is a software issue not a mechanical one...so yes they lied...
    When I schedule my car with an appointment I stay there...I walk out to the service garage to see if my car is on host...if its not I look for it in the parking lot...when I find it I scream at the guys at the service desk...Trust me...It works...I DIDN'T MAKE A APPOINTMENT SO MY CAR AND I COULD SIT HERE...(the reason why I looked for it in the parking lot so they can't say its being test driven or being moved)...I always ask for their supervisor...and I'm very loud...Loud enough so everyone can here if my car isn't being worked on then everyone else car isn't either...So we all are waiting for nothing...Then you would see 2 or three people get up from the waiting area to ask about there car...
    My 2007 didn't' have a transmission problem...it seems only cars made in the US had the software problems...My 2007 was made in TX...so go figure...
    They might have fixed the software by now...I would take it in and have them reinstall the update...BUT FIRST CHECK BEFORE YOU GO IN AND FIND THE LATEST UPDATE NUMBERS...WHEN, you go in...and they say no problem...Ask the stupid **** which update they will down load to your car?
    Let him GIVE you the numbers...Then check them against they one you have...If it matches or is a higher number then go ahead and let him do it...if its not...Tell him to F off...Don't let them have your car...It will screw it up even more...and don't let him see your numbers because he will say, Yes that's the same update...
  • banditboybanditboy Posts: 54
    edited February 2012
    When i brought my 2007 i found about the lag. It was fixed in cars build after may. i found this out after alot of research, i actually picked and payed for the car to be build in June. i waited 4 weeks to get mine,

    anyway ,i have the opposite issue.how ever i feather the car the car takes off with a sudden lurch when you touch the accelerator .I never had a car like this where you move as soon as you touch the accelerator

    My wife drove it for 60k and seem to not have this issue. Anyway i got her a odyssey after our 2nd kid and got the car. I cannot believe we are still on the stock brakes at 68k....its just passed inspection.she is very gentle on cars. She even towed a bunch with this car.

    now i drive it every day i jump off the line everytime the second issue is the steering is hyper sensitive.I coming from a mazda6 5 speed and Jetta 2.0T .both the same price range but nicer and crave corner. this car is scary.Is it normal for steering to this sensitive and also same question for the accelerator,
  • wwestwwest Posts: 10,706
    I would suggest reading up (owners manual?) on hill-hold, hill-start and be sure that your use of the brakes in coming to a full stop isn't inadvertently engaging same.
  • 22blaq22blaq Posts: 1
    i bought a 07 v6 it has 112k miles on it and my transmission stopped pulling on me is this common and i hooked it up to a OBDII and it told me that my pressure control solenoids are stuck off
  • killjoykilljoy Posts: 20
    Try taking it to the dealership and work its still under warrenty...They will/might do it because they get paid by toyota corp...Don't let me F with you by telling you it isn't...Just tell them the car has never had any warrenty work done to the transmission and there is a recall...Let them do the work and find out for you...

    Note...the recall is just on the computer side of the transmission...2007 Camry has a shifting problem that can only be addressed with software update...its funny back in 2007 and 2008 some people were talked into getting a free replacement...now that sound pretty nice BUT the replacement had the same problem...and you were out your car for weeks while they really didn't do anything but get paid to give you the same problem...

    And they kept coming out with updates that really didn't solve the problem...Toyota was more then happy to update your software but if you didn't check the fireware numbers that you had, chances are they didn't do anything but update it with the same software and bill Toyota corp...The only problem is you had to wait hours or leave your car for days...

    I brought my camry in for an appontment...I told them I would wait...30 mins later I asked about my car...they told me its being worked on...I went out into the parking lot...I didn't see my car on the rake...They moved it to the back of the lot...I went in and told the butt wipe, I wanted to speak to the manager...When he walked up I bitched him out...I was so loud that the people in the waiting room heard me...I told him how many customers have brought in there vehicle and have waited while their car was just moved to the rear of the shop...I didn't make a appointment to sit here...I will not be held victim for your scheduling conflicts...I told him to check the notes on my car...
    (my brother works for Toyota Corp) he read the notes and I was out of there in 20 mins...

    Good luck and don't let them F with you...In 2008 I trade mine for a 2009 Hybrd Camry (the 2009 came out in March of 2008)...and I never looked back...(keep in mind that I loved driving my 2007 SE)
  • We have a 2007 Camry hybrid (~40,000mi) that has developed a horrible intermittent noise when the gas engine comes on. The noise is very loud and sounds like gears grinding or not meshing right(??). Any thoughts on the cause of this? Starter motor not engaging right? Because it is currently intermittent getting it fixed may be a bit tricky. Drivetrain is under warranty for 2 more months. Any thoughts?
  • Bring it into a Toyota Dealiership right away...Tell them everything you listed and make sure they record it all on paper/computer...When they fix it and if anything happens after...just bring it back in and tell them that what they did didn't fix the problem...since they worked on it they have to refix it...or fix it correctly...They have to pick up the bill...and you can get them to give you rental car for free...explain to them its a fine thing how you are left by the side of the road because your product fell apart...the least you could do is supply me with a vehicle so I can drive my kids to school...Don't worry I will make sure I speak of you when I write Toyota Corp...

    All problems, bitches and complaints refer to Toyota Corp...Tell them how your faith in Toyota is gone...Remember to get whoever helps you, get their card...Names and dates are very important...When they read your letter make it so that whoever reads it is crying from your story...Toyota Corp will light a fire under their butt...

    Good luck...
  • I was driving on the side street and car just literally stalled on me. Steering wheel suddenly became so hard to steer. Luckily i was able to make a right and pull my car on the side. I had my car towed and replaced my battery. I thought it was just a battery problem. Vsc and traction warning came up. Towed my car to the dealer and diagnosed as solenoid pressure pump but they said they have to open the transmission pan to see whats going on. It will cost me about 750 just to open it up. And to see what could be the problem. Didnt have extended warranty for power train my mileage is about 89,000. I towed itback to my house till i figure out whats best to do. Does anyone have the same problem and what was done? Pls help..
  • chuck28chuck28 Posts: 257
    Have you checked the codes. Auto zone checks for free. I know the car is not drivable. If you can get a scanner auto zone sells them. It would be a start and maybe verify the problem. Can't always trust the dealship.
    Hope you will get more reply on the forum.
    Keep us informed.
  • Thank you. I went to get a second opinion and aamco will check it for me they said it could be electrical and not transmission.Ty ill keep you guys posted.
  • chuck28chuck28 Posts: 257
    Hi, wondering if you got results from Aamaco. Hope you were able to resolve the problem Look forward to hear about it
Sign In or Register to comment.