Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Cherokee Grand Cherokee Engine and Performance Problems

1242527293035

Comments

  • This is a 1989 4wd 2.5l 4-cyl auto 2-door Cherokee. Granted that by design it's not very powerful... But in addition it has a really annoying quirk.

    When under hard throttle acceleration (what other kind is there with a 2.5l four?), motor doesn't seem to be pulling at full power. But when the throttle is backed off halfway or more, the motor actually "surges" and runs stronger at part-throttle than it does at full throttle. Also occurs in normal driving, just not as obvious. Not a misfire, just weak...

    For various reasons, over a couple of years, have ended up replacing EGR valve, dist. cap & rotor, wires, plugs, fuel filter, tried swapping fuel pumps, swapped to a different throttle body (& checked correct fuel pressure), replaced O2 sensor, catalyst (loose pieces were rattling around inside), replaced water temp and inlet air sensors, swapped ignition module and MAP sensor at one point or another, bought a new (high-altitude) CPS, etc. Last update was to add a "torquer cam" (great results from that). But still it surges.

    Took it in to Jeep dealer for analysis -- they "tweaked" the TPS setting, then told me their best guess is that this is caused by "a slow computer" (a $500 replacement based on a guess?). I've been in electronics many yrs; generally you either have a good computer or a dead computer -- a "slow" computer would have to violate numerous laws of physics... (the Renix CPU is like the Eagle; not much in the way of retained error codes or diagnostics to look at)

    Starts & runs (as well as can be expected), gets good mileage, but the non-linear throttle response is crazy. Any ideas, or anyone seen this on another Jeep? Maybe it's generic to the 4-cyl?
  • berttbertt Posts: 3
    Man, I am experiencing similar problems with my 1997 JGC Laredo 4.0 with 175,000 miles on original engine. Several months ago, although the engine would turn, my Jeep would not start. I replaced the fuel pump but was informed that it was not the issue. My backyard mech told me it was the crankshaft sensor. The manual states that a faulty crank sensor would cut off power to the fuel pump and injectors. I purchased a crank sensor from CarQuest. I noticed that, prior to replacing the crank, he removed the spacer that it came with. About a month later I am still experiencing the same problem, and it also sputters and shuts off. Then after 10 minutes turns back on. I then replaced the ignition coil. Same problem. Replaced the camshaft sensor. Still the same problem. Changed the MAP sensor. Going crazy here! Problem still persists. I called the dealer and they said that the crank needed to be installed with the spacer. I went and purchased the spacer, installed it properly, or at least I thought so. Still shutting off. I read the manual once again, and considered the EVAP canister, Air charge temp sensor, charge air temp sensor, coolant temp sensor, O2, TPS, etc, etc, etc.... Love my Jeep but bank account is shrinking here. Need your help. feel free to email me at atroche1978@aol.com
  • tidestertidester Posts: 10,110
    feel free to email me ...

    Let's keep the discussion here so everyone will benefit. :)

    tidester, host
    SUVs and Smart Shopper
  • berttbertt Posts: 3
    Coll! Any advise for me on this one? I'm getting real p.o.'d looking out my window at my Jeep just sitting there.
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,950
    Did any codes ever get thrown off? Maybe you can borrow a code reader and see if any are stored, then post them here for someone to interpret.
  • berttbertt Posts: 3
    Initially I had a mechanic scan it with the scan tool. The only code was for the crankshaft position sensor. I replaced the cps but after several days, same issue. Since then I replaced ignition coil, fuel pump, map sensor, camshaft position sensor only to have the same result. I've been on countless forums only to find that many other Jeep owners suffer from the same problems. On one forum a guy wrote about how he thoroughly cleaned the three plugs to the pcm with electronics cleaner and filled the prong slots with conducive grease. He claims not to have any problem now. Another wrote about buying a brand new pcm from the dealer. Another wrote of new O2 sensors. Another wrote about replacing the EVAP canister. I'm confused. I love my Jeep......a lot! Please help.
  • It could be many things here is a list to start checking. Egr comes up alot when checking resources.

    1 Inspect M.A.P. Sensor Faulty M.A.P. Sensor.
    2 Inspect EGR Valve Improperly Functioning or Faulty EGR Valve
    3 Inspect Fuel Injector Dirty or Worn Fuel Injectors.
    4 Inspect Idle Air Control Valve Damaged, Loose, or Faulty Idle Air Control Valve.
    5 Inspect Idle Speed Actuator Damaged, Loose, or Faulty Idle Speed Actuator.
    6 Inspect Throttle Position Sensor Faulty or Incorrectly Connected Throttle Position Sensor.
    7 Inspect Fuel Filter Clogged or Dirty Fuel Filter.
    8 Inspect PCV Valve Plugged or Damaged PCV Valve.
    9 Inspect Carburetor Worn, Faulty or Damaged Carburetor.
    10 Inspect Valve Burned, Worn, or Sticking Exhaust Valves.
    12 Inspect TimingSet Slipped TimingChain or Worn TimingGear(s).
    13 Inspect Fuel Pump Faulty Fuel Pump.
    14 Inspect Camshaft Camshaft Lobes Worn.
    16 Inspect Point Set Burned, Worn or Incorrectly Set Ignition Points
  • tidestertidester Posts: 10,110
    Thanks for that. It should help the OP.

    tidester, host
    SUVs and Smart Shopper
  • I am having a problem with my 2007 jeep grand cherokee too. When I go to start it randomly it tells me "transmission over temp" in the message board and will not roll over or start. I had it towed to the dealer ship and no codes or anything they took a guess and said the transmission control module or something like that could be wrong of course this is a guess and at $625 dollars to for the part is crazy for a guess...and I am out of warranty at 67,000 miles anyone have any idea or has this happened to you. :sick: :confuse:
  • I am having the same exact problem that you are. Luckily my jeep is under warranty, this is the third time that it has been towed to the dealership. They replaced the battery and the starter, worked for a couple weeks, and back to the same thing. I will keep you posted on what the dealer tells me. I only have 500 miles left on the warranty tho so I hope they are not trying to delay me...
  • My jeep is doing the exact same thing. The dealership has looked at my car 4 separate times. Replaced the ESM and a wire that had moisture on it. Car did not start again the other day after the last time I picked it up. Does anyone have a solution to this issue?
  • Just got my car back from the dealer! According to my receipt this is what they did: Check engine system wi tech B212C stored intermittent, disconnect starter solenoid wire, check for voltage 12v, replaced solenoid wire end. This is after replacing the starter and battery on two other visits to the dealer. I really hope this was the solution. I hope this can help everyone else, if you find another solution please let me know... It's quite frustrating watching my jeep get towed into the dealership, especially for the 3rd time with the same problem.
  • when i bought this jeep i couldnt fill the gas tank over 1/2 cause it leaked.i changed the tank and drove it for about 2-3 hours after and it started to spit and sputter if i slowed down it would idle but a little ruff. let it sit for a minute it would act like it run again go to take off and it would spit and sputter again then it died and wouldnt start again. i put a fuel pump (mechanical fuel pump) and it started for about 1-2 minutes and idled fine and then it died and did not start again. ??????whats wrong???
  • ibt2ibt2 Posts: 1
    Hey, where exactly is the oil sending unit located on the '99 Grand Cherokee. About to replace mine due to pressure problems, but not sure exactly where to find it.
  • kelii777kelii777 Posts: 1
    I have a 4.0 grand cherokee laredo that is suddenly failing (bogging out and misfiring) upon hard acceleration, uphill, or otherwise under load. For the most part it idles perfectly.

    But I cannot make it up a hill without it bogging out and dying. I checked the cap and rotor and found fluffy corrosion and replaced them. The problem remained. I replaced the plugs and the problem remains.

    All I can think of is it's either an ignition or fuel delivery problem.

    Can a coil start to fail where it just can't deliver enough current to the plugs when the demand is high? Or should I start looking elsewhere like the fuel filter etc?

    This is a '94 with 140,000 well maintained miles, and otherwise runs perrrfectly.

    One other thing is that this happened about a year ago for a day or two, then suddenly stopped and has worked normally until now. Now it's constant and is unusable.

    Anyone ever experience something similar?
  • wpgdodgewpgdodge Posts: 1
    You can't repair this part. It is a very common problem with this model. The part # is 55111009A0 and you can buy it for 177.00 msrp and the dead cost is 118.99. You can buy it from your Chrysler/jeep retailer for somewhere between those prices.
  • 1 Inspect FreshAir Intake Hose Clogged or Damaged FreshAir Intake Hose.
    3 Inspect Throttle Position Sensor Faulty or Incorrectly Connected Throttle Position Sensor.
    4 Inspect Fuel Filter Clogged or Dirty Fuel Filter.
    7 Inspect Fuel Injector Dirty or Worn Fuel Injectors
    Inspect Mass Air Flow Sensor Damaged, Loose, or Faulty Mass Air Flow Sensor or Circuit
  • I've been dealing with the issue for a while now and I'm out of ideas.

    I've had my jeep for about a year and the last 6 months it's been doing this squealing thing that baffles me. It started with my AC compressor. No problem, pulled it off put on a bypass pulley and called it a day. Then it starts shredding belts, I poke around, found the idler between the bypass pulley and the alternator had some play in it. Charged it, squeal goes away. Then the tensioner pulley ate itself, replaced that. But now, I'm looking at this thing and it looks like my power steering pulley is canted inboard, and now it takes one or two of the serpentines off my belt, and then stops squealing.

    I'm thinking that the misalignment of the power steering pump is causing some funky pull on the alternator because that appears to be where the squeal is coming from. It's either that, or the solenoid in the starters sprag clutch never disengages and it's just being lathed into.

    Anyone ever come across something like this? What did you do to fix it?
  • jtny69jtny69 Posts: 1
    I experienced the same thing and it ended up being the fuel filter. Hope you figured it out
  • turn the key and it takes a solid 5-8 seconds to get goin, every time, for about a week now. clean plugs, new fuel filter and lines (changed 1.5 months ago), not a big gear head but lookin for some advice, any idea what it could be? it wasnt a gradual probel meither, 1 day it started up real fast next day 5-8 seconds, and it does that when i let it sit over night or for 2 minutes...thoughts?
Sign In or Register to comment.