Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Lincoln Continental Maintenance and Repair

12346»

Comments

  • I cannot tell you for sure on the 2000 w the V8, but I have a 94 Continental with the V6 and on that you have to unbolt the front engine mount & raise the engine to remove most of the bolts on that side of the engine for any work.
  • wickmanwickman Posts: 2
    I have a 1994 contental and the dash lisht says check DCL and the bell rings WHEN EVER it wants (I am going crazy with this bell ringing) i have had 3 different mechanics look at it and they all tell me it has something to do with the suspension system. I have replace the air bags over the years twice (have had the car for 15 years) the bells still rings and the check DCL light comes on. Everyone I have talked to and have had the car hooked to the computer says that since in this car has a first generation computer it only tells you that DCL has SOMETHING to do with the air ride. Finally I got so irritated with the bell going off and saying check DCL that I took the car to dealer who put the car on the computer and I was told that SOMETHING is wrong with the air bags and that I should change the suspension over to the replacement springs and that would take care of the Check DCL warning light and bell. So I paid Ford $150.00 for this information and then went and paid my mechanic $972.65 to change over my suspension to the new coil springs to stop the check DCL light and bell from ringing. Got my car back Thursday June 29 car rides like a dream. But guess what the check DCL light came back on and the bell again RINGS whenever it wants. What a rip off, called ford and they tell me that if i had got them to install the new springs they would of have found out why the check DCL light and bell comes on and that they could not help me unless I give them another $150.00 for them to put car back on computer to see why the check DCL light still comes on. Does anyone know what DCL is which part that it is and how can I replace it. Already replace dash with one from junk year do I need to replace another one. HELP PLEASE
  • bishop208bishop208 Posts: 1
    edited October 2011
    I have a 95 Lincoln Continental with 190k on it was a 1 own well kept vehicle when i bought it 6 years ago with 120k. My car was in the shop for 2 weeks about a month ago, just getting some regular repairs after a long road trip, But since I got it back I first had to replace the battery because it was dead. about a day later I put my car in drive in the mourning and it shut off. after doing that 2 or 3 times and shifted like normal and I went on my way. Over the past month it has been getting worse and now does in every mourning and does it when I put it in reverse sometimes too. After the car warms up it doesnt do it quite as much. Also while its cold in the mourning it idles rough and shuts off when I come to stops for 1st 2-3 mins of driving. Idles in Park fine. So far ive changed the following, Spark Plugs, wires, MAF, IAC, checked egr, Fixed small vacuum leak, fuel filter, O2 sensor, and transmission is less then 2 years old brand new from ford. The Only code I get is P1131 Lack of heated oxygen sensor with lean conditions bank 1. other then That the only other issue I find is bad motor mount which I plan to change. Any ideas?
  • cphilcphil Posts: 13
    I have a 02 Lincoln Continental with approx. 62,000 miles. Every once in a while my light comes on witht the bell ringing saying, "low tire pressure" I have them checked with not one shop but 2 or 3 and get the same answer, no low air pressure This message goes on for a few miles and then at some point when I shut off the motor and restart it the problem seems to go away.. I just wonder if anyone here knows what causes this since the tire pressure is ok? Thanks, Cat
  • caddy1967caddy1967 Posts: 2
    THE SAME THING IS HAPPING WITH MY CAR CAN I GET SOME INFO
  • caddy1967caddy1967 Posts: 2
    DIDYOU EVER GET THAT CAR FIXED
  • Kirstie@EdmundsKirstie@Edmunds Posts: 10,676
    Since there are 120+ messages that came before yours, no one knows which "same problem" you're experiencing. Your best bet is to describe the issues that you're having and see if others have ideas for you.

    Need help navigating? kirstie_h@edmunds.com - or send a private message by clicking on my name.

  • raulvraulv Posts: 1
    100kmiles Lincoln Continental 1999 ....steering deviation

    recently I detected a problem with the tire convergence, I went to the suspension workshop and after the mechanical inspections was necesary the replacement of right joint bearing, the convergence it's tuned now, but I have doubt on the camber aspect. I observed a little disaligned on the upper part seeing on front view (it's this normal for a front wheel drive car) the wheels was aligned and balanced.

    Then during driving and when I need increase the speed suddenly the steering change by it self very quickly to the right (particulary when I push more gas to forward trafic).

    The rest of system is working as new car.

    Any of you could give a comment to eliminate this anomaly.
    thank you
    Raul Valdez Coahuila Mexico
  • The factory installed alarm system occasionally self activates with the doors locked or unlocked. Has happened 4 times since March (I've owned the car since last September); twice at my wife's hairdresser and twice in our driveway. When arming the system the horn chirps but lights don't flash; when disarming the lights don't flash and owner's manual doesn't mention lights. Any ideas on what is causing this ?
  • Hi there,
    I have the same exact car & SAME EXACT problem!...
    please advise how you got that fixed?
    I have 110.000k on my car. & air suspension needs to be fixed. but all the rest is good
    hate to get rid of it. PLEASE ADVISE!
    thanks
    N.
  • I know you posted this quite a while ago. I have a very similar problem on my 1998 Lincoln Continental. Did you find out the problem? Thanks, Bob
  • cphilcphil Posts: 13
    Hi Bob. Not sure what post you are referring to but from what I can remember, it was my air filter not installed properly when I had a new one installed.. it was loose..Hope this helps since it was an easy fix.
  • The heating & air conditioning quit working on the car. We had replaced the part with one we got from the junk yard but it only worked about 30 days or so. I cannot remember what the part was called, can anyone help me so I can get heat & air conditioning back in the car. :cry:
  • dwayp4dwayp4 Posts: 1
    My 1998 contintental is running loud at the bottom what could it be it was nice and quiet
  • agpyleagpyle Posts: 1
    Bot a 1980 Lincoln Continental for my daughter. Passed safety but there are some things that need fixing and replacing and having a hard time finding parts. Hood needs new pistons, there is no intake hose from the front of the engine to the air intake and door locks aren't working. Does anyone have any suggestions on where to go. We live in peterborough, ont.
  • 76_cont76_cont Posts: 2
    The trunk on my 76 continental is locked it didnt have a lock where the key goes when i got it n & now the pop trunk button in the glove box stopped workin... How can i get this thing open to put a new lock on it??
12346»
Sign In or Register to comment.