Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Honda Civic Care and Maintenance

13839404244

Comments

  • MrShift@EdmundsMrShift@Edmunds Posts: 43,641
    Those all sound fine to me, but I think you could do the pollen filter yourself. Cooling system flush is a good thing, and as for the throttle body service---well, throttle bodies DO get dirty but if you aren't having any symptoms, I'd probably skip that one for now unless you are using one of those K&N type "lifetime" filters.
  • This matter has been resolved satisfactorily.
  • This matter has been resolved satisfactorily.
  • The MIL in my '96 Honda Civic is on. We have been having ridiculously cold weather lately. We disconnected the battery and rehooked it up when it warmed up and the light disappeared for a day - the temperature dropped to -35 C that night. The light is now back on and tightening the gas cap and disconnecting and reconnecting has not worked this time around. Another piece of advice I received was to check the O2 sensor. First, where is this sensor(s) located and second, how do I check this? As a student, I would really like to avoid any unnecessary trips to the garage. My budget can't handle unexpected expenses :(

    Any advice or suggestions would be greatly appreciated!!
    Thanks
  • Get the codes read off the car's computer. You'll waste more money by guessing and the codes will give you the clues you need to spend as little as possible. It could be nothing more than a vacuum leak.
  • mikefm58mikefm58 Posts: 2,882
    Go to your local auto parts store such as Auto Zone or Advance Discount Auto parts and they will read the code for free and then recommend the part to replace. All the items you mentioned can cause the MIL to come on.
  • I took your advice (thank you) and had the codes read. P0108 came up for the MAP sensor but unfortunately I am having a tough time trying to track down this part so far. Any suggestions? Also, again, I would like to avoid the garage as much as possible. Where is the MAP sensor located and how does one go about replacing it?

    Thanks!
  • mikefm58mikefm58 Posts: 2,882
    I googled "map sensor honda civic" and that one looks like it's over my head. The code P0108 is "MAP Sensor high-voltage (low vacuum) problem". Sorry I couldn't help more.
  • I replaced the MAP sensor and presto, the light turned off. The car seems to be running smoothly except is still getting sub-par gas mileage. Anything that comes to mind?
  • mark19mark19 Posts: 123
    yes, have you unplugged the battery for 10 minutes or more? That should reset the main computer. It will "re-learn" the system and should increase your fuel economy.
  • The battery has been disconnected, but only for a few minutes. I'll try your suggestion, thanks! :)
  • wco81wco81 Posts: 495
    Have a 2007 EX Sedan, about 7000 miles on it.

    It's been running fine for the over 2 years I've had it. Short commute.

    I've been running the heat more than usual (Northern Calif. winters are usually mild).

    I notice when I have the fan on the ventilation system slightly up and the temperature set to a couple of bars into the red portion of the dial, the cooling fan (not the ventilation fan) always runs when I start the car.

    It goes on and off all the time but every time I start, whether from a cold start in the morning or later after it's been warmed up, that fan is running.

    Not all the time but on and off.

    Seems odd that using the heater would cause this fan, which seems to be for cooling down the engine, would run.

    Anyone else observed this?

    Is it something I should have checked out?
  • colleenacolleena Posts: 6
    I posted awhile back about my '96 Civic Ex that was having what appeared to be a MAP sensor issue. The new part seemed to do the trick for the past few months, but unfortunately the MIL is back on again and the car is stalling like before. I have not had the chance to get the codes read again yet, but in the meantime is there anything else that you can suggest as a possible issue?

    Thanks!
  • ttc1980ttc1980 Posts: 1
    I'm been trying to figure out how to manually reset my oil life % back to 100%. Can you tell me how to do this? Greatly appreciated. Pls reply back to tiffany.chan.adi@gmail.com

    thx! :blush:
    TTC
  • heart2heart2 Posts: 38
    Have a 2005 2Dr. and release for fuel door does not work. Have to release it each time from trunk. Is this difficult to repair myself? Any links to instructions or parts?
  • You can check on page 294 of the Owner's Manual.
  • bearcrkrdbearcrkrd Posts: 167
    I have an '08 LX Sedan. If it's running and I turn on the heater fan, a fan instantly comes on in the engine compartment. If the heater is left on when I tun off the car, when I start it, that fan or motor in the engine bay is on, too. I understand it is the same little belt/motor or whatever the heck it is, that runs the air conditioner. I haven't got out and poped the hood and looked when it's running, but it does kinda sound like the fans that blow on the radiator when you idle for a long time, or in hot weather. I'll try to remember to check that out next time I visit a friend when it's sunny! It is normal, I'm 99.99% sure.
  • colleenacolleena Posts: 6
    During a particularly hot spell I left the two back power windows cracked about 2 inches. Unfortunately for me, my '96 Civic window regulator decided to kick the can and now I can't get the windows back up. Is there a way to manually raise the windows, at least temporarily, until I can get the problem fixed properly?
  • patpat Posts: 10,421
    I don't know if this would work for your car, but I had a window regulator go out on my Acura TL. I was able to pull the window up with one hand on each side of it while standing outside the car and it stayed up until I could get it fixed.

    Hope this helps!
  • booneylooneybooneylooney Posts: 1
    edited March 2010
    my car has about 70k miles on it. today my mil light comes on, and i checked the manual to see what could possibly be wrong. i thought it might be my engine oil is low since it has been 5k since i had an oil change....will do that this weekend. i have tighten the gas cap but i refuel about 7 days ago....the mil light keeps brinking and then stay on after i added more oil.....but sometimes the acceleration kind of stall for a few seconds.....can someone help???will it be okay to drive it to work until i can get into the dealership on the weekend?
Sign In or Register to comment.