Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Maintenance and Repair

1111112114116117165

Comments

  • tandy1tandy1 Posts: 1
    i have a 95 jgc that has the same problem, it will run fin for about 3 or 4 days and then i will go to start it wether it was sitting all night or i just shut it off to fill up with gas and it wont turn over. all the lights will come on but when i turn the key foward there is just a click and it is as if i just turned the key to acc. i have to disconnect the battery for about 15-20 min and just it to start the car. i have been to my local stereo shop and had the owner who i am very good frinds with check out the whole alarm wiring and relays for the starter and he sed it very well may be the celonoid in my starter.
  • samm1samm1 Posts: 1
    i have a 1989 jeep cherokee and im having problems with using alot of my accessoires and lights. when i start my jeep the battery gage shows a good 14, but when i turn on my lights, heater or anyother accessory then the battery power drops almost instantly killing my jeep. I just replaced my alternator and coils and the problems still persists. any ideads on what it might be and how i could fix it??
  • dandgdandg Posts: 86
    My 94 Jeep GC ,5.2,154K on it, has been kicking a "high voltage from O2 sensor" code. I replaced the sensor a while back and although it seemed to be solved for a bit it is now returning intermitantly.I hooked it up to a friends scanner and could see the o2 volts climp over 1.20 and the check engine light kick on.It seems to top out at 1.40.

    Any ideas? PCM? (there is also the most common "check 4 wheel drive switch" light and beeb that has been on and off over the three years I owned it)
    Relay? read where ASD relay is in that loop,but not sure if a relay could be intermitant.
    Anyone else been down this road?New Sensor seem to be working as it shows below 1.0 when light is not on changes voltage when driving it
  • svienssviens Posts: 1
    I have a 1998 Jeep Grand Cherokee and for the past year the keyless remotes would only work if I'm about 2 feet away. I've had the batteries replaced in both remotes but the problem still exists (nothing changed).

    Any suggestions?

    Steve
  • i think i have the same problem. i have a laredo 94 and for some reason i cant drive my car. the security system goes off on me everytime i try to start it. this happened once before but i dont remember exactly what i did to fix it. i've been locking and unlocking doors, jumped it a few times, and try everything i could think of. all i have is a key i dont have the wireless key or anything like that. does anyone think they can help me out? replies would be appreciated
  • My JGC 2000 is all-time 4 WD. The rear axle seems to rumble/shudder when turning to right or left. The mechanic said that it sounds like its related to LSD so we have :mad: just replaced the rear differential case but the noise is still there. Nothing much noticable when going in a straight line. Please help - any suggestions welcome!
  • Bad Viscious coupler
  • howie56howie56 Posts: 21
    I'm wondering if You have traction control on your Jeep ? I have a 2005 JGC w/traction control and it has gone out on me already and the vehical shudders when you turn right or left as the rear brakes are grabbing cause it thinks the vehical is sliding out of control. The garage have to replace the control unit in the steering coluum to fix the problem .. Not sure if it's your problem but I hope this helps . :shades:
  • Lately when driving my 93 jeep cherokee - it seems to just stall for no reason. No noise - nothing. it's like the car is turned off and you just coast to a stop with no power steering. When I try to restart it just cranks over and over but doesn't start. No abnormal noise when trying to start - it just doesn't "start" just turns over. After sitting for 1-5 minutes - it usually starts. I typically drive it for no more than 10 minutes at a time. It usually stalls after driving for about 5 minutes.

    In a previous thread someone mentioned a PCM. What is it?

    thanks
  • tidestertidester Posts: 10,109
    What is it?

    Powertrain Control Module.

    tidester, host
  • xscoutxscout Posts: 141
    The Powertrain Control Module is one of the likely causes. It is mounted on the firewall in the engine compartment on the passenger side. You can get them at most auto parts stores rebuilt for around $250.00-$280.00 and they are fairly easy to install. Just remember they are a computer so keep your body grounded to avoid static just to be safe. The crankshaft position sensor is another suspect. Although cheaper (@$50.00) it is slightly more difficult to install due to it's placement under the car. In either case, the car usually runs great or dies with these parts, no in between!
  • kforcekforce Posts: 8
    My 2000 had the same problem. The Crankshaft position sensor shorted out. Unfortunately the short caused the 5 volt reference to ground damaging the PCM. The computer begins to overheat and shuts down the motor. When it cools it resets, clears all codes and allows the engine to start. You probably have to replace both the sensor and the computer. Also the Camshaft position sensor is the same sensor as the crankshaft sensor. They work in unison with each other. If it shorted you will have the same problem. I replaced both sensors and the computer. Runs better than it ever did.
  • Thanks for your response. I am not too clear on the details here but I'm hoping that you may be able to help further. Following your helpful reply the mechanic disconnected the front driveshaft (transfer case to front axle) and drove the Jeep. He said the rumbling stopped. So he now agrees that the rumbling was caused by either the viscous coupler or the front driveshaft, but I was wondering if when this driveshaft was connected to the viscous coupler that it might be the additional stress on the coupler that is causing it problems and creating the rumbling rather than the driveshaft itself?
    Also do you know which of these parts are serviceable - can I buy a replacement viscous coupler (is this the same as a transfer case coupler and does it sit inside the transfer case?) and are there any replacable parts on the front driveshaft - the mechanic tells me it has a coupling on either end. I live in a really bad place to try to get the parts so when we order I want to get it right.

    Thanks again.
  • dandgdandg Posts: 86
    the viscous coupler is a common problem with these at a certain milage and it is not "serviceable" it must be replaced but is not a hard thing to do,although it is expensive,part inside the transfer case.The T case does not have to be removed and the whole replacement can be done in less than 1hr.If I remember correctly they are around 700 from the dealer,I did find one after market from a rebuilder shop for something like 350 if I recall.
    Hope this helps
  • I purched my 2005 Grand Cherokee used a year ago (I bought from a reputable dealership and did a carfax on the car) and enjoyed the car until it reached 38,000 miles. Then everythings started to go wrong. Electrical problems first, then fuel problems and battery problems. The car has died on me 3 times in the past 3 months and I have had it at the dealership 5 times since mid November for various unscheduled maintenance. First it was a fuel sending unit, then the battery died, then a new fuel cap and most recently I had all the fuel hoses and clamps replaced. To me, I have had way to many problems with this car. Has anyone else experienced these problems? Do you think Lemon laws could apply to this car?
  • Okay sounds like the route I should take. Thanks.
  • I just finished a long trip that I took in 4WD Full Time (I was in snow and slush for part of the trip). I got home and parked my lovely 2000 Jeep GC Laredo. This morning, I went to the store. While waiting at a light, I decided to put my Jeep back in 2WD, since I am home, with no snow.

    When turning at a light (A U-turn), suddenly, my Jeep didn't want to turn. I actually thought I had a flat (It felt like when you have a flat and try to turn). Pulled into a parking lot. Nope. No flat. I looked around, and couldn't see anything obvious.

    Pulled forward into a parking space and got lunch. Pulled out, and it didn't want to go in reverse. It did, but stopped almost like I was in a small trench or something. Forward works ok, so I headed home (a few blocks). Had to make another U-turn... same problem. Got through the turn, and made it home. Pulled into my parking space, and it doesn't want to turn, but did (This time, turning to the right).

    These problems only started right after shifting from 4WD to 2WD. BTW, mine is the Selec-Trac automatic transmission.

    Any ideas? Coincidence?
  • It appears that the shift from 4WD to 2WD did not complete, thus leaving me "in limbo", so-to-speak. Putting it back in 4WD, driving it a bit, then back to 2WD seems to have fixed it (I realize I still have a differential repair issue). I haven't driven it much since, just around my apartment complex a bit, but it seems to be working again.
  • mhjeepmhjeep Posts: 4
    I have a hose (small about 3.8" diameter) coming off what I think is the front differential of my jeep. It connected to the differential, but no longer connected to anything on the other end. #1 what is this hose/line? #2 To what is it supposed to be connected? #3 Does this disconnected hose present a safety or serious operating problem?
  • Well, I am just in time again; 2500 miles over the warranty, my memory seat stopped working. Sometimes it does work, but most times it does not. Also, the headlights do not come on when the wipers are turned on. Are these problems related. I am thinking maybe a body control module. Does anyone have any experience with these memory seat failure? Please share your thoughts.
  • I have a 2001 JGC Laredo 4x4 and I am getting a loud noise when I put it in reverse any ideas? Im guessing its the timing belt, but I dont know exactly what it could be. I would greatly appreciate any suggestions.
  • tuggajbtuggajb Posts: 646
    This hose is the diff vent it goes from the diff to a mounting on the firewall just a vent has a small cap on the end mounted to firewall

    tuggajb
  • xscoutxscout Posts: 141
    What engine and 4WD system do you have? As far as I know, none of the Jeep engines for that year had timing belts. Does the noise continue after you put it in reverse? Give as many details as you can.
  • Brought my 2004 cherokee ltd in for a simple oil change and tire rotation today. Got car back at 5pm just as mechanics were heading out the door, my luck. The one working on my car said I had a problem with the automatic air pressure monitoring system. I had asked them to check it because it didn't seem accurate to me. He said they checked and didn't know why it was reading incorrectly. I had mentioned that I had gotten a spare tire sensor missing or bad message. He'd not been told and didn't look at that. Said might be a missing antennae. Ok. Bring back Monday. I take the car and put on headlights. Upon doing so the illumination on the inside guages goes dim. Asked the service advisor about it and he looked for an intensity setting which there wasn't. Remind them when I bring it back for the air system problem on Monday. Could they have done something while checking out the tire pressure system? What could cause the dimming of the guages upon turning headlights on.? Any possible answers? Thanks. :confuse:
  • I also have a 2004 Jeep Grand Cherokee Limited with no heat on the passengers side. I found a web site to contact to report the possible recall.
    http://www-odi.nhtsa.dot.gov/ivoq/
    I am going to report my problem to and I am hoping enough people contact this website so that Chrysler will issue a recall.
  • Since June 2006, my '95 JGC stalls at any time and any moment; Just dies; 3 mechanics 4 parts replaced: Crank Position Sensor, fuel rely switch, MAP Sensor and stater sensor; Car stalled last week, I hit the powertrain control modules - as suggested by 1 mechanic who could not duplicate the stall - and the car started; Happened again 1 minute later, now vehicle runs, but waiting for next stall at highway speed; I've seen threads about the PCM and want to replace; Here's my Q: Does it need to be programmed? Is it difficult to replace on my own? Does the jeep nation have possible other solutions? ideas?
  • Same problem with my 2003 JGC Limited. Thanks for the site info, going to report my problem.
  • hi there,
    did anybody find a solution to this problem?
    Yesterday -for the first time- the "check gages" sign lit up in my 2001 Jeep Grand Cherokee, and I have no clue what this implicates...
    Thanks so much to any help!!!
    M
  • Yesterday -for the first time- the "check gages" sign lit up in my 2001 Jeep Grand Cherokee, and I have no clue what this implicates... :cry:
    Thanks so much in advance to any help!!!
    M
  • xscoutxscout Posts: 141
    You can try unplugging and reattaching the three connectors to the PCM to make sure they are clean and tight. If that does not help you need to replace the PCM. I did this on my Jeep and it's about a 20 minute job and not difficult. The main thing to remember is that the part you are replacing is a computer and it is possible to damage it with static electricity. Use a wrist band like you would if working on a computer to keep yourself grounded. My rebuilt unit with 1 year warranty cost about $260. Good luck!
Sign In or Register to comment.