Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Maintenance and Repair

1174175177179180247

Comments

  • hesitatehesitate Posts: 1
    I purchased a 2006 JGC in July of 06. The vehicle has approximately 11700 miles on it. Over the past month or so, my wife and I noticed that our vehicle would hesitate when we made U-turns or turns while the vehicle was coasting and when we stepped back onto the accelerator. We have taken the vehicle to our dealership at least 3 times and each time the dealer tells us that they cannot duplicate the condition. Anyone have similar hesitation problem.

    Also the dealership has replaced the window motors several times, however the windows sound like they are laboring when the window goes up.

    Any insight would be appreciated. :confuse:
  • nachojeepnachojeep Posts: 5
    I'm having the same problem. When I turn left or right out of a drive way. Every time I take it to the dealer they say they can not find a problem. Did you have any luck?
  • smokebeesmokebee Posts: 30
    Grand daughters 99 Jeep Cherokee was submerged ( to top of engine)for about 1 hour. Have drained engine--as soon as thr rains stop will drain tranny and rear end. May need to dry mother board on computer and clean and check all switches. Questions--where is the computer located and can it be opened? Any other suggestion welcome.
    Thanks, Smokebee
  • soccermansoccerman Posts: 8
    I finally have a new viscous coupler and the mechanic is trying to install. He has removed the rear driveshaft to get access to the transfer case cover. He has removed the bolts holding the transfer case cover but the cover, which is loose/moving, will not pull off. He is concerned that there is something on the inside of the transfer case cover (retaining clip maybe?)which may be attached and preventing the cover from coming off. He doesn't want to force it and break something- getting parts where I am is tough.

    Any ideas if this cover should just come away, or if there is something else to remove? Thanks.
  • tuggajbtuggajb Posts: 646
    Have to remove rear retainer (where the drive shaft hooks on with 4 or 5 bolts
    on this part there is a rubber plug about 1 1/2 in long take out and there is a snap ring under it that you have to release
    after that you have oil pump and stuff
    look like PIA to change
    don't know if can send scan to you need e-mail to try to send file
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 39,049
    You can scan it and save it as a jpg and post it on your CarSpace page in an Album there. And that way people finding this thread in a future search will be able to see the scanned info.
  • soccermansoccerman Posts: 8
    Okay thanks. Please email the scan to hnftravel@hotmail.com
    By the way, what is PIA ?
  • tidestertidester Posts: 10,110
    By the way, what is PIA ?

    Roughly translated, it means "pain in the anterior." :)

    tidester, host
    SUVs and Smart Shopper
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 39,049
    Some dude did write a CarSpace Guide about ways to fix scratched or yellowing headlights. :P

    Some people say to seal it after all the sanding and polishing. Tuggajb (now where have I seen that name before? :) ) used lacquer from Home Depot to seal his after polishing the lens.
  • soccermansoccerman Posts: 8
    It seems that the problem is actually at you first step - getting the rear retainer/ access cover removed. The driveshaft is uncoupled and the bolts have been taken out but the retainer/access cover which should simply slide over the driveshaft is moving but not coming off so we can't get access to the rubber plug, snap ring or oil pump etc.

    We thought by taking out the bolts that the cover would just slide back. Other than the bolts is there anything esle that could be stopping it?
  • tntweirtntweir Posts: 1
    my latch broke off for my 1998 jeep cherokee,how do I get my hood open now???
  • patdowerpatdower Posts: 11
    I have all wheel drive in my Cherokee, it stopped working this winter, I am afraid of damaging it further by driving it as is. Also I have reduced traction with only one drive wheel. The jeep is so powerful i am at a disadvantage in inclement weather due to the reduced traction. Any ideas as to what to do?
  • jhuckjhuck Posts: 17
    I see that I never gave an update. It was the oil pump and sensor. All replaced to the tune of almost 2K. Worked great again until now. Going to post that...
  • jhuckjhuck Posts: 17
    I have a 2000 Jeep Grand Cherokee. I am not sure I can explain this very well. It all started with a break light being out. New bulb and it still didn't work but when the lights are on the bulb does light up. Then I moved the bulb and it's plug to the other side. Now when the lights are on the break light does not light up at all. In trying to figure all this out I then noticed that the bottom bulbs do not light up at all. Pulled those bulbs and everything is intact. My problem started with the top one of the three and when I went investigating the bottom doesn't work at all and the middle ones are fine.
    I plan to look at fuses next. But when pulling the cover I only see one that is break related - Break switch. Could it be that one? I remember the break switch on my Honda being unrelated to the lights though.
  • tuggajbtuggajb Posts: 646
    If you have installed the right bulb 3157

    the holders for the bulb have been known to go bad from heat can get them from jeep for bout 10 12 bucks try that first other wise prob bad tail lamp assembly
  • sarchersarcher Posts: 1
    I have the same car and I had to change the water pump at Mobil for $268 bucks recently. The car kept leaking the coolant until one night i came out to go for a drive and noticed all the coolant leaked out.As of now that problem is fixed. The Jeep has cost me about $2,000 in expenses from going to the service dealer and recently Mobil.The car is at 79,100 miles and I purchased it at 44,000 appoximately. The money I spent fixing the car I could of bought a new car!!I had to change my fan assembly TWICE and the relay over 10 times. This was very pricey, i'll say $760 for fan and module at the same time. The car kept overheating even after they told me they put in a new fan assembly. I recommend not to go to the dealer for service because they are inexperience,pricey, and non-caring. I'm getting rid of this Jeep A.S.A.P. I WILL NEVER BUY A CHYRSLER PRODUCT AGAIN!
  • crowe3crowe3 Posts: 1
    MY 95 GRAND CHEROKEE WAS RUNNING FINE. WE STARTED AND DROVE ABOUT 100 FEET AND IT DIED. I HAVE CHECKED THE RELAYS THEY ALL APPEAR TO BE GOOD. I AM HOPEING IT IS NOT THE FUEL PUMP.
    ANY IDEAS?
  • danielrpdanielrp Posts: 3
    0300 - Random/Multiple Cylinder Misfire Detected
    0302 - Cylinder # 2 Misfire
    0306 - Cylinder # 6 Misfire
    1762 - Governor Pressure Sensor Offset Volts Too Low or High

    The vehicle starts, but it is very sluggish. I have not changed my spark plugs in about 60K miles, so I think that that may solve the 03XX codes....what do you think????\

    Also, what can I do to fix 1762? Thank you for your time.

    Roy Daniel
    SSgt USMC
  • tuggajbtuggajb Posts: 646
    1762 check trans oil level Have you changed your trans fluid?
    if so did you use atf4 non other must use atf4 in your trans anything else will scrue you up
    what engine you have?
    on the right side (pass)side in engine compartment behind coolent tank is computer have had to unplug and clean contacts regrease(with dilitric grease get at radioshack) and rehookup
    make sure that you disconect your battery before doing anything to computer hookups
  • danielrpdanielrp Posts: 3
    1. I have never changed my transmission fluid. I will try that.

    2. I have a 4.0L 6

    3. Is the computer realted to the cylinders?
Sign In or Register to comment.