Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Maintenance and Repair

1202203205207208247

Comments

  • Have had similar on my 97. Crankshaft Position Sensor is indicated. It's a [non-permissible content removed] to change unless you have little hands and arms. Don't try if you are on blood thinners. And the engine needs to be cool 'cause you are right on the rear end of the passenger side exhaust manifold. The 2 bolts had allen inside hex heads. I found the allen feature essential for getting a tool on the bolts. A socket just didn't have the space. Mine had dirty sensor contacts and seems a lot happier since being cleaned and reinstalled. Worth a shot.
  • Sounds like worn out CV joints. New axle assemblies are cheap (Advance Auto Parts) and pretty easy to remove and replace. Be sure you have a big hammer and a sharp chisel to break them loose from the spindle supports. The CV joints and boots pull through the holes in the spindle supports. Less extra removal of stuff than it appears. Some good freeing solution like BG Enforce will reduce the number of hammer blows required for disassembly.

    No guess on converting to 2 wheel.
  • If the ground isn't really solid at the battery, all sorts of strange electric gremlins can appear. If you have original cables and they are in sound condition, really good cleaning and tightening may make the gremlins go away. If the cables are corroded or, even worse, after market jerry rigged, best replace with an OEM battery harness. I got one on line for about 135 bucks, but what a beauty. It's really a complete harness with all the original wrapping and custom fittings for Alternator, body grounds and starter. Takes more'n a few minutes to install, but helps a lot since voltage and grounds are critical for a computer controlled vehicle.
  • rwengrrwengr Posts: 177
    I assume that when you turn the key, you hear the starter motor turning the motor. I have two suggestions for troubleshooting.

    Check out harborfreight.com. I think you can buy a fuel pressure gauge for less than $30. I bought mine last year. Auto parts store usually wants at least $60. I have a 97 JGC. It has a test port on the fuel line near the engine. Looks like the little valve on your tires. The hose from the gauge screws onto it. Observe gauge while you are starting the car. If you don't have the test port, investigate further before buying a gauge. Buy or borrow a Haynes manual for info about your vehicle (about $20) to analyze what you measure.

    If fuel pressure looks OK, you can buy an inexpensive tool at an auto parts store to check ignition. I have one. I forget what it's called. You check one ignition wire at a time. Remove ignition wire from plug and put it on the test tool. In low light or a shadow you should be able to observe spark on the test tool when you start the engine. You can verify that each plug should be firing when you start the engine, assuming the spark plug is OK.

    Good Luck.
  • it turns but it just won't kick over. it's getting fuel. cuz we have taken the cap off the fuel rail and fuel comes out.
  • tuggajbtuggajb Posts: 646
    crank pos senser
  • The reply about a fuel pressure gauge is good gouge. If the pressure is not high enough, your injectors won't function properly.
    Also, the one who said you might have a failed crankshaft position sensor could have a good point. If that puppy aint workin, the engine doesn't know when or where to direct spark or apply fuel. If it's bad but not gone, the engine may sort of try to start, but it won't and it'll sputter, backfire through the intake, and so on without running. You may be able to remove, clean and reinstall the sensor. Be advised it's a bit of a chore because it fits into the engine block on the passenger side right behind the exhaust manifold. Very limited space to work.
  • Long shot---are you sure you are usning the correct key? The valet key usually starts it but will not keep running. Use your spare set and try it.
    Good luck
  • i bought a 91 cherokee limited its in fairly decent shape overall, but the oil pump failed, according to the previous owner. i checked compression and was within limits according to the manual, changed the oil and it doesnt knock at all, so i went ahead n bought it. got the new oil pump in today n while the pan was off i got a good look at the cam n it doesnt look like its gotten hot and its not worn uneven or anything. so basically i cant see any damage so far from the oil pump failure, is there anything else i should look at?

    when i picked up the new oil pump one of the options was a high volume pump that had a note that said its for cherokees with s in the vin for the engine code. mine has an s, but the guy said it didnt require it it was just an option. so i get home n spent the afternoon dropping the pan n changing the pump, n when i get in and start it up the oil pressure guage stays pretty much arround the line between 0 n 40 doesnt go up or down more than 1/16" while driving. the manual says oil pressure should be 37 psi at 1600rpm, so is the high volume pump required? or is everything worn out to the point theres no oil pressure? id think it would be knocking at that point???

    thanx for ur help in advance
  • rwengrrwengr Posts: 177
    I assume you removed all sludge from oil pan and bottom of engine. If not, go back. Also, make sure the screen on the inlet tube is not clogged. You could still have engine sludge affecting oil pressure. Inspect the oil pan. If there is any sign of paint flaking, replace it.

    To be absolutely sure of the situation do the following: If inline engine, remove valve covers. For a v engine, remove input manifold. This is the only way to see if your engine is full of sludge. If it is heavily sludged, cleaning is tedious but it can be done. But if heavy, it has to be physically cleaned before flushing it Put liquid Gunk engine oil flush in a spray bottle. Won't hurt the engine at all.

    Or you can hope its not heavy and treat and hope without opening it up.

    After you re-assemble, flush it with Gunk engine oil flush(or similar product) per instructions on bottle.

    It's hard work. Even if you didn't find heavy sludge during inspection I would still treat it at least once. After you change your oil, drive it 100 miles and then examine the dipstick. The oil should only be discolored a little. If it's black, then you still have sludge. If it continues to be black and you didn't open it up, you probably have heavy sludge.

    After the oil starts to look clean, put a high-performance oil filter (Mobil 1 ?) in it. It improves the flow.

    With the oil clean, new pump and hi performance filter you should see some improvement. As a last resort, try replacing the oil pressure sensor if it's not big $ or too difficult. I would not change the sensor until I completed all the cleaning.

    If you like the car, you can't lose by cleaning the oil delivery system. If oil pressure improves during test drive, but then returns to previous level, it means you are still clogging. You may have to flush again. I have a 96 Ford Windstar. I had to physically clean it and then flush about 4 times to get oil pressure lilght to go out.

    If engine oil is clean, new pump, hi performance filter, and sensor and you still have oil pressure problem, I would measure voltage at oil sensor to verify it's not a gauge problem. Or you may want to measure it first. You may need Chrysler shop manual to to analyze what you measure.
  • 30583058 Posts: 3
    I just installed rear brake pads, one rear rotor, and one rear caliper. the caliper instruction reads....be certain to adjust parking brake after installation of new caliper. what's the need for this....and if necessary how do i adjust emergency brake since my emergency doesn't hold very well any way. thanks!

    Stu
  • 30583058 Posts: 3
    I just installed rear brake pads, one rear rotor, and one rear caliper. the caliper instruction reads....be certain to adjust parking brake after installation of new caliper. what's the need for this....and if necessary how do i adjust emergency brake since my emergency doesn't hold very well any way. thanks!

    Stu
  • tuggajbtuggajb Posts: 646
    there is a little hole on the bottom of the rear backing plate that you use a brake adjusting spoon to adjust the shoes
  • i dont have the alarm remote for my 91 cherokee n when i replaced the battery the alarm went off, i tried putting the key in n trying to start it, but now it wont start. is the alarm keeping the struck from running? it seems like it wants to start , even does sometimes but imediately dies.
  • I have a '03 that now has the same problem. Let me know if you have a solution... thx
  • I have a 1997 jeep cherokee 150000 miles. Everything excellent on it except for the transmission. What can I do to sell it without having to sell it for scrap?
  • tidestertidester Posts: 10,110
    Prepping Your Used Vehicle for Sale may be helpful along with Pricing my used vehicle for private sale.

    tidester, host
    SUVs and Smart Shopper
  • hey guys i lost my owners manual and was trying to figure out which fuse is the one to take out to have the interior lights stay off when i open the door. i have a 2001 4 door jeep cherokee sport. any help appreciated, fire away!
  • Did you resolve this issue? My 97 cherokee sport has the same issue exactly. It's as though you are describing my drive home from the store tonight. If you did resolve, can you pass the info on? Thanks in advance.
  • hort of being specific----open the door and pull small amperage fuses one at a time until the light goes out. Bingo that is the on. Of course some other lights may be affected as well so U will need to check the other lights.

    In the old days when I was young and courting my girl in our 39 Dodge I simply drilled a short piece of metal, attached it to the door switch and folded it over the switch pin when I had the door open. Worked for me.
Sign In or Register to comment.