Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Maintenance and Repair

1241243245246247

Comments

  • rwengrrwengr Posts: 177
    My guess is you have an operating pressure problem that for some reason, does not become significant until the tranny fluid gets hot.

    Make sure you have absolutely no leaks, especially the trans cooler lines. They should be bone dry. I believe leaks affect the pressure.

    I think you can rule out an electrical fault.

    I have a 97 and believe it or not Autozone had new trans cooler lines in stock. They were a pain, but not to bad to replace. You may need a spcecial tool to disconnect them at the transmission.
  • I have the exact same issue right now. if you find out i would like to know too. :(
  • My dash lights up with all the waring lights from time to time. I took it to AutoZone and they put a scanner on it and told me my EGR Valve and Senor are bad. I cannot locate the parts for my Jeep and now questioning weather that is the problem. My Jeep runs fine. Hope someone here has and idea.
  • I trade my car for this the buddy said the oxy sensor needed to be replaced and muffler put back on. Muffler hasn't been put on yet. Several people said it could different things. It idles kinda ruff at times, stall twice as i was driving it, when you go to step on the gas it bogs out and acts like it wants to stall. Going up hill is a no go, on big hills it will almost come to a complete stop cuz it has no power at all. We replaced the throttle post sensor, oxy sensor and the fuel filter, still no better, its a 318 v8 and the check engine light is on.. Any idea's??? Putting the exhaust on it today.
  • rottlyrottly Posts: 2
    get the jeep it will run longer by far than either one of those and we really need to stop buying non-american vehicle's even if they are used KEEP AMERICA WORKING or we will be mexico...now that im off my soapbox.i have owned 8 jeeps all from 10k miles to 280k miles at the time of purchase and ALL of them have been great any only had 2 problems which jeep took care of both of them call nissan or toyota and ask for good will n see how far that gets ya hahaha window regulator on my 2006 liberty went out at 85k they replaced ALL of them for free cause it was a known problem 2006 commander had surface rust on hood well paint was bubbling so there would have been rust soon @50k jeep took care of that to both out of warranty i had a 1996 cherokee with 580,000 miles when i sold it ORIGINAL motor and tranny show me another suv like that jeep is tough and reliable cant beat them and they hold there value like a caddy...why would they hold there value o ya cause they are awesome vehicles
  • rottlyrottly Posts: 2
    does your oil look milky?is there white smoke coming from exhaust?take your radiator cap off and look at the coolant in the radiator wile it is running(do not do it with hot engine make sure engine is cool or you will get hot coolant on your face)if you see any of these things you have a blown head gasket/cracked head. but no its definately not because of your o2 sensor or muffler could be a clogged cat may soo look for a clogged cat all the symptoms i listed then if non of that helps do a compression check
  • Our 2004 Jeep Grand Cherokee Laredo (V6) check engine light came on during our first cold spell about two weeks ago. Mechanic said he saw code for "heater failure" but kept it all day and it ran fine. Mechanic also said they checked it over and could not figure out why the light went on because it was running perfectly fine. All gauges were fine and no fluids leaking or low. Needed an inspection for NYS so I had to wait 30 miles and drove it 60 miles in a week with no problems. Had inspection done a week ago and it passed. Last week, noticed squeaky belt noise on idle at traffic stops a few times but chalked it up to extreme cold again as car ran fine. Today, put on heater and noticed a slight burning smell when I exited car. Got back in car five minutes later and noticed nothing leaking. Got back in car, turned on heat and noticed temp gauge just starting to creep from dead middle to slightly right but not higher. Turned off heat and it started to creep back down and stay left of middle. Now I am paranoid there is a problem. Does this sound all normal or am I correct in suspecting an issue?
  • um yeah with the heater on that needle should NOT move! it is normal for it to do that when you run the a/c but not the heat, you need to have that looked at...and if he says its fine, slap him in the face and go to a new shop....
  • okay, so this will sound a little weird, but i'm gonna throw it out there anyway... i have '93 GC Laredo with the 4.0L engine and SelecTrac transmission, which i leave in 2WD 90% of the time, unless i'm off in the toolies. i bought the car in late 2007, and the first two years or so i had the car, it was getting something around 15mpg city, and 25-28 in freeway driving, but it idled real rough, stumbled, and sometimes stalled. the rough and stumble went away as soon as the throttle came off idle, and it ran fine as long as i wasn't stuck at a stoplight too long. anyway, i took it in in august of 2010 for repairs, they found a vacuum leak, which they fixed, and now the idle is much better - still not super smooth, but better. but my mileage now is down around 11-12 in city and 18-19 on the highway. my driving habits didn't change...

    the fact that i was getting over 15 city/25 highway tells me the car is CAPABLE of that kind of performance. how would fixing a vacuum leak cause it to drop like that? more to the point, how can i get it back???
  • dageorgiudageorgiu Posts: 1
    edited February 2012
    So i was givin a jeep to me from a friend last week, and been fixing this left and right on it. So my last problem that i cannot figure out to fix, is that my driver side door wont lock, (and the door actuator is dead i know i have to repalce but not worring about it now) it closes and stay closed but when i put the key into the door and turn it to lock it. it turns (but it bounces back a little bit, it doesn't feel it clicking when u make that full turn) but doesnt lock.. does anyone know of a DIY write up w/ photos plz if possiable. on how to fix this problem. or know what i need to replace to make this door once again lock.

    Thanks.
  • The vacuum leak added more air to the engine creating a leaner air-fuel ratio. Result is better mileage but poor emissions. The rough idle was caused by the computer trying to adjust the emissions and not finding a setting, so it was doing a cha cha. I did the same thing on purpose to get mine to pass NJ emissions. Pulled a pair of vacuum lines for normal running and hooked them up to pass inspection.
  • that's a little like what i thought, but i never had any trouble getting it through emissions (though a leaner mixture usually helps). is there a way a shop or dealer can reprogram the computer to obtain better mileage? or do i just need to create an "artificial" vacuum leak to get that mileage again?
  • A shop may or may not do it since it may be a violation. You can always ask. My inclination would be to pull a vacuum line again and try that for a while and see how the mileage and performance changes.
  • Hello, first let me thank you for a place to ask a question. I have a 1996 Jeep Cherokee Country. I need some good advice because money is an issue, after just replacing a heater core and battery.

    It has been sluggish to turn over, I thought perhaps because it was cold out.
    I had my battery and alternator checked today. The Alternator was charging, but I had to replace the battery. It was old, so I thought nothing of it.

    I started it tonight, and turned on the heat. When I am parked using heat it made the battery gauge drop a bit, while still parked I turned on defrost and it really dropped down to a little above 9. So I shut off the defrost, and drove- while driving I tried it again. It drops slightly below 14. Sometimes when i turn on defrost belt seems to squeak- if this matters. What is causing this? Is it safe? Any ideas?
  • A couple of ideas that may help, first of all if its cold and its sluggish to start, have you got the correct weight oil in the crankcase. That car is designed for 5W-20 oil. Oil gets thick when cold and will cause difficult starting. I have a 2011 Chrsler 200 and when it was 5 below zero, it was sluggish to start too. As far as the voltage drop, could be a few simple things. Are your battery connections clean and tight? They put in a new battery so was it done propely so that everything is tight? How are the battery cables? Any corrosion under the insulators will cause a draw. If it drops voltage with the heater on, could be a bad heater blower motor or you just need to oil the fan bearings. That sqeal you hear may be the fan bearings. Not unusual for that year of car to need a heater fan blower replaced. Hope this helps. None of these fixes are expensive.
  • Is anyone else having problems with rear struts (shocks?) on 2011 JGC? A few weeks ago mine started "squeaking" when going over bumps. Took it in to shop and they replaced them under warranty. Literally a week or so later I'm starting to hear a whisper of the same sound coming from the rear - the same way it started last time. I'm still under warranty, so it's more of the hassle factor at this point. But wondering if I'm the only one???
  • tuggajbtuggajb Posts: 646
    when you use defrost the ac comes on loose belt will cause squeal and low voltage
  • I am not sure this is the best place to post, but worth a try

    we have a 2012 jeep grand Cherokee with a panoramic moon roof. I never thought about this before buying, but we use a soft roof top cargo carrier attached to the cross-bars. Its not loaded with heavy stuff, just beach towels and duffel bags with clothes. I am not sure I am comfortable with it sitting on the back part of the moon roof. Dealership doesn’t think it will be a problem.

    Does anyone have any thoughts or experience with this?
  • I would never own a car with a moonroof again. They all leak eventually. As far as the panoramic one, remember GM had these on the trailblazer and Envoy and they were a nightmare. I would be very careful how you attach your cargo carrier. If it shifts, the roof is toast. I question some people's car buying judgement. No offense but this may be a bad option in a year or two. Ever think resale value if they get a bad rap?
  • I have the same jeep with the panaramic roof while I dont anticipate problems if I were to utilize the roof rack I would purchase the rails sold by jeep as an accessory. Better safe than sorry
Sign In or Register to comment.