Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Maintenance and Repair

17273757778247

Comments

  • denbedenbe Posts: 1
    We have a 1993 Jeep Grand Cherokee that I believe has a part time shimmy in the front end caused by the all time four wheel drive hardware in the transmission locking up. Since the rest of the car is in excellent shape, is normally only driven a few thousand miles a year, and four wheel drive is not needed, does anyone know if removing and driving the car minus the front drive shaft is possible, or is the yoke assembly in the transfer case removable (thereby letting the gear oil run out?) Thanks for any help. <:)
  • mtomassimtomassi Posts: 2
    i have a 99 jgc 45000 miles,never a problem with the exeption that last week i did not drive the car for 2 days and when i tried it would not start,i got a boost from a neighbor since i knew that the baterry was only 3 months old and it started right away BUT now my speedometer,tachimeter and left back breaking light does not work,the rest is perfect.
    checked the fuses they are ok.
    any ideea?
    or if anybody had the same kind of problem what is the cost aprox.
    i just service the car after the manual,the rest is all foreign for me.
    thank you,
  • pmf65pmf65 Posts: 2
    I know this may seem like a stupid question, but I am new to the jeep world and have never had this problem. I have a 96 grand cherokee laredo and I can't remove my rear tire. I have never had a 4 wheel drive before, and this one has select-a-trak, I don't know if there is anything I need to do to be able to remove the tire, or if there is some kind of lock that I am not aware of, or if it is just so rusted on that I can't get it loose? I told you it was a stupid question, but mean while I am stuck with a flat tire.
  • pmf65pmf65 Posts: 2
    mine was doing that for a while, off and on, and finally it just wouldn't start at all, unfortunatly it ended up being my fuel pump, hopefully yours is something easier
  • div2div2 Posts: 2,580
    I know first hand that BMWs with alloy wheels have a similar problem; the dissimilar metals of the wheel and hub interact which fuses them together. If you can pump up the tire I'd try installing the lug nuts finger tight and driving the GC in several figure eights. That will usually break the wheel loose. If you can't inflate the tire you will have to loosen the wheel by whacking on the back side with a big hammer-use a block of wood to cushion the wheel and prevent any dents or gouges. That said, I'd be very hesitant to try this procedure if the truck is only held up by the emergency jack; I'd want the car on a good pair of jack stands. In any event, once the wheel is off you can prevent future problems by cleaning the mating surfaces of the hub and wheel with a wire brush followed by the application of a thin coating of anti-seize paste.
  • ggibsonggibson Posts: 2
    I have a '94 GC with 74K miles on it. My engine is overheating, and I can't figure out what the cause might be. No emergency lights have come on on the dash, but the temperature gauge is going all the way up to 270 deg after a short time of running it (even just idling). The odd part is that the heater is putting out cool air (not hot at all), and the radiator cap is not hot to the touch. The engine is also running a bit rough--not idling well and sometimes accelerates hesitantly.

    I checked the fluids and all seemed to be within acceptable range. The engine coolant was maybe a little low, so I added some new coolant but it still overheats. Any insights into what the problem might be, and if I need to take it in to the shop?
  • xscoutxscout Posts: 141
    Sounds like your thermostat is not opening. If the hot engine water can not get to the radiator it would stay cool and the heater also would not put out heat do to the lack of coolant circulation. This is an inexpensive and easy repair, just do it after the engine is cool.
  • crookstercrookster Posts: 40
    About 2 days ago all of my windows wouldnt roll up or down this is when the car was on. I took out the key and put it back in and it still wouldnt work. So i left the car in the parking garage. The next day i put in the key and the car wouldnt start up. It took me 5 trys to start up the car. I just had the 15k service done at the jeep dealership for $650. :mad: , but I understand that you must take care of the car so that was not a problem. Can somebody please tell me what is wrong. Also i have taken in the car for a/c problems (twice), rotor problems (twice), and electrical problems (once) can this car classifiy as a lemon in NY? The truck only has 16k on it. plz help
  • huffologyhuffology Posts: 1
    I have an intermittent problem with the marker lights on my 1996 Jeep GCL. When I turn on the lights, the fuse blows immediately. I've checked bulbs, wires and replaced the headlight switch. After the fuse blows, braking or activating the turn signal will make the dash lights illuminate intermittently. Does anyone understand this problem or know of a way I can troubleshoot???
  • no its not my fuel pump i can hear it when i turn the key on even if it dont start. i'm pretty sure its the starter now. i'm gonna go buy 1 and i hope it fixes my problem. thank u 4 ur help.
  • deniseadenisea Posts: 2
    I own a 1999 jeep grand cherokee V8, I have to replace the CV Joints on this. I have the part on order, and am just wondering what it actually takes to replace this yourself. Since I have owned my jeep I have had to put over 5000 into it on problems I have had. I have no more money to put into it, and have to replace these myself. HELP ME PLEASE!
  • deniseadenisea Posts: 2
    Also I am wondering if there is such thing as an inner and outer CV Joint..... Someone I know mentioned this to me but it just doesnt sound right?
  • tokentoken Posts: 5
    Tell them to check the torque converter. I just had mine replaced and it was making the exact same sound.
  • tokentoken Posts: 5
    Hello. I just got my 2005 Jeep Grand Cherokee back from the dealership. They had it for 2 weeks to replace the torque converter. I called Chrysler customer service and told them they lost two Jeep customers (between family members we have owned 6 Cherokees). The rep said "well that's your choice". Unbelievably rude.

    Lucy Samuels
  • keni76keni76 Posts: 3
    My car has been at the garage for almost a week now. When I brake, it seems to "pop" just before the car completely stops. And when I take my foot off the brake, it doesn't roll forward with the power that it should. Garage says it is starting out in 2nd gear, and not dropping into 1st when I stop like it should. But the garage and a transmission shop that they took it to have been unable to figure out why. No computer codes, etc. We decided to change the transmission fluid and filter to see if that helps. It's at 43000 miles. 2WD V6. I've never changed the fluid, but I bought it used 2 years ago and don't know what happened before that. Has anyone seen this before and have any ideas?

    I've already had the rotors resurfaced and had to replace a power window motor. Fuel pump needs to be replaced too but I don't have $500 right now. Any help would be greatly appreciated.
  • mstoverinkmstoverink Posts: 22
    Unfortunatelly I don't have much experience with Jeeps as I just bought my 97 JGC about 2 months ago. But on a vehicle I owned previously (little 4 banger import) I had to replace my CV joints also. I knew nothing about them or how to do it until I asked around on some forums, some parts stores, and also two local mechanics. The answer I got every time was to replace the axels. Keep in mind, this was a front wheel drive import, not a 4X4 SUV, but I think mechanically it's pretty much the same. Basicly, there is a right axel and a left axel. Both axels have two cv joints. On each axel, there is a cv joint near the wheel and there is also a cv joint near the front differential. If one joint is bad, it puts a more stress on the other joints and they may wear out soon also. If you just want to rebuild the CV joint it is *probably* the one near the wheel, but my suggestion would be to replace the axel.

    Check out your local parts stores and local mechanics. I found a parts store (AutoZone, I think) that had factory rebuilt axels for my car for about $60 each (I had to return the old axels so they could turn them back in) and they guaranteed the part. Most mechanics don't want to do the work unless you're buying the parts from them as well. But I found one that would do it and would still guarantee the maintenance. Anyway, to have both front axels replaced cost me about $220 for parts and maintenance, good as new. My suggestion would be to check out parts stores and mechanics and get some quotes. If you can't afford it, go spend $15 and get a Haynes Repair Manual from the auto parts store and check out the steps to replace or rebuild the axel or the joint or whatever. But looking at my manual, it looks pretty involved. Hope this helps. Good luck.
  • fifthfifth Posts: 6
    I have a 2005 Jeep GCL with the 5.7 Hemi. It has the NAG1 German 5 speed automatic in it. Shortly after I got it in Dec 2004, I noticed that at 60 MPH, sometimes the tac would read 2100 RPM and sometimes it would be at about 1750. I took it back to the dealer and after going for a ride with their diagnostic computed hooked up to it, I learned that the transmission does not shift into 5th gear until about 63MPH(100KM in metric). The torque converter also has lock up abilities in 3rd, 4th, and 5th. which made things a little harder to understand but the diagnostic computer clarified what was going on. I felt that it should be shifting into 5th gear at 45-50 like most vehicles do. The dealer was not sure and called Chrysler. They said that my transmissision is operating as designed. At 13MPG, it sure would be nice to have it shift sooner since the Hemi plays with the vehicle but it as it stands, it will spend most of its life in 4th gear. Has anyone else experienced this?
  • chellet66chellet66 Posts: 2
    I'm curious if you replaced the BCM and if it fixed the problem, and if not what did? I'm having the same problem, but it gets worse. My A/C isn't working either and the windows won't go down. It's 95 degrees here. HELP PLEASE!
  • stevezjstevezj Posts: 1
    Hello, I'm new to this forum, anyway I currantly own a 1998 5.9 grand Cherokee. I 'm having a minor electrical problem, and was wondering if any other fellow 5.9 owners had the same thing happen and what the solution was........My instument cluster quits at random, and when it does I lose all power options like the windows and locks....then at random it comes back on, the only thing I notice in common, is that my air bag idiot light came on and stays on........can anyone shed some light on this?
  • keni76keni76 Posts: 3
    I'm going to answer my own post in case it helps others. The garage changed the transmission fluid, gasket, and filter. This year model uses synthetic tranny fluid, so it was more expensive, but completely resolved the issue. It was crazy, but I'm happy to know it wasn't something more expensive than that!
Sign In or Register to comment.