Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Jeep Grand Cherokee Maintenance and Repair

19192949697165

Comments

  • steverstever Viva Las CrucesPosts: 40,788
    Differential vent tube?

    Steve, Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • pberginpbergin Posts: 1
    I have the same problem with my 96 JGC, did you ever find out what to do to fix it?
  • ajs077ajs077 Posts: 3
    Thanks. Is this a common fault with this motor? How big a job is this? Does anyone know a good place to get aftermarket or mopar parts for the 4.7i V8 as I'm in Australia and the Jeep dealers really like charging for simple cheap parts. eg: Sump plug $24.00AUS.
  • bleachlbleachl Posts: 7
    While Driving My 1999 Jeep Grand Cherokee Limited, 4.0L, 2WD, it just stops running and cuts off. Sometimes it will start right away and sometimes it will not start for at least 16 hours (that's the longest it took me). Has anyone else had this problem and what was the solution. I changed the fuel pump and it's still doing it. Can anyone help me.
  • Hi, tried this last week, and didn't get any replys. Gonna try once more !!

    I have a 98 Grand Cherokee, and have a question! Every time I start it, and it is cold, The engine winds out to a higher rpm for a several seconds before shifting into 3rd gear. Once it makes the shift, then everything is ok. It also only does this ONCE at initial startup. After this it shifts normally until allowed to completely cool down for the night. I thought it was just a cold weather issue and didn't address it over the winter, but now it is warming up and I still have the issue. This happens in drive only and only shifting from 2nd to third. Also, the dashboard switch to override the over-drive works correctly, as well as the floor shifter for all other gears. I do also get an occasional hard shift into reverse and an occasional slight tranny 'whine' when in reverse. Any ideas? Am I on the brink of a tranny failure? Fluid level ok, and seems clean..... tia
  • dillinsdillins Posts: 2
    I have a 2000 JeepCherokee Limited. Cracked block/head. Cost was $2500 to repair at Jeep dealer. Warranty is no good through Quality Guard. I have a $100 deductible and free rental car. They jerked both the service dept and me around for 3 weeks. Didn't send an inspector for 2 weeks. Started out by saying I didn't have a warranty. Had to refile the paperwork. Then the inspector said that the water pump had been replaced because he couldn't see engine paint on it. Funny, my engine has no engine paint. Dealer says its the original water pump. All told I am out $3200 between repairs and rental car. Dealer is still trying to appeal the decision. One word of advice -- don't buy the warranty from the dealer unless it is one from the factory. This Jeep dealer only sold non-factory warranties for their extended policies. Quality Guard does not answer any phone messages (oh yes, most of the time you end up with voice mail). When I called to start the process the adjuster on the phone told me from the beginning that he was going to refuse the claim. How's that for service!!!! :mad: :(
  • steverstever Viva Las CrucesPosts: 40,788
    You may want to check out the Extended Warranties discussion and see if anyone in there has had problems with them.

    You also may want to ask your state's insurance office about filing a complaint since most extended warranties are a type of insurance and insurance is a pretty heavily regulated industry.

    Steve, Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • pinballgovpinballgov Posts: 1
    HI all, my a/c problem is that the clutch will not engage, not sure why it was working untill I had to change the radiator and fan. I ahve checked all fuses and found all of them to be good I have looked in the book and see something about the transducer not sure if this is the problem, what should I check next any and all information will be greatly appiecated thanks

    BILL :(
  • taffy3taffy3 Posts: 26
    Thanks Steve
    Yes, you're right. I got under a parked Jeep and the pipe just runs along the front drive shaft tube. It's just a breather pipe.
  • steverstever Viva Las CrucesPosts: 40,788
    Good to hear - time to buy that dog a new chew toy. :shades:

    Steve, Host

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • gcjlownergcjlowner Posts: 1
    I've noticed that my rear liftgate on my 1996 JGC Limited hasn't been closing completely. It wasn't a problem until today. Now it definitely does not close and all of the interior lights remain on signifying that a door is ajar.
    Any thoughts on what is preventing it from closing completely?
  • jamaajamaa Posts: 2
    I had a 1995 that did the same thing. Turned out to be the crankshaft position sensor.
  • jamaajamaa Posts: 2
    It's not leaking from the cover, but from where the axel housing connects. I've already replaced it once with one I bought from the junkyard. It began to leak from also. Has anyone else seen this problem? Where is a good place to buy a new/used one?
  • emcoalsemcoals Posts: 4
    I'm now in the "too firm" camp after almost a year. Any after market solutions for front seats. Hear the SRT seats are great. Maybe I should trade up. But I do like the one I have now a lot. Thanks.
  • crookstercrookster Posts: 40
    I own a 2004 wj with a 4.7 power tech. After every 1500 since having my oil change the color of the oil is almost black. This has happened 2 times now. The wj has 28000 miles on it. Also when I put it into drive the car jerks forward. What could these problems be? Thanks
  • enedzienedzi Posts: 3
    Hi fellow Jeep owners,
    I would like to remove my factory cross rails on my 2006 Grand Cherokee luggage rack. I want to install Yakima cross pieces so that I can use my old mountain bike trays. Any ideas?

    There is a large knob that can be removed. Once you do this a bottom flat latch falls loose but is still held by a clip on the outer part of the rail. I can’t figure out how to release the outer part of the clip. It would be best if I could remove them and then put them back on if I ever sell the jeep.

    Ideas are welcome. Happy trails.
    Eric
  • 81trekker81trekker Posts: 51
    A rented one this past week while in Colorado. I got it because I was planning to visit the national forest and thought I might need high clearance and four wheel drive.
    While it had the clearance, shifting into four wheel drive required consulting the owner's manual. I reviewed it quickly and planned to avoid trying to use it. After driving Toyotas and Nissans off-road for 25 years, the jeep shifting system is the most confusing I've seen. I looked underneath for the skid plates. Might have been one under the oil pan but not on the transfer case or the gas tank. I didn't bother looking under the front, but doubt the bottom of the radiator was protected either. I started on a bumpy dirt road and found its handling to be very unsure. I slowed down my pace to avoid control problems. No mud flaps so there were a couple rock chips in the side. My Nissan Frontier Nismo runs circles around this vehicle. I'd rather take our 1998 Toyota 4Runner with 120K miles off-road than this b.s. "trail rated" Jeep. Even our 04 Nissan Armada is more off-road ready (I added all optional skid plates), although a bit large for many places.
    Thanks but no thanks to the Jeep. - 81 Trekker
  • bleachlbleachl Posts: 7
    Thank you for your help. I turns out it was the crankshaft sensor. :)
  • jczarjczar Posts: 1
    I have a 2000 Jeep Grand Cherokee and it seems the fan motor is bad. How do you get the fan shroud out? I can get to three of the four bolts but not the one behind the front wheel gearbox. :confuse:

    Thanks
    John
  • gex555gex555 Posts: 2
    SAME Problem HERE ...99 JGC car wont start and when the battery is connected i get a ticking from the gauge area and they all spin like crazy. REDH894 Please help me by telling me what it is that you found out ....i have had the jeep only one month. dead cell? over charge? or perhaps a short in the electrical system? anyone else with advice much appreciated
  • bleachlbleachl Posts: 7
    I have reason to believe that the P0320 code is a faulty crankshaft sensor. I tried to change it myself but was unsuccessful. I couldn't get my hand in there nor could I get a socket in there. I can't even see where the electrical connection is. Has anyone had the experience of changing one who can give me any pointers. All help would be appreciated. If it can't be done at home, how much will a shop charge (rough estimate). Thanks... :confuse: :sick: :(
  • bleachlbleachl Posts: 7
    Did you change it yourself or did a shop do it. If a shop did it, about how much will it cost? :)
  • bleachlbleachl Posts: 7
    I have a 199 Jeep GC Limited, 2WD, 4.0L and I have a faulty crankshaft sensor. I tried to change it myself but was unsuccessful. Do you have any pointers for me before I go crazy. Does it have to be done at a shop if it's a '99. Help..... Thanks in advance... :cry: :confuse:
  • beezzerrbeezzerr Posts: 1
    I have a Jeep Cherokee 4.0L, 175,000 miles, and last week it had a major hesitation taking off from a stoplight, had to pull over, then it ran fine. Now everytime I shut if off, (even if its only been on for 30 seconds from cold), it makes this clicking/poping sound coming from the motor. Sounds like cooling metal. Its never made this sound before, what could it be? Any thoughts?

    Thanks in advance
  • 96 Jeep GC, Pulled to a stop and the engine died. Car didn't want to start, so I gave it gas and it started. Let off the gas and it dies again. I then balanced the gas/brake and was able to get into a parking spot. Ok, now the trouble... the battery is dead, it'll jump start with depressing the gas, but once I let off the gas it'll die. Any idea?
  • jgeislerjgeisler Posts: 2
    This can be caused by a weak battery. Have the battery checked first and replaced second if needed. Make sure you have tried to charge the battery before having it checked. Alternatively, your alternator may be bad. Most parts stores can check this while on your car.
  • Ok, with it connected to a good battery of another car I am now getting nothing. The lights won't even turn on. I've checked all the fuses, all good. Still believe it's the battery? or something else?
  • shilohkidshilohkid Posts: 1
    I too am having the same problem. What did you discover??
    Please help.
  • gex555gex555 Posts: 2
    I havnt found anything new ...except i charged the battery and got it checked and it is a good battery after hooking it back up everything acts normal except the car wont start. It will turn over and make the starting sound but just wont start not even a hint of it starting ...but as i said lights and all work.
  • taffy3taffy3 Posts: 26
    I'm considering removing the cat on my 98 GCLtd. Don't need them where I live.
    Anyone done this and seen any adverse/positive effects?
Sign In or Register to comment.