Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Hyundai Santa Fe Maintenance and Repair (2006 and earlier)

1828385878894

Comments

  • somedai1somedai1 Posts: 416
    but hyundai has come a long way - don't you think they may have gotten better?
  • tenpin288tenpin288 Posts: 804
    This is from your first and only other post on your Santa Fe from May 2005...

    Just bought a new one, and love it. Put 1000 miles on it in 4 days. Checked gas milage today on back roads at 50-65 MPH. Average of 26 MPG. I have the 2.7 L engine with the 4 speed tranny. Hooked it up to my double ATV trailor to see how it tows. Great!!!! Hardly know the trailor is behind me. Oh it may have to shift up big hills, but it will work just fine. I'll keep everyone posted with updates on how it does in time.

    What happened in the meantime? :confuse: I don't doubt you have had problems, but please give us some more info so that others can make better informed decisions.
  • I own a 2001 Santa Fe; have only kept it this long because of the expense of replacing it, after many long years of having the car in the shop for numerous problems. Some were covered under the highly touted warranty, but many were not. 500 miles into ownership of my new vehicle, the evaporator stopped working. Thus, no A/C in September in South Florida. Even after receiving a replacement evaporator (so they claimed), the A/C never worked properly until the car went thru a very major check up/tune up. At 12,000 miles a new alternator went in. The window motor burned out. Something in the steering column went. A fuel sensor failed and nearly killed me during entry onto the highway. I had just received the recall notice for that, but not soon enough as my car shut down while I was entering traffic on the interstate. Then the locking mechanism failed on my rear door latch and anyone could open the hatch w/o setting off the alarm. It may have been weeks before I discovered it and I park on the City street. I was fortunate that time. Then another alternator burned out. The left brake light has had the bulb changed many times and it keeps burning out shortly thereafter. The latest mystery, at 80,000 miles, is with the radio, which was allegedly an upgraded model (one of those "mandatory options" that came with the vehicle) that could never seem to pull in half of the stations that my husband gets in his little Toyota Corolla. The radio switches back and forth between CD player and radio, without any help from me, and this without any CD in the mechanism. If I turn it off, it turns itself back on. Honestly! Over and over again, as if it were haunted. The only way to stop it is to turn off the ignition, which is not very convenient when I'm out driving. See what I mean? No more Hyundai for me, no matter how cosmetically appealing the vehicle may be.
  • Ok, so my girl has this 02 Santa Fe... goes to the dealership for every scheduled maintenance that it needs... around March of last year the catalytic converter at the exhaust manifold goes out... The dealership does not replace it but does replace the secondary cat.

    Two weeks later the blown out guts of the primary cat clog up the new secondary... this time a Non-Hyundai dealership replaces the primary, but not the secondary, a muffler shop does the honors.

    Three months down the road and the primary goes out again...

    She goes back to the Hyundai dealership... they replace it...

    Again it goes out... it's under warranty... (aftermarket)... it's replaced...

    Now... January 2008 and the primary goes out once more.

    A local shop replaces it... but can't find a reason as to why it keeps failing.

    The car has over 100k on it... at the onset of this problem it had 90k.

    Other than this the car runs find... gets better than 20mph.

    But at $500 per cat... to replace, we are at the $3k level.

    Any ideas?
  • Just had my sf repaired and was told it was a cam position sensor valve?
    In laymens terms what is it?
    Aslo I was told I should have a de-carb fuel service clean done. I did not do this, should I have?
  • somedai1somedai1 Posts: 416
    can't recall exactly what it does - tells computer the position of cam - can't recall what that translates into as far as car function.... but the decarb - should be done every 15k miles - it's a total fuel system cleaning to get all the built up carbon out uf the car engine internally...
  • Thanks for the info. All I can say is that the engine light came on. So naturally I assumed it was the gas cap. After a few weeks it would go on and off (the light) so I just did not pay attention to it any more. That is until I broke down on the highway. I should have known because my gas milage started to drop a lot in the last few days before the break down.
    I will go back to the dealer and get the de-carb.
  • Does anybody know where I can download details of how to service and carry out repairs on my Santa Fe 2.4. I have tried to contact Hyundai directly without success but as my car is now 6 years old I want to start repairing it myself,especially replacing brake pads. Santa Fe's are not that common in England and bookstores don't stock any technical manuals. Please help.
  • Stever@EdmundsStever@Edmunds YooperlandPosts: 38,946
    Check the Hyundai Online Shop Manuals Access discussion for links. This post would be a good start:

    doohickie, "Hyundai Online Shop Manuals Access" #7, 27 Nov 2006 11:13 am

    There's some other links in the Online Repair Manuals guide, but I think most owners are pretty happy with the free offerings straight from Hyundai.
  • Go directly to the Hyundai website and you can get the only factory service manual that there is for $80.00 US. It's the only shop manual!!!

    Buzz ~
  • Is there a way to remove the windshield wipers for replacement. Just the rubber part not the entire arm. I have done my other cars in the past but I can't seem to remove the original wipers for replacement in my Santa Fe? The clip or holder seems to be tight.
  • Many thanks Steve
  • Many thanks gojuiceguy
  • I have a 2002 Santa Fe 4 cyl engine.
    Prior to my 100 mile warranty full warranty under a lawsuit expired I began feeling problems when at a stop or when driving and accelerating that there was no power, it would lurch or just appear like nothing was happening and then it would lurch forward and gear in. I was told by dealer if i cant replicate the problem and no check engine lights come on there is nothing they can do.
    NOW THE STORY BEGINS::
    Late March 2007 107K?? miles I am under a 10y/100K & powertrain 12yr/120K mile warranty due to a lawsuit. I brought it in and same problem and it was noticeable and codes went off and they replaced my transmission under warranty. Some errors in installation and missing parts we decided to take to another dealer. they finished the work correctly and it still displayed the same issues. so again in MID June 2007, codes fly and another transmission has installed, but the problems are resolved for a short time and then it begins again except i take it in and i am being told its how i drive.... wrong.... AUgust same thing occurs the next day i got my car back from taking it in time and time again except now im driving and it drives 35 and then shuts down in middle of traffic i was told i should get a new battery ...... i did fast and it ran fine for a few weeks with very little noticable but i couldnt replicate it enough to prove to mechanic at the dealer. finally again dec 2007 they had my car for nearly a month i replaced the following parts that may relate to the concer:
    2 crankshaft sensors seal
    trans mission service timing belt not sure when but maybe 30K miles before this problem was first taken into the shop in March 2007.
    currently in december 2007:
    crankshaft sensor again due to seal leak and seal
    balance belt
    timing belt
    o2 sensor
    electronic control module (ECM)
    catalytic converter
    coil and spark plugs

    i get car back and bolts loose and I took it back and they fixed bolt but i told them it was shifting funny
    for 3 weeks it slowly began to come back again and this time worse then ever...safety issue too
    im driving from stop or accelerate or drive to accelerate and it wont shift and it ramps up to 5000 - 6000 RPM so i back off pedal and sometimes it shifts and sometimes it doesnt. feels stuck at 65 and wont shift gears....then goes to 30 shakes and loud ping and rattle noise from the engine or under the front of the car. i cant speed up it shakes and feel wont shift and wants to cut out. I have this same problem and now it is worse then starting in March 2007 when was able to replicate it.
    THE SAFETY ISSUE is I was on highway just last saturday and driving 65 with semi behind me and it shuts down to 30 MPH shakes almost stops semi almost ran me over as i try to pull off road.

    Finally, the same codes in dec2007 popped up as it does now..... P0320 /P0300
    now it is back in shop and their techline suggested a fuel reglator on the gas line. i wait 3 days for a part and today they say it isnt it thats wrong.... now they are saying a crankshaft blade.
    PS : mass airflow was checked and no codes are coming up on the transmission. before codes did pop up and now the codes are P0320 & P0300
    input and output speed sensors would pull codes.

    I AM TRYING TO GET MANY HEADS TOGETHER TO FIGURE OUT THIS PROBLEM OUT CAUSE HYUNDAI CANT FIGURE IT OUT AND THIS CAR IS COMPLETELY UNSAFE TO DRIVE.
    PLEASE RESPOND IMMEDIATELY IT IS STILL IN THE SHOP.
  • perelsonperelson Posts: 2
    The clutch is slipping badly on my my 2003 Sata Fe with 5 speed manual transmission. The vehicle has 46,000 miles. Is there a way to get Hyundai to cover this repair? Is this normal wear & tear? It seems to me the clutch shoulkd last for more than 46,000 miles. If it is not covered by warranty, is it better to get the clutch repair done at a clutch specialty shop or at the Hyundai dealer?
    Is there a better clutch replacement available in the "after market" than the one that Hyndai will use?
    I've read a post from 1/7/08 on car survey.org that stated that the clutch on his 2004 Santa Fe went out at 43,000 and he was given a new clutch by Hyndai, free of charge beacuse the original clutch was defective: is was a "double mass flywheel" which caused overheating and accelerated clutch wear.
    Does anyone have any information about this "defect"?
  • perelsonperelson Posts: 2
    My 2003 Santa Fe with 46,000 miles has a badly slipping clutch.
    I could not locate the TSB you refer to in your 7/11/06 post. Does anyone have any information about this TSB? Anyone have information about how to get Hyundai to pay for the clutch repair?
    If Hyundai won't pay for the clutch repair, is it better to get the repair done at an independent clutch specialty shop than at Hyundai?
  • boltguyboltguy Posts: 94
    try this link. If it doesn't work, you may have to create an account at hmaservice.com first.

    03 santa fe clutch tsb
  • jtisonjtison Posts: 2
    I'm not a professional (mechanic). I am, however, in the middle of an automatic transaxle course. So you're entitled to take what I say with a grain of salt.

    Just because your ECU isn't throwing codes doesn't mean there's nothing wrong with your tranny. All the ECU can report is what the various sensors report. If your ATF is cooked, at improper level, not to spec, dirty, or heavily oxidized, your clutches and brake bands aren't going to work properly -- this kind of failure often causes the kinds of symptoms you're describing. I know because this has happened to me with other vehicles I've owned. Exact same symptoms, too.

    If a so-called professional looks at your tranny and says there's nothing wrong with it because it's not throwing codes, I'd find another mechanic; particularly if it's out of warranty and I'm paying the bills. And as much as I hate to remind you, P0300 & P0320 have got zippo to do with a tranny.

    I'm looking at the 2002 shop manual, and it sounds to me (from what you describe) that you've got a clutch slipping ... I'd need more information about what "drive to accelerate" means before I'd take a guess at which one.

    I'm also guessing that the pinging and shuddering is happening because of an overrev condition. That's to be expected downshifting from 4th at freeway speed. I just wouldn't make that a habit, if you catch my drift (see if you can park your SF for a while).

    I think you have a faulty transmission on the inside. It probably needs a rebuild. If you look through the list of transmission-related DTCs, you won't find anything for clutch or brake slippage -- they'll catch certain solenoid & valve failures, but not everything that can possibly go wrong. I'd start with a full line pressure test ... you might get a better clue as to *which* clutch/brake/servo ... but it doesn't really matter. You're headed for a rebuilt transmission if my guesses are all right.

    Unfortunately, the only way to actually prove any of this is with a rebuild; but a line pressure test will at least point the way. You're going to have to find a sympathetic transmission specialist to back you up, I'm afraid.

    Has the dealership tried swapping out the ECU yet? They might as well. Something doesn't make sense about the codes it is and has been throwing ... tranny slips and the ECU reports cylinder misfires ... yeah, right. Somehow, I think this problem is over their heads.

    Best of luck.

    --Jim--
  • dc_califdc_calif Posts: 2
    I currently have 36k miles on the car ahd have had an issue since I got it. At times it shifts up oddly or shifts noisy. What I'm more concenred with is that someitmes I come to a stop and the car stops but it keeps pushing forward and the rpm's drop and the car nearly stalls. Its as if the car never comes out of gear into natural to stop. The dealer says that there are no codes and they can't reproduce it.

    Anyone else having this problem?

    Thanks in advance.
  • somedai1somedai1 Posts: 416
    sounds like problems that a few of us have had - turned out to be throttle body or throttle sensor or o2 sensor problem - but it's strange you have had no svc eng light come on... what kind of driving do you do? what kind of gas? been doing the regular scheduled maintenance?
Sign In or Register to comment.