Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Hyundai Santa Fe Maintenance and Repair (2006 and earlier)

18889909193

Comments

  • I have a '01 Santa fe, w/ 17620 miles, 2 weeks ago I had the alternator & battery replaced.Today while I was out I noticed that rear light were on & the switch was off.When I got home, I checked I have blinkers, tail lights, backup lights, but no brake lights when the pedal is depressed.If I pull the fuse the lights go off, but I still have no brake lights.Checked all the appropriate fuses and none are blown.Husband is checking light bulbs but any other suggestions.
  • i have a 2003 sante fe v6 with 108000 mi. it ran fine this morning but will not start this afternoon. turns over but that is it
  • doderdoder Posts: 1
    My 04 SF 3.5 has been battling this for over 2 years. At first we thought it was tire balancing, old tires, etc. Nope. I took it in yesterday to dealership and was told it is a problem with the "transfer case" that it is failing. Not good news obviously as that can kill the whole tranny at total failure.

    I will say this, I will never buy another SF or Hyundai again due to all the problems we have had with this vehicle and we are the only owners aside from the dealership that we got it from.

    Good luck.
  • If you have a 2.7 engine, I'd check the CPS(crankcase position sensor). This sensor is located just above the starter. It is a common problem with the santa fe and will cause the car to jerk/stutter/completely shut off/ and stall at stop lights. What happens is that over time the rubber cable that holds three wires coming out of the sensor, breaks down-falls apart- and the insulation also cracks and breaks down leaving three bare wires dangling as you drive along. At some point(totally random) some bump in the road will short out two of the wires and your car will stop working(sometimes just for a short period). Most of the time you can restart your car and then drive off. If it becomes bad enough, the shorting wires will totally kill your car. To replace the CPS($75) from the dealership- take off skid plate, Take off shield cover of starter(by taking off two bolts and a nut, rotate 90 degrees and remove towards driver side). Sight from around the oil filter back towards and above the starter. That is where the CPS is located. It can be removed by using a 10mm 1/4 inch drive socket with small extension. You can't use a 3/8 inch drive because the clearance is too tight. Only one bolt holds it in. Will take a couple hours to replace because it is very awkward to get to on your back in a driveway. Fixed my 03 santa fe that had this problem for over five years last month. Couldn't believe how badly the cable and wiring had deteriorated just past the sensor(maybe an inch and a half of bare wires). Looks to me like it was badly designed as far as the materials used to make the sensor. Anyone that hasn't changed out this sensor after 75k miles should do it asap. Could save you a tow and a ton of money.
  • hmarksterhmarkster Posts: 4
    edited December 2011
    This is also a problem with a faulty EGR valve (Exhaust Gas Recirculation valve). I'm having to replace mine now. Although I don't have the problems you are having, my research on the EGR valve has shown that your symptoms can be caused by this valve. Check with your dealership as there is a Technical Service Bulletin (10020878 / 0636006) for this part issued in December of 2006. My problem is that it is leaking and causing the Check Engine light to come on. Over time, if not repaired, it will cause stalling when you stop the car and poor acceleration.
  • I have had a 2002 and now have a 2004 Santa Fe..in regards to your back seat, make sure your gray straps are always visible..pull them forward so your seats can be pulled flat down on both sides..next take off the head rests which has a small slide that you push and at the same time slide the head rests up..on the sides of the back rest is a lever that you push or slide at the same time to push the seats down..they will be somewhat flat, just make sure there is nothing in the seats or the floor to harbor your quest...also I have noticed on my 2004, radio it will play the radio but not show..just gently tap the screen and it will pop up..do not now why it is doing it but having it checked with dealer soon..hope this helps..have my own questions on edmonds regarding my gas tank...seems to be leaking..any one else with problems please post...any help would be greatly apprciated!
  • When one tries to register for Hyundai's service site (www.hmaservice.com), they ask you to state what vehicle you have. For the Santa Fe there are only two choices:

    Santa Fe CM
    Santa Fe SM

    There are three levels of trim on a Santa Fe so that can't be it. Maybe it is 4 cylinder or 6 cylinder?

    Anyone know which i should choose for my 4 cylinder GLS?
  • I just noticed that the left side of my 2004 Santa Fe GLS 3.5 has gone dark. The parking, tail and both side marker lights went out. The turn signals and flashers still work. Has anyone else experienced this.
  • bow45bow45 Posts: 21
    Hi all,

    I own a 2003 Santa Fe LX V6 3.5 AWD which has a leaky automatic transmission cooler in front of the radiator. Does anyone know how much it would cost to replace it?

    Thanks in advance.
  • Did you ever find the problem, mine is having the same problem with the 2.7L 4WD Auto.
  • My 2005 Hyundai Santa Fe drivers door side lamp is out. A service place (not a Hyundai dealer) I had taken my car to for other work looked at it and told me the door panel needed to be removed to research the problem as it was not the bulb, possibly a socket issue. Is this something I can do myself? Can anyone guide me as to how to remove the door panel? has anyone else had this problem and what was the solution?
    Thanks in advance...
  • bgass1329bgass1329 Posts: 1
    edited March 2012
    I had the same issues with my 2002 Hyundai Sante Fe with filling up my car with gas. Everytime I would fill the car up with gas it would not start right away After a few times it then would start up with no problem afterwards I went online and did some research on this problem and I was told the same thing to that it was the purge valve which cost around $250.00 and most of this price is the labor cost the part is cheap from my research I did. I also have a problem where when Im driving my Hyundai Santa fe every once in awhile when I accelerate my car jolts like my transmission is slipping. Do the car stalling to start up when gas is put in the car sound like a purge valve problem?
  • quentinsquentins Posts: 2
    I had replaced the MAF about six months ago with a Bosch because it was giving me the p0102 maf code. It turned out is was a bad hose and it fixed the problem. Now I am getting P0102 Mass Flow Sensor-VAK VOLUMN PER FLOW SENSOR CORCUIT LOW= 2 OF 2 P0102 (pd) MAF FLOW SENSOR CIRCUIT BAD. Well the first thing I did was check the hoses, cleaned the MAF and reset the battery. It ran go for about twenty minutes but idles very rough but accelerates OK. I am at my wits end andybody know what is going on here. I need to fix this as my son is heading off to college in the fall and I dont want him to deal with these types of preoblems.-Thank You
  • quentinsquentins Posts: 2
    I have been getting PO172 and 1073. I purchased a MAF and reset the computer. It then ran good for about an hour but rough. I then cleaned the throttle bottle and put back together. It starting running really bad and drove it for about an hour to clean it up but still almost stalls. The acceleration if better though. I then got code po401. The first thing I thought about was the egr valve. Well this is what the strange thing that is happening. When I take the middle hose of the 3 hoses off the throttle body the one that is green the car starts running perfect. It doesnt shake and acclerates really good. If I stick the hose back on it starts shaking again. Would that be a bad egr valve and what is the the chance of that going bad at the same time. Also the egr is only 8 months old. So i think by buying the MAF that solved that problem but did it create another problem. Also cleaning the throttle body cause this to? I could replace the egr but I really dont think there is any thing wrong with it and could it be something else?.-Thank You for Your Help!
  • falmar1falmar1 Posts: 12
    Don't know if you got the problem fixed by now but I had almost the same thing happen. I had about an inch of water sloushing around the housing of the wire harness which mounts the lights which in turn caused a short circuit. After I removed the water, all is well now
  • Not sure what you call it but when you put something in the rear of the Santa Fe you pull a cover to hide what is in the rear of the automobile. When I pulled it out to cover an item it was not working. Well I took it apart and tried to rewind the cover like a window shade but it now appears to unfixable. Any suggestions where to look and buy another at a low cost?
  • I broke mine a couple of years ago and went to the Hyundai dealership to replace it. It cost me $300. They suggested checking places like craig's list for these type parts. You can find almost anything on craig's list, I would try there first and see what you can come up with. Maybe you'll get some other ideas from that.
  • Same here; I have a 2002 Santa Fe that started locking itself up every single time we'd open or close the doors and sometimes while driving and it started about 4 years ago. Also, the two front windows stopped working...the electrical system also messes with the radio, etc. Not much fun I have to say!
  • I seem to recall that these were discontinued a couple years ago, but you can order one much cheaper online and the old ones (2008 or 2009) will still fit. I order one from Parts.com. Search the Hyundai accessory catalog for "cargo cover" be careful what color you are ordering, they come in beige or black only.
  • We have been trying to pin a problem down for a while now. The vehicle is a 2006 Santa Fe 2.7L FWD. The problem is intermittent and has only posted an error code once. What happens is that you will be driving and the engine sometimes will act like it is choking out. On 3 occasions it actually did die out completely while driving along the interstate. I would cry bad gas, but we have eliminated that by trial and error. The only gas that we are sure of being a problem is BP. We put BP in this vehicle and we may as well get the walking shoes on. Luckily the 3 times it did die out, it did eventually start back up eventually. Once we did get an error code when the check engine light came on. We took it to the dealership and they plugged their scanner up to it. They got a code saying there was a faulty O2 sensor. They cleared the code and said they would replace it. And they updated to code on something, I think the ECM. Unfortunately they were out of stock on the O2 sensor and said they would call once they got one/some in. A couple days later we got a call and they said the district service rep had declined to replace the O2 sensor under warranty. They said drive it and see if the problem came back. Well, it did except for the check engine light and they did nothing. Now the vehicle is outside the bumper to bumper warranty and the problem still flares up from time to time. And nobody seems to have an idea what to do to fix it. No code = no clue. We have had a few mechanics say that a faulty O2 sensor might cause the car to run a little rough. But they said it would';t cause it to stall out. To me it seems pretty obvious that it has something to do with the fuel mixture. Why else would BP gas always cause the problem? Anyone have a clue on what we can do to get this fixed? I don't want to take stabs in the dark since it is now out of pocket with the warranty expired.
Sign In or Register to comment.