Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





2002 Highlander turn signals flashing, relay chatter in engine compartment, and tachometer broke

budhbudh Posts: 109
edited April 6 in Toyota

A few days ago I went to take my 2002 Highlander AWD 3.0L V6 with 210,000 miles from work to get some lunch and found the doors locked and the left and right turn signals front and rear were both flashing for no reason. I unlocked the Highlander and tried to turn off the emergency flashers but the lights kept flashing and the turn signal stalk was in normal position. But when I started the Highlander, the lights stopped flashing and everything was fine! When I parked the car, as soon as I turned the vehicle off (key still in RUN), the lights began flashing again and stayed flashing when I took the key out of the ignition. Several hours later after the vehicle was stopped, the lights were still flashing but now flashing erratically, and when I lifted the hood I could hear what sounded like unusual relay chatter near the fuses on the left front of the engine compartment.

But when I started up the Highlander, again, as before, everything returned to normal.

Another item I noticed was that my tachometer is no longer working and I am sure it was working the day before this all started.

Any idea what is going on? For now, my Highlander has it's battery disconnected!

Comments

  • budhbudh Posts: 109

    The battery was disconnected for three days, and when re-connected, the flashers no longer acted abnormally and the tachometer was working again. However, the VSC and ABS lights were both flashing quickly on the dashboard. The vehicle appeared to be running fine.

Sign In or Register to comment.