Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Sequoia Maintenance and Repair

17071737576106

Comments

  • ggesqggesq Posts: 701
    I think you might have misunderstood my original post. I was willing to do the air filter replacement by myself.
    The oil and spark plugs- I will leave to my dealer.

    My main concern/question is- to the forum- other than the oil/air filter/spark plugs----is there any other service that I should get done at 30k miles i.e. engine coolant and/or transmission fluid or something else I am missing???
  • rbestrbest Posts: 1
    The rear door of my 2003 Sequoia will not open. I had it open then closed it, when I went to open it again, it would not open. I hear the unlock sound, but cannot open from the latch. The rear window still works. Has anyone else had this problem?
  • kotsykotsy Posts: 1
    Any one have a sound like your exhaust is leaking from the drivers side firewall? It drives me nuts. The dealer thinks it may be a cracked manifold. My mechanic at a private shop has a post that says it may be the timing chain??? Any thoughts???
    Chris
  • harboharbo Posts: 136
    Sorry for the late response.

    The TSB on the work order is BR005 - 02. TSB replace calipers bearings backing palt.
  • dylandondylandon Posts: 3
    The V8 Sequoia has a timing belt...check the oil level? may have to remove exhaust shield to confirm cracked manifold.
  • dylandondylandon Posts: 3
    Depend on what enviroments you are in, the car should have a major service at 30K interval.
    Oil change
    Air Filter
    Transmission Fluids drain & refill (Type IV not Dexron III)
    Rear Differential drain & refill (GL-5 gear oil)
    Coolant flush or drain & refill
    Wiper inserts
    Spark plugs (remove and inspect the white porcelain area, if it has brown/rust marks--need to replace, the seal is worn)
  • dixiedixie Posts: 3
    I plan on purchasing a sequoia sometime in the future and my husband wants to order it. I would like some of ya'll's sage advice on the process. Thank you.
  • We get a vibration in the front of our 2006 Sequoia. They first replaced the back wheel bearings because of a recent technical bulletin. It still was there. They then did the front. Still there. It's not a loud thumping, but more of a light vibration ... all between 37 & 43. I've seen differential mentioned elsewhere. Any other ideas?
  • Were you getting a vibration feeling in the front? We get one at 37-43 mph. They have replaced both the front & back wheel bearings and rear axle. Still hear it. They are ready to give up. They said it's normal differential noise. We are in Maryland.
  • harboharbo Posts: 136
    Ya'll gonna use it in the sunshine of dixie or snow & ice & junk like that? When you go on line you can spec out the vehicle according to your wants and pocket-book.

    2WD is less expensive to buy and maintain and has better mileage. 4WD obviously gets you through the junky stuff.
  • helsinkihelsinki Posts: 1
    Hello All,
    Three weeks ago I ran off the road in my Sequoia into about 2 feet of snow. It was already in 4wd so I tried to back out, no dice, tires just kept spinning. I put it in neutral, took off vsc and put it in low and waited for the idiot indicator to stop blinking. Once it stopped blinking I continued to try to get out of the snow bank. The car was at about a 30 degree angle, everytime I turned the steering wheel a bit I heard a loud grinding noise, which I thought was the car sliding further into the roadside ditch. After about 15 minutes of trying to get unstuck, I gave up and called a tow truck. Th truck came and pulled me out. I took the car for a test drive and there was something definitely wrong, the grinding noise was getting worse by the second. I pulled over and checked under the car and saw fluid leaking from the front transfer case, definitely not good. The wrecker took the car to a local dealer who then took the front axle apart. The front axle is toast, inside the transfer case is nothing but broken teeth and mashed metal, I will try to post pictures sometime.

    Now the fun part. The dealer is telling me that this is not covered under warranty because it is "operator error". I cannot for the life of me figure out what error I made, could it be that I did not push the button hard enough, or wait long enough after the light stopped blinking.

    I love my Sequoia, and this is my second Toyota, but I will be damned if I am going to eat the cost of this repair. If I am forces to eat the cost, I will never own a Toyota again.

    BTW, I moved from NY to Finland, it is the local dealer in Finland who is telling me that the repairs are not covered.

    Looking for any advice, stories about front axel problems, etc.. that can help me get this squared away.

    Scott
  • dixiedixie Posts: 3
    We live in Cheyenne, WY, so snow and ice. I apologize for not mentioning that before. I plan on getting 4 wheel or all wheel drive.
  • zyangzyang Posts: 1
    I have the same problem as you, same year and model. And I though I was the only one having this problem. I've even show the pictures with time and date. I've been asking the dealership and they told me that the sending unit inside the gas tank is malfunctioning. After $600.00 repair bill, the problem has re-occurred. Now I'm calling the Toyota 800-331-4331. I would recommend that you call Toyota at the number insteading of spending $600.00 repair bill that will not solve the problem.

    Now is wait and see what Toyota will do for me.
    Zachary Yang
  • lait2000lait2000 Posts: 33
    You need to bring your TOY back to whoever told you to spend $600 and tell them BS. They need to send their technician back for training. Your 2003 is fully covered by warranty and you don't have to spend a penny for this. Mine is also 2003 and I had to bring in 2 times to make this correction. This is a oil sending unit problem. and there is a new TSB just came out for a new part. More details, Please see my post number 1289 in this section. Good luck.
  • jwtjwt Posts: 2
    Thank you! I will check this out. The 'thumping' will occur anytime, any place & at any speed, get's louder & louder, sounds like something is going to blow up, I have to pull over & stop. We have very low mileage on 04, under 10k. jwt.
  • gaphgaph Posts: 3
    I should clarify my original posting. Yes, it is a vibration that the driver and passenger feel through the floor. It started about four months ago and has got worse. Some days it's worse than others.
  • jowenjowen Posts: 1
    Our Navigation screen in our '06 Sequoia no longer dims at night (It never really dimmed but rather the background went from white to black).

    There also used to be an option on the display menu to dim it manually but that option is no longer there. I am about ready to take this in to the dealer but thought I would try this route first.

    Any help is appreciated!
    :cry:
  • lvaughnrlvaughnr Posts: 2
    Hi everyone,
    I have a 02 SR5 Sequoia. The rear leather seats are extremely squeaky and drives me nuts. Does anyone have a similar problem and what was the solution?
    Thanks,
    Vaughn...
  • 5ofakind5ofakind Posts: 3
    Have you read your DVD Nav Owners Manual....it is pretty thorough....I suggest reading the entire booklet before taking to dealer.....I am sure it is just a setting
  • martyb6martyb6 Posts: 1
    I also have an '01 Sequoia with 71k miles. This past week the engine light came on and it stopped on me several times. I have taken care of it well, but they told me the entire transmission needs replacement @ $3800. It's just out of warranty, but I think its rediculous at 71k the trans would go! I had a 4Runner I drove til 185k with absolutely no trans problems. The engine made several hard shift bang noises before I asked them to look at, but found nothing. I'm absolutely beside myself this would happen so soon!
Sign In or Register to comment.