Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Sequoia Maintenance and Repair

17677798182106

Comments

  • my '05 4wd is getting severe tire wear on the outside edges of my new tires...

    alignment has been done by toyota
    balance has been done by toyota

    I saw a post on here suggesting the following alignment specs for an older sequoia:

    camber: +0.25 degrees
    caster: +2.75 degrees (4WD) or +3.00 degrees (2WD)
    total toe: +0.08 degrees

    do these specs hold true for the '05 model as well
  • does the ball joint recall effect the '05 sequoia as well?
  • The VSC light also came on my wife's 2003 Sequoia at around 30K mi. Before taking it to the dealer, I decided to have a look at the wheels and the sensors. It turns out that the wheel sensors are magnetized, especially on the rear wheels.
    When I took out the sensors from the wheel hubs, I noticed that there was an accumulation of rusted metal flakes built up on the magnets of the sensors. I cleaned the metal flakes off of the tips and reinstalled them. I had to reset the computer by disconnecting the negative terminal of battery. After I did thise, the VSC trac light stayed off.
    To me this seems to be a maintenance item as I expect that the rusted metal flakes will accumulate to some critical mass over time such that it'll trigger the VSC traction light to come on.

    Before you take it to a dealer, you might try cleaning off the megnetic tips of the sensors and see if it solves the problem for you.
  • This was a recall on ballbearings covered under warranty.
  • This also happened to me and oil gage did not work. replaced under Warranty some sensor part.
  • kumarkumar Posts: 22
    I called up my local toyota service department and asked how much it would cost for my 05 sequoia's 30K service. They gave me a price of $717 which will include all manufacturer's recommended services.

    Oh my gosh... :mad:

    Could any one tell me what you have paid for your 30K service? If possible would you please also tell me what are the line items that you have done for the 30K service?
    If I like to cherry pick the "must-have" items, what would those be?

    Thanks for your help! :)
  • I have been unable to find programming instructions for the remote for a 2002 Sequoia. Anyone help?
  • I had the same problem with my 2002 Sequoia SR5 with 45,000 miles. I took it to my Toyota dealer and was told that my VSC computer was dead and they could not pull any codes from the unit. They said it was going to cost about $2100 to replace the VSC computer and told them I was not going to pay it. I asked them for the telephone number to Toyota Customer relations and instead had me talk to the service manager. I explained to him that I have Toyota vehicles for their reputation of quality,reliability and have all my vehicles serviced at this dealership including oil changes. I also explained that the VSC problem seems to affect 01 and 02 Sequoias the same year models that had the TSB brake caliper/rotor upgrade and that it appeared to me that VSC software or computer was not updated to meet the demands of the newly installed brake upgrade.

    The service manager listened to my argument and said he would speak with the Toyota factory rep. I received a telephone call from the dealership that Toyota would repair the VSC computer for free. I am a loyal Toyota owner and the only other one I would consider would be Lexus.

    Kudos to Toyota and my dealer for doing the right thing and fixing my VSC computer problem. Do I think the VSC computer will fail again? I don't think so because I heard from other Sequoia owners that the VSC computer was updated for later models.

    I think the Sequoias are a fantastic vehicle and I will keep my Sequoia. I am a traffic officer and have investigated thousands of real world crashes. I picked the Sequoia because in my opinion it's one of the safest and probably the most reliable SUV on the road.

    By the way, there's a website that sells computer parts to all makes of vehicles. See http://www.ecudirect.com/index.asp
  • kumarkumar Posts: 22
    I own a Toyota SUV, V8 4.7L, and has mileage of 30K. I have routine oil change at 3,750 miles.

    The service center tells me that I should pay ~$310 :( , just to flush the engine and fuel system. They will also charge me the other regular 30K services for about $410.

    Do I need to do this kind of service? any recommendation?

    Thanks!
  • I have 103K on my 01 Sequoia 4wd and all 4 lights lit up and the truck went into a protective mode where it will limp along at about 1 mph. I had it towed to the dealer, but recall an incident a year or so ago, where it was the brake fluid level which caused the VSC and Trac lights to come on. Anyone know if this could also cause all the lights to come on.

    Any ideas on what could of triggered it. I pulled up to a stop sign went to pull out and no power to the power train, yikes. The engine runs fine, all the gauges read normal, no leaks, no runs, no errors. It just won't go. Now someone said pulling the neg cable from the battery will reset it. Turning it off and back on did not.

    Unfortunately it is with the dealer and you know what that means, hmmmm, what is the most expensive thing possible - gee, that's exactly what your problem is. We'll have to rebuild your entire truck for a paultry $60K.

    So any ideas are welcome on what I can test before relinguishing to the dealer.
  • dgutdgut Posts: 12
    Hi,

    My Sequoia had 107,000 when this happened to me. Only I was going 70 mph on an interstate when the car decided to put on the brakes and cut power to the engine. It was diagnosed by the dealer as a YAW rate sensor and a Steering angle sensor. We traded it in. Good Luck
  • I would recommend that you take out the sensors on the rear wheels and clean off the tips of the sensors. The tips of the sensors are magnetic so, on mine, it had accumulated rusted metal flakes on the tips which interfered with the sensor's function.
  • My 01 SR5 4WD with 80,000 had four, sometimes five lights on for a couple days. It didn't go into protective mode, though. Nor have some others I have heard of. Of course there are the ones like yours that have disabled the truck.

    Mine turned out to be the skid control ECU, according to the dealer. The part was $1800, with a couple hours labor to install. No recurring problems after a week...time will tell, though.

    What really would have been interesting is if you had disconnected the battery cable for a while. Wish I had known to try that with mine first, before I took it in. I have heard reports on another forum of that working just fine (!!!???)

    Don't know anything to tell you, except ask the dealer if he thinks Toyota could help defray the cost of the part, if it turns out to be expensive, like mine.
  • mus1mus1 Posts: 3
    I have a ’01 sequoia SR5 2-wheel drive, the suv does not respond when i step on the accelerator pedal, I have to step on the accelerator pedal hard before the car can move which is unusual. I changed the throttle position sensor, MAF sensor, fuel filter and spark plugs but the problem still persist .the check light , TRAC and VSC are on .

    I used a scan tool to check for codes but there is no fault code returned. the VSC, TRAC and Check light is still on. Any ideas
  • Anyone ever notice the motor sounding like a diesel motor when it first starts? Usually goes away after the motor warms.
  • Anybody had to replace a driver or passenger side mirror? Looks like the door panel has to be removed. Any tips would be appreciated.
  • dadof6dadof6 Posts: 61
    The exhaust manifolds give a ticking noise when cold after they have some age/miles on them. New manifolds will cure it but will set you back a good $1000. Noise is not harmful or a safety issue.
  • dadof6dadof6 Posts: 61
    You should have a "scheduled maintence guide" as part of your owners manuel packet,look for the page labeled 30,000 mile service then compare it to what your service center wants to do.
  • dadof6dadof6 Posts: 61
    Sludge comes from lack of oil changes--sounds like you need a new service center!
Sign In or Register to comment.