Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





abs,traction control lights. Pontiac Grand Prix.

steve572steve572 Posts: 2
edited August 31 in Pontiac

We own two of these cars and they have treated us well for service up till this issue showed up. After reviewing the comments from this forum and having my car diagnosed at the dealership I decided to go ahead and replace the simple wiring harnesses mentioned here and my car is back to normal. The job took about two hours for both sides and we soldered the splice joints then covered them with shrink tube. The diagnostic at the dealer showed a right front circuit code in more than one instance of having it checked. Of course it doesn't tell you that a wire is broke, but it is a clue. In my case the lights came on almost immediately upon tires rolling when the wire finally broke, or broken ends couldn't touch each other. My car had all of the issues mentioned here with the lights and pulsing brakes. I paid $128.00 for both harnesses, complete, just splice them in, from a reputable GM Dealer. I'm happy to have the best car I've ever owned back to normal and now know to look for this if the other one has this issue. The car I drive has 120,000 plus a little and the other is @ around 90,000. I should also mention that when disassembling the old harness it had moisture, sand and salt inside the protective casing. 4 inches from the connector end is where it broke. Right side of car. Thanks for the talk here and good luck to those of you with this issue. Steve572, in Michigan

Comments

  • steverstever Viva Las CrucesPosts: 40,837

    "In Michigan" - man, that's a difficult state for cars. I've been in the UP for 3 winters now and my two old cars were rust free after a decade in the high desert around Boise. It didn't take long for the rust to start up. Just sold them and will be moving to NM soon. :smile:

    Good info - thanks for the post.

    Moderator
    Need help navigating? stever@edmunds.com - or send a private message by clicking on my name.

  • Appreciate the info.... having the same issue and it is getting progressively worse.

  • rondanydrondanyd Posts: 1

    This is precisely the car that I just bought. Mine has 73000 on it. If the same problem comes up at least I'll know what to do about it. Thanks!

  • gmcustsvcgmcustsvc Posts: 4,105

    @rondanyd said: This is precisely the car that I just bought. Mine has 73000 on it. If the same problem comes up at least I'll know what to do about it. Thanks!

    Sorry you're having trouble with your vehicle. I'm glad you were able to get information from fellow forum members toward resolving this. If any assistance is needed with regard to reaching out to your dealership, we're happy to help. You are welcome to send an email to socialmedia@gm.com attn:Andraya with your VIN, contact info, mileage and dealership name.

    Andraya GM Customer Care

Sign In or Register to comment.