Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





Toyota Highlander Maintenance and Repair

1243244246248249261

Comments

  • 2004 FWD 4-cylinder with about 98K on the odometer. Recently when I am driving with the heat on, I notice that the air blowing from the vents sometimes changes from hot to cool or lukewarm. The round heat-control know is in the red area, and I don't touch the knob. The knob itself feels normal when I turn it. I can get the heat back by turning it up all the way. The engine temprature gauge on the dashboard continues to read normal.

    Has anyone else had this experience? I'm going to ask my mechanic about it next time I have the oil changed, but I'd like to have some idea what is going on before I talk to him. Thanks.
  • mrgrldmrgrld Posts: 6
    Hey there, This is a common problem for Highlanders. I fixed mine within 30 mins. All you have to do is remove the panel. Once it is removed, you will see that the wire from the board is off. You need to solder it back on. It is very tricky but not hard if you have patience since it is very tiny. Google some more and you will see some people actually took pictures while fixing it. Good luck.
  • car_dcar_d Posts: 2
    Take a look at this link. This guys has details including pictures on how to fix it. I followed these steps and fixed earlier this summer

    http://www.devalcourt.com/2010/03/fixing-2004-toyota-highlander-ac-and-heat-issu- e/
  • mikefm58mikefm58 Posts: 2,882
    Your problem may not be as severe as needing wires soldered as mentioned in the previous posts. Try pulling off the temp. control knob, it pulls straight out. Check the nut that tightens down the bolt you should see, and if it's loose, simply tighten it down with your fingers. Replace the temp. control knob, wiggle it to make sure it's tight.

    If that fixes the problem, I would redo the nut you tightened and use some lock tight so it doesn't loosen again.

    MY 04 HL has the same issue and that's what I've been doing.
  • has anyone taken there highlander in for the recent recall? about how long dose it take, do they replace the brake fluid or try and sell u a flush, my 2004 just turned 48000 last night not seeing any leaks and fluid is still on full should i pay for a brake flush or let it keep on going? one more thing what about batteries, car is 7 yrs old its a panasonic and still startinl strong in these teen and 20 degree mornings shoukd i consider replacing it soon
    I don't have the smarts when it comes to these things any advise. great big thanks to all
  • I took ours in for the recall, took a few hours, becuase it was te first one they did...Our battery is still the one from 05 when we bought the vehicle and we live were it gets -30...We will be replacing soon, just becuase it's time to and we don't want to push it...
  • Choochooman, I don't know the details on your battery, but in my years of experience any car battery over five years is prone to failing unexpectedly, frequently at a most inconvenient time.

    My advice: Replace your battery now and forego the headache that a dead battery in mid winter will bring. It's hard to do since your current battery "seems to be fine but it will be a wise move.
  • Last summer, the Panasonic battery in my 2001 Highlander was beginning to not hold a charge very long, after nine years, so I replaced it. I would have bought another Panasonic battery if I could have found one.
  • Thanks to everyone who replied. I tightened the nut and drove about 8 miles running errands this afternoon. Only time will tell, but it seems like that took care of the problem. Odd thing is that the knob felt normal before, but it does feel tighter now.

    BTW, for future reference (which I hopefully won't need) I printed a copy of the article with pictures on how to solder the wires back. That's an amazing piece of work!
  • If you have white Panasonic battery it might last you another couple of years. Any auto-parts store can get it tested and tell you if it's time to replace it.
  • I have a 2010 Highlander Limited. When I come to a stop on an incline the traction/anti slip light comes on. I was told this is normal, but it happened to me while I was stopped in traffic on a normal grade. I usually shift the car in Neutral while waiting in traffic. All of a sudden the engine raced abnormally fast and I was affraid to shift into drive. I through it into park with my foot firmly on the brake and it went back to normal. Can anyone give me insight as to what may have caused this problem. Could this be related to the abnormal acceleration problem experienced by Toyota in the last year or so ?
  • With it under warranty, I would take it in and let them run a diaganosis on it and check codes to make sure they are all uptodate...I have a 2005 and it has cut off totally while driving, they never found out why, thought it could have been tied to auto light usage...those weird anamolies could really be a number of things...stay safe
  • wwestwwest Posts: 10,706
    "..I usually shift..."

    Then you're one in ~ten million.....

    You may have just happened to shift into neutral at the very same time the A/C compressor clutch was energized. The engine/transaxle control ECU has learned, over time, just how much to additionally crack open the throttle to accomodate, compensate for, the additional load of the A/C compressor. You threw a monkey wrench into that calculation by "unloading" the engine from the driveline at the same time the compressor kicked in.
  • Thanks for ur feedback. That may caused this problem. I am taking it to the dealer as a precaution and will ask about that possibility. That statistic about shifting into Neutral sounds unbelievable. I thought of it as an added safety measure in case someone walks in front of the car it gives you a little more time to react.
  • We are taking our 2002 Highlander, V-6, with 102,000 miles on a 3500 mile trip in March. I have never had the timing belt replaced. I did have to have the engine replaced after 54,000 miles as it was leaking oil badly, but since that, a great vehicle. I just don't want to break down on Route 95. I understand if I have the timing belt replaced, it is a good idea to go ahead and spend the extra $$$ to have the water pump replaced also?

    Any recommendations, pro or con, and what would be a rough estimate for that work to be done...something in the $ 400 - $ 600 range ?????

    Last big trip we took, the front brakes went and I had to spend $ 600 at a shop out of town to have all new front brakes....on vacation, I don't want that headache again.

    Thanks for any ideas anyone has....I am a car illiterate and will freely admit it.
  • kyfdx@Edmundskyfdx@Edmunds Posts: 25,906
    Did you get a new engine at 54K miles? If so, then that engine only has 48K miles on the timing belt....

    Moderator - Prices Paid, Lease Questions, SUVs

  • I paid about $630 for TB and WP replacement at a Toyota dealer in Pittsburgh@ 109K miles Both should be replaced. They sometimes have coupons and my dealer had a free loaner car. I now have 133K miles and the vehicle is whisper quiet. It is an 03

    Hope this helps
  • I just spoke to the dealership. The short block was replaced, but the heads were not changed. They received the parts order for that repair, and the timing belt WAS NOT replaced. To do it now, it would be $ 500 for the belt alone and another $ 300 for the water pump...not including tax. So would be about $ 865 for the whole thing. One responder got the whole thing done for much less, so I'll have to shop around.
  • mikefm58mikefm58 Posts: 2,882
    I can't say for the HL, but for my 99 Honda CRV, all the Honda shops have a "Timing belt special" where they replace the timing belt, water pump, all the accessory belts, and a free rental car for the day for a set price. The CRV cost me $600+.

    I'd say call all the Toyota shops in your area and ask if they have a "Timing belt special" that includes the items I mentioned. The price for the water pump seems high, ask him if that includes labor and how much he's charging for that. It should be zero as they have to take the water pump off to do the timing belt anyway.
  • wwestwwest Posts: 10,706
    I have an aftermarket shop that I trust that has done our belt+water pump for under $500.
Sign In or Register to comment.