Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!





GMC Envoy Owners Meet the Members

1235

Comments

  • wildernmwildernm Posts: 8
    I've noticed that GMC vehicles, specifically Envoys, experience electrical problems and none of the dealerships are able to figure out the electrical gremlins. I had two Envoys and both of them experienced electrical problems and the dealership couldn't figure out how to fix them. All I can recommend is to keep all of your service records and document all of the conversations you have with the dealership, GM, etc. regarding the repairs of your vehicle. It sounds like you may have passed the time for use your State's Lemon Law, but you'll want to check. If you aren't able to take advantage of the Lemon Law, you can try and file a claim against GM. If you try and do this on your own, be prepared for GM to stall you (always coming up with excuses on why they can't settle your claim). The only way I settled my claim was to hire an attorney to settle my claim and he took his fees out of the settlement amount. Bottom line, the only way to fix your problem is to get out of the vehicle. I always felt that this was GM's problem and they need to fix it, but they failed/refused to do so. I'm really disappointed about GM's failure to correct the problem. They thought by giving me an extended warranty, free of charge, that would solve the problem. I was tired of paying a car note each month to drive rental cars so my Envoy could sit in the shop. The dealership even had a difficult time to get GM to respond to them. I fortunately had a very good dealership, but they sell a defective product. I really like my Envoy, but was so frustrated with all of the problems, I actually had my own parking spot at the dealership since I was there so often. Remember to keep to all of your records so you can take legal action against GM. Good luck! Hopefully you'll be able to get enough from your settlement to cover your negative equity or give you a good down payment on a new vehicle.
  • afforteafforte Posts: 5
    I am having the exact same key stuck in the ignition problem, right now myself. We've had to have it towed to a dealership today. The battery went dead, we jumped it and it started, but the next day it went dead again and this symptom happened. Originally I thought it was some type of kill switch with the security system that disenabled it, because of the battery. We bought and installed a new battery and master fuse, but to no avail. It won't start, but will turn all the way toward the dash, but will not engage the starter; it actually kills the power. It will not turn backward to the auxiliary/accessory position to remove the key. Has anyone else had this problem? How is/was it corrected? How much? My wife bought this car and is totally dissatisfied, based on the constant breakdowns, problems, recalls, repairs, items not covered on the warranty and bad dealer service.
  • nanabnanab Posts: 1
    Hi, I'm new to forums (this is the first time I have ever contacted anyone so if I do something or say something wrong, please let me know) My service engine light came on a while ago, I asked onstar to run a diagnostic on it and they told me to check my gas cap, there seems to be a vapor leak. After I got home I opened the gas cap, later I restarted my 2004 XUV but the light stayed on, (I only drive back and forth to work about 9 miles a day) I thought the light would go out, did not. Then my speedometer started showing I was going 90 mph, clearly I was only about 35. the speedometer has since completely stopped. (50260 miles on it) most put on vacationing in SC and driving back to Pa. Today, I took it to a service shop they put it one their diagnostic machine and told me I have some problems, I should take it to the dealer. My vehicle is out of warranty. The solenoid is not working and my speedometer stepper motor ? is not working. Any ideas of how much this is going to cost me? Anyone else have this kind of problem?
  • halloydhalloyd Posts: 1
    Jillianne- Do you have, or does anyone have, the recall info on the fuel guage electrical issue @ GMC? Thanks.
  • wildernmwildernm Posts: 8
    I haven't had a recall for that.
  • I don’t have the recall info, no......I just know that mine went out and they fixed it. Apparently they were already aware of the recall...they seemed to know exactly what was wrong with the vehicle (kinda makes me mad...the whole thing could have been avoided if they would have fixed it or let me know when GMC found out.) I have a 2006 SLT Envoy XL and I am guessing the recall was on all of those at least. I am sure if you were to call your dealership and ask them if it applies to your vehicle they should know. I am sorry I could not tell you more...I am not familiar with vehicle info...I just know the basics and what is "obvious". The signs if it happening were that my gas gauge was not accurate. When I started it one day it said I had gas, as I drove my gas gauge sunk down to empty within a min. After getting gas and filling the tank the vehicle tried to reset the gas gauge and it did not work so my check engine light came on. That’s when I knew something was really wrong.
  • dbertaindbertain Posts: 1
    Hi,
    My 2003 Envoy jumps constantly from 4th to 5th(overdrive) at speeds mostly between 63-68 MPH (which is how fast I used to drive). My research points to the Transmission Control Module but it's confusing whether or not that unit has to be replaced completely or can be "re-programmed".

    Other articles point to a servo or even a loose electrical wire.

    I also notice a manual overdrive shift kit is available for purchase from the dealer and I'll resort to that if I have to. Hopefully I could install that myself.

    Aamco wants me to bring it in for their free diagnostic but I haven't had good luck with them as usually they take an R&R approach until it's finally fixed.

    Any suggestions would be appreciated.

    Thank you very much.
    -Doug
  • I have been having a problem for about 4 months now, where you put the key in turn it, everything comes on except it won't start, starter not clicking or anything.So they said get a new battery which we did and the problem continue. And then when it did start it would idle real rough and the check engine light would come sometimes, but if you turned it off and back on, if it start it would usually run fine and the check engine light would go out. Took to the dealership again and they said there was carbon build up and it just needed some maintenance, so paid for that like $300. 2 days later it would start again. When it doesn't start the the security light does NOT blink or come one and you cant even take it out of park. So the same problems are there still. Took it in again they said it needed a new throttle body??? I said are you kidding me, keep looking. So they replaced the PCM because there was a TSB on it. The whole time we have had a case file with GM headquarters because the local dealership is horrible. Saturday it started doing it really bad, you could usually get it to start in about 10minutes or so, but now it goes hours. So I called the dealership for them to get a tow truck and come pick it up and they said sure, I stated I wanted a courtesy vehicle and they said enterprise is closed, I said 13 miles away there is one open and they continued to say no. So called GM headquarters and they spoke with the dealership, still nothing. So I paid an online service to look up the owners name, address and telephone number and called him(he owns something like 8 new dealerships in the Charleston area) he seemed he was going to be helpful and stated he could not get me a loaner car till Monday. So my wife got the car started and took it in on Monday, they started accusing her of lieing and all this other stuff and would not give her a loaner car(we have 55k miles on our car warranty only ran out at like 45k when we started having this issue) because we are outside of warranty and they want to keep the vehicle for a week or 2 because they don't know what is wrong. So we called GM headquarters again, and they said the best thing to do now is for us to contact a lawyer. Anybody who has had experiences filling a claim against GM, I would really appreciate some information.
  • Hi Im Alisha and I have a 2004 GMC Envoy with the 4.2L In6 Beautiful Red Metallic and I love it (Most of The Time).
  • I have a 2006 envoy and 2 weeks ago it stalled at a light and now it stalls occasionally on the hoghway and will not start at times like it has a dead battery yet all the lights will come on. My friend ran a diagnostics check and found no fault codes and I know I am gonna get killed in this car. i am in no position to go to the dealer and they also find nothing and then charge me to replace an ignition , computer, or several other things. At this point all I have is a case at GM and I am extremely worried. Anyone else having this issue or problem?
    Rich L.
  • Hi Rich hate to hear about this problem your having but maybe i can help ,specially since mine put me threw a few hoops a few months ago, I know on mine when it began to stall it was when i first cranked it it wouldnt hold an idle and would die now keep in mind i had just bought a new battery for it about a 2 weeks before hand so i immediantly thought something had happened again with the battery but checked it out and it was fine ,so then i thought possibly a sensor but it was weird because my check engine light wasnt on and it wasnt throwing any codes, Have you checked out your Crank or Cam Sensor those are known to be problems in these models at least for me they were and I completely understand about the dealer they'll take you to the cleaners for sure but then again most your local auto repair shops unfortunatly arent with a [non-permissible content removed] either, But i would suggest checking those sensors or you know it very well could be fuel related make sure to check out the Throttle Body and the ISC(idle speed control)motor .And this maybe a stupid question but all of your grounds are connected properly right? If you havent already double check them to be sure.

    Good Luck
  • We just bought a used 2004 Envoy and had a similar problem. The dealer would not fix it becasue we didn't purchase their extended warranty. We ended up having to replace the control module, becasue the instrument panel was going crazy, lights coming on while driving, guages not owrking, flashing "unknown driver", etc. Do you know if any other years were effected, what happened with your case?
  • Hey guys, not sure if its too late to help any of you or not but i know how you feel. I own a 2005 Envoy SLT myself and i have had the stalling while driving problem and the not starting problem with all of the lights coming on in the dash. I will tell you what fixed both of my problems. I purchased a cam positioning sensor and replaced it. (its right on the front of the head behind the fan) that solved the stalling while driving problem. The not starting problem took an ignition switch on the underside of the steering column, both inexpensive and easy fixes, but very stressful problems!!
  • :confuse:
    I am having the same problems you were having, can you tell me the dealership name and number you took your car to. I have an appointment Monday and would like to have all my ducks in a row. I find it odd and I am sure there are more situations like your vehicle and mine especially since as I read your description of what was happening and it sound like you were talking about my car. I appreciate any and all information you can give me. Please me email me at mbell033@yahoo.com

    Thank you
  • tidestertidester Posts: 10,110
    Please me email me at ...

    It's better to keep the discussion right here so everyone will benefit. :)

    tidester, host
    SUVs and Smart Shopper
  • After I changed the the control module for the blower I am getting cold and hot air, does anyone has had the same problem?
  • I have had nothing but problems with my Envoy. I purchased my truck used in December 2006 and in March 2007 all of my problems began. My airbag light came on and I took it to the dealer since I had purchased the extended warranty coverage and I needed a new computer system. In May 2007 I was driving home on the highway and my lights started to flicker on and off constantly and my car began to shut down I was able to get into the shoulder just in time before it died. I had it towed to the dealership again and this time they said the ignition switch was no good. In September 2007 I was leaving for work in the morning to find out that my car wouldn't start all the lights would come on but it just would not start. I again returned to the dealer and they said they had to put in another ignition switch. In January 2008 I returned to the dealer due to the car not starting again and needed another ignition switch. In April 2008 I returned once again for another ignition switch because it would not start the day I was leaving for a road trip. In September 2008 I had to bring it in because my 4 wheel drive trasfer case and switch had to be replaced. In January 2009 everytime I got gas it would not start so they said I need a new purge valve. Today, the car stalled again while driving. I am so frustrated with this car and GM period. I will never ever again buy an american made car because I feel they are so unreliable. In April 2008, I callled a Lemon Law Lawyer and gave them the run down and they said I qualify under the Maynard-Ferguson Law. They have been in touch with GM and I have kept them aprised of the situation and they are expecting some kind of settlement from them. If you are having tons of problems my suggestion would be to contact a lemon lawyer to see if you qualify or not and always keep all of your receipts for your backup. :lemon:
  • Well it looks like I am about to sing the same old song. I bought a 2002 envoy in November and the four wheel drive light is on when it is cold,, When the light is on the four wheel drive doesn't work. But it goes off when the car has been running for a while, I shut it off and then turn it back on. But I am also having this starting problem that everybody is talking about. All of the lights go on but nothing else happens. I have never had it take more than ten minutes but I don't want to wait around and see what happens. I took the truck to the dealer I bought it from who sent it out to a GMC dealer, they had it for over two weeks, told me they were going to report the rental that they gave me stolen because I wasn't twenty five ( an entirely different fiasco) and I go to pick the car up and the light was still on! As though they didn;t even turn it on after they "fixed it" so the dealer I sent it to spent a ton of money to have the transfer case fixed at the GMC dealer and it didn't do a damn thing. But I don't have the time to go back and forth to the dealer (over and over) for this car...I am honeslty scared now for the stalling problems to start (the car only has about 65,000) miles on it. Please let us know if you get any farthur with GMC. Otherwise I'll just take a loss ( i did finance the car) and get something else.
  • mooncetmooncet Posts: 1
    Hey guys. Two months ago I bought a 2005 GMC Envoy XL (not SLT/no security system), 4.2 Liter, In-line 5.

    A couple weeks ago the Passlock light on the instrument cluster came on. A day later, all of the lights on the instrument cluster started going on and off at random (just really going crazy), and all the gauges stopped working. This kept happening intermittently over the next couple days. I'd go a half the day with no problem, and then non-stop problems the rest of the day. Just totally random.

    We took it to our mechanic who replaced the ignition switch and sent us home. It started happening again just a couple hours later. We called our mechanic, and he told us it had to be the Body Control Module.

    In the meantime, we had started having problems with the power shutting down completely on the vehicle while driving it. Usually when slowing down or accelerating rapidly. This seems to happen right at the same time all instrument cluster starts going nuts.

    We took the Envoy to a GMC dealer service center, replaced the Body Control Module, and had them program it. I took it off the lot, and the power shut down halfway down the road to the freeway. I took it straight back. They said they found a wire that was not properly grounded near the body control module. They said they fixed it, and sent me home again.

    That evening, I left to go to the store and the exact same thing happended as before...Passlock code, crazy instrument cluster lights, engine died.

    We took it back to the GM service center. They say they can't figure out what the problem is. The power actually shut down as we pulled into the garage. We showed them when we got it to start back up all the lights going on and off (flickering). They've had it all day now, and they say they can't get it to act up again to test it.

    Does anyone have any idea what might be causing this? We've now had our car in and out of shops for almost 2 weeks, and we've spent close to $1,000 fixing and replacing things that haven't solved the problem at all. We're just about out of money, and this is our only car. I would really appreciate any suggestions.

    I've looked around online, and seen plenty of people complaining about the same problem, not just with Envoys either. But I can't find many that have any suggestions. The only ones I've seen with any regularity are: Ignition Switch (which we tried), Body Control Module (which we tried), and Cam Positioning Sensor (which the GMC mechanic says he doesn't think it is).

    Help!!!!!

    Thank you,

    Mooncet

    By the way, the only other thing we've noticed is that moving the middle row seat (which happens to be right above the Body Control Module) seems to make it worse. It happens even when no ones touching it, but it happens more when someone is. I pointed this out to the GMC mechanic, and he tested it out when we first brought it back this morning. He folded it forward, and wiggled it back and forth, and it caused the instrument cluster lights to fluctuate. I'm sure that this has to be part of the problem.
  • kam2002kam2002 Posts: 1
    I have a 2002 Envoy, the back lights stay on, even when you cut the car off. What should I do to fix this?

    It drains the battery really quick! Please I need help to fix this problem, I am unemployed and have to fix it myself.

    Thank you for your help in advance! :confuse:

    Kathy
  • My daughter has an '02 Envoy that has the MIL on. This code reflects low operating temperature. My scanner shows an operating temperature of between 174-178 degrees.
    My question is, is this considered low? If so, this would be a thermostat problem. If not, it could be a sensor problem.
    Has anyone else had this experience?
  • we own a 2005 envoy slt 4x4....Have had small problems until now.. The fog lights come on after car is off...put key in the ignition and now can not get key out...lights would come on in the interior durning the evening.....drain the battery..dead ...today took battery to store to check batter..awaiting results..durning the past five years we have had to change the tires four times,parking brake broke,back led broke,check engine light still on...now car is out of warranty.The moulding around the doors just horrible...oh ya and still making payments on this P.O.S.I will never buy another GM truck,suv or car just garbage after only 5 years come on GM open your eyes...... :mad: :mad: :mad: :mad: :mad: :lemon: :lemon:
  • gmcustsvcgmcustsvc Posts: 4,108
    bigred72,
    Have you taken your vehicle into the dealer for these problems?
    Christina
    GM Customer Service
  • I bought this Envoy new in 2004 Here are the PROBLEMS I'VE HAD SO FAR:

    *Front differetial - replaced...Cost $3600.00 Dealer split difference w/ me since just out of warranty, and previous complaints from me about FWD performance.
    *Transmission - went out... Just happened @ 100k miles. Cost $3000.00
    *Rear tail-lights - continuously burning out
    *Cigarette lighters - continuously burning fuses
    *Radio lights - Half of radio lights are burnt out
    *A/C - Fan blower will not work on highest (5) setting.. Cost wanted $500.00
    *Windshield washer fluid motor - burnt out. Has been for a long time. Cost wanted $500.00
    *Rearview mirror - Broke... Cost wanted $500.00.. You've gotta be kidding!

    ***Many other problems, but I am tired of complaning and coming upon deaf ears. Thanks for listening. I will never buy a GM vehicle again!
  • Were you able to determine what was causing the noise?
  • I have the same car and same issues; transmission, differential, tail lights, interior lights, and now?

    The emblems on the side are wedging against the front quarter panels and are flipping off...

    I had everything fixed, by the way. The price tag now? Over 12,000.00 in repairs, not to mention the payment itself...

    Never again.
  • clarkem5clarkem5 Posts: 2
    We have a 2005 Envoy. Recently the four wheel drive service light, the ABS light and the brake light on the dashboard came on and stayed on. Also the heater/AC fan will not work. My mechanic changed the fan motor and the resister and the fan worked for about a minute and then quit. I have an appointment to take it to the dealer tomorrow but I am afraid of what the repairs will cost since I am on a fixed income. I am also not secure in the knowledge that the repairs will solve the problem since I have had repairs by my dealer in the past that were not satisfactory. I am beginning to think that the public is being ripped off by GM.
  • gmcustsvcgmcustsvc Posts: 4,108
    clarkem5,

    I apologize for the problems you are experiencing with your Envoy. Please keep me posted on any information from the dealership.

    Thank you,
    Caron, GM Customer Service
  • clarkem5clarkem5 Posts: 2
    It turned out that the ignition switch was bad. When it was replaced, the problems were no longer there. The problem was not the fault of GM.
  • I have a clicking noise seems to be coming from behind the dash glass. Also had a dead battery. Battery was replaced, but I still have the noise. Dealer service writer was stumped as to origin of noise. Can hear it really well with key in "on" position, engine not running. You too?
Sign In or Register to comment.